Ubuntu

[CMI8738-MC6 - C-Media CMI8738, recording] Recording problem

Asked by martin on 2012-01-09

I have bought a new sound card for my computer and there is no sound coming out of it. It is a pci trust sound card and I have an ATI N996

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: alsa-base 1.0.24+dfsg-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-14.23-generic 3.0.9
Uname: Linux 3.0.0-14-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu4
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: martin 1800 F.... pulseaudio
 /dev/snd/controlC0: martin 1800 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'IXP'/'ATI IXP rev 80 with ALC655 at 0xfdffa000, irq 17'
   Mixer name : 'Realtek ALC655 rev 0'
   Components : 'AC97a:414c4760'
   Controls : 41
   Simple ctrls : 26
Card1.Amixer.info:
 Card hw:1 'CMI8738'/'C-Media CMI8738 (model 55) at 0xdc00, irq 20'
   Mixer name : 'CMedia PCI'
   Components : ''
   Controls : 41
   Simple ctrls : 22
Date: Mon Jan 9 13:45:55 2012
InstallationMedia: Kubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaRecordingTest: ALSA recording test through plughw:CMI8738 failed
Symptom_Card: CM8738 - C-Media CMI8738
Symptom_Type: None of the above
Title: [CMI8738-MC6 - C-Media CMI8738, recording] Recording problem
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/17/2006
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: RC410-SB450
dmi.chassis.type: 3
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd01/17/2006:svnGateway:pnE4034:pvr:rvn:rnRC410-SB450:rvr:cvn:ct3:cvr:
dmi.product.name: E4034
dmi.sys.vendor: Gateway

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Solved by:
Daniel Letzeisen
Solved:
2012-01-09
Last query:
2012-01-09
Last reply:
2012-01-09
Daniel Letzeisen (dtl131) said : #1

I think this is a simple matter of configuring the add-in card to use alsa index 0. If it's truly a bug, I'll change it back to a bug report.

Daniel Letzeisen (dtl131) said : #2

The card is not set as the default sound card. If you only want to use the sound card and not the motherboard's built-in audio, then the easiest way is to turn off the onboard audio in the BIOS.

Another way is to add the following two lines to /etc/modprobe.d/alsa-base.conf

options snd-cmipci index=0
options snd-atiixp index=1

martin (martin-harris) said : #3

Hi, yes, it was just a case of moving the card up as the default. its
all working now thanks.

On 09/01/12 16:10, Dave Lentz wrote:
> Your question #184174 on alsa-driver in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/alsa-driver/+question/184174
>
> Dave Lentz posted a new comment:
> I think this is a simple matter of configuring the add-in card to use
> alsa index 0. If it's truly a bug, I'll change it back to a bug report.
>

Best Daniel Letzeisen (dtl131) said : #4

You're welcome. Please mark the question as solved.

martin (martin-harris) said : #5

Thanks Dave Lentz, that solved my question.