Run apps installed but not listed on Ubuntu 10.10 "Applications" menu?

Asked by lpandz on 2011-03-28

I just installed what is displayed as "WM dock applet displaying lm_sensors temperature values" or "wmtemp" under the Ubuntu Software Center > Get Software > System. After the install, I expected to find the app listed under Applications > System Tools but "wmtemp" is not there. I looked on all menus just to be thorough and I still did not find it. I rechecked the installed software category, and the page for wmtemp describe wmtemp as "installed" on the left-side of the horizontal bar and "remove" at the right-hand side of the said bar. Those words would seem to indicate that the install was successful but was it? If indeed there was a successful wmtemp install, where is the link to the app and/or how do I run the app? -- 2011.03.28Mo.1304UTC --

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu alacarte Edit question
Assignee:
No assignee Edit question
Solved by:
Sam_
Solved:
2011-03-28
Last query:
2011-03-28
Last reply:
2011-03-28

You'll maybe find it if you right click the panel and click 'add item'

lpandz (andzgod) said : #2

Hello actionparsnip.

In between the initial install attempt, I did try to right-click on the panel and next went "Add to Panel". The ensuing window listed items but "wmtemp" is not included. I also tried the "Run application..." applet (after adding it as an item for the said panel) and next launched the applet. There was an heading named "Show list of known applications" (side-comment: Shouldn't that be "Show list of installed applications" instead?) but I still couldn't find "wmtemp" or anything even remotely connected to "temperature", or "hardware", and the like wordings. I also tried the text-box: I typed "wmtemp" and next clicked on the "Run" button: the ("Run application.." applet) window was dismissed but nothing seemed to have changed or launched. I re-checked the panel in any case to see if the icon for "wmtemp" is now there but still no luck.
-- 2011.03.28Mo.1427UTC --

delance (olivier-delance) said : #3

Have same issue with lmsensor, which worked previous summer.

Best Sam_ (and-sam) said : #4

apt says it's a
<dock applet for Window Maker>

You need to logout, then choose session wmaker.

http://maketecheasier.com/create-a-great-window-maker-desktop/2009/02/14
http://ubuntuforums.org/showthread.php?t=85363

If it still doesn't display after login to wmaker try in a terminal:
sensors

If there is an output, wmtemp should display something.

lpandz (andzgod) said : #5

Hello delance.

If "lmsensor" have anything to do with the issue, and further that if "lmsensor" is involved with communicating with the hardware sensors, then I guess that my issue is near to being dead in the water. That leaves me having to find other apps that would supply the same functionality. I have a 6-core AMD 1090-T processor which I am thinking of over-clocking and for me to be able to safely do that, I need some way of reading the hardware temperature sensors. On the Windows side there is the "CPUz" app. Any ideas as what apps are out there in the Linux world that would come close to the functionality of "CPUz" (and does not have the issue I'm having with "wmtemp")?
-- 2011.03.28Mo.1618UTC --

lpandz (andzgod) said : #6

Hello Sam_

I'll try your suggestion and I'll post a feedback as soon as I have them.

Hmm.. Is there a way for me to edit my post here in LaunchPad? I can't find the "Edit" button so I'll write my edit here:

Errata:
In my 2011.03.28Mo.1618UTC post, what I meant was "HardwareMonitor" and not "CPUz".

-- 2011.03.28Mo.1637UTC --

lpandz (andzgod) said : #7

Hello Sam_

I just read something about the WM (Window Maker) using your indicated links and it seems to me that the WM software is rather dated. The idea of workspaces in WM then is already implemented in U1010 (Ubuntu_v10.10) so if I have WM installed in U1010 , I figured that there'll be some clash there. Not worth it, in my mind, for the trouble of understanding (and next maintaining) WM where a simple need to have some sensor temp values is all I wanted. The good thing is that the sensor command in a terminal-window session worked to display values for voltages and temps -- which is good enough for my purposes.

For the install process of the wmtemp, going forward, I would like to suggest that, what I refer to as "back dependency" be implemented as a mechanism in the "core" of app install process under Ubuntu. That is, software that is a module or component of a larger software, like wmtemp is to WM, should be indicated as requiring the larger software to be installed first. The user is not to be placed in a situation where a module was so-called "installed" but cannot in fact be used in as much as the the larger software is not yet in place or otherwise not installed/working in a system. Had this mechanism been in place, I would have been informed that I cannot use wmtemp if WM is not first installed. Something like: "The wmtemp software needs Window Maker to be installed first. Would you like to install Window Maker now? -Yes -Learn more -Cancel install" would have saved the day.

Thanks everyone. :-)
-- 2011.03.29Mo.1936UTC --

lpandz (andzgod) said : #8

Thanks Sam_, that solved my question.

Sam_ (and-sam) said : #9

> what I meant was "HardwareMonitor"

- System administration -> system monitor
- Just another GUI: hardinfo.
http://packages.ubuntu.com/maverick/hardinfo

- To monitor sensors there're so called applets which can be added to the panel.
Right click on empty space of panel -> add to panel
search the list for system monitor, CPU monitor.

- Lightweight system monitor Conky (package: conky-all), highly configurable.
## Example line for sensors in Conky:
${color}Sensors:$color${exec sensors}

http://conky.sourceforge.net/variables.html
http://ubuntuforums.org/showthread.php?s=2c841dc0eadb0764990e91d2cb43317e&t=281865&page=1678

Sam_ (and-sam) said : #10

btw. I've just learned about 'Window Maker' today in regard of your question.
The discription told me there needs to be a Window maker to use wmtemp, when it says:
dock applet *for* Window Maker.

However if this isn't sufficient in your eyes then just report a bug and request a more reliable discription of the package in software center. It may help to make Ubuntu better.
https://help.ubuntu.com/community/ReportingBugs