Newly installed applications not showing

Asked by Kino Velez on 2010-07-31

UBUNTU 10.4
I install Thunderbird configured it, read mail and closed it. I does not show up in applications menu. Same thing happened with Glipper I reinstall it and does not show up in the menu. Every other application until yesterday showed up right away in Applications menu.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu alacarte Edit question
Assignee:
No assignee Edit question
Solved by:
Kino Velez
Solved:
2010-07-31
Last query:
2010-07-31
Last reply:
2010-07-31

Sometimes after install new app they are not displayed into the Ubuntu menu so please open a terminal and type:

killall gnome-panel

or exit from your session and login back...

Hope this helps

Kino Velez (kvelez) said : #2

I had tried that already. Any other suggestions?

Please copy and paste the result of this terminal command:

id

and

ls -la $HOME

Thanks

Kino Velez (kvelez) said : #4

kino@ubuntu:~$ id
uid=1000(kino) gid=1000(kino) groups=4(adm),20(dialout),21(fax),24(cdrom),25(floppy),26(tape),30(dip),44(video),46(plugdev),104(fuse),105(lpadmin),119(admin),121(nopasswdlogin),122(sambashare),1000(kino)
kino@ubuntu:~$ ls -la $HOME
total 276
drwxr-xr-x 41 kino kino 4096 2010-07-30 17:25 .
drwxr-xr-x 3 root root 4096 2010-07-13 03:00 ..
drwx------ 3 kino kino 4096 2010-07-15 04:42 .adobe
-rw------- 1 kino kino 196 2010-07-30 18:05 .bash_history
-rw-r--r-- 1 kino kino 220 2010-07-13 03:00 .bash_logout
-rw-r--r-- 1 kino kino 3103 2010-07-13 03:00 .bashrc
drwx------ 2 kino kino 4096 2010-07-27 16:02 .bogofilter
drwx------ 10 kino kino 4096 2010-07-30 18:04 .cache
drwxr-xr-x 15 kino kino 4096 2010-07-30 17:13 .config
drwx------ 3 kino kino 4096 2010-07-13 03:08 .dbus
drwxr-xr-x 2 kino kino 4096 2010-07-13 03:08 Desktop
-rw-r--r-- 1 kino kino 41 2010-07-30 16:39 .dmrc
drwxr-xr-x 2 kino kino 4096 2010-07-13 03:08 Documents
drwxr-xr-x 2 kino kino 4096 2010-07-30 17:01 Downloads
-rw------- 1 kino kino 16 2010-07-13 03:08 .esd_auth
drwxr-xr-x 7 kino kino 4096 2010-07-30 17:03 .evolution
-rw-r--r-- 1 kino kino 179 2010-07-13 03:00 examples.desktop
drwxr-xr-x 2 kino kino 4096 2010-07-15 03:55 .fontconfig
drwx------ 4 kino kino 4096 2010-07-30 18:04 .gconf
drwx------ 2 kino kino 4096 2010-07-30 18:18 .gconfd
-rw-r----- 1 kino kino 0 2010-07-30 16:44 .gksu.lock
drwx------ 11 kino kino 4096 2010-07-30 17:46 .gnome2
drwx------ 2 kino kino 4096 2010-07-13 03:08 .gnome2_private
drwx------ 2 kino kino 4096 2010-07-24 11:49 .gnupg
drwxr-xr-x 2 kino kino 4096 2010-07-29 19:47 .gstreamer-0.10
-rw-r--r-- 1 kino kino 132 2010-07-30 16:39 .gtk-bookmarks
dr-x------ 2 kino kino 0 2010-07-30 16:39 .gvfs
-rw------- 1 kino kino 7318 2010-07-30 16:39 .ICEauthority
drwxr-xr-x 2 kino kino 4096 2010-07-13 03:53 .icons
drwx------ 3 kino kino 4096 2010-07-15 04:22 .kde
drwx------ 2 kino kino 4096 2010-07-29 19:54 .kino-history
-rw-r--r-- 1 kino kino 3002 2010-07-29 19:54 .kinorc
drwx------ 3 kino kino 4096 2010-07-13 03:52 .local
drwx------ 3 kino kino 4096 2010-07-15 04:42 .macromedia
drwx------ 4 kino kino 4096 2010-07-13 03:09 .mozilla
drwxr-xr-x 2 kino kino 4096 2010-07-13 03:08 Music
drwxr-xr-x 2 kino kino 4096 2010-07-13 03:08 .nautilus
drwxr-xr-x 3 kino kino 4096 2010-07-29 20:38 .openoffice.org
drwxr-xr-x 3 kino kino 4096 2010-07-19 16:39 Pictures
drwx------ 3 kino kino 4096 2010-07-27 17:32 .pki
-rw-r--r-- 1 kino kino 37 2010-07-20 17:19 .printer-groups.xml
-rw-r--r-- 1 kino kino 675 2010-07-13 03:00 .profile
drwxr-xr-x 2 kino kino 4096 2010-07-13 03:08 Public
drwx------ 2 kino kino 4096 2010-07-30 16:39 .pulse
-rw------- 1 kino kino 256 2010-07-13 03:08 .pulse-cookie
drwxr-xr-x 2 kino kino 4096 2010-07-15 04:22 .qt
-rw------- 1 kino kino 7723 2010-07-30 17:25 .recently-used.xbel
drwx------ 2 kino kino 4096 2010-07-15 03:39 .ssh
-rw-r--r-- 1 kino kino 0 2010-07-13 03:23 .sudo_as_admin_successful
drwxr-xr-x 2 kino kino 4096 2010-07-15 04:22 .swscanner
drwxr-xr-x 2 kino kino 4096 2010-07-13 03:08 Templates
drwxr-xr-x 2 kino kino 4096 2010-07-13 03:53 .themes
drwx------ 5 kino kino 4096 2010-07-19 16:39 .thumbnails
drwx------ 4 kino kino 4096 2010-07-30 16:52 .thunderbird
drwx------ 2 kino kino 4096 2010-07-14 12:53 .update-notifier
drwxr-xr-x 2 kino kino 4096 2010-07-29 19:52 Videos
-rw------- 1 kino kino 24100 2010-07-30 18:18 .xsession-errors
-rw------- 1 kino kino 28410 2010-07-29 21:03 .xsession-errors.old
kino@ubuntu:~$

Be sure your disk have no errors please force a check from terminal type:

sudo touch /forcefsck

close all applications, then to reboot and to perform the hard disk check type:

sudo reboot

Then please add a new user (a testuser) and check if in this user the menu is good
menu System→Administration→User and groups

Kino Velez (kvelez) said : #6

When through all the steps. Still stuck in the same situation. Created two new users and it did not make a difference.

Please try this:

Open a Terminal from the menu Applications->Accessories->Terminal

Tip: right click with mouse on the terminal title caption and select the item "Always on Top" doing this you will force the terminal window to stay on top of the other windows and you will find very easy to copy single row from this web page into the terminal...
Something more about using the terminal https://help.ubuntu.com/community/UsingTheTerminal

Then type or better copy and paste a row a time then press enter:
(Tip: select the single row to copy then right click into the terminal and to quick paste click with middle button of mouse )

sudo cp -arf /var/lib/dpkg /var/lib/dpkg.backup
sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status
sudo cp /var/lib/dpkg/available-old /var/lib/dpkg/available
sudo rm -rf /var/lib/dpkg/updates/*
sudo rm -rf /var/lib/apt/lists
sudo mkdir /var/lib/apt/lists
sudo mkdir /var/lib/apt/lists/partial
sudo aptitude clean
sudo aptitude autoclean
sudo apt-get update
sudo dpkg --clear-avail
sudo dpkg --configure -a
sudo aptitude install -f
sudo aptitude update
sudo aptitude dist-upgrade

give your user password when requested, you don't see nothing when you
type it, then press enter.

Hope this helps

Kino Velez (kvelez) said : #8

Wow that took sometime. At this stage I am ready to can the system and do a fresh install as something has to be corrupted. Do you agree?

Please wait a bit more might be reinstalling some package or waiting some other answers can solve...

i suggest you to reinstall alacarte from terminal type:

sudo apt-get --purge --reinstall install alacarte ubuntu-desktop

Kino Velez (kvelez) said : #10

That one ran for a while. Same results.

arochester (arochester) said : #11

I assume that you can run Thunderbird from the Run Menu...

How about manually editing the Menu - http://linux.about.com/od/ubuntu_doc/a/ubudg10t2.htm

Kino Velez (kvelez) said : #12

No I can't and either program shows up up in alacarte menu. Right now the only way to run Thunderbird it is to go back to the installation folder and run the Thunderbird shell script.

As far a Glipper when I try to install it says reinstall but never shows up in the menu or selectable in alacarte.

arochester (arochester) said : #13

Have you tried installing Thunderbird with Ubuntuzilla? - http://sourceforge.net/apps/mediawiki/ubuntuzilla/index.php?title=Main_Page

Kino Velez (kvelez) said : #14

I got rid of evolution mail. Reinstalled Thunderbird and now it shows up. Makes no sense but it worked. No showing up did not make any sense either.
As far as the clipboard manager which I really want since I have been using multi clipboard in windows for over ten years (saves the last 100 clipboards) there is no way it will show up. Can you suggest a different one.

Please close this marking this as solved... for the clipboard manager please made a new question...

Thank you

If you log off and on, does it add then. I've had similar but next boot it was fine.

If it's not then try manually adding an item using alacarte to see if it gets added.

Kino Velez (kvelez) said : #17

Will do thanks to all who helped.