Ubuntu 11.10 shuts down on battery power

Asked by Ian Farrell on 2011-12-13

I have used ubuntu for a long time since the first stable release but with the new release when I unplug my laptop my system shuts down and says battery critically low and shuts down every time. I am currently running debian's newest stable release as I couldn't find a solution. I also tried linux mint 12 (being based on ubuntu)and had the same problem with the battery going to critical with a full charge. I have no probs with it in windows vista or debian. Battery charges fine no problems. I also tried ditching unity to see if that helped but still had the problem with gnome 3. Finally giving up on using ubuntu all together. It even does this when I run the live cd and unplug. I am running a Toshiba Satellite a215-s4747 with an AMD Turion 64 x2 dual core tl-56. Atheros wireless and ATI radeon. Stock laptop from the factory with only a memory upgrade done. Everything is tiptop except when i boot ubuntu or a close derivative. Any help would be appreciated or knowledge of a larger bug?

carlos a becerra (1sparda) said : #1

Hi ian, thank you for being and active user of ubuntu, I am not an expert, but I would try the best I can to help in your issue.
Let me ask you, did you tried another OS, any other than a linux distribution?
If so , did the bug happen again?
It looks like you may have a bug, specifically a regression bug, were you using gnome or kde? as this is an upstream bug.
another question, did you try using only the command line?
why don you try testing the precise 12.04 build?
I found some bugs that look very similar to your question, so why don't you follow this bugs, until we can get more information.
Thank you for taking the time to help make ubuntu better.

Ian Farrell (revitfarrell) said : #2

I was using gnome when it happened. Also above I stated I tried windows vista with no problems as well as Debian and Slackware 13.37. However ran into this problem with both Ubuntu 11.10 and Linux Mint 12. If I have time I will try the 12.04 build and see what happens. It sounds like a bug I linked 2 other bugs to my problem that sound the same. Not sure if this is a Gnome 3 bug or a Ubuntu bug but it kinda sounds like it may be a Gnome bug since it affects me in Linux Mint 12 as well. I wonder if this needs to be posted over to the guys at Gnome?

Ian Farrell (revitfarrell) said : #3

Oh i also experienced the problem while using Unity as well.

Ian Farrell (revitfarrell) said : #4

.

Ian Farrell (revitfarrell) said : #5

Just wanted to add that I tried both the 64bit install and the regular i386 install and had the problem with both either installed or running live if this info helps at all.

I'm a total Linux newb and I have the same problem on an HP G60 with the same processor. From what I'm finding, ACPI needs an up to date BIOS to function properly.

I'm having issues with the OEM BIOS provider not supporting Linux, but I've found a few options. If you can find your processor model number, you can use Coreboot, which seems to be the only free BIOS provider left alive:

http://www.coreboot.org/Welcome_to_coreboot

If you know how to find your processor model, I'd love you forever of you could clue me in:

https://answers.launchpad.net/ubuntu/+source/acpi/+question/182301

Can you help with this problem?

Provide an answer of your own, or ask Ian Farrell for more information if necessary.

To post a message you must log in.