Problema de sonido chip ALC889A HD audio karmic

Asked by WiLLiTo on 2009-11-13

Buenas a todos

Necesito ayuda con problemas en karmic:

Cada vez que suena algo justo antes se escucha un chasquido bastante molesto que no se como corregir. Esto ocurre con cualquier fuente ya sea sonido de sistema, juegos, videos, musica, etc... mientras continua la reproduccion todo suena bien pero cuando para y va a sonar otro sonido se repite el chasquido (ej. chasquido -> cancion mp3->silencio ->chasquido ->siguente mp3)

Tengo sonido de placa ( chip ALC889A HD audio ) y funciona con el ALSA.

Cualquier comentario o idea es bienvenida

Un saludo

Question information

Language:
Spanish Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Jorge Suárez de Lis
Solved:
2009-11-14
Last query:
2009-11-14
Last reply:
2009-11-13
Jorge Suárez de Lis (ys) said : #1

Es preferible que crees una pregunta para cada cuestión, el sistema no está preparado para contestar a varias preguntas... Te voy a contestar a la de sonido, que es la primera:

Es posible que ese chasquido lo produzca cuando se enciende o se apaga la tarjeta, vamos, que esté provocado por el modo de ahorro de energía. Para desactivarlo:

* Pulsa alt+f2
* Escribe: gksudo gedit /etc/modprobe.conf.d/alsa-base.conf
* Pon tu contraseña para poder obtener privilegios para editar el archivo. Al final de todo verás:

    # Power down HDA controllers after 10 idle seconds
    options snd-hda-intel power_save=10 power_save_controller=N

* Prueba a cambiar power_save=10 por power_save=0
* Guarda el archivo, cierra y reinicia el sistema.

WiLLiTo (victor-gg83) said : #2

Ok edito y dejo esta como la de sonido y creo otras

En un par de horitas que salga del trabajo pruebo lo del ahorro de energia.

Gracias por la ayuda

WiLLiTo (victor-gg83) said : #3

Vale con esto ya no suena el chasquido desagradable solo suena un "pup" nos vamos acercando...

Voy a probar un "power_save" más alto (pensé en desactivarlo pero no se como afectará al consumo)

Un saludo

Best Jorge Suárez de Lis (ys) said : #4

power_save=0 equivale a desactivarlo, según la información del módulo (modinfo snd-hda-intel)
Puedes probar a seguir las recomendaciones de este artículo. Son bastante genéricas, pero bueno:
FAQ #781: “Solucionar problemas de sonido en Ubuntu 9.10 Karmic Koala”.

WiLLiTo (victor-gg83) said : #5

Vale fallo mio :$

Me lié leyendo pero ya sabemos al más:

editando /etc/modprobe.d/alsa-base.conf

Si se cambia power_save_controller=N por power_save_controller=0 cambia el chasquido por un sonido menos molesto.

Si se cambia power_save=10 por power_save=0 desactivando el ahorro ya no se produce el sonido.

Para los que no les interese desactivar el ahorro simplemente poner un número alto power_save="X" donde X es el número se segundos antes de entrar en modo ahorro de energía. De 2 a 5 minutos estaría bien.

Gracias por la ayuda Jorge

WiLLiTo (victor-gg83) said : #6

Thanks Jorge Suárez de Lis, that solved my question.