I installed the latest version of Ubuntu on Bootcamp Assistant on my Macbook.

Asked by Daniel Harrington

Hi everyone,

I'm very new to Ubuntu and have been conducting several experiments using that platform. I like it, but I'm getting sick and tired of the annoying grub screen that shows up and asks me to select a certain platform. I expected that Boot Camp would work as it does when running a Windows Operating system. However, when I hold down the option key, it doesn't give me the choice between mac or ubuntu. Every time now, the Grub screen comes up. I can not access my Leopard platform. Seriously I did not see this coming. Now I am stuck with a MacBook, still containing necessary files that I did not back up. I'm practically crying now. Somebody please help me!!! I need to simply remove Ubuntu and the Grub program without erasing my Leopard files. HOW DO I DO THIS!?

Thank you for any help,
Daniel Harrington

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Daniel Harrington
Last query:
Last reply:
Revision history for this message
Tom (tom6) said :


Are you able to boot into Ubuntu on your hard-drive? If so then hopefully we can just edit the grub-boot-loader to boot into Leopard or at least to see the Leopard partitions.

Good luck and regards from
Tom :)

Revision history for this message
Daniel Harrington (daniel-graffix3d) said :

Hey Tom,

Thanks for your help. I think I know what you are talking about.
Ubuntu is the only platform I can access at this time so, yes, I can 'boot'
into Ubuntu.
I'm looking at it right now actually.
How does one edit the Grub-boot-Loader?
Where do I go from here?


On Fri, Jul 31, 2009 at 11:55 AM, Tom
<email address hidden>wrote:

> Your question #78753 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/78753
> Status: Open => Answered
> Tom proposed the following answer:
> Hi
> Are you able to boot into Ubuntu on your hard-drive? If so then
> hopefully we can just edit the grub-boot-loader to boot into Leopard or
> at least to see the Leopard partitions.
> Good luck and regards from
> Tom :)
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/ubuntu/+question/78753/+confirm?answer_id=0
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+question/78753
> You received this question notification because you are a direct
> subscriber of the question.

The ring must be sent deep into Mordor and cast back into the fiery chasm
from whence it came.

One of you...
       ...must do this.

Revision history for this message
Tom (tom6) said :

Ok, first of all can you go up to the top taskbar/panel and click on

Applications - Accessories - Terminal

and into that type in

sudo fdisk -l

then post the results into this thread in Launchpad. Please try to post into the Launchpad site rather than just replying to the email because it makes things a bit messy here otherwise ;) Note that the "-l" at the end is a lower-case "-L". Once you've posted the result here then try looking in the "Places" menu to see what the different "Media" contain ;) Hopefully you'll find all your files in there :)

Good luck and regards from
Tom :)

Revision history for this message
Daniel Harrington (daniel-graffix3d) said :

Hello again.

I typed in sudo fdisk -l and pressed enter.
This is what came up:

[sudo] password for daniel:

Does it want me to put in my password?
I've tried to put in my password but it acts as if the keys are stuck or something,
It won't place what I typed.

Get back soon,
-Daniel Harrington

Revision history for this message
Tom (tom6) said :

Oh yes, it hides what you type and doesn't show stars or anything just in case someone is looking over your shoulder or is able to capture your screen. Knowing how long a password is hugely helps break it ;)

So just type you normal password in and don't worry about noting showing up ;)

Revision history for this message
Tom (tom6) said :

Have you had any luck finding your files in the "xx.y GB Media" in the "Places" menu?

Revision history for this message
Daniel Harrington (daniel-graffix3d) said :

Ok, I did it.

This is what came up:

WARNING: GPT (GUID Partition Table) detected on '/dev/sda' ! The util fdisk doesn
't support GPT. Use GNU Parted.

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00007ea5

      Device Boot Start End Blocks Id System
/dev/sda1 1 26 204819+ ee GPT
/dev/sda2 * 26 15283 122552320 af Unknown
/dev/sda3 15283 19132 30782279+ b W95 FAT32
/dev/sda4 19132 19436 2442383 83 Linux

What does it mean?

-Daniel Harrington

Revision history for this message
Daniel Harrington (daniel-graffix3d) said :

All I see is Computer, Macintosh HD, BOOTCAMP. I see no "GB Media"

Revision history for this message
Steve (stupendoussteve-deactivatedaccount) said :

It's telling you it can't repartition the disk. Bootcamp already did
this for you, "Bootcamp" is the name of the volume it created.

Install in place to that without modifying the partition table.

Revision history for this message
Daniel Harrington (daniel-graffix3d) said :

What do I do?

Say what? I'm sorry I don't understand properly.

Revision history for this message
Tom (tom6) said :

Great :))))
What's in Macintosh HD ? It might not let you look because you haven't yet installed the appropriate libraries in Ubuntu. Hmm, maybe it's better not to even try to look. The important thing is that it is there & so therefore your files aren't lost :)) Also it's good to see BootCamp.

It looks as though sda2 is your "Macintosh HD" either sda1 or sda3 is your BootCamp & sda4 is Ubuntu. The Ubuntu partition does look very tiny tho and also there's no swap partition so i would guess that Ubuntu is feeling a bit cramped and acting a bit weird and tetchy.

I've not been able to find what to add to grub's menu.lst to boot into Mac but i have found this forum

and also this guide

although you've already done a lot of it. I would be cautious about it's advice because resizing or deleting partitions is not a great plan. At the moment at least you can just about use Ubuntu and all the other partitions seem quite vital too right now. I don't think that simply removing Ubuntu will get you booting back into Leopard. I think you have to get Ubuntu's grub to boot you in or find out how to use bootcamp or something to boot you into Leopard and i'm not sure how to do either right now. Hopefully you'll be able to post into the forum i just gave a link to and get an answer there. Please let us know!

Do you have an Ubuntu Cd and can you use the Cd to boot up the machine? Does it give a menu item "Try Ubuntu without changes to this machine"? If so then the firefox in there should be able to access the internet too. Also please let us know if you have a Leopard Cd.

Another question is that if you open the "Documents" folder in "Places" can you get a status bar across the bottom showing how much free space you have in Ubuntu? I want to see if there's enough to add a bit more functionality so that we can read your Leopard files without worrying.

Sorry all i seem to have is questions right now but at least we know your data is still there. Please let me know if any of that guide makes sense and perhaps post what you think is a good plan based on that. With your knowledge of Mac and mine of Ubuntu then maybe we can work this out together. Of course someone else might drop in that knows a lot about Macs but mostly we deal with Windows refugees in here rather than Mac users keen to explore.

Good luck and regards from
Tom :)

Revision history for this message
Daniel Harrington (daniel-graffix3d) said :

Hi Tom,

Thanks for all your help.
I'll have to look through those forums to see what is there.
What is sda? I'm not sure what that means.

Yes. I do have the Ubuntu CD. Yes it does have the 'Try Ubuntu without changes to this machine' option. But, I have to let you know that Ubuntu is not letting me access the internet because my mac uses the driver for AirPort and I don't think it's compatible with Linux. Therefore, I won't be able to download anything to help it. (I'm using the internet from my desktop computer which is running Vista.)
Yes. I do have a Leopard CD. However, the last thing I want to do is reset Leopard... it will erase the important files I can't access on the Mac. It won't let me access my mac documents through 'Macintosh HD,' -only the Leopard platform settings and files.

The bottom bar in documents folder says I have 243.2 MB of free space. Doesn't sound like very much...

Thanks for all your help! I do think we will figure out a way. I need to research a little more.
I'll get back when I have some Ideas.

I wonder... is there a program that could help me extract the files from the
MAC partition and allow me to back up my Leopard X Documents.


-Daniel Harrington

Revision history for this message
Tom (tom6) said :

Another couple for links to things that might hopefully be helpful

(i think you tried this one already)


Err, and i just posted a new question about this in here

Revision history for this message
gadolinio (gadolinio) said :

Have you tried booting with Ubuntu's LiveCD? ("Try Ubuntu without changes to this machine"). If so, does it let you see your personal files? In the "places" menu you have every hard disk partition being recognized. Try each of them to see if your mac files are there. Try this a couple of times if it doesn't work at first... look everywhere in the File Navigator.
I'd also look deeper inside the Machintosh HD drive. Do you know the normal path of your documents inside mac?

Revision history for this message
gadolinio (gadolinio) said :

Well, this is in Spanish... don't know if you understand it.
(sorry if something like this has already been posted here; i haven't seen all the guides)

The part i think could be of your interest here (a home-made translation of mine):
·Modifications in the boot menu
   ··Changing the default OS
If we have windows and we then install ubuntu, the default GRUB's configuration will make ubuntu boot.
If for any reason we need windows to boot by default:

    * We edit GRUB's configuration file:
$ sudo gedit /boot/grub/menu.lst

    * We look for this line:
default 0

    * Change the "0" for the number that the OS we want to start with has in the list.
    * Save changes and close the editor.

Hope this helps. Remember that you can be asked for your password when you enter the first command ("sudo"), and that you won't see it being written as you type it in; that's normal.

Revision history for this message
Daniel Harrington (daniel-graffix3d) said :

Yes. I've tried this several times. I actually found my files... but it doesn't let me access them through ubuntu. When I click on the Mac HD document folders it says: You do not have administrative access to files. Nothing I can do to fix it.

I actually found a way to boot into mac, but it's kind of tricky. I put in any CD into the drive and then restart. Then, while it reboots and tries to read the disk, I hold down the eject key to release the CD... after the CD ejects it goes to the Apple Splash boot screen, and all is well.

Revision history for this message
Daniel Harrington (daniel-graffix3d) said :

Now that I'm in Mac, I want to remove Ubuntu and the Bootcamp partition, but the Disk utility is having trouble. Bootcamp won't let me remove the partition. At least I have my files backed up now.

I think I'll just try to recover the whole damn system. Thanks for every ones help!!!

Revision history for this message
Tom (tom6) said :

Ok, first thing would have to be to repair the boot system so that it just boots straight into Mac. It's probably a lot easier to do that inside Mac? Once you have fixed that then it should be easy to boot up a LiveCd of Ubuntu and delete the ubuntu partitions from

System - Administration - Partition Editor

but it will be difficult to do that if you are booted into the hard-drive that you are trying to delete partitions from. It's better to use a LiveCd sesion for that sort of thing although take care not to delete the wrong ones! Then when you've left the space "unallocated" boot back into Mac and then resizing your Mac partition should be fairly easy (not ideal but fiarly easy).

Sorry chap, good luck and regards from
Tom :)

Ps i didn't check Gandolinio's links but they are probably well worth a skim through at the very least.

Revision history for this message
Daniel Harrington (daniel-graffix3d) said :

Thanks a Bunch!!! That should work I think.

Revision history for this message
Tom (tom6) said :

Sorry chap :( Good luck with that
Regards from

Revision history for this message
Tom (tom6) said :

Hey Daniel

Did you manage to sort this all out in the end? If not then please try posting the question again
as there may be different people at the front-desk there now and someone may have the answer.

It might also be worth trying a more general linux forum

Perhaps this link might have something helpful

Good luck and regards from
Tom :)