W: Error GPG - NO_PUBKEY

Asked by renacer on 2009-07-09

W: Erro GPG: http://ppa.launchpad.net jaunty Release: As seguintes assinaturas não puderam ser verificadas porque a chave pública não está disponível: NO_PUBKEY 2836CB0A8AC93F7A

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Leo Milano
Solved:
2009-07-10
Last query:
2009-07-10
Last reply:
2009-07-10

This question was originally filed as bug #397513.

Philip Muškovac (yofel) said : #1

Thank you for taking the time to report this bug and helping to make Ubuntu better.
It seems to me that you added a launchpad ppa to your software sources and forgot to import the gpg key. You can find the gpg key on the same site where you added your ppa from.

Please try this and tell us the results. Thank you in advance.

Chris Coulson (chrisccoulson) said : #2

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs#When%20not%20to%20file%20a%20bug.

renacer (ruimoinhosster) said : #3

Thank you for your answer, but I can't find gpg key.

On Thu, Jul 9, 2009 at 21:16, Philip Muskovac <
<email address hidden>> wrote:

> Your question #76524 on Ubuntu changed:
> https://answers.edge.launchpad.net/ubuntu/+question/76524
>
> Philip Muskovac posted a new comment:
> Thank you for taking the time to report this bug and helping to make Ubuntu
> better.
> It seems to me that you added a launchpad ppa to your software sources and
> forgot to import the gpg key. You can find the gpg key on the same site
> where you added your ppa from.
>
> Please try this and tell us the results. Thank you in advance.
>
> --
> You received this question notification because you are a direct
> subscriber of the question.
>

Leo Milano (lmilano) said : #4

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 2836CB0A8AC93F7A

:)

Leo Milano (lmilano) said : #5

(of course you need to run the above command in a terminal)

renacer (ruimoinhosster) said : #6

Yes I did that, but doesn't work. Returns this number:
2836CB0A8AC93F7A

On Fri, Jul 10, 2009 at 01:52, Leo Milano <
<email address hidden>> wrote:

> Your question #76524 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/76524
>
> Leo Milano proposed the following answer:
> (of course you need to run the above command in a terminal)
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/ubuntu/+question/76524/+confirm?answer_id=4
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+question/76524
>
> You received this question notification because you are a direct
> subscriber of the question.
>

Leo Milano (lmilano) said : #7

Really? It worked here. Have you tried doing an apt-get update after that? It should not complain any more .... did you have a network connection when you ran it?

renacer (ruimoinhosster) said : #8

OK. I tried again and now it worked perfectly.

Thank you so much.

It was complicated. Don't you agree?

It was more simple if exists a clear information besides th information:

*deb http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu jaunty main

in kubuntu.org

*Don't you agree?

You were very useful and friendly.

Thank you so much.

On Fri, Jul 10, 2009 at 02:41, Leo Milano <
<email address hidden>> wrote:

> Your question #76524 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/76524
>
> Status: Open => Needs information
>
> Leo Milano requested for more information:
> Really? It worked here. Have you tried doing an apt-get update after
> that? It should not complain any more .... did you have a network
> connection when you ran it?
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+question/76524
>
> You received this question notification because you are a direct
> subscriber of the question.
>

Best Leo Milano (lmilano) said : #9

My pleasure. Yes, it would be nice to have this info in the Kubuntu announcement. Could you please mark the question as "answered"? I tried, but I don't see the option, you are probably the only one who can do that.

renacer (ruimoinhosster) said : #10

Thanks Leo Milano, that solved my question.