Can't get xterm font to be readable size

Asked by Steve Hayward on 2020-11-17

Followed a couple of leads going back to 2018, such as: Place .Xresources file in Home directory - content:
xterm*font: *-fixed-*-*-*-18-*
Execute xterm and get:
xterm: cannot load font "-Misc-Fixed-bold-R-*-*-18-120-100-100-C-180-ISO-ISO10646-1"
Need to use xterm to Run C program using Code:Blocks 20.03
- I'm barely more than a newbie

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2020-11-21
Last reply:
2020-11-21

This question was reopened

pressing [Ctrl] key and the right mouse button simultaneously while you have focus in xterm window. Then a pop-up menu will come up which can be used to set the font size to your taste. By pressing [Ctrl] key and the middle mouse button, you get a pop-up menu which helps you set/unset a lot of other features of your xterm window like enabling/disabling the scroll bars and so on.

Steve Hayward (steve-hayward) said : #2

Ctrl+RtMouse shows pop-up all right but I can't read the menu - font too small (also pop-ups don't stay open which is inconvenient for attempting to deal with the limitations of a menu with too small font). Similarly with Ctrl+MiddleMouse.
I'm hoping there's another way to do settings for xterm.
Thanks actionparsnip. Sorry for slow response - I'm not well at the moment.

----- Original Message -----
From: "actionparsnip" <email address hidden>
To: "STEVE HAYWARD" <email address hidden>
Sent: Tuesday, November 17, 2020 3:55:54 PM
Subject: Re: [Question #694061]: Can't get xterm font to be readable size

Your question #694061 on Ubuntu changed:
https://answers.launchpad.net/ubuntu/+question/694061

    Status: Open => Answered

actionparsnip proposed the following answer:
pressing [Ctrl] key and the right mouse button simultaneously while you
have focus in xterm window. Then a pop-up menu will come up which can be
used to set the font size to your taste. By pressing [Ctrl] key and the
middle mouse button, you get a pop-up menu which helps you set/unset a
lot of other features of your xterm window like enabling/disabling the
scroll bars and so on.

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+question/694061/+confirm?answer_id=0

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+question/694061

You received this question notification because you asked the question.

Manfred Hampl (m-hampl) said : #3

For diagnostic purposes, what is the output of the following commands:

uname -a
lsb_release -crid
apt policy xterm
xterm -version

What happens when you press and hold the ctrl key and then press and hold the right mouse button, then pull the mouse down to where you guess might be the fifth entry in the pop-up window and finally let go the mouse button and the ctrl key?

Steve Hayward (steve-hayward) said : #4

uname -a
Linux steve-XPS-13-7390 4.15.0-1100-oem #110-Ubuntu SMP Thu Oct 15 15:02:18 UTC 2020 x86_64 x86_64 GNU/Linux

lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 18.04 LTS (beaver-three-eyed-raven X92)
Release: 18.04
Codename: bionic

apt policy xterm
xterm:
  Installed: 330-1ubuntu2
  Candidate: 330-1ubuntu2
  Version table:
 *** 330-1ubuntu2 500
 500 http://ca.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
 100 /var/lib/dpkg/status

xterm -version
XTerm(330)

Q. What happens when you press and hold the ctrl key and then press and
hold the right mouse button, then pull the mouse down to where you guess
might be the fifth entry in the pop-up window and finally let go the
mouse button and the ctrl key?
A. xterm shows a larger font but still not readable fpr my eyes. I tried the 6th and 7th entries down and got larger fonts but still not large enough.

----- Original Message -----
From: "question694061" <email address hidden>
To: "STEVE HAYWARD" <email address hidden>
Sent: Friday, November 20, 2020 10:05:53 AM
Subject: Re: [Question #694061]: Can't get xterm font to be readable size

Your question #694061 on Ubuntu changed:
https://answers.launchpad.net/ubuntu/+question/694061

    Status: Open => Needs information

Manfred Hampl requested more information:
For diagnostic purposes, what is the output of the following commands:

uname -a
lsb_release -crid
apt policy xterm
xterm -version

What happens when you press and hold the ctrl key and then press and
hold the right mouse button, then pull the mouse down to where you guess
might be the fifth entry in the pop-up window and finally let go the
mouse button and the ctrl key?

--
To answer this request for more information, you can either reply to
this email or enter your reply at the following page:
https://answers.launchpad.net/ubuntu/+question/694061

You received this question notification because you asked the question.

Manfred Hampl (m-hampl) said : #5

Which screen resolution do you have?
What is the output of

xrandr -q

Steve Hayward (steve-hayward) said : #6

Screen 0: minimum 320 x 200, current 3840 x 2160, maximum 8192 x 8192
eDP-1 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 294mm x 165mm
   3840x2160 60.00*+ 59.98 59.97 48.00
   3200x1800 59.96 59.94
   2880x1620 59.96 59.97
   2560x1600 59.99 59.97
   2560x1440 59.99 59.99 59.96 59.95
   2048x1536 60.00
   1920x1440 60.00
   1856x1392 60.01
   1792x1344 60.01
   2048x1152 59.99 59.98 59.90 59.91
   1920x1200 59.88 59.95
   1920x1080 60.01 59.97 59.96 59.93
   1600x1200 60.00
   1680x1050 59.95 59.88
   1600x1024 60.17
   1400x1050 59.98
   1600x900 59.99 59.94 59.95 59.82
   1280x1024 60.02
   1440x900 59.89
   1400x900 59.96 59.88
   1280x960 60.00
   1440x810 60.00 59.97
   1368x768 59.88 59.85
   1360x768 59.80 59.96
   1280x800 59.99 59.97 59.81 59.91
   1152x864 60.00
   1280x720 60.00 59.99 59.86 59.74
   1024x768 60.04 60.00
   960x720 60.00
   928x696 60.05
   896x672 60.01
   1024x576 59.95 59.96 59.90 59.82
   960x600 59.93 60.00
   960x540 59.96 59.99 59.63 59.82
   800x600 60.00 60.32 56.25
   840x525 60.01 59.88
   864x486 59.92 59.57
   800x512 60.17
   700x525 59.98
   800x450 59.95 59.82
   640x512 60.02
   720x450 59.89
   700x450 59.96 59.88
   640x480 60.00 59.94
   720x405 59.51 58.99
   684x384 59.88 59.85
   680x384 59.80 59.96
   640x400 59.88 59.98
   576x432 60.06
   640x360 59.86 59.83 59.84 59.32
   512x384 60.00
   512x288 60.00 59.92
   480x270 59.63 59.82
   400x300 60.32 56.34
   432x243 59.92 59.57
   320x240 60.05
   360x202 59.51 59.13
   320x180 59.84 59.32
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)

----- Original Message -----
From: "question694061" <email address hidden>
To: "STEVE HAYWARD" <email address hidden>
Sent: Saturday, November 21, 2020 2:41:04 AM
Subject: Re: [Question #694061]: Can't get xterm font to be readable size

Your question #694061 on Ubuntu changed:
https://answers.launchpad.net/ubuntu/+question/694061

    Status: Open => Needs information

Manfred Hampl requested more information:
Which screen resolution do you have?
What is the output of

xrandr -q

--
To answer this request for more information, you can either reply to
this email or enter your reply at the following page:
https://answers.launchpad.net/ubuntu/+question/694061

You received this question notification because you asked the question.

Do you have to use xterm? Is there no scope to use Gnome Terminal?

Manfred Hampl (m-hampl) said : #8

There are som esuggestions for yterm in https://www.youtube.com/watch?v=Zv8BieM0aOk

e.g.
start it with the command "xterm -fa Monospace' -fs 18" (or even bigger numbers)

use shift-numpad_+ to increase the font size

Steve Hayward (steve-hayward) said : #9

Thanks!! Settings for Code:Blocks > Environment > General provides options for which terminal to launch console programs - Gnome Terminal works just fine.

----- Original Message -----
From: "question694061" <email address hidden>
To: "STEVE HAYWARD" <email address hidden>
Sent: Saturday, November 21, 2020 7:20:50 AM
Subject: Re: [Question #694061]: Can't get xterm font to be readable size

Your question #694061 on Ubuntu changed:
https://answers.launchpad.net/ubuntu/+question/694061

    Status: Open => Needs information

actionparsnip requested more information:
Do you have to use xterm? Is there no scope to use Gnome Terminal?

--
To answer this request for more information, you can either reply to
this email or enter your reply at the following page:
https://answers.launchpad.net/ubuntu/+question/694061

You received this question notification because you asked the question.

Steve Hayward (steve-hayward) said : #10

Now I have a wealth of solutions. I've chosen to go with actionparsnip's hint/nudge that led me to be able to select Gnome Terminal instead of xterm - nice and simple. Thanks much for your attentions and help!

----- Original Message -----
From: "question694061" <email address hidden>
To: "STEVE HAYWARD" <email address hidden>
Sent: Saturday, November 21, 2020 8:20:49 AM
Subject: Re: [Question #694061]: Can't get xterm font to be readable size

Your question #694061 on Ubuntu changed:
https://answers.launchpad.net/ubuntu/+question/694061

Manfred Hampl posted a new comment:
There are som esuggestions for yterm in
https://www.youtube.com/watch?v=Zv8BieM0aOk

e.g.
start it with the command "xterm -fa Monospace' -fs 18" (or even bigger numbers)

use shift-numpad_+ to increase the font size

--
You received this question notification because you asked the question.

Can you help with this problem?

Provide an answer of your own, or ask Steve Hayward for more information if necessary.

To post a message you must log in.