Cant ubgrade to ubuntu 18 or above Fio error

Asked by fupazuzi on 2020-10-10

I am running ubuntu 16 and tried to upgrade to 18 or above.
The error message that briefly appears to a black screen :

Could not get fio for li->DevIceHandle: Invalid
Failed to get device path
Failed to find fs Invalid parameter
Failed to load image\EFI\BOOT\grubX64.efi:Invalid
start_image() returned Invalid Parameter
Press any key to continue...

System:
Fujitsu Siemens Lifebook S751

- Intel Core i5-2520 M 2.50Ghz
- 8 GB RAM 80 GB ssd
-Intel® Sandybridge Mobile x86/MMX/SSE2

Here what so far I have done
I have also verified that the system is running on BIOS not UEFI and the processor suports 64bit OS;s
Tried with several versions (18,19, 20 ubuntu and 19,20 Mint) and useddifferent image files from theubuntu and Mint websites.
 I have also tried the native ubuntu bootable usb creator and the MKUSB.
Checked users with similar system and problems that were pointing to make changes in Bios , but simply the BIOS parameters wr'nt there in my system.
What should I do?
Thnak you in advance

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2020-10-12
Last reply:
2020-10-12
Bernard Stafford (bernard010) said : #1

Open the BIOS during computer startup (press and hold either F2 or F10 or F12. Go to the Security section Disable Secure Boot and Fast or Quick Boot. Go to the Boot Order and make USB the first in the Boot Order. Insert the OS on a flash drive in the USB. Select Save and Exit in the BIOS. Computer will restart. You will see the OS on the flash drive start.

Is the system a dual boot or is Ubuntu the only OS on the system?

fupazuzi (fupazuzi) said : #3

The system is dual boot ( Ubuntu 16.04 and windows 7 However I recently
found out that windows do not seem to be working.

On Sat, 10 Oct 2020, 18:41 actionparsnip, <
<email address hidden>> wrote:

> Your question #693388 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/693388
>
> actionparsnip requested more information:
> Is the system a dual boot or is Ubuntu the only OS on the system?
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+question/693388
>
> You received this question notification because you asked the question.
>

fupazuzi (fupazuzi) said : #4

Thank you Bernard
I did disable the fast boot however could not disable Secure boot.
There is a non accessible menu under the bios security tab that accepts no modifications .
https://photos.app.goo.gl/nRsEcRoynE2g9AoN7
How can that be solved?

Bernard Stafford (bernard010) said : #7

Did you try highlighting (Security Chip) TPM Enabled and press Enter change status to Disable. Save (Trusted Platform Module) Secure Boot should be the same way. Highlight the entry - press enter - up and down keys to change to disable enter again to select entry, navigate to different selection Esc key. Save and Exit after you are done.
Did you change the Boot Order to 1st-USB 2nd-HDD 3rd-Network ? If you did it should run the USB you have your choice of Linux to install on it. Are you saving the out of date windows 7? Or starting over with a new install.

fupazuzi (fupazuzi) said : #8

I tried to change the TMP sttings but the security tab doesnät get highlighted. It makes a beep instead showing that this item cant be activated.
Boot order is ok ,

Can you help with this problem?

Provide an answer of your own, or ask fupazuzi for more information if necessary.

To post a message you must log in.