mplayer problem

Asked by hormosapiens on 2007-05-20

Hi

im having problems with mplayer. it cant play anything.
when I click play a movie it says in a window:
fatal error!

error opening/initializing the selected video_out (-vo)device

I tried to configure the vo changing the drivers. 2 of them worked but not properly. I tried them all.

Maybe this info could help.

alex@Hack:~$ mplayer ./configure
MPlayer 1.0rc2-4.2.3 (C) 2000-2007 MPlayer Team
CPU: Intel(R) Pentium(R) 4 CPU 3.00GHz (Family: 15, Model: 4, Stepping: 3)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing ./configure.
File not found: './configure'
Failed to open ./configure.

Exiting... (End of file)

please need help
thank you.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Massimo Forti
Solved:
2007-05-20
Last query:
2007-05-20
Last reply:
2007-05-20

mplayer ./configure is nothing, configure file don't exist and not will be a reproducible file.

You must edit the file:
/home/your_user_name/.mplayer/config
and add or change the "vo" value as:

vo=xv,x11,null

Earth (matt-h) said : #2

Hello.

Your error (thank you for the details) suggests you need to be using a different video output device.

From the terminal, run
mplayer -vo help

to see a list of possible devices. try playing a video using each of xv, x11, gl, gl2 to see which works best. eg
mplayer -vo xv video.mpg

Then on deciding, edit ~/.mplayer/config and/or /etc/mplayer/mplayer.conf and add a line similar to the follow to specify the default device:
vo=gl

I imagine automatix has specified a device you do not possess as the default, so you may need to remove/edit a line starting vo=

hormosapiens (hormosapiens) said : #3

I will try it out now and post the result.
thank you very much.

On 5/20/07, Antonio Pérez-Aranda Alcaide <email address hidden>
wrote:
>
> Your question #6932 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/6932
>
> Status: Open => Answered
>
> Antonio Pérez-Aranda Alcaide proposed the following answer:
> mplayer ./configure is nothing, configure file don't exist and not will
> be a reproducible file.
>
> You must edit the file:
> /home/your_user_name/.mplayer/config
> and add or change the "vo" value as:
>
> vo=xv,x11,null
>
> _______________________________________________________________________
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/ubuntu/+question/6932/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+question/6932
>

hormosapiens (hormosapiens) said : #4

this is my file mplayer/config

can you tell me if something is wrong??

im using fglrx with a ati x1300 res:1440x900 with feisty xserver 7.2 kernel
2.6.20

#
# MPlayer configuration file
#
# Configuration files are read system-wide from /usr/local/etc/mplayer.conf
# and per user from ~/.mplayer/config, where per-user settings override
# system-wide settings, all of which are overrriden by the command line.
#
# The configuration file settings are the same as the command line
# options without the preceding '-'.
#
# See the CONFIGURATION FILES section in the man page
# for a detailed description of the syntax.

##################
# video settings #
##################

# Specify default video driver (see -vo help for a list).
#vo=xv

# Use SDL video with the aalib subdriver by default.
#vo = sdl:aalib

# FBdev driver:
#
# mode to use (read from fb.modes)
#fbmode = 640x480-120
#
# location of the fb.modes file
#fbmodeconfig = /etc/fb.modes

# Specify your monitor timings for the vesa and fbdev video output drivers.
# See /etc/X11/XF86Config for timings. Be careful; if you specify settings
# that exceed the capabilities of your monitor, you may damage it.
#
# horizontal frequency range (k stands for 1000)
#monitor-hfreq = 31.5k-50k,70k
#
# vertical frequency range
#monitor-vfreq = 50-90
#
# dotclock (or pixelclock) range (m stands for 1000000)
#monitor-dotclock = 30M-300M

# Start in fullscreen mode by default.
#fs=yes

# Change to a different videomode when going fullscreen.
#vm=yes

# Override the autodetected color depth, may need 'vm=yes' as well.
#bpp=0

# Enable software scaling (powerful CPU needed) for video output
# drivers that do not support hardware scaling.
#zoom=yes

# standard monitor size, with square pixels
#monitoraspect=4:3

# Use this for a widescreen monitor, non-square pixels.
#monitoraspect=16:9

# Keep the player window on top of all other windows.
#ontop=yes

##################
# audio settings #
##################

# Specify default audio driver (see -ao help for a list).
ao=alsa,

# Use SDL audio driver with the esd subdriver by default.
#ao = sdl:esd

# Specify the mixer device.
#mixer = /dev/mixer

# Resample the sound to 44100Hz with the lavcresample audio filter.
#af=lavcresample=44100

# Specify default audio codec (see -ac help for a list).
ac=mad,

##################
# other settings #
##################

# Drop frames to preserve audio/video sync.
#framedrop = yes

# Specify your preferred skin here (skins are searched for in
# /usr/local/share/mplayer/skins/<name> and ~/.mplayer/skins/<name>).
#skin = Abyss

# Resample the font alphamap.
# 0 plain white fonts
# 0.75 very narrow black outline (default)
# 1 narrow black outline
# 10 bold black outline
#ffactor = 0.75

# cache settings
#
# Use 8MB input cache by default.
#cache = 8192
#
# Prefill 20% of the cache before starting playback.
#cache-min = 20.0
#
# Prefill 50% of the cache before restarting playback after the cache
emptied.
#cache-seek-min = 50

# DVD: Display English subtitles if available.
#slang = en

# DVD: Play English audio tracks if available.
#alang = en

# You can also include other configuration files.
#include = /path/to/the/file/you/want/to/include

hormosapiens (hormosapiens) said : #5

this is my file mplayer/config

can you tell me if something is wrong??

im using fglrx with a ati x1300 res:1440x900 with feisty xserver 7.2 kernel
2.6.20

#
# MPlayer configuration file
#
# Configuration files are read system-wide from /usr/local/etc/mplayer.conf
# and per user from ~/.mplayer/config, where per-user settings override
# system-wide settings, all of which are overrriden by the command line.
#
# The configuration file settings are the same as the command line
# options without the preceding '-'.
#
# See the CONFIGURATION FILES section in the man page
# for a detailed description of the syntax.

##################
# video settings #
##################

# Specify default video driver (see -vo help for a list).
#vo=xv

# Use SDL video with the aalib subdriver by default.
#vo = sdl:aalib

# FBdev driver:
#
# mode to use (read from fb.modes)
#fbmode = 640x480-120
#
# location of the fb.modes file
#fbmodeconfig = /etc/fb.modes

# Specify your monitor timings for the vesa and fbdev video output drivers.
# See /etc/X11/XF86Config for timings. Be careful; if you specify settings
# that exceed the capabilities of your monitor, you may damage it.
#
# horizontal frequency range (k stands for 1000)
#monitor-hfreq = 31.5k-50k,70k
#
# vertical frequency range
#monitor-vfreq = 50-90
#
# dotclock (or pixelclock) range (m stands for 1000000)
#monitor-dotclock = 30M-300M

# Start in fullscreen mode by default.
#fs=yes

# Change to a different videomode when going fullscreen.
#vm=yes

# Override the autodetected color depth, may need 'vm=yes' as well.
#bpp=0

# Enable software scaling (powerful CPU needed) for video output
# drivers that do not support hardware scaling.
#zoom=yes

# standard monitor size, with square pixels
#monitoraspect=4:3

# Use this for a widescreen monitor, non-square pixels.
#monitoraspect=16:9

# Keep the player window on top of all other windows.
#ontop=yes

##################
# audio settings #
##################

# Specify default audio driver (see -ao help for a list).
ao=alsa,

# Use SDL audio driver with the esd subdriver by default.
#ao = sdl:esd

# Specify the mixer device.
#mixer = /dev/mixer

# Resample the sound to 44100Hz with the lavcresample audio filter.
#af=lavcresample=44100

# Specify default audio codec (see -ac help for a list).
ac=mad,

##################
# other settings #
##################

# Drop frames to preserve audio/video sync.
#framedrop = yes

# Specify your preferred skin here (skins are searched for in
# /usr/local/share/mplayer/skins/<name> and ~/.mplayer/skins/<name>).
#skin = Abyss

# Resample the font alphamap.
# 0 plain white fonts
# 0.75 very narrow black outline (default)
# 1 narrow black outline
# 10 bold black outline
#ffactor = 0.75

# cache settings
#
# Use 8MB input cache by default.
#cache = 8192
#
# Prefill 20% of the cache before starting playback.
#cache-min = 20.0
#
# Prefill 50% of the cache before restarting playback after the cache
emptied.
#cache-seek-min = 50

# DVD: Display English subtitles if available.
#slang = en

# DVD: Play English audio tracks if available.
#alang = en

# You can also include other configuration files.
#include = /path/to/the/file/you/want/to/include

Best Massimo Forti (slackwarelife) said : #6

error opening/initializing the selected video_out (-vo)device

Ok, this error is because you haven't select the right vo option. Open a mplayer, select configure (right click mouse --> Preferences) select Video section and after select xv or x11. Restart Mplayer. Thanks

hormosapiens (hormosapiens) said : #7

thank you massimo