Kernel 5.4.0-24-generic breaks networking in 20.04

Asked by rtimai on 2020-04-17

WORKAROUND REPORT
THIS IS NOT A SUPPORT REQUEST

Network is broken after installation of kernel 5.4.0-24-generic by Software Updater. System Settings > Network page displays 'VPN' and 'Network Proxy' and no 'Wired' section. 'Wired Connection' is not shown in the status menu of the GNOME3 topbar. Web browser unable to resolve addresses, no connection.

Most network troubleshooting information online is outdated. LinuxConfig.org provided Focal-specific instructions -- but none of the procedures were successful.

WORKAROUND
I remembered that a kernel update was included in a recent software update, and discovered that reverting to the previous kernel 5.4.0-21-generic restored normal network operation.

Users who have chosen to upgrade early to a Development Release may be left without a connection to research or receive an update that restores connectivity. This information may be helpful BEFORE a dist-upgrade.

~$ dpkg -l | grep linux-image | awk '{print$2}' # LIST ALL INSTALLED KERNELS
...
linux-image-5.3.0-45-generic
linux-image-5.4.0-21-generic
linux-image-5.4.0-24-generic <== BREAKS NETWORKING IN FOCAL
linux-image-generic

~$ lsb_release -d ; uname -rp ; gnome-shell --version ; echo $XDG_SESSION_TYPE
Ubuntu 20.04 LTS
5.4.0-21-generic x86_64
GNOME Shell 3.36.1
wayland

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
Last query:
Last reply:
Revision history for this message
Best actionparsnip (andrew-woodhead666) said :
#1

Yes, the key word here is "Development Release"

If you report bugs you can help get the release ready for release day

Revision history for this message
rtimai (rtimai) said :
#2

Thanks actionparsnip, that solved my question.

Revision history for this message
Manfred Hampl (m-hampl) said :
#3

On my test system with Ubuntu 20.04 and kernel 5.4.0-24-generic wired networking operates normally.
Which network device do you have that is not functioning?

Revision history for this message
rtimai (rtimai) said :
#4

@Manfred_Hampl: I'm sorry you can't replicate. My case may be an outlier,
who knows. I believe NetworkManager was not starting, no way to view
network settings, networking did not exist. My description of what what I
experienced is the best I can offer. I followed LinuxConfig.org
troubleshooting instructions, for multiple ways to start NetworkManager,
all of which failed with no visible errors. The hardware was recognized by
lspci on both kernels 5.4.0-24 and -21. Network operation reappeared and
was restored to normal on 5.4.0-21, all previous settings preserved. I will
report here and pursue further if the network is still disabled in later
kernel versions.

On Fri, Apr 17, 2020 at 3:22 PM Manfred Hampl <
<email address hidden>> wrote:

> Your question #690017 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/690017
>
> Manfred Hampl posted a new comment:
> On my test system with Ubuntu 20.04 and kernel 5.4.0-24-generic wired
> networking operates normally.
> Which network device do you have that is not functioning?
>
> --
> You received this question notification because you asked the question.
>

Revision history for this message
Manfred Hampl (m-hampl) said :
#5

" The hardware was recognized by lspci ..."

What hardware do you have (e.g. output of "sudo lshw -C network")?

Revision history for this message
rtimai (rtimai) said :
#6

FYI ONLY
I finally tracked my issue down to the hardware, Realtek RTL310xE series Fast Ethernet, and the kernel module r8169 used to support it, which has been reported to work poorly since Ubuntu 18+, and now with kernel 5.4+. Fixing it involves compiling the driver from the Realtek source. I'm amazed I did it, and here I am online with kernel 5.4.0-24. Fortunately this is probably not a widespread issue.

Revision history for this message
Manfred Hampl (m-hampl) said :
#7

You might consider creating a bug report about that problem, hoping that a working version of the driver for this hardware be added for future versions of the kernel packages.

Revision history for this message
rtimai (rtimai) said :
#8

@Manfred _Hampl:
 *-network
       description: Ethernet interface
       product: RTL810xE PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:07:00.0
       logical name: enp7s0
       version: 07
       serial: ec:8e:b5:0d:f6:7e
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list
ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8101
driverversion=1.035.02-NAPI duplex=full ip=192.168.1.64 latency=0 link=yes
multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:57 ioport:4000(size=256) memory:c5000000-c5000fff
memory:c5100000-c5103fff
  *-network
       description: Wireless interface
       product: BCM43142 802.11b/g/n
       vendor: Broadcom Inc. and subsidiaries
       physical id: 0
       bus info: pci@0000:0d:00.0
       logical name: wlp13s0
       version: 01
       serial: 44:1c:a8:ae:23:11
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet
physical wireless
       configuration: broadcast=yes driver=wl0 driverversion=6.30.223.271
(r587334) latency=0 multicast=yes wireless=IEEE 802.11
       resources: irq:16 memory:c3000000-c3007fff

I could not find the ubuntu-kernel-network portal (I think it was on
AskUbuntu) so, please feel free to pass this information on to whomever
might find it useful.

You may want to know that this is not the first time I've had network
trouble with networking hardware. I don't know if Realtek and Broadcom are
connected, but I've had driver problems with both. I fixed a Broadcom
BCM43142 driver issue not very long ago for a disabled Bluetooth
connection, which required me to download a driver archive and extract a
specific .bcm driver to a specific system folder location (don't remember.)
Both of these issues appear to be a result of Canonical deciding to drop
support for certain hardware, which is why it doesn't feel very important
to try to notify Ubuntu developers about this. I am glad volunteers like
"ghostrider-reborn" are taking up the gauntlet and offering support. The
source Realtek site is not well documented and notoriously difficult to
navigate. The volunteer github page is an invaluable help, providing the
correct driver, and he provides excellent instructions for compiling and
activating the driver. His instructions are also in the README.md file in
the .zip archive.

https://github.com/ghostrider-reborn/realtek-r8101-linux-driver

Roger T. Imai
Franklin TN USA
Ubuntu 20.04 LTS <=== NO LONGER BETA ! ! !
5.4.0-24-generic x86_64 <=== CURRENT KERNEL ! ! !
GNOME Shell 3.36.1 on Wayland (Xwayland)

On Sat, Apr 18, 2020 at 6:19 AM Manfred Hampl <
<email address hidden>> wrote:

> Your question #690017 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/690017
>
> Manfred Hampl posted a new comment:
> " The hardware was recognized by lspci ..."
>
> What hardware do you have (e.g. output of "sudo lshw -C network")?
>
> --
> You received this question notification because you asked the question.
>

Revision history for this message
rtimai (rtimai) said :
#9

@Manfred_Hampl: I'm sorry, I gave you the wrong information in mentioning
my previous Bluetooth fix.The driver file that had to be placed was a file
called */usr/lib/firmware/BRCM/BCM43142A0-0a5c-216d.hcd* . If I recall
correctly, it was not a replacement, but restoration of support which was
non-existent for the Broadcom wireless network interface card. The NIC
appears in the 'lshw -C network' listing I sent earlier.)
--Roger

Revision history for this message
Manfred Hampl (m-hampl) said :
#10

If the cause of your problem is a missing firmware file, then this needs a different solution (not a change of the kernel packages, but an addition to the firmware package).

Revision history for this message
rtimai (rtimai) said :
#11

@Manfred_Hampl
Kernel 5.4.0-24 was updated again today, to 5.4.0-25, and it again broke my ethernet connectivity. The kernel modules are setting the networking drivers, so it is the ubuntu-kernel team that should update the network drivers in linux-modules or linux-modules-extra. I sent an updated message to the ubuntu team site (I found it again) below, but oddly, it looks like the ubuntu-kernel-network team has no active projects! So, now what?

 https://launchpad.net/~ubuntu-kernel-network

SUMMARY:
If you are on a Wired ethernet connection, and you enter 'sudo lshw -C network' -- if you see 'RTL810xE PCI Express Fast Ethernet' you need to replace the r8619 driver with the Realtek-provided r8101. Help at:

 https://github.com/ghostrider-reborn/realtek-r8101-linux-driver

If you are on a wi-fi (Wireless) connection and your lshw listing shows 'Broadcom Inc. and its subsidiaries' you may need to ADD a Broadcom-provided driver. Broadcom Wireless (integrated wi-fi and Bluetooth) is complicated by discrepancies in the naming of modules requested by the kernel. This volunteer on github explains, and provides help. It helped me -- but YMMV (your mileage may vary, i.e., your results may vary):

 https://github.com/winterheart/broadcom-bt-firmware

The complexity of driver issues may be a reason kernel 5.4.24+ no longer appears to support this Realtek-Broadcom hardware module. Well, anyway, these two resources were a life-saver for me. Thank you winterheart and ghostrider-reborn. I think they are both Chinese, and I hope they stay well in the coronavirus pandemic!

CAUTION: Anyone with the above hardware should download the wired and wireless drive archives immediately, because any kernel update will leave you with no connection. Explanations and instruction are provided in the README.md files in each archive.

In an emergency with no second computer, you can revert to booting with kernel 5.4.0-21 or earlier, which will temporarily restore your networking. You may have to hold down the Shift key to see the boot menu. Also, I think you should make sure you are booted on the current kernel when you perform the driver fix procedures.

Roger

Revision history for this message
rtimai (rtimai) said :
#12

@Manfred_Hampl
I just read through the extensive dmesg listing, and the Realtek driver that replaces the non-working r8169 is proprietary.

[ 589.644101] r8101: This product is covered by one or more of the following patents: US6,570,884, US6,115,776, and US6,327,625.

Have not found a notice for the Broadcom modules, but it's likely they too are proprietary.

This means that Canonical wil not include it in their kernel distributions, and support will have to remain third-party, by our github volunteers.

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#13

It's the firmware that is proprietary but you can use your own firmware in your own system to make it work.

Personally I like to buy hardware that I know will work out of the box with zero effort.

Revision history for this message
rtimai (rtimai) said :
#14

COMMENT UPDATE: FYI, yet another kernel upgrade to 5.4.0-26 today, and again networking disappeared. The procedure provided by "ghostrider-reborn" in msg #11 above once again fixed everything.

So, kernel 5.4.0-21 supported RTL810xE PCI Fast Ethernet. Kernel upgrades 5.4.0-24 , -25, and -26 appear to have dropped support for this module in the r8169 driver. Replacing the r8169 with the Realtek-provided r8101 driver restores connectivity. I think the drivers are included in the linux-modules-extra package.

Ubuntu 20.04 LTS
5.4.0-26-generic x86_64
GNOME Shell 3.36.1
wayland

This will be my last update to this thread, for ubuntu-kernel developers' eventual reference, if at all.

Revision history for this message
Manfred Hampl (m-hampl) said :
#15

If your intention was a dialogue with the kernel developers, then this is the wrong medium for that purpose.
To get he attention of kernel developers, you should create a bug report with all relevant details.

Revision history for this message
Johnsandman (info-tvnr) said :
#17

Yes here same to me no network anymore and my 'double desktop ' screen was changed Not the old fashion I had before. I am using kubuntu 20.04