Screen flickering with Firefox full screen

Asked by Antonio on 2009-04-24

Ubuntu 9.04 just installed, Gnome 2.26.1, Firefox 3.0.9, Compaq nx6110. (Also observed in Ubuntu 8.10).

1. Firefox windows in full screen mode cause screen to flicker (alternating firefox and desktop) when firefox window is about to become the active one with Alt+Tab window switching events.

2. Some events in full screen Firefox window, like right mouse click on links, combo pop-up or Ctrl key pressed to mark mouse position, make screen to flicker the same way.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Sam_
Solved:
2009-04-27
Last query:
2009-04-27
Last reply:
2009-04-25
Tom (tom6) said : #1

To fix the flicker go up to the top taskbar and click on

Applications - Accessories - Terminal

and type in (or copy & paste with mouse right-clicks)

gstreamer-properties

Click on the "Video" tab and change the top option "Output" from "Auto" to " ... (No Xv)". I don't think it even needs a reboot!

Good luck and regards from
Tom :)

Tom (tom6) said : #2

Sorting out flash movies is just by downloading from one of these sites

64bit http://labs.adobe.com/downloads/flashplayer10.html
32bit http://get.adobe.com/flashplayer/

and use the "Select version to download" to get the deb/Ubuntu version. I think this install automatically but you might have to double-click the download. Sorting the rest of the multimedia and the graphics is a bit of a pain tho.

https://help.ubuntu.com/community/Medibuntu

but for sorting the latest drivers for your graphics card we would need to know if it's intel, ati or nVidia and that should finally sort out almost everything.

Antonio (antodasana) said : #3

Hi Tom, thank your very much for your answer.

Unfortunately I'm still having the problem. I began noticing it in 8.10 (my 9.04 is a new install, not an upgrade); it didn't happen in 8.04, same computer. Besides, it's happening in at least other laptop I have installed 9.04 too. That's the reason I think this is a bug.

Regarding flash movies I don't understand what you mean; never asked about it.

Anyway the video card is:

Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)

Regards.
Antonio.

Tom (tom6) said : #4

Hmm, you tried the "gstreamer-properties" settings?

Antonio (antodasana) said : #5

I did as exactly you pointed it out, even rebooting the system.

gstreamer-properties -> Video -> Salida -> Complemento -> change "Detectar automáticamente" for "X Window System (Sin Xv)"

I have also tried with all other output options with same results.

I have tried with my non-su account.

Navneet (navneet-ts) said : #6

Hi!

I upgraded my system from 8.10 yesterday and this strange ficker started. I don't have it as a continuous flicker and neither is it while I switch back to Firefox. I have a single flicker when the mouse is moved after the system has been idle for about a minute. I had the power on always.

I never had a issue in 8.10 and think it is some bug in 9.04. But I don't have the expertise to explore the issue.

And I did try the solution that Tom suggests, but still no success.

Best Sam_ (and-sam) said : #7

It might be related with Compiz.
If it's gone when turning off visual effects it might have to do with Compiz (3D accel) or graphic card(driver).
system -> appearance -> visual effects = none

Or test settings in Compiz config manager CCSM (system preferences).
General options -> dispaly settings
Sync to VBlank
Refresh Rate
Detect refresh rate
Detect Outputs

General options -> general
Unredirect Fullscreen Windows

Back to main menu.
Check settings in section Utility -> workarounds

Reference:
http://wiki.compiz-fusion.org/CCSM
http://wiki.compiz-fusion.org/

Navneet (navneet-ts) said : #8

Hi Sam!

I have Compiz turned off. The other things that you speak about are not found in the Ubuntu Preferences.

I tried the command line to configure compiz and it exits with the following message. It also makes the minimize/maximize/close buttons disappear and I can't close any windows. The command line error is here.

navneet@hammerhead:~$ sudo compiz-manager
[sudo] password for navneet:
Checking for Xgl: not present.
xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log
Blacklisted PCIID '8086:2a02' found
aborting and using fallback: xterm
no xterm found, exiting

Sam_ (and-sam) said : #9

>Blacklisted PCIID '8086:2a02' found

Your graphic card is blacklisted in usr/bin/compiz
http://wiki.compiz-fusion.org/Hardware/Blacklist

Please note, it's not recommended to start graphical apps e.g. compiz or alike with administration privileges.

However if you don't need Compiz you may stick with metacity (default window manager in GNOME). You shouldn't have any flickering with metacity. In case you may also deactivate composite option in metacity (however you have to when running compiz).

How to start metacity in a terminal:
metacity --replace

To turn off composite in metacity open from a terminal:
gconf-editor

Navigate to /apps/metacity/general -> disable -> compositing_manager ##if it was activated at all

Diagnostic:
To find out if metacity is running:
ps -ef | grep metacity

To find out if compiz is running:
ps -ef | grep compiz

In case you'd like to test compiz inspite of your graphic card you may edit xorg.conf
First make a backup of the file in case to restore it via recovery mode.
Please open a terminal type or copy&paste:

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.old

Open xorg.conf:

gksudo gedit /etc/X11/xorg.conf

add to device section:
        Option "AccelMethod" "EXA"

Save the file.
Restart Xsever by logout/login

Testing of:
glxinfo | grep direct

You may check again in appearance -> visual effects (should be the last tab)
if you can enable any effects - Normal or Extra -.

To find error messages use logfiles, e.g. Xorg.0.log (in system adminstration -> system log)
or .xession-errors (hidden in /home/user)

In case for a variety of configuratin options CCSM can be installed via Synaptic.
It will appear in system preferences.
Or can be started in a terminal:
ccsm

Reference:
https://help.ubuntu.com/community/LinuxLogFiles
Example of other options in xorg.conf
http://launchpadlibrarian.net/20233613/xorg.conf

Antonio (antodasana) said : #11

Thanks Sam, that solved my question.

Antonio (antodasana) said : #12

HI Sam.

In my case disabling visual effects has worked it out. 9.04 had installed 'Normal' by default.

I find CCSM very interesting, I will test it some other time. By now, I guess my graphical card simply isn't powerful enough.

Thank you and regards.
Antonio.

Bwayne (bwayne7777777) said : #13

Hi Guys

I upgraded to Jaunty 64 bit version less than a week ago.

I'm running an old eMachine athlon 3200 64 and an ATI Radeon 9600, 2gb ram This old workhorse does just fine with Ubuntu.

I had the same Firefox full screen flicker. My screen does not flicker in non-fullscreen mode. I tried the suggestion above (regarding gstreamer-properties) and also disabled compiz....... still flickered! So I restored my settings to their original values.

Then very unscientifically, I noticed the screen only flickered when tooltips were active as I hovered the mouse over tabs or icons in the slide-down (hidden) menubar. Each time I moved the mouse slightly, a tooltip would pop-up and I would get the annoying full screen flicker.

So, I decided to disable tooltips, see this page
http://phalkunz.com/2006/10/30/disable-annoying-firefox-tooltips/

Flicker stopped! It worked for me and I hope it works for you.

This must be a bug with Jaunty because I did not have the problem with 8.10. I like tooltips but the screen flicker was just too annoying. I guess I'll have to wait for a bug fix before I re-enable my tooltips.

Regards
Bwayne

PS I don't know if this is somehow related to the above problem, but my Google-Earth was working in 8.10 and now it no longer works in 9.04. GE freezes on startup and causes me to perform a "forced-close." I suspect GE might need an upgrade for Jaunty as it just barely worked for me under 8.10. (lots and lots of screen flickering). I reduced GE flickering in 8.10 by changing the screen resolution.

Antonio (antodasana) said : #14

Hi Bwayne.

In my case it doesn't work, still flickering.

It seems this is a bug.

Regards.
Antonio.

Bwayne (bwayne7777777) said : #15

Hi Antonio

Sorry to hear my little temporary "fix" didn't work for you.

I agree. Jaunty appears to be very buggy.

The dreaded "screen flicker" has reared its ugly head in several other areas on my computer. I had not noticed them before because I just upgraded to Jaunty and have not had the chance to thoroughly examine Jaunty.

Other really weird things are occuring. For example: Thunderbird worked perfectly with 8.10 now it is mal-functioning with 9.04. Sometimes Thunderbird will work properly and sometimes it decides it won't get or send email. I have other problems too but this is not the forum for those problems as we are concerned here with "screen flicker."

I would like to repeat that the following problems only involve Firefox in full screen mode. That is the mode where you press the F11 key to maximize your screen real estate when browsing. I don't get any "screen flicker" when using Firefox in non-full screen mode. Also, curiously I don't have any screen flicker with Thunderbird even with tooltips enabled. This is puzzling because you would think the code is written in the same fashion for both programs by Mozilla.

Here are the two additional instances where I get "screen flicker."

1. I use Gmail notifier to let me know when an email arrives in my inbox. If I have Firefox onscreen in full-screen mode when my Gmail notifier slides down from the system tray............ I get screen flicker!

2. If I am on a web page in F11 mode and I hover the mouse over a thumbnail of a video...... I get screen flicker!

I left the "wonderful world" of Windows about 6 months ago, so I'm a noob when it comes to Ubuntu. But I'm seriously considering reverting back to 8.10. The only probem is that I'm not sure if 8.10 will still be fully supported regarding things like security upgrades and repositiories.

Best Regards
Bwayne

I apologize in advance if I don't respond immediately to any inquiries as I am going on vacation in a few days and will be gone for 2 weeks. But I will get back to you.

Tom (tom6) said : #16

Great to hear a number of solutions have worked to cover different instances of flickering. As they are neatly collected in one place i thought i would link to an old bug-report about screen-flicker. Thanks Sam and Bwayne, also Antonio of course for making this an excellent thread for the "Solved Answers" database :)

@ Bwayne
8.10 is fully supported for another 12 months approximately, until just before the release of 10.04, but we tend to find a lot of improvements in the new release happen, usually in the couple of weeks immediately after release because significantly more people post bug-reports :) Good luck on your hols, hope you have as much fun as i have just had :)

Thanks and regards to all from
Tom :)

Daniel Holbert (dholbert) said : #17

There's a single 'gconftool' command that fixes (or works around) this bug here:
https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/153204/comments/12

No need to restart window manager or anything -- it worked for me immediately after running the command.

apepin (andre-pepin) said : #18

Works for me :),
Thanks Daniel.

Chris W (chriswininger) said : #19

I use Jaunty with an Dell E6600 laptop. The video card info is as follows

"00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)."

This is an Intel dual core system with 3 gigs of ram. The place I seem to get screen flicker is running flash movies in full screen. I can play other types of media in full screen fine, but as soon as I maximise a flash video I get this crazy flickering back and forth between the flash video and components of the web-page it's being displayed on.

I have another machine, an old e-machine running the same version of Ubuntu and firefox. It does the same thing.

It sounds like this may be a variant of the same bug others are describing here. I have tried everything suggested on this forum so far and have had not luck. If anyone has any thoughts let me know. Thanks.

Bwayne (bwayne7777777) said : #20

Hi Chris W

I am responding to you as a result of your question via an email forwarded to me through Launchpad.

I can't believe how slick and seamless Launchpad is.

I had the screen flicker problem about 3 months ago on my eMachine T6000 (see my post above referring to Question #68456 under Bwayne).

My screen flicker problem was resolved due to the very kind suggestion offered by Daniel Holbert regarding the Compiz bug (see Daniel's link on this thread, #68456). I am happy to report I have re-enabled my tooltips and I get absolutely no screen flicker.

Hope it works for you too.

Regards
Bwayne

By the way, I decided to stay with Jaunty and I am looking forward to Karmic.

Chris W (chriswininger) said : #21

Thanks for the replay. I tried that fix. It did not completely fix the problem but it did have an interesting result. The problem is less severe. When I had that flag turned on not only did the screen flicker in full screen streaming flash videos, but sometimes the play back of audio would seem to slow with the flicker. After flipping off the full screen flag as suggested by bug #153204 the full video is more watchable. It still flickers quite a bit but the audio isn't affected by the flicker and the flickers seem to be a little less frequent.

Flicker may be the wrong word. It's like a problem in the paint method of the application. Pieces of the website hosting the stream momentarily show through along with white lines.

In any event your suggestion definitely had an impact but did not completely fix the problem.

Thanks again and let me know if you have any other thoughts.

Tom (tom6) said : #22

Errr, please forgive me if this has already been tried or suggested in one of the links or something but on a command-line
https://help.ubuntu.com/community/UsingTheTerminal
try typiong

gstreamer-properties

in the box that pops up click on the "Video" tab and change "Output" to "...(No Xv)", sorry i can't quite remember what the full line says. It's worth remembering what it was set on before in case this has no effect - then you could switch it back.

Good luck and regards from
Tom :)

Chris W (chriswininger) said : #23

Unfortunately I have tried this. It was mentioned earlier in the thread. In my case it did not help.

I ran the line suggested by Daniel Holbert
           gconftool-2 --set /apps/compiz/general/screen0/options/unredirect_fullscreen_windows --type bool 0
This helped a little bit but did not fix the problem completely. I also turned off tool tips as suggested in this thread. It did not appear to do anything.

Thanks for the advice though. It seems like Linux still has a lot of problems with Full screen flash.

Tom (tom6) said : #24

My full screen flash is working fine even without decent drivers for my ati card! Apparently there are a lot of troubles with intel cards at the moment
http://distrowatch.com/weekly.php?issue=20090817#feature

I haven't read the article but Caitlyn is usually good at giving links and good advice so i'm looking forward to reading it sometime, maybe tomorrow. If she does help please let us know what you did that finally fixed it.

Since this question was originally posted by someone else and is marked solved i would recommend re-posting your question as a new question but keep it as brief as you reasonably can
https://answers.launchpad.net/ubuntu/+addquestion
you can always use the url link back to here if anyone wants details
https://answers.launchpad.net/ubuntu/+question/68456

Getting fresh eyes on your particular problem might help a bit more especially since there are usually quite a few people passing the front-desk during the course of a day but there's very few of us in these old questions.

Good luck and regards from
Tom :)