Bluetooth dysfunctional in Xubuntu 18.04

Asked by Jesse Stern on 2018-09-13

Hello, I'm having trouble with Bluetooth in a basic and fully updated install of Xubuntu 18.04. If I try to turn Bluetooth off in the xfce panel, nothing happens. If I exit the panel applet, it disappears from the Panel tray (as expected) but then I am unable to restart bluetooth. (Error: `Bluez daemon is not running, blueman-manager cannot continue. This probably means that there were no Bluetooth adapters detected or Bluetooth daemon was not started.`)

I have searched here and on SO, tried every suggestion on this thread (https://ubuntuforums.org/archive/index.php/t-1174624.html), but none of them seems to have any effect.

For example, when disabled, if I `sudo service bluetooth start`, nothing happens. if I `sudo bluetoothd`, the terminal stops responding and sometimes (but not usually) the bluetooth applet icon returns to the panel tray. If I run `hwinfo --bluetooth` or `sudo lshw | grep "bluetooth" -i` I get nothing. On a previous install of Ubuntu Studio, Bluetooth seemed to work OK. Could this indicate a missing driver? Do I need to manually install a driver for Xubuntu?

I rarely use bluetooth, so disabling it is an option, but basic functionality would be nice (i.e. the ability to turn bluetooth off/on).

FWIW, I posted this question back in August on AskUbuntu, and got the Tumbleweeds badge :/ so any reply, link, or suggestion would be helpful. Please and thank you.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2018-09-29
Last reply:
2018-09-30
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Jesse Stern (nl1k) said : #2

Anyone?

Sent from my iTypeOnThisThing

> On Sep 29, 2018, at 01:32, Launchpad Janitor <email address hidden> wrote:
>
> Your question #673813 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/673813
>
> Status: Open => Expired
>
> Launchpad Janitor expired the question:
> This question was expired because it remained in the 'Open' state
> without activity for the last 15 days.
>
> --
> If you're still having this problem, you can reopen your question either
> by replying to this email or by going to the following page and
> entering more information about your problem:
> https://answers.launchpad.net/ubuntu/+question/673813
>
> You received this question notification because you asked the question.

Manfred Hampl (m-hampl) said : #3

You could try some extended diagnostics, e.g. installing the package bluez-tools and executing the commands "bt-adapter --list" and "bt-adapter --info".

What output do you receive for the command
systemctl status bluetooth
If it is not running, you could try starting it with
sudo systemctl start bluetooth

Can you help with this problem?

Provide an answer of your own, or ask Jesse Stern for more information if necessary.

To post a message you must log in.