how to install Jaunty alternate install from USB?

Asked by Brandon Williams on 2009-04-02

Is there a process that works for installing Jaunty to lpia from a USB stick?

Here is what I did:

1. Used usb-creator to install ubuntu-9.04-beta-alternate-lpia.iso from here:

2. Downloaded vmlinuz and initrd.gz from here:
and copied those two files into the install directory on the usb drive, overwriting the files that were already in the directory after step 1

3. Copied the .iso file onto the usb drive.

After each step, I attempted the installation. Here are the results:

1. System boots into console-based installation, but it cannot find the installation media.

2. System boots into console-based installation, but it cannot find the installation media.

3. System boots into console-based installation, and then begins to recursively attempt to detect hard drives, which never completes and just keeps being run over-and-over.

Is there a key step in the process that I am missing? Is there a completely different method that I should try? Is there some specific set/type of information that would be helpful in debugging the problem?

Craig Huffstetler (xq) said : #1

You just don't copy the .ISO file to the drive. You also must ensure that your BIOS on your P.C. supports "booting" from USB. This is usually accomplished by pressing F2, or another key, when your PC first "comes on" (or starts to boot up) and going to the "Boot Sequence" and selecting USB as the first thing it looks for. You have to reset this later on.

Let's start with the USB. First you can move the .iso file off of the USB drive.

The best thing I can tell you is to read this (it's the best thing):

That will tell you everything you need to know.

The program you need to prepare your USB Drive is UNetbootin described further down on that page. From there on out the page will be your guide. I hope that helps :-)

Craig Huffstetler (xq) said : #2

And this is even quicker, easier and I realize you might not be in Linux:

Also, please keep in mind there is a Windows installer available! You can read about it here:

Cheers! I hope you have a great day. Let me know if I can help along the way.

Thanks for trying Craig. Your suggestions do not apply to my question, though. Maybe I need to clarify what I did.

I used usb-creator, which takes an ISO image and installs it to a USB stick so that you can boot off of the USB. After booting from the USB stick that was prepared in this way, the installation program starts. However, it wants to find the installation media on CD, and there is no CD. It won't just look on the USB stick.

So, I then downloaded hd-media vmlinuz and initrd.gz files for my architecture and copied them into the install directory on the USB stick. Now when I boot from the stick, it is look for an ISO on either the stick or the hard drive, rather than looking for a CD. That's what the hd-media versions of vmlinuz and initrd.gz are supposed to make it do. However, there's no ISO for the installer to find.

So, I copied the ISO onto the USB, along with all the other stuff that's already there. Now when I boot from the stick, the installer enters a recursive loop of trying but failing to detect hard drives. I have to press Ctrl+Alt+Delete to make it stop.

It would be great if someone who is knowledgeable about USB installation using the Jaunty beta alternate install ISO would comment. My method looks like one that should work, as per the instructions here:

Craig Huffstetler (xq) said : #4

What version of usb-creator are you using? It appears that the version (usb-creator 0.1.15) that is "shipping" with Jaunty Beta has quite a few bugs associated with it, like the one you describe (looking for a CD).

It also appears that there are multiple bugs filed again Unetbootin for problems that do not create bootable USB media. I encourage you to add to the bug list so that we can work on the issues.

One quick question:
Can you try to use an earlier version of usb-creator and see if it will burn the media properly?

I am not adding this as an answer, only an information request. I am just trying to find an alternate solution for you.

This may be a bug in the Linux kernel itself, on the USB image we provide, just from looking at your last reply. The recursive loop is what worries me.



See bugs: 346700, 349786, 349974, 353274 (there are a few more...)

Another alternative is to install Intrepid (via USB) and then upgrade after the install. I'm sorry for the problems.

I am using usb-creator version 1.1.10 for Hardy from here:

I'm having a hard time figuring out whether usb-creator is actually intended to support installing the alternative install disk to USB. Maybe it's just meant for live-cd images, which I've used it for successfully in the past.

The next things I will try are:
1. carefully follow the "Manual Approach" method from the Installation/FromUSBStick
2. install from the MID USB image and the convert it over to a standard install

I tried the MID image, which boots, but gives me a non-functional pointer. I tried the "Manual Approach" from the wiki page, but it's effectively no different than my procedure using usb-creator and the couple of extra steps. It failed in the same way.

For testing purposes, I tried my method with the equivalent Intrepid image and kernel, and it works much better ... it recognizes the hardware and finds the ISO, just as it should. I'm convinced now that this is a problem with the lpia hd-media kernel in Jaunty, not my procedure, so I will open a bug.

If anyone comes across way to install lpia Jaunty from a USB stick, I'll be happy to hear about it.

Craig Huffstetler (xq) said : #7

Please let me know the bug # so I can tie it to this question, thank you.

Looks like you found bug 354226 and linked it in already. Thanks.

Arnaud Soyez (weboide) said : #9

I confirmed your bug report.

What I did to install a CLI system is I used the MID Live lpia iso, and when it gets into the graphical interface, I pushed ctrl+alt+f2 to switch to another TTY. And then I installed using cdebootstrap. This is quite an expert installation and it is very long and hard to do.

Here are my notes for the installation, DO NOT use if you don't know what you are doing, or if you are a beginner:

Install from the alternate installation media now works. Here are the details of the process as it currently stands:

1. download required files:
    a. the lpia alternate install ISO from here:
    b. vmlinuz and initrd.gz image from here:

2. use usb-creator to install the alternate install ISO to a USB stick

3. copy the hd-media vmlinuz and initrd.gz into the install directory on the USB stick
     (e.g. if the USB stick is mounted as /media/disk, copy to /media/disk/install)

4. copy the ISO image onto the root of the USB stick (e.g. /media/disk in the above example)

5. boot off the USB stick and run the installer
    a. It will warn you: "No installable kernel was found ...". Continue without a kernel for now.
    b. Eventually, after everything else is done, the grub installation step will fail.
          i. Press Alt+F2 to switch to a console prompt.
         ii. Install the kernel:
              # chroot /target
              # apt-get install linux-lpia
        iii. Press Alt+F1 to switch back to the installer and repeat the grub install step.
    c. The installation is complete now. Reboot into Jaunty.

Arnaud Soyez (weboide) said : #11

Wouldn't it be better to use daily ISO releases ? (from )

Emmet Hikory (persia) said : #12

    Could you try that again, skipping the step of copying the hd-media kernel and initrd.gz? Those shouldn't be required in order to install from a USB stick.

The combination of bug 355376 and some comments in the Installation/FromUSBStick guide led me to the mistaken assumption that the hd-media kernel and initrd.gz were required for this installation. Now that bug 355376 has been fixed, USB stick installation from the lpia alternate install ISO works without any special steps required. I used usb-creator version 0.1.10~hardy1.

Simply use usb-creator to create a USB startup disk from the ISO, boot from the USB stick, and follow the prompts.

I was a little premature with my previous comment. The installation was successful, but the linux-lpia meta package was not installed. As a result, the kernel module for the dell mini's wireless card was not available.

I mounted the USB stick as /media/cdrom0, enabled the cdrom apt-get source, and installed linux-lpia. After that, the wireless module was available (sudo modprobe wl).

This is the only glitch that I've noticed.

ski (skibrianski) said : #15

I'm having the same problem with the lpia intrepid RC. I find it quite frustrating that canonical is focusing on selling its lpia solution to resellers without making the regular installation work properly.

Arnaud Soyez (weboide) said : #16

Ski, bug 354226 and bug 359174 are fixed (see Related bugs on the right side of this page).
Can you try again with the daily built iso from: ?

Craig Huffstetler (xq) said : #17


Arnaud's comment should resolve your question. We have tested this quite a bit and found that the daily builds have incorporated the fix. If not, please let us know what is going wrong and post a bug.

Thank you!


Bug 354679 does not exist in the Intrepid MID image. If the other two bugs (fixed in Jaunty) are present in the Intrepid alternate install ISO image, then I suggest that you perform your initial Intrepid install with the MID image and then add/remove packages as necessary to end up with a full Intrepid lpia install.

As the others have done, I also encourage you to open bugs against the Intrepid installer when you encounter them.

Please note, though, that this question was intended to be Jaunty specific, and with the resolution of the two bugs Arnaud mentioned, the question is solved for Jaunty, to the best of my knowledge.

ski (skibrianski) said : #19

Oops - I typed intrepid when I meant jaunty. I meant the jaunty RC. Thanks for your tip about linux-lpia, Brandon, that was very handy for me. I haven't tested the daily yet, but I can only assume it fixes 359174, too. Cheers.