black screen,no Graphic Login screen to get to desktop

Asked by dontgetshocked on 2007-05-05

I new to ubuntu but have loaded on my playstation no problems, so I put it on my laptop(netbook) anyways I added 9 must software and a feww more in add/remove programs I rtied to boot after ubuntu logo comes and and then few black screens blinks then no login busted graphics at the top of the screen worked perfect before I was adding stuff getting a feel of the OS can someone help me? ussoldier73 on yahoo mail

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
dontgetshocked
Solved:
2007-05-07
Last query:
2007-05-07
Last reply:
2007-05-05

Sure;y there is some code to fix this without losing everything and starting over again.

Massimo Forti (slackwarelife) said : #2

Thanks for your question.
When you boot the ubuntu you recive some errors ??? like xorg error (windows blue like dos), or you have not problem ???
Thanks

I dont receive any errors because no screen appears after the startup screen. In other words the next screen, the login screen does not appear, it just hangs there waiting with the mouse cursor spinning.

Massimo Forti (slackwarelife) said : #4

you recive a message like localhost@localdomain:

Thanks

No, I dont receive ANY errors, no screen appears after the boot menu. I get to the part where the login screen should appear but it does not appear.

Massimo Forti (slackwarelife) said : #6

black screen ??? :O
Try this:

ctrl + alt + F1

what you recive ???

thanks

I can get to the text mode desktop screen as i mentioned before. This is where I tried using code such as sudo dpkg-reconfigure xserver-xorg with no results.

Massimo Forti (slackwarelife) said : #8

but if you do a startx command what do you recive like a output on the screen ???

thanks

Massimo Forti (slackwarelife) said : #9

but if you do a startx command what do you recive like a output on the screen ???

thanks

Please review all previous posts. When I input the code startx I get a message that it is already started, but nothing happens like a login screen appearing. The mouse cursor just keeps going with a blue screen, nothing else happens.The screen does a requery and then, again no other information is displayed.

Massimo Forti (slackwarelife) said : #11

Ok, you can do this:

$: sudo /etc/init.d/gdm stop

this stop you xserer, after do startx

let me know, thanks

burrina (mynotebook) said : #12

Ok, I now have Ubuntu loaded after trying the code; However the mouse cursor is a black X and I have no Minimize/Maximize or Close buttons on any of my windows. Also, when i choose System/Administration/Login Window, I get the following error message; Failed to run gdm setup as root, unable to copy user's xauthorization file.

What should I try next?

Thanks,

burrina (mynotebook) said : #13

I just now clicked on the desktop effects and enabled and then disabled it and now the windows have buttons and my mouse is normal again. I am afraid to re-boot or logoff since i fear more errors will occur. Now what do you suggest?

burrina (mynotebook) said : #14

Failed to run users-admin as root unable to copy the users xauthorization file is the message I get when I try to use anything under the System/Administrative Menu.

What do you suggest i do to fix this ?

burrina (mynotebook) said : #15

Now, I also have NO sound either using Amarok or thru Thunderbird.

burrina (mynotebook) said : #16

I opened a terminal and used this code to try and get back my user settings; sudo chown username ~/.Xauthority && chmod 775 ~/.Xauthority
This worked to allow me to open users and groups but not login window.
you might in fact be using a different display manager, such as KDM (KDE Display Manager) or xdm. If you still wish to use this feature, either start GDM yourself or ask your system administrator to start GDM.

Now when I try and open the Login Window thru System/Administration I get this error;
GDM Gnome Display Manager is not running
You might in fact be using a different display manager, such as KDM (KDE Display Manager) or xdm. If you still wish to use this feature, either start GDM yourself or ask your system administrator to start GDM.

What should I try next?

Thanks for all your help, I re-installed and so we can consider this post closed.

Thanks Again...

Hi,
I'd like to see a solution for this as I am experiencing the same problem. It started when I changed the login screen to one of the other choices. I don't remember the name, but it is quite similar to the default one, but blue. I think it was the first available choice on the list that comes with Ubuntu 7.04. I also activated automatic login *and* timed login to make the given user log in automatically after 30 sec. Then I rebooted, and the problem was a fact.

I'd like to mention that I'm using Gnome, but in order to run Kontact etc. I installed kubuntu-desktop, but never started a KDE-session. However, I have been using Ubuntu 7.04 with Gnome for several days before I made those stupid changes. I can log in using recovery mode. This gives me root access to the command line, but I don't know my way around in CLI. I'm also afraid of making a mistake that might crash my system for good.

I can also edit text-files with nano
Is there a way I can get the default Ubuntu login screen back and undo the automatic login settings I made, using the command line / editing some configuration file?

Bjorn Hakon
Oslo, Norway

Bjørn Håkon Mathisen wrote:
> Your question #6130 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/6130
>
> Bjørn Håkon Mathisen posted a new comment:
> Hi,
> I'd like to see a solution for this as I am experiencing the same problem. It started when I changed the login screen to one of the other choices. I don't remember the name, but it is quite similar to the default one, but blue. I think it was the first available choice on the list that comes with Ubuntu 7.04. I also activated automatic login *and* timed login to make the given user log in automatically after 30 sec. Then I rebooted, and the problem was a fact.
>
> I'd like to mention that I'm using Gnome, but in order to run Kontact
> etc. I installed kubuntu-desktop, but never started a KDE-session.
> However, I have been using Ubuntu 7.04 with Gnome for several days
> before I made those stupid changes. I can log in using recovery mode.
> This gives me root access to the command line, but I don't know my way
> around in CLI. I'm also afraid of making a mistake that might crash my
> system for good.
>
> I can also edit text-files with nano
> Is there a way I can get the default Ubuntu login screen back and undo the automatic login settings I made, using the command line / editing some configuration file?
>
> Bjorn Hakon
> Oslo, Norway
>
>
After pressing ALT-F2 which gets you to the command line type in the
following commands.
sudo /etc/init.d/gdm restart
See if that gets you in, otherwise type in this command
sudo /etc/init.d/gdm stop
then type in startx
Hope this helps

--
Freedom to choose, "Linux" , the peoples operating system.

Thanks! That helped.
The commands
sudo /etc/init.d/gdm stop
startx
did the trick, but in order to access Administration -> Login screen, I had to start gdm. Then I was able to make the changes needed. Now the system is back in business again.

Actually, I pressed ALT+CTRL+F2, and that opened tty2. I entered all the commands from here, and the black screen with the spinning mouse-pointer was back. Pressing ALT+CTRL+F7 brought me back to the x session, and now when gdm was started, I could change anything I liked. BUT ... With every change I made, the "bad-screen" came back. I figured that I was thrown back to tty2, so I just pressed ALT+CTRL+F7 and could continue to change settings. After a restart, everything was normal.

Thanks again!

Bjorn Hakon
Oslo, Norway

sdd (stuart-d-davies) said : #21

I have a similar problem. Instead of the nice Ubuntu login screen I get dumped to the command line login prompt. After login I have to type startx in order to start the gui.

Can any one tell me how I got to this position. This started suddenly after installing some ALSA tools. It would also be good if I could go back to the original login process

regards

Stuart
Cardiff UK.

tbone87 (tbone87) said : #22

Same exact problem as Bjørn Håkon Mathisen - I originally tweaked login settings only to find out that my login screen no longer loaded...

BUT - I have not been able to recover the login screen. I have been able to get in and access the Administration -> Login screen - BUT after a restart, the problem persists.

Bjorn Hakon, do you mind sharing your Login Screen settings that allowed you to view the login screen? Any other suggestions?

I don't mind, but I'm at work right now. I'll have to have a look when I get home. (09:30 AM here in Oslo now. I'll be home at around 05:00 PM CET)

Regards
Bjorn Hakon

tbone87 (tbone87) said : #24

Update:
Forgot to mention that I have neither a Shutdown nor Restart when from desktop - so I just use terminal for that...
But any changes I made in Administration -> Login screen weren't working - as my login screen wasn't appearing at all at startup.
When I used...
sudo /etc/init.d/gdm start
to actually access the Login options, I would receive a blue error screen...

"There already appears to be an X server running on display :0. Should another display be tried? Answering No will cause gdm to attempt starting the server on :0 again. (You can change consoles by... X servers are usually on consoles 7 and higher) Yes/No"

Then I would ALT+CTRL+F7 and continue tweaking Login options... as neither Yes nor No led to anything productive.

SO - I'm instead using xdm instead of gdm - and I get a login screen. I am still using terminal for shutdown, as Shutdown & Restart are still missing...

This took a while ... sorry.

I installed Ubuntu 7.04, and it worked correctly with the default settings.That would be the theme named "Human". I installed each and every update that was available. Then I changed a few settings:
- I changed the background to no backgroung-image and blue colour.
- To match the blue colour, I chose a blue login screen from the list, that looked a bit like the default one ( you enter username, press enter and then you enter the password ).
- I enabled automatic login.
- I enabled timed login. These two steps were done to have a particular user to be logged in automatically after 30 seconds.
- I rebooted.
- GDM crashed ...

To fix this, I did the following:
- At the black screen, I pressed ALT+CTRL+F2
- I entered "sudo /etc/init.d/gdm stop"
- I entered "startx"
- Every time the black screen came back, I entered ALT+CTRL+F7 to get back to the X-session The black screen would come back after about each and every mouse-click. I just kept hitting the ALT+CTRL+F7 until I was done with this:
- Disable timed login
- Disable automatic login
- Choose the default login screen named Human
- Save the settings
Then I rebooted, and in my case, Ubuntu was back in business.

If you need any specific info from particular files, please let me know, and I'll post the files or the part of the files that are of interest.
For the time being, I'm stuck with Windows 2000 Pro for reasons that have nothing to do with Ubuntu. But when W2k is obsoleted, Ubuntu will be my next OS.

Bjorn Hakon

Wait, I forgot something. In order to change the login screen, GDM had to be running, so I entered sudo /etc/init.d/gdm start
 at the command line (tty2 or ALT+CTRL+F2). That made the black screen appear at tty2, but not at tty7 (or or ALT+CTRL+F7 if you like). Whenever I clicked a checkbox at tty7, I was thrown back to tty2 and the black screen. Hitting or ALT+CTRL+F7 sent me back to tty7 and X. This was working in a way, and because GDM was running (at tty2), I was able to select the Human login screen.

A not so unimportant step that slipped my mind as I wrote my previous post. Sorry about that.

Bjorn Hakon

asleroid (turguta) said : #27

I also had this problem after trying to update my nvidia drivers on debian. To get back to the way things were, all I had to do was:

sudo dpkg-reconfigure -phigh xserver-xorg

then I selected nv from the options

after that

startx

got me the desktop the way it was. then I rebooted to get the login screen.

nikgenius (nikhil-chowdhary) said : #28

Hi,

I am also facing the same issue. After I turn the computer on I just see a black screen with the mouse curser and do not see the Login screen to type my username or password. I didn't do any changes since the last time it worked correctly. Please help. I dont want to reinstall it again because on the other partation i have installed Windows XP and if I reinstall Ubuntu I would have to install XP also, which is time consuming and hectic.

thanks

nikgenius (nikhil-chowdhary) said : #29

Please help me!

please help me show the Steps in making a GNOME login screen?

Isn't everyone just looking to edit /etc/gdm/gdm.conf-custom ???

Mine currently contains:

[daemon]
AutomaticLoginEnable=true
AutomaticLogin=$USER
TimedLoginEnable=true
TimedLogin=$USER
TimedLoginDelay=10

Just replace $USER with your username. Then run: sudo /etc/init.d/gdm restart

4now (robertblonski) said : #32

After weeks of learning and setting up my P4 with Ubuntu for a friend
I thought I would do some final tweaks today - and changing the login image messed everything

This has been the most helpful thread
but I'm stuck at:

when i choose System/Administration/Login Window, I get the following error message; Failed to run gdm setup as root, unable to copy user's xauthorization file.

so I can't revert to the default login image

please someone rescue me

coffeejack (john-johnson2q) said : #33

This started the day I installed Fiesty and still here with the Heron install. I get a black screen, but just type in user name, hit enter, then password, and everything comes up. If you know what the log on screen looks like, just pretend its there and type the information. If I change /etc/x11/xorg.conf from 1280-1024 to 1280-800 the resolution looks a bit odd but the log on screen comes up. I have tried every suggestion including new installs. I have slide in drives and other distro's work fine on the same machine.

I recently added a new monitor, Viewsonic ViewPanel VA800.
I am using ATI 8.9 driver from AMD/ATI.
I was getting blank screens for login as well as other user logins.
Fixed problem by <CTL><ALT><keypad+> or <CTL><ALT><keypad->
Apparently both login and other users when logged in do not default to the new setup.
Each is mutually exclusive.

I recently added a new monitor, Viewsonic ViewPanel VA800.
I am using ATI 8.9 driver from AMD/ATI.
I was getting blank screens for login as well as other user logins.
Fixed problem by <CTL><ALT><keypad+> or <CTL><ALT><keypad-> to increase/decrease resolution.
Apparently both login and other users when logged in do not default to the new setup.
Each is mutually exclusive.

satheesh kumar (satheesh-bbk) said : #36

I installed ubuntu 9.04.

Then I added a third party software(dont remember the name) to add more visual effects.There were several options in that software.When i select one among those options the screen becomes multi-colour striped pattern.From then i couldnt access anyother option(i cant see the desktop itself).I dont get the login screen even after re-booting.The similar stripe-pattern only appears.........

I tried several options including the Recovery mode options during booting.But the problem remains still.........

 anybody please me help to fix this problem..................

You may have installed 'envyng' to get additional OEM support in video driver.

The command required is "envyng -t"
At boot, select 2nd option for repair. At menu, select "root" option.
On command line, run "envyng -t", it will bring up a menu.
Pick menu item to restore to your original configuration.

on command line run...
cd /etc/X11
ls -l

Pick a previous xorg.conf from the listing that is before the day you used the program.

on command line run...
mv xorg.conf xorg.conf.old
cp xorg.conf.(listedNameExtension)
shutdown 0 -r

This should restart you machine with the previous video setting,
If "envyng" is not the program, you'll probably receive a 'program not found' error of some type.
At this point replacing the xorg.conf file may or may not fix your problem, but is probably worth a try.

Paul

Bogus Altern (bogus-altern) said : #38

I found the black screen was because somehow the file /etc/gdm/custom.conf was altered.

Thanks Brett Alton for making me think of that file. :-)

The default session was no longer "ubuntu default" but "kde-plasma"

The later one doesn't appear to work on my system

Was my box hacked by someone who want s to be funny?

I reverted it back to what it was and did a sudo /etc/init.d/gdm restart

Strange....

bogus