no puedo poner mi webcam en presario cq40

Asked by Javier on 2008-11-09

Hola, mi portátil es una presario cq40 y le instalé ubuntu 9.04, al buscar los dispositivos que tiene para video me di cuenta que es el

00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)

que es lo que me da con lspci.
Traté ponerle el controlador gspca pero al darle

make install clean

me despliega:

mkdir -p /lib/modules/`uname -r`/kernel/drivers/usb/media/
rm -f /lib/modules/`uname -r`/kernel/drivers/usb/media/spca5xx.ko
rm -f /lib/modules/`uname -r`/kernel/drivers/media/video/gspca.ko
install -c -m 0644 gspca.ko /lib/modules/`uname -r`/kernel/drivers/usb/media/
install: no se puede efectuar `stat' sobre «gspca.ko»: No existe el fichero ó directorio
make: *** [install] Error 1

y despues de eso le tipeo

modprobe gspca

y me da:

FATAL: Error inserting gspca (/lib/modules/2.6.28-13-generic/kernel/drivers/usb/media/gspca.ko): Invalid module format

la cámara que viene es una syntek 5216, no sé si es que no la soporta.

Antes de hacer todo esto yo había instalado cheese y me funcionó la primera vez, en algún punto mientras estaba con el gspca también me funcionó pero no correctamente, ahora cuando inicio cheese se enciende la luz de la cámara por un leve instante pero se apaga (señal de que no funciona).

Gracias de antemano por cualquier ayuda

Question information

Language:
Spanish Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2008-11-20
Last reply:
2009-01-06
Javier Jardón (jjardon) said : #1

Hola Javier,

puedes pegar aqui lo que te sale al poner en una consola: lspci

Gracias

Javier (jalonsoma) said : #2

javier@javier-laptop:~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:01.0 PCI bridge: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
00:1f.6 Signal processing controller: Intel Corporation 82801I (ICH9 Family) Thermal Subsystem (rev 03)
01:00.0 VGA compatible controller: nVidia Corporation GeForce 9300M GS (rev a1)
02:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100
05:00.0 Memory controller: Intel Corporation Turbo Memory Controller (rev 11)
06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)

Javier (jalonsoma) said : #3

Gracias por el interes, esto sigue igual.

javier@javier-laptop:~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory
Controller Hub (rev 07)
00:01.0 PCI bridge: Intel Corporation Mobile 4 Series Chipset PCI
Express Graphics Port (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB
UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB
UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2
EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio
Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express
Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express
Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express
Port 3 (rev 03)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express
Port 6 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB
UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB
UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB
UHCI Controller #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801I (ICH9 Family) USB
UHCI Controller #6 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2
EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI
Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
00:1f.6 Signal processing controller: Intel Corporation 82801I (ICH9
Family) Thermal Subsystem (rev 03)
01:00.0 VGA compatible controller: nVidia Corporation GeForce 9300M GS (rev a1)
02:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100
05:00.0 Memory controller: Intel Corporation Turbo Memory Controller (rev 11)
06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)

2008/11/20, Javier Jardón <email address hidden>:
> Your question #50803 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/50803
>
> Status: Open => Needs information
>
> Javier Jardón requested for more information:
> Hola Javier,
>
> puedes pegar aqui lo que te sale al poner en una consola: lspci
>
> Gracias
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+question/50803
>
> You received this question notification because you are a direct
> subscriber of the question.
>

--
Javier Alonso Maroto

Javier Jardón (jjardon) said : #4

Hola,

prueba a añadir

   options snd-hda-intel enable_msi=1

en tu /etc/modprobe.d/alsa-base y reinicia

Según parece esto les ha solucionado el problema algunos.
Te dejo linkado el bug de donde lo saqué ;-)

Saludos

claudio (claudio-noguera) said : #5

Tengo el mismo problema que Javier. Mismo modelo de portátil. La solución propuesta no resuelve el problema.

Fernando Tortosa (fernandokts) said : #6

Tengo el mismo modelo de portatil. Tengo una solución casi completa:
en tu /etc/modprobe.d/alsa-base, añade:

options snd-hda-intel model=toshiba

Despues de reiniciar tengo bien el sonido en los altavoces, pero ahora los micros frontales (de la pantalla) no funcionan. Solo los q se enchufa.

Fabián Rodríguez (magicfab) said : #7

Qué chipset de sonido tiene ? Para encontrarlo, en terminal:

aplay -l

(es una L minúscula)

Si quiere dar más detalles y ayudar a corregir el problema con un bug report más completo, por favor ejecute estos comandos, enviarán la información al sitio web alsa-project.org y darán una referencia web que podrá incluir aquí:

wget http://alsa-project.org/alsa-info.sh -O alsa-info.sh
bash alsa-info.sh

Para ver un ejemplo de información recopilada:

Fabián Rodríguez (magicfab) said : #8

Qué chipset de sonido tiene ? Para encontrarlo, en terminal:

aplay -l

(es una L minúscula)

Si quiere dar más detalles y ayudar a corregir el problema con un bug report más completo, por favor ejecute estos comandos, enviarán la información al sitio web alsa-project.org y darán una referencia web que podrá incluir aquí:

wget http://alsa-project.org/alsa-info.sh -O alsa-info.sh
bash alsa-info.sh

Para ver un ejemplo de información recopilada:
http://www.alsa-project.org/db/?f=dc2bd408e3911daee0b62fd70264849ef19162df

claudio (claudio-noguera) said : #9

Lo de options snd-hda-intel model=toshiba a mí no me funciona.
Mando mi script de alsa-info:
http://www.alsa-project.org/db/?f=778f67673696831debcc726466ca891a3ebcb778

claudio,
Veo q en tu configuración en /etc/modprobe.d/alsa-base tu tienes dos lineas relacionadas a snd-hda-intel. La primera dice q tu modelo es "model=laptop" y la ultima dice que es "model=toshiba". En la parte "Loaded sound module options" está como "model=laptop". Creo q esta ha sido considerada, por eso es mejor remover la primera.

Mi alsa-info es:
http://www.alsa-project.org/db/?f=6e036db56f2aa89ab7a97df95578cdbb9ec342b0

Mi kernel es compilado por mi, por eso esta diferente. Pero siempre he utilizado el original de ubuntu.
Puedes ver también q mi alsa es el 1.0.18a. Pero creo q con el 1.0.17 de los paquetes de ubuntu, funcionará bien.

claudio (claudio-noguera) said : #11

Vale, perfecto. Gracias.

¿Alguna solución para el tema del micrófono?

Fabián Rodríguez (magicfab) said : #12

Para el micrófono, por favor abre una nueva pregunta, asegúrate de generar de nuevo el alsa-info y pegar la nueva URL.

Can you help with this problem?

Provide an answer of your own, or ask Javier for more information if necessary.

To post a message you must log in.