Ubuntu 8.04: problem with installation sofware

Asked by pgmmpk on 2008-11-01

hello folks!
i'm new here, and not good with computer and all .Sorry My English is verry bad!
My problem with installation is here:E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.
i would appreciate any kind of help.

 Regards: sasamorska

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
pgmmpk
Solved:
2008-11-07
Last query:
2008-11-07
Last reply:
2008-11-07
pgmmpk (pgmmpk) said : #1

Found a workaround for this.

The core of the problem is that gspca drivers in 8.10 apparently implement V4L2, while many applications are still using V4L1 protocol. See http://hansdegoede.livejournal.com/3636.html .

Diagnostics:
install camstream
start camstream, open trace window, and start camera. Expect to see messages like:
VIDIOCSYNC(1) failed (Invalid argument)

How to workaround this (see also https://lists.linux-foundation.org/pipermail/bugme-janitors/2008-October/011912.html):

1. Download and unpack http://people.atrpms.net/~hdegoede/libv4l-0.5.0.tar.gz
2. See README, and install: sudo make install
3. Open terminal window
4. $ export LD_PRELOAD=/usr/local/lib/libv4l/v4l1compat.so
5. $ camstream
Start camera, should now work.

How to make skype work:
1. create new shell script (call it skype_wrapper), put it somehwere (e.g. /usr/local/bin/skype_wrapper). Content:
#!/bin/bash
export LD_PRELOAD=/usr/local/lib/libv4l/v4l1compat.so
skype
2. Open System/Root Menu manager, locate Skype, Edit the shortcut replacing command "skype" => "/usr/local/bin/skype_wrapper".
3. Start skype (restart, if already running). Test video should now work.

Guys, if anyone knows how to **really** fix it (not going thru the pain in the @$$ above), please let me know.

Credit for the solution should go to http://hansdegoede.livejournal.com/3636.html . Errors and typos are all mine ;)

Regards,
-Mike

bjorn (bjornlofgren) said : #2

Hi All,
I have the same problem after upgrading to 8.10 last night
My webcam Logitech worked before and now, No picture as said above.
Now, I have downloaded the file libv4l but could not load.
Can somebody explain in plain language how to write to get this going as I am not good at this yet..but learning fast.
I have unpacked but get stuck following the read me file as I did try to write in the terminal but all I got is an answer file could not be found.....
Please let me know how to do

Thanks // Bjorn

pgmmpk (pgmmpk) said : #3

Bjorn,

You probably are missing development environment, linux kernel headers, or both. What is the exact problem? What error message you are getting?

Check (using Synaptic) that package linux-headers-2.6.27-7 is installed
Check that gcc and make commands are working: just type them from terminal window.

Good luck
-Mike

bjorn (bjornlofgren) said : #4

Mike,
I have the linux-header installed as checked in synaptic.
From the READ ME I have;
"Simple type the following commands from the libv4l-x.y.z directory
(adjusting PREFIX as desired):
make
make install PREFIX=/usr/local"

I typed in the command in terminal but I do not know what PREFIX= is. I wrote the filename libv4l as follows; make install libv4l=/home/lena/Skrivbord
Please note that is in Swedish as the dir is Swedish but I used the directory were the unzipped files are located.
The answer is in Swedish but you probably can see my mistake and advice

Thanks // Bjorn

pgmmpk (pgmmpk) said : #5

Bjorn, do not specify any prefix - let it use the default place for installation (/usr/local). Also, you need to be a superuser to install there, so do not forget to prepend "sudo", like this:

$ sudo make install
<it will prompt for the current user password here, enter it>

Good luck,
-Mike

bjorn (bjornlofgren) said : #6

I tried what you adviced
and in the directory of the libv4i I wrote;
sudo make install libv4l

The answer I goy back was no such command exist.
As I am a dummy on this yet, can you please write how I should write in the terminal.
My folder for the libv4l-0.4.0 is in /home/lena/Skrivbord

Sorry I am not up you your standard in this but learning fast...I hope

Best regards // Bjorn

pgmmpk (pgmmpk) said : #7

Bjorn, lets move this conversation to private. Please, respond to "pgmmpk at gmail dot com".

Literally, you have to do the following:

1. Open terminal window. You will get a prompt (dollar sign, usually).

2. In this terminal window, change directory to where the archive has been unpacked. If you downloaded the archive to Desktop, and used "right-click/unpack here" to unpack, it will be:

    cd ~Desktop/libv4l-0.5.0/

3. Type **only** this:

    sudo make install

4. Send me the output.

Good luck,

-Mike

pgmmpk (pgmmpk) said : #8

Ubuntu gurus,

can you please tell me if there is a better way to make V4L v1 applications work with gspca drivers?

I am not marking this question as "Solved", because for many the workaround presented here is not acceptable (requires too much technical knowledge).

-Mike

Crosshair (will-e-carlson) said : #9

Same Problem. Ubuntu 8.10 i386 with a logitech Quickcam. Any better work around?

gare-calhoun (gare-calhoun) said : #10

HI -

Have similar problem - Ekiga and Cheese DO work (Ubuntu supplied software).

Skype 2.0.0.72 and Camorama Do NOT work with Error & / Green Screens when testing, respectively. (It is like these softwares are looking in wrong place for the video steam...)

I do not want to install non-ubuntu software to fix this.

Thanks for any help!
g

fraiddoki (fredo-5555) said : #11

i have a same problem, there is a fix in repository?

Thanks Mike, I had the same problem after upgrading to 8.10 with a Canyon CNR-WCAM413 listed as
Z-Star Microelectronics Corp. Luxya WC-1200 USB 2.0 Webcam
Your fix got me up and running again.
Cheers,
jonny

In my case the workaround doesn't fix...
The webcam worked perfect with 8.04 but it messed up when migrating to ubuntu 8.10.
Some output data:

$ lsusb
Bus 004 Device 003: ID 0ac8:0302 Z-Star Microelectronics Corp. ZC0302 WebCam

After going through the 5 steps that Mike pointed, the webcam works under camstream

Then, the webcam doesn't work in skype, camorama and ekiga.
I do:
$ export LD_PRELOAD=/usr/local/lib/libv4l/v4l1compat.so
$ skype
ERROR: ld.so: object '/usr/local/lib/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored.
ALSA lib ../../../src/pcm/pcm.c:2156:(snd_pcm_open_conf) Cannot open shared library /usr/lib32/alsa-lib/libasound_module_pcm_bluetooth.so

I'm stuck, because I don't know how to proceed since the variable is not preloaded...
Thanks

Lobo (igal-lupo) said : #14

pgmmpk
I tried it al what i could do and no success yet. Is there is other way to get my webcam work then go back to 8.04.

This the status now
yigal@yigal-laptop:~$ uname -a
Linux yigal-laptop 2.6.27-7-generic #1 SMP Tue Nov 4 19:33:20 UTC 2008 i686 GNU/Linux
yigal@yigal-laptop:~$ lsusb
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 003: ID 09da:0006 A4 Tech Co., Ltd Optical Mouse WOP-35 / Trust 450L Optical Mouse
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 0ac8:0302 Z-Star Microelectronics Corp. ZC0302 WebCam
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
yigal@yigal-laptop:~$ lsmod | grep video
videodev 41344 1 gspca_main
v4l1_compat 22404 1 videodev
video 25104 0
output 11008 1 video
yigal@yigal-laptop:~$ lsmod | grep gspca
gspca_zc3xx 55936 0
gspca_main 29312 1 gspca_zc3xx
videodev 41344 1 gspca_main
usbcore 148848 8 snd_usb_audio,snd_usb_lib,gspca_zc3xx,gspca_main,usbhid,ehci_hcd,uhci_hcd
yigal@yigal-laptop:~$ grep gspca /var/log/messages
Nov 7 07:47:33 yigal-laptop kernel: [ 5193.578262] gspca: disconnect complete
Nov 7 07:47:33 yigal-laptop kernel: [ 5194.165135] gspca: probing 0ac8:0302
Nov 7 07:47:33 yigal-laptop kernel: [ 5196.164183] gspca: probe ok
Nov 7 07:47:33 yigal-laptop kernel: [ 5196.164192] gspca: probing 0ac8:0302
Nov 7 07:47:33 yigal-laptop kernel: [ 5196.190757] Modules linked in: xt_limit xt_tcpudp ipt_LOG ipt_MASQUERADE xt_DSCP ipt_REJECT nf_conntrack_irc nf_conntrack_ftp xt_state ipv6 i915 drm binfmt_misc sco bridge stp bnep rfcomm l2cap bluetooth ppdev acpi_cpufreq cpufreq_ondemand cpufreq_stats freq_table cpufreq_powersave cpufreq_userspace cpufreq_conservative container sbs pci_slot sbshc af_packet sbp2 parport_pc lp parport joydev pcmcia snd_usb_audio snd_usb_lib snd_hwdep evdev serio_raw psmouse gspca_zc3xx gspca_main snd_hda_intel videodev v4l1_compat arc4 snd_pcm_oss snd_mixer_oss snd_pcm ecb crypto_blkcipher pcspkr sdhci_pci sdhci tifm_7xx1 mmc_core yenta_socket rsrc_nonstatic tifm_core pcmcia_core snd_seq_dummy battery ac iwl3945 video output iTCO_wdt iTCO_vendor_support rfkill snd_seq_oss mac80211 led_class snd_seq_midi cfg80211 snd_rawmidi snd_seq_midi_event snd_seq wmi snd_timer snd_seq_device button snd soundcore snd_page_alloc shpchp intel_agp pci_hotplug agpgart iptable_nat nf_nat nf_conntrack_ipv4 nf_conn
yigal@yigal-laptop:~$

INSTALL libv4l 050
igal@yigal-laptop:~$ cd ~Desktop/libv4l-0.5.0/
bash: cd: ~Desktop/libv4l-0.5.0/: No such file or directory
yigal@yigal-laptop:~$ cd Desktop
yigal@yigal-laptop:~/Desktop$ cd libv4l-0.5.0/
yigal@yigal-laptop:~/Desktop/libv4l-0.5.0$ sudo make install
make -C libv4lconvert V4L2_LIB_VERSION=0.5.0 install
make[1]: Entering directory `/home/yigal/Desktop/libv4l-0.5.0/libv4lconvert'
mkdir -p /usr/local/include
install -p -m 644 ../include/libv4lconvert.h /usr/local/include
mkdir -p /usr/local/lib
install -m 755 libv4lconvert.so.0 /usr/local/lib
cd /usr/local/lib && \
   ln -f -s libv4lconvert.so.0 libv4lconvert.so
mkdir -p /usr/local/lib/pkgconfig
install -m 644 libv4lconvert.pc /usr/local/lib/pkgconfig
make[1]: Leaving directory `/home/yigal/Desktop/libv4l-0.5.0/libv4lconvert'
make -C libv4l2 V4L2_LIB_VERSION=0.5.0 install
make[1]: Entering directory `/home/yigal/Desktop/libv4l-0.5.0/libv4l2'
mkdir -p /usr/local/include
install -p -m 644 ../include/libv4l2.h /usr/local/include
mkdir -p /usr/local/lib/libv4l
install -m 755 libv4l2.so.0 /usr/local/lib
cd /usr/local/lib && \
   ln -f -s libv4l2.so.0 libv4l2.so
install -m 755 v4l2convert.so.0 \
   /usr/local/lib/libv4l/v4l2convert.so
mkdir -p /usr/local/lib/pkgconfig
install -m 644 libv4l2.pc /usr/local/lib/pkgconfig
make[1]: Leaving directory `/home/yigal/Desktop/libv4l-0.5.0/libv4l2'
make -C libv4l1 V4L2_LIB_VERSION=0.5.0 install
make[1]: Entering directory `/home/yigal/Desktop/libv4l-0.5.0/libv4l1'
mkdir -p /usr/local/include
install -p -m 644 ../include/libv4l1.h /usr/local/include
mkdir -p /usr/local/lib/libv4l
install -m 755 libv4l1.so.0 /usr/local/lib
cd /usr/local/lib && \
   ln -f -s libv4l1.so.0 libv4l1.so
install -m 755 v4l1compat.so.0 \
   /usr/local/lib/libv4l/v4l1compat.so
mkdir -p /usr/local/lib/pkgconfig
install -m 644 libv4l1.pc /usr/local/lib/pkgconfig
make[1]: Leaving directory `/home/yigal/Desktop/libv4l-0.5.0/libv4l1'
yigal@yigal-laptop:~/Desktop/libv4l-0.5.0$

I can not get anything to work, I really like to see my granddaughter on line using skype. I hope that you can give me the last push before I go back to hardy.

Thanks

pgmmpk (pgmmpk) said : #15

Lobo, I see that you successfully installed the library. This is only the first stem. Now you have to make sure that the library is used by skype. Please, follow the other steps in the workaround. Or, exit skype, open a terminal window and do:

$ export LD_PRELOAD=/usr/local/lib/libv4l/v4l1compat.so
$ skype

Hope it helps.

Pedro, did skype ever work after the upgrade? It seems that it is trying to load audio library and fails. I am not a skype expert and not sure what this means.

-Mike

Lobo (igal-lupo) said : #16

Thanks

I am sorry but I got this mass and no skype or camorama works.

yigal@yigal-laptop:~$ export LD_PRELOAD=/usr/local/lib/libv4l/v4l1compat.so
yigal@yigal-laptop:~$ skype
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
Starting the process...
Skype Xv: Xv ports available: 17
Skype XShm: XShm support enabled
Skype Xv: Using Xv port 66
Starting the process...
Skype Xv: Xv ports available: 17
Skype XShm: XShm support enabled
Skype Xv: Using Xv port 66
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
ALSA lib pcm_bluetooth.c:1619:(bluetooth_init) BT_GETCAPABILITIES failed :
Input/output error(5)
Starting the process...
Skype Xv: Xv ports available: 17
Skype XShm: XShm support enabled
Skype Xv: Using Xv port 66

2008/11/7 pgmmpk <email address hidden>

> Question #49739 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/49739
>
> Status: Answered => Open
>
> pgmmpk is still having a problem:
> Lobo, I see that you successfully installed the library. This is only
> the first stem. Now you have to make sure that the library is used by
> skype. Please, follow the other steps in the workaround. Or, exit skype,
> open a terminal window and do:
>
> $ export LD_PRELOAD=/usr/local/lib/libv4l/v4l1compat.so
> $ skype
>
> Hope it helps.
>
> Pedro, did skype ever work after the upgrade? It seems that it is trying
> to load audio library and fails. I am not a skype expert and not sure
> what this means.
>
> -Mike
>
> --
> You received this question notification because you are a direct
> subscriber of the question.
>

--
Best regards/Saludos/ 谢 谢 בברכה
Yigal Lupo

Calle Los Jacintos N-163, Departamento N° 301
Ica, Ica, Peru.
Email 1; <email address hidden>
Email 2: <email address hidden>
Mobil 1: 011-511-99-428-5078
Mobil 2: 011-511-99-362-0674
Nextel: 428*5078

pgmmpk (pgmmpk) said : #17

So you have the same problem as Pedro.

Does skype work without the LD_PRELOAD? If no, then something is wrong with the skype. If yes, something is wrong with the library, and you have to address this to the library author http://hansdegoede.livejournal.com/3636.html.

-Mike

tgirardi (tgirardi) said : #18

For those who this procedure worked: What version of skype are you using?
I'm using version 2.0.0.72 and this fix didn't worked for me.
If I start camstream I get VIDIOCSYNC(1) failed (Invalid argument), so the diagnostic goes as expected. After using "export LD_PRELOAD=/usr/local/lib/libv4l/v4l1compat.so" camstream works fine, but not skype.

Thanks in advance for any help.

Skype worked before the upgrade and works perfectly after upgrading. I'm using version 2.0.0.72

The mic integrated in the webcam is the one I use to speak through skype, and works fine.
I only noticed that the video in the webcam was not working, when my little child wanted to make a video call to grandparents.

Lobo (igal-lupo) said : #20

Pedro

I have the same problem the only deference is that i am the grandfather (abuelito)
I was reading all over and try it as you can see but no change.
i looks like we will have to wait to Ubuntu staff to send an update on this or go back to 8.04

bjorn (bjornlofgren) said : #21

Command suggested do not work for me.
"export", I get al kinds of info
"preload...." I get no answer back from the terminal.
I can not get the webcam in camorama or aMSN

Bjorn

fre 2008-11-07 klockan 18:15 +0000 skrev tgirardi:
> LD_PRELOAD=/usr/local/lib/libv4l/v4l1compat.so

bjorn (bjornlofgren) said : #22

I agree but with the 8.10 I get more functions on the web radio through
rhythmbox I did not have before. I guess you get some, loose some

Bjorn

fre 2008-11-07 klockan 19:31 +0000 skrev Lobo:
> Question #49739 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/49739
>
> Lobo posted a new comment:
> Pedro
>
> I have the same problem the only deference is that i am the grandfather (abuelito)
> I was reading all over and try it as you can see but no change.
> i looks like we will have to wait to Ubuntu staff to send an update on this or go back to 8.04
>

Martin Slota (martin-slota) said : #23

Hi,

my webcam (Logitech QuickCam Express) worked perfectly in Ubuntu 8.04. After upgrading to 8.10 it still works well in Cheese but not in Skype.

I installed the library as suggested and now I get the following:

$ ls /usr/local/lib/libv4l/v4l1compat.so
/usr/local/lib/libv4l/v4l1compat.so
$ LD_PRELOAD=/usr/local/lib/libv4l/v4l1compat.so /usr/bin/skype
ERROR: ld.so: object '/usr/local/lib/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored.
...

and the webcam still doesn't work. Does anybody have an idea why it does not want to preload the library?

Martin

Lobo (igal-lupo) said : #24

I am back with Hardy and all is OK now. I was looking around trying to make it work and no success. I reinstalled Skype again and notice that it loads libv4l that is not libv4l1.
I am asking myself:
How many people have the same problem?
When Ubuntu staff will be fixing the problem?
This kind of small bugs make it more difficult to spread Ubuntu between my winy skeptical friends, it needs too much skill to make it work.

pgmmpk (pgmmpk) said : #25

Exactly. The mediocre support for the webcams is dragging down the adoption of ubuntu/linux. And it seems that every new release introduces new problems in this area. Argh. Sorry for grunting...

-Mike

Coeus (steve-overlee) said : #26

Just confirming that my Logitech Pro 9000 also used to work on 8.04 and is now getting the following error when I run Camorama:

"Could not connect to video device (/dev/video0). Please check connection"

Lobo (igal-lupo) said : #27

I am back with 8.04. Looking for some fix that works to upgrade but no
result for me yet.
try this one:
http://ubuntuforums.org/showthread.php?t=945803&page=2
2008/11/8 Coeus <email address hidden>

> Question #49739 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/49739
>
> Coeus posted a new comment:
> Just confirming that my Logitech Pro 9000 also used to work on 8.04 and
> is now getting the following error when I run Camorama:
>
> "Could not connect to video device (/dev/video0). Please check
> connection"
>
> --
> You received this question notification because you are a direct
> subscriber of the question.
>

--
Best regards/Saludos/ 谢 谢 בברכה
Yigal Lupo

Calle Los Jacintos N-163, Departamento N° 301
Ica, Ica, Peru.
Email 1; <email address hidden>
Email 2: <email address hidden>
Mobil 1: 011-511-99-428-5078
Mobil 2: 011-511-99-362-0674
Nextel: 428*5078

Lobo, you rock :)
This solution posted in the ubuntuforums link solved my problem... now the video works under skype.

Anyhow, I understand that this is a temporary solution, since the rest of apps (ekiga & camorama) cannot display any video by now...
Thanks!

bjorn (bjornlofgren) said : #29

What I do not understand is that I can get my QuickCam working on XavTv. I guess this means there is a driver used.
Problem is how can.will it work in the other applications?
As I am new Ubuntu user and Linux is still a big question, I can not get this. Is it possible to use the same driver/fix used in XavTv and apply this to the other programs like Skype, aMSN, Comorama.........???
Seems you guys gave up and start using the 8.04 which I am also leaning to but when fiddling with all drivers you guys suggested and did not work for the webcan, I actually got my radio streem working, this did not work before in 8.10 but id work in 8.04.
The problem is that I do not know which one.

Bjorn, I'm running video in skype under ubuntu 8.10, and I simply did as follows:

[...]
in order to have a more easy life, ive created a file in /usr/local/bin called skype that superseeds the binary in /usr/bin/ which is in charge of running skype...

type:
$ sudo gedit /usr/local/bin/skype

and paste the following 2 lines:

#!/bin/bash
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype

then make it executable:
$ sudo chmod a+x /usr/local/bin/skype

no more crazy command typing just run with the shortcut, or alt-f2 and type skype
[...]

You may try and report the result...

bjorn (bjornlofgren) said : #31

Thanks Pedro,
Just a quick question, when creating a file, what will the file include?
Is it just an empty file?

sön 2008-11-09 klockan 20:45 +0000 skrev Pedro Fernandez:
> Question #49739 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/49739
>
> Pedro Fernandez posted a new comment:
> Bjorn, I'm running video in skype under ubuntu 8.10, and I simply did as
> follows:
>
> [...]
> in order to have a more easy life, ive created a file in /usr/local/bin called skype that superseeds the binary in /usr/bin/ which is in charge of running skype...
>
> type:
> $ sudo gedit /usr/local/bin/skype
>
> and paste the following 2 lines:
>
> #!/bin/bash
> LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype
>
> then make it executable:
> $ sudo chmod a+x /usr/local/bin/skype
>
> no more crazy command typing just run with the shortcut, or alt-f2 and type skype
> [...]
>
> You may try and report the result...
>

It's not an empty file. It includes the following 2 lines included between start and end signs:

--START--
#!/bin/bash
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype
--END--

Lobo (igal-lupo) said : #33

Pedro
I have a question for you.
Is your solution will do it with Live CD install?
I am thinking of doing it with the Live CD and then if it will be OK I will make an online upgrade - 8.04 to 8.10.

Thanks.

bjorn (bjornlofgren) said : #34

I created a document aMSn.ocd with the 2 lined you adviced.
My problem is I can not add this file to /usr/local/bin as I get the
locked file in/bin and message "you are not the owner of this file" and
can not save.
Please let me know how to do..........

sön 2008-11-09 klockan 21:19 +0000 skrev Pedro Fernandez:
> Question #49739 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/49739
>
> Pedro Fernandez posted a new comment:
> It's not an empty file. It includes the following 2 lines included
> between start and end signs:
>
> --START--
> #!/bin/bash
> LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype
> --END--
>

Casey Link (unnamedrambler) said : #35

Why is this question marked as solved? It is clearly not solved.

tgirardi (tgirardi) said : #36

I agree with Casey. None of the solutions mentioned above worked for me.

I checked all of the links also and understood the whole background of the problem, but, although the solutions seems logical, none of them solved it.

Lobo (igal-lupo) said : #37

I was recommended by FRODON (Ubuntu Forum)http://ubuntuforums.org/showthread.php?p=6144505#post6144505
 to install Skype from Medibuntu http://www.medibuntu.org/
I can not do it myself - I am back with hardy - maybe one of you that uses Intrepid can do the check on this idea and let us know?
Note that you may need to uninstall Skype.

Lobo (igal-lupo) said : #38

Hi Marijane

You are not in the right place to look for the answer for your problem

First: You should goole some thing like "webcam problem ubuntu.
second. go to Ubuntu forum http://ubuntuforums.org/ make yourself a
member, learn how to use it and you will find the answer.
Normaly logithech webcam work right out of the box.

Enjoy you Ubuntu.

2008/11/17 maryjane <email address hidden>

> Question #49739 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/49739
>
> Summary changed to:
> Ubuntu 8.04: problems with logitech quickcam
>
> Description changed to:
> hello folks!
> i'm new here, and not good with computer and all this stuff...
> i've just bought a logitech quickcam E2500 and it seems to me that it has
> been made just for the windows corporation...
> is there a way to make it work with ubuntu 8.04?
> and if so, could anyone explain me in simple words how to install it?
> if not, could you tell me wich webcam is compatible with ubuntu?
> i would appreciate any kind of help.
>
> maryjane
>
> --
> You received this question notification because you are a direct
> subscriber of the question.
>

--
Best regards/Saludos/ 谢 谢 בברכה
Yigal Lupo

Calle Los Jacintos N-163, Departamento N° 301
Ica, Ica, Peru.
Email 1; <email address hidden>
Email 2: <email address hidden>
Mobil 1: 011-511-99-428-5078
Mobil 2: 011-511-99-362-0674
Nextel: 428*5078

gary (grcrosby) said : #39

Alright, just upgraded to Ubuntu 8.04 and saw a Logitech Communicate STX on sale and bought it. Now finding out that it is not a workable device. When I plug it into a usb port, I loose my network connection. Downloaded camstream, plugged in the device, openeed a trace window, no response from camstream. Network goes down, I reboot. I am going to try windows in a virtual machine to see if that is at least a work around...

gary

Eurico Zimbres (zimbres) said : #40

Thanks Pedro Fernandez,

Your solution worked for me. My problem is solved and my web cam A4tech P935, which uses a chipset from Z Star, is now working. Merry Christmas for all.

I am using Ubuntu 8.10-Intrepid with Skype 2.0

Zimbres

Lauri Uotinen (lauri-uotinen) said : #41

This worked for me (amd64):
LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so skype

chkneater (chkneater) said : #42

Hi, I was having the same problems as everyone else with my QuickCam. While screwing around I accidentally figured out that using the Sudo command from a terminal *should* work for Camorama at least. For me it's not a big deal to use the terminal so I'm fine using the cam from there, so if nothing else here works try that. I had no problems with it in 8.04 but upgrading to 8.1, it stopped working. Maybe this will help fix the bug also. BTW, trying Camorama without the Sudo I got the same errors, so make sure to do sudo.

Eurico Zimbres (zimbres) said : #43

Hi Chkneater, I think that if it works with a sudo command, then the problem is about permission of the files.

Followed the instructions to the letter.

When I try and launch camarama I get

camstream: error while loading shared libraries: libv4l1.so.0: cannot open shared object file: No such file or directory

Pretty desperate to get this working as I am working away and promised my kids they could "see" daddy.

Damien (damien-timebank) said : #45

hey <email address hidden> I have the same issue, followed this workaround and get error while loading shared libraries: libv4l1.so.0: cannot open shared object file: No such file or directory

I can see libv4l1.so.0 in the usr/local/lib/libv4l directory so don't get why it can't be found

did you manage to find a solution?

btw - skype works perfect for me, I'm just trying to get camarama working as a test hoping that it will also solve the issue of my webcam not working with 12seconds.tv

Martin Slota (martin-slota) said : #46

I had problems with skype and I was getting the same message. In the
end it started to work with this library:

/usr/lib32/libv4l/v4l1compat.so

2009/2/26 Damien <email address hidden>:
> Question #49739 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/49739
>
> Damien posted a new comment:
> hey <email address hidden>  I have the same issue, followed this
> workaround and get error while loading shared libraries: libv4l1.so.0:
> cannot open shared object file: No such file or directory
>
> I can see libv4l1.so.0 in the usr/local/lib/libv4l directory so don't
> get why it can't be found
>
> did you manage to find a solution?
>
> btw - skype works perfect for me, I'm just trying to get camarama
> working as a test hoping that it will also solve the issue of my webcam
> not working with 12seconds.tv
>
> --
> You received this question notification because you are a direct
> subscriber of the question.
>

El Viejo Lobo (yigal-lupo) said : #47

Damien

As you can see in the past posts, I when back to Hardy. A few weeks ago i had to upgrade to Intrepid. I spent hour trying to find the fix or work around for this webcam problem, I found no solution for my laptop Dlink USB webcam.From all what I learned reading and trying different ways to resolve the problem I learned that the problem as to do with the new Kernel 2.6.27.13 so I boot with the other kernel 2.6.24.44. Boot/esc.election of kernel. camarama and skype are on.

El Viejo Lobo (yigal-lupo) said : #48

Damien

As you can see in the past posts, I when back to Hardy. A few weeks ago i had to upgrade to Intrepid. I spent hour trying to find the fix or work around for this webcam problem, I found no solution for my laptop Dlink USB webcam.From all what I learned reading and trying different ways to resolve the problem I learned that the problem as to do with the new Kernel 2.6.27.13 so I boot with the other kernel 2.6.24.44. Boot/esc.election of kernel/ enter. camarama and skype are on.

mikebravo (oldmikebravo) said : #49

This problem may be solved as far as the developer is concerned, but for the run of the mill user, it is not!
I am using Logitech STX QuickCam Communicate 08d7 and it worked under Hardy (8.04) and stopped working when I updated to Intrepid (8.10). If this problem were really "solved" the fix would have been pushed out in an update. Even Microsoft can do that.

gary (grcrosby) said : #50

I agree. This is one of the reasons I ended up going back to 8.04.
There were too many issues getting hardware working on 8.10 & I did
not have either the time nor the inclination to find all the fixes
requred for the house desktop. For now, I may try 9.04 as a live
distro, but if I cannot get my, admittedly older, hardware to function
I will stay with the LTS distro.

2009/3/2 mikebravo <email address hidden>:
> Question #49739 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/49739
>
> mikebravo posted a new comment:
> This problem may be solved as far as the developer is concerned, but for the run of the mill user, it is not!
> I am using Logitech STX QuickCam Communicate 08d7 and it worked under Hardy (8.04) and stopped working when I updated to Intrepid (8.10). If this problem were really "solved" the fix would have been pushed out in an update. Even Microsoft can do that.
>
> --
> You received this question notification because you are a direct
> subscriber of the question.
>

Lolwhites (lolwhites) said : #51

I am trying pgmmpk's workaround, but when I type "sudo make install" I get the following:

make -C libv4lconvert V4L2_LIB_VERSION=0.5.0 install
make[1]: Entering directory `/home/laurie/Desktop/libv4l-0.5.0/libv4lconvert'
cc -c -MMD -I../include -I../../../../linux/include -fvisibility=hidden -fPIC -g -O1 -Wall -Wno-unused -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -o libv4lconvert.o libv4lconvert.c
make[1]: cc: Command not found
make[1]: *** [libv4lconvert.o] Error 127
make[1]: Leaving directory `/home/laurie/Desktop/libv4l-0.5.0/libv4lconvert'
make: *** [install] Error 2

What am I doing wrong? I should add my webcam hasn't worked properly for months now.

pqb (peterqb) said : #52

There seem to be endless permutations of this problem.

Logitech QuickCam Pro 4000 shows picture when I test it in Skype, but the microphone is not detected by Ubuntu 8.10. Camerarama also shows a good quality picture, so I guess there's no problem with that on my machine.

I can call the Skype test number, and hear the message, but mine is not recorded.

Pulse is set for sound in and out, and ringing tones etc.

Various solutions for sound problems are proposed on forums, but they are difficult to implement for someone (like me) who has little experience of Linux, and I am loath to start if I am not fairly sure the solution will work at the end of the trail.

I tried the sound recorder which is provided in "programs", and this did not pick up anything either.

If my hardware details help I can add them (if you tell me how to find them from Ubuntu). Sorry I am using this system for the 2nd day.

pqb (peterqb) said : #53

I looked in Pulse Audio Applet (icon on top bar of window) and chose default source then tried the different choices until one worked. My Skype test message was recorded. The sound recorder also works, so maybe this really is the solution.
--
pqb

bayvista (opus9743) said : #54

Hi. Tried your 'fix' for my Creative ??? webcam but no joy. Nothing seems to find the camera. I think that I will have to buy a new webcam. One on the 'supported' list. Any help appreciated.

pqb (peterqb) said : #55

My fix didn't work again after a few days. The problem for me was to get it working with Skype. In the end I went into Skype options and chose the camera from the sound input menu. It really was a question of trying each one until I found one that worked.

Does your camera work for video? Mine did all along, and it was just the sound that was the problem.

There doesn't seem to be a universal fix for this, and playing around with available settings may be the way you solve it.

[Any programmers/experts out there?]
--
pqb

bayvista (opus9743) said : #56

My sound is OK but the camera is not recognised by any of the camera programs. It is a few years old and I think I should upgrade. It works fine on Windows but then it came with Windows Drivers.

pqb (peterqb) said : #57

Look back in this thread before you do. Have you tried Camerama? I think it's to sort the image from the camera if it doesn't work. There could be drivers for it itf that doesn't work. Try Add/Remove and synaptic package manager or google it.
--
pqb

bayvista (opus9743) said : #58

I have tried Camerama. The message I get is: "Could not connect to video device (/dev/video0). Check connection. I'll go back through this thread again.
Lsusb shows the device correctly. It's the next step that's missing.

pqb (peterqb) said : #59

This site gives advice:

http://www.linux.com/feature/118896

If you google 'creative webcam linux drivers' you'll get that and other potentially useful pages.

Good luck.
--
pqb

mikebravo (oldmikebravo) said : #60

It has probably been said before, but it worked for me so perhaps it is worth saying again:

 LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
 OR
 LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so skype

 Open a terminal and run either of these two lines. Skype should start and work normally. (Has to be done each time you use Skype video.)

That fixed the Skype video green screen for me. Adding it to the command line in Skype Launcher properties did not work.
I use a Logitech STX QuickCam communicate 08d7.

bayvista (opus9743) said : #61

Thnks for comments. I'll try them out.

HeadInTheClouds (jerrymweeks) said : #62

Thanks pgmmpk
Your description worked for me finishing up using /v4l2convert.so
in skype_wrapper
For ease, I chose to run sudo nautilus then
browse to /usr/local/bin
right click skype_wrapper
then set permissions for users and to make it executable.
However although it worked, the video is really dark.
In Camstream brightness and contrast control seems jammed, both worked at the start, then contrast jammed, now brightness has joined in, both have gone to the left (low as possible)

oh - now for good measure (must have been feeling left out ;-)), saturation has also gone fully to the left

HeadInTheClouds (jerrymweeks) said : #63

For the records, I am using a Logitech Quickcam Go, pn: 861232-0010, it seems some logitec quickcams can suffer with brightness etc
http://www.quickcamteam.net/documentation/faq/logitech-webcam-linux-usb-incompatibilities

theultimate (theultimate2) said : #64

Pgmmpk thank you very much! I was searching three months for this problem. This completely solved it. Now skype is working fine. You saved me from spending money for another webcam :)

Job Muriuki (heviejob) said : #65

I use a light wave LW-IC500 webcam. ID 0c45:6143 Microdia is its wendor and product Id. I have set everything as stated above. I used the skype shell script and got it working but its showing unreal colours eg it shows yellow instead of blue plus the image is greenish and pretty dark too.What could i be doing wrong?

arend (arend-bayer) said : #66

I am using jaunty and a logitech QuickCam. I still had to add
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so

before running skype or camstream - is this expected? If so, this should probably be added to http://help.ubuntu.com/community/Webcam/.

Lobo (igal-lupo) said : #67

I got a new webcam that I made sure it is working with jauny before i paid
it in the store.

On Sun, Jul 19, 2009 at 7:02 PM, arend
<email address hidden>wrote:

> Question #49739 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/49739
>
> arend posted a new comment:
> I am using jaunty and a logitech QuickCam. I still had to add
> LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so
>
> before running skype or camstream - is this expected? If so, this should
> probably be added to http://help.ubuntu.com/community/Webcam/.
>
> --
> You received this question notification because you are a direct
> subscriber of the question.
>

--
Yigal Lupo.
Phone: 829-969-1212
<email address hidden>
OS Ubuntu 9.04

pqb (peterqb) said : #68

The particular issue I was exploring was using a web cam for Skype with a
computer without another microphone, so it had to use the web cam's mic.
Trying different Skype settings eventually solved the lack of sound.
--
pqb

2009/11/17 Steve McGrath <email address hidden>

> Bug #484190 status changed in Ubuntu:
>
> New => Incomplete
>
> Status change explanation given by Steve McGrath:
>
> Thank you for taking the time to report this bug and helping to make Ubuntu
> better. Please answer these questions:
> 1. Is this reproducible?
> 2. If so, what specific steps should we take to recreate this bug? Be as
> detailed as possible.
> This will help us to find and resolve the problem.
>
> https://bugs.launchpad.net/ubuntu/+bug/484190
> "error in VIDIOCGMBUF: Invalid argument"
>
> This bug is linked to #49739.
> Ubuntu 8.04: problem with installation sofware
> https://answers.launchpad.net/ubuntu/+question/49739
>
> --
> You received this question notification because you are a direct
> subscriber of the question.
>

This:
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so {myvideoappname} - doesn't work
and this one
LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so {myvideoappname} - doesn't work too.

v4l1compat.so has 0.6.0 version.

Also tried lib by installing through sudo apt-get install libv4l-0 libv4l-dev, but no positive result.

So, finally what I have to do for my cam work properly at any software (skype, camstream,xawtv, cheese......)??
I see only brown/green lines.

Thank you.

Skype Video was working fine on my Asus 64bit laptop, up until a couple days ago. No matter which "Fix" I try, I'm still getting similar errors to this:

ERROR: ld.so: object '/usr/lib32/libv4l/v4l1convert.so' from LD_PRELOAD cannot be preloaded: ignored.

And if I make a call or check the Video Options, I get this error:

X Error, request 133, minor 18, error code 8 BadMatch (invalid parameter attributes)

I am using ubuntu10.04LTS as an application on my Sony Vaio(vgn-cr120) besides the preloaded Window Vista. I am unable to activate my web cam. I posted the same problem a couple of weeks back. I got a mail from Thomas Kruger. He gave me the Id of the web cam:05ca:1839 and asked me to check periodically http://www.ideasonboard.org/uvc/ for the device and its driver. I have not found the same in that page since then. I am getting frustrated with this. If any one could help me solve this problem?

pqb (peterqb) said : #72

Presumably the web cam works with Windows?

How does Ubuntu load? Boot from separate partition on internal disk, or through Virtual Box or similar? If the latter, ie some kind of virtuaization, check in the virtualization program that it has access to peripherals.

What program are you trying to use the web cam with? (eg Skype). Playing around with the settings in preferences may lead to success. I had to do that with Skype and a Logitech wen cam, for example.

Next is to google for the make and model of the web cam alongside Ubuntu and Linux in the search. Does anything come up?

The driver might be available through the synaptic manager, if it not installed already.
--
pqb

Lobo (igal-lupo) said : #73

LinkedIn
------------

I'd like to add you to my professional network on LinkedIn.

- Igal

Igal Lupo
Owner at Walu Digital SRL
Dominican Republic

Confirm that you know Igal Lupo
https://www.linkedin.com/e/lhmr0o-gpqw6nid-6f/isd/3434255970/Bkbm9OHx/

--
(c) 2011, LinkedIn Corporation

MODERATORS! Let him go away with ban cookies =)

Sent ban request... to <email address hidden>

Thanks

Lobo (igal-lupo) said : #80

LinkedIn
------------

I'd like to add you to my professional network on LinkedIn.

- Igal

Igal Lupo
Owner Manager at Forestry Industry Group Dominicana SRL
Dominican Republic

Confirm that you know Igal Lupo:
https://www.linkedin.com/e/lhmr0o-hb8thx8c-3n/isd/3434255970/Bkbm9OHx/?hs=false&tok=1y_BM8xt3815A1

--
You are receiving Invitation to Connect emails. Click to unsubscribe:
http://www.linkedin.com/e/lhmr0o-hb8thx8c-3n/_r9wiZl7qJJCuRy-lO7ASZ92qp-6hOVf4coLEZAIvKmaku0EryeM/goo/question49739%40answers%2Elaunchpad%2Enet/20061/I3395852548_1/?hs=false&tok=1zLLJcAM_815A1

(c) 2012 LinkedIn Corporation. 2029 Stierlin Ct, Mountain View, CA 94043, USA.