cant play youtube videos

Asked by Tahsin on 2007-02-26

I have java enabled and i also have flash player when i

Installed plug-ins
Find more information about browser plug-ins at mozilla.org.
Help for installing plug-ins is available from plugindoc.mozdev.org.
Java(TM) Plug-in 1.5.0_08-b03

    File name: libjavaplugin_oji.so
    Java(TM) Plug-in 1.5.0_08

MIME Type Description Suffixes Enabled
application/x-java-vm Java Yes
application/x-java-applet Java Yes
application/x-java-applet;version=1.1 Java Yes
application/x-java-applet;version=1.1.1 Java Yes
application/x-java-applet;version=1.1.2 Java Yes
application/x-java-applet;version=1.1.3 Java Yes
application/x-java-applet;version=1.2 Java Yes
application/x-java-applet;version=1.2.1 Java Yes
application/x-java-applet;version=1.2.2 Java Yes
application/x-java-applet;version=1.3 Java Yes
application/x-java-applet;version=1.3.1 Java Yes
application/x-java-applet;version=1.4 Java Yes
application/x-java-applet;version=1.4.1 Java Yes
application/x-java-applet;version=1.4.2 Java Yes
application/x-java-applet;version=1.5 Java Yes
application/x-java-applet;jpi-version=1.5.0_08 Java Yes
application/x-java-bean Java Yes
application/x-java-bean;version=1.1 Java Yes
application/x-java-bean;version=1.1.1 Java Yes
application/x-java-bean;version=1.1.2 Java Yes
application/x-java-bean;version=1.1.3 Java Yes
application/x-java-bean;version=1.2 Java Yes
application/x-java-bean;version=1.2.1 Java Yes
application/x-java-bean;version=1.2.2 Java Yes
application/x-java-bean;version=1.3 Java Yes
application/x-java-bean;version=1.3.1 Java Yes
application/x-java-bean;version=1.4 Java Yes
application/x-java-bean;version=1.4.1 Java Yes
application/x-java-bean;version=1.4.2 Java Yes
application/x-java-bean;version=1.5 Java Yes
application/x-java-bean;jpi-version=1.5.0_08 Java Yes
Shockwave Flash

    File name: libflashplayer.so
    Shockwave Flash 9.0 r31

MIME Type Description Suffixes Enabled
application/x-shockwave-flash Shockwave Flash swf Yes
application/futuresplash FutureSplash Player spl Yes
Totem Web Browser Plugin 2.16.2

    File name: libtotem-basic-plugin.so
    The Totem 2.16.2 plugin handles video and audio streams.

MIME Type Description Suffixes Enabled
application/ogg Ogg multimedia ogg Yes
video/mpeg MPEG video mpg, mpeg, mpe Yes
audio/wav WAV audio wav Yes
audio/mpeg MP3 audio mp3 Yes
Helix DNA Plugin: RealPlayer G2 Plug-In Compatible (compatible; Totem)

    File name: libtotem-complex-plugin.so
    The Totem 2.16.2 plugin handles video and audio streams.

MIME Type Description Suffixes Enabled
audio/x-pn-realaudio-plugin RealAudio document rpm Yes
Windows Media Player Plug-in 10 (compatible; Totem)

    File name: libtotem-gmp-plugin.so
    The Totem 2.16.2 plugin handles video and audio streams.

MIME Type Description Suffixes Enabled
application/x-mplayer2 AVI video avi, wma, wmv Yes
video/x-ms-asf-plugin ASF video asf, wmv Yes
video/x-msvideo AVI video asf, wmv Yes
video/x-ms-asf ASF video asf Yes
video/x-ms-wmv WMV video wmv Yes
video/x-wmv WMV video wmv Yes
DivX® Web Player

    File name: libtotem-mully-plugin.so
    The Totem 2.16.2 plugin handles video and audio streams.

MIME Type Description Suffixes Enabled
video/divx AVI video divx Yes
QuickTime Plug-in 7.0 (compatible; Totem)

    File name: libtotem-narrowspace-plugin.so
    The Totem 2.16.2 plugin handles video and audio streams.

MIME Type Description Suffixes Enabled
video/quicktime QT video mov Yes
Java(TM) Plug-in 1.6.0-b105

    File name: libjavaplugin_oji.so
    Java(TM) Plug-in 1.6.0

MIME Type Description Suffixes Enabled
application/x-java-vm Java Yes
application/x-java-applet Java Yes
application/x-java-applet;version=1.1 Java Yes
application/x-java-applet;version=1.1.1 Java Yes
application/x-java-applet;version=1.1.2 Java Yes
application/x-java-applet;version=1.1.3 Java Yes
application/x-java-applet;version=1.2 Java Yes
application/x-java-applet;version=1.2.1 Java Yes
application/x-java-applet;version=1.2.2 Java Yes
application/x-java-applet;version=1.3 Java Yes
application/x-java-applet;version=1.3.1 Java Yes
application/x-java-applet;version=1.4 Java Yes
application/x-java-applet;version=1.4.1 Java Yes
application/x-java-applet;version=1.4.2 Java Yes
application/x-java-applet;version=1.5 Java Yes
application/x-java-applet;version=1.6 Java Yes
application/x-java-applet;jpi-version=1.6 Java Yes
application/x-java-bean Java Yes
application/x-java-bean;version=1.1 Java Yes
application/x-java-bean;version=1.1.1 Java Yes
application/x-java-bean;version=1.1.2 Java Yes
application/x-java-bean;version=1.1.3 Java Yes
application/x-java-bean;version=1.2 Java Yes
application/x-java-bean;version=1.2.1 Java Yes
application/x-java-bean;version=1.2.2 Java Yes
application/x-java-bean;version=1.3 Java Yes
application/x-java-bean;version=1.3.1 Java Yes
application/x-java-bean;version=1.4 Java Yes
application/x-java-bean;version=1.4.1 Java Yes
application/x-java-bean;version=1.4.2 Java Yes
application/x-java-bean;version=1.5 Java Yes
application/x-java-bean;version=1.6 Java Yes
application/x-java-bean;jpi-version=1.6 Java Yes

But i cant play youtube videos it says

Hello, you either have JavaScript turned off or an old version of Macromedia's Flash Player. Get the latest flash player.

What do i do?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2007-02-26
Last reply:
2009-11-23
jz (jz+) said : #1

Javascript is different from Java (not related). To check if JS is enabled you can do the following in Firefox.

1. Click "Edit > Preferences"
2. Click on "Content"
3. "Enable JavaScript" should be checked

If this is the case you should focus on trying to figure out what might be wrong with Flash...

For starters have you tried reinstalling Flash from within Synaptic?

JLR (artirj) said : #2

Install flashplayer-nonfree

To install flashplayer-nonfree, run in the terminal:

sudo aptitude install flashplayer-nonfree

sheila (sheila-yao2000) said : #4

Hi, this is Sheila.

I've installed flashplayer-nonfree for ubuntu edgy 10.6, but firefox plays video without sound.

I can listen to CD music, but the video from youtube or any news web site has no sound.

Here is the plugins from firefox:
=================================
Installed plug-ins
Find more information about browser plug-ins at mozilla.org.
Help for installing plug-ins is available from plugindoc.mozdev.org.
Totem Web Browser Plugin 2.16.2

    File name: libtotem-basic-plugin.so
    The Totem 2.16.2 plugin handles video and audio streams.

MIME Type Description Suffixes Enabled
application/ogg Ogg multimedia ogg Yes
video/mpeg MPEG video mpg, mpeg, mpe Yes
audio/wav WAV audio wav Yes
audio/mpeg MP3 audio mp3 Yes
Helix DNA Plugin: RealPlayer G2 Plug-In Compatible (compatible; Totem)

    File name: libtotem-complex-plugin.so
    The Totem 2.16.2 plugin handles video and audio streams.

MIME Type Description Suffixes Enabled
audio/x-pn-realaudio-plugin RealAudio document rpm Yes
Windows Media Player Plug-in 10 (compatible; Totem)

    File name: libtotem-gmp-plugin.so
    The Totem 2.16.2 plugin handles video and audio streams.

MIME Type Description Suffixes Enabled
application/x-mplayer2 AVI video avi, wma, wmv Yes
video/x-ms-asf-plugin ASF video asf, wmv Yes
video/x-msvideo AVI video asf, wmv Yes
video/x-ms-asf ASF video asf Yes
video/x-ms-wmv WMV video wmv Yes
video/x-wmv WMV video wmv Yes
DivX® Web Player

    File name: libtotem-mully-plugin.so
    The Totem 2.16.2 plugin handles video and audio streams.

MIME Type Description Suffixes Enabled
video/divx AVI video divx Yes
QuickTime Plug-in 7.0 (compatible; Totem)

    File name: libtotem-narrowspace-plugin.so
    The Totem 2.16.2 plugin handles video and audio streams.

MIME Type Description Suffixes Enabled
video/quicktime QT video mov Yes
Shockwave Flash

    File name: libflashplayer.so
    Shockwave Flash 9.0 r31

MIME Type Description Suffixes Enabled
application/x-shockwave-flash Shockwave Flash swf Yes
application/futuresplash FutureSplash Player spl Yes
======================================

Thanks.

Sheila

err ... shouldn't that be:

sudo aptitude install flashplugin-nonfree

plugin not player

Muggie (imaginontech) said : #6

I installed Ubuntu 9.10 on an older (2002) Compaq laptop for my husband. He seemed to like it but he likes to watch Youtube videos but it requires flash. It seems the version for Ubuntu is not compatible with my hardware. The Adobe site for some reason thinks Ubuntu needs at least 512 MB RAM and 128 video Ram to run it despite Windows and Mac only needing 128MB, I have no clue why. If anyone can explain this I'd love to know.

I was wondering if there was a Ubuntu application similar to the iPhone/iPod Touch app that allows you to bypass the Flash version of Youtube? This would fix the whole issue as I even had his old PCIMCA wireless card working in Ubuntu and now it doesn't seem to want to connect to my network when I restored Windows for him. I am beginning to think repairing (new hdd) the old iBook would be easier and that was a bear to replace a hard drive in. Our budget doesn't allow a new machine for a while.

Vikram Dhillon (dhillon-v10) said : #7

How about this [1] Mintube isn't based on flash so you should be fine :)

[1] http://www.ubuntugeek.com/install-minitube-in-ubuntu-9-10-karmic.html

--
Regards,
Vikram Dhillon

On Sunday 22 November 2009 09:45:02 pm Muggie wrote:
> Question #3925 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/3925
>
> Muggie requested for more information:
> I installed Ubuntu 9.10 on an older (2002) Compaq laptop for my husband.
> He seemed to like it but he likes to watch Youtube videos but it
> requires flash. It seems the version for Ubuntu is not compatible with
> my hardware. The Adobe site for some reason thinks Ubuntu needs at least
> 512 MB RAM and 128 video Ram to run it despite Windows and Mac only
> needing 128MB, I have no clue why. If anyone can explain this I'd love
> to know.
>
> I was wondering if there was a Ubuntu application similar to the
> iPhone/iPod Touch app that allows you to bypass the Flash version of
> Youtube? This would fix the whole issue as I even had his old PCIMCA
> wireless card working in Ubuntu and now it doesn't seem to want to
> connect to my network when I restored Windows for him. I am beginning to
> think repairing (new hdd) the old iBook would be easier and that was a
> bear to replace a hard drive in. Our budget doesn't allow a new machine
> for a while.
>

Can you help with this problem?

Provide an answer of your own, or ask Tahsin for more information if necessary.

To post a message you must log in.