trying to install flashplugin-non free

Asked by John Kelly on 2008-07-14

"Following Tangs instructions to install fllashplugin-non free Edit Aministration Synaptic manager etc I get as far as " mark for installation" and "Apply doesnt allow me to select it . Help

thanks
john
absolute beginner

I found mark for installation as being control+1 but nothing happens

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2008-07-17
Last reply:
2008-07-17

This question was reopened

Andy Ruddock (andy-ruddock) said : #1

What happens if you open a terminal and enter :

# sudo apt-get install flashplugin-nonfree

entering your password when prompted?

If the above solution doesn't work, you could also go to http://www.adobe.com/products/flashplayer/,
- download the file
- open terminal, cd to where you extracted the folder and run "sudo ./flashplayer-installer"

John Kelly (lioganach) said : #3

complete beginner!
whats a terminal

John Kelly (lioganach) said : #4

L815
where is open terminal cd

Andy Ruddock (andy-ruddock) said : #5

A terminal is a window where you can type commands to be executed directly.
It's a bit old school but you get to control what's happening with a little more detail, and you get to see error messages that a gui program might hide from you. On the other hand, you need to know exactly what to type and which commands to enter.
Open a terminal window in gnome by going to the Applications menu and clicking on it, then select the Accessories sub-menu - you'll find an icon for Terminal in this list, so just click on it.

A window should open with a prompt which looks something like :
user@machine#
where "user" is your username that you logged in with and "machine" is the name you gave your computer when you installed Ubuntu.

When typing commands the convention is to show them like this :
# command_to_type
where "#" represents the prompt, and "command_to_type" is the command you've been asked to type. Type the command as given and press the Return (or Enter) key.

If you've been asked to type two or more commands you need to be sure that you're typing exactly what you're asked and not trying to do do two things at once.

With that in mind, open a terminal window, at the prompt enter the command :
# sudo apt-get install flashplugin-nonfree

Please report back what is displayed on the screen after you've done this, so we can determine what steps you need to take next.

John Kelly (lioganach) said : #6

having entered the command sudo etc when I press "enter" my user name and machine name appears underneath the same as I started with earlier before adding the command

thanks
john

Andy Ruddock (andy-ruddock) said : #7

So the screen looks just like this?

username@machine# sudo apt-get install flashplugin-nonfree

username@machine#

You don't get asked for your password, no other prompts?

Can you try

# which sudo
# sudo -v
# apt-get -v

and report back the results please?

John Kelly (lioganach) said : #8

the same as before......user name and machine name appear underneath

Andy Ruddock (andy-ruddock) said : #9

You don't get any feedback from any of the commands?

Andy Ruddock (andy-ruddock) said : #10

You're not typing the "#" character are you?

John Kelly (lioganach) said : #11

I am typing the character "#" at the flashing prompt box

Andy Ruddock (andy-ruddock) said : #12

The "#" represents the prompt, just type the commands following it, try again with

# apt-get install flashplugin-nonfree

John Kelly (lioganach) said : #13

Hi
thanks for your patience!
I tried apt-get etc what came up was...
E: Could not open lock file/var/lib/dpkg/lock-open 13Permission denied
E: Unable to lock the admisistration directory(ver/lib/dpkg/), are you root?

next time I tried sudo apt-get etc what came up was...

Reading packaged lists..Done
Building dependency tree
Reading state information done...done
E: Couldnt find package flashplugin-nonfree

Tobias Wolf (towolf) said : #14

Close Synaptic or the Add/Remove window and retry. Only one program can manage packages at a time.

Andy Ruddock (andy-ruddock) said : #15

Ok, we'll try via Synaptic, so make sure that all windows are closed, and you just have a plain desktop.
From the System menu select Administration and then Synaptic Package Manager

You should be prompted for your password, so enter it and continue.

When the main Synaptic window comes up, select the Settings menu and click on Repositories.

A dialog with 5 tabs should open, the first being labelled "Ubuntu Software", and underneath is is list headed "Downloadable from the Intenet".
Make sure that the entry "Software restricted by copyright or legal issues (multiverse)" has a tick in the check-box.

Close the dialog by clicking the Close button.

Select the Edit menu and click on "Reload Package Information".

When that's finished the available package list should refresh - that's the top right pane.
Scroll down until you find "flashplugin-nonfree" (the list is arranged aphabetically by package name)

Click on the box to the left of the package name and select "Mark for installation" from the menu that pops up.

Now click the Apply button in the toolbar at the top of the window, the package should be downloaded and installed.

Report back your success or any error messages you get and we'll take it from there.

Tang (robertmcgreg) said : #16

John Kelly wrote:
> Question #39203 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/39203
>
> Status: Needs information => Open
>
> John Kelly gave more information on the question:
> Hi
> thanks for your patience!
> I tried apt-get etc what came up was...
> E: Could not open lock file/var/lib/dpkg/lock-open 13Permission denied
> E: Unable to lock the admisistration directory(ver/lib/dpkg/), are you root?
>
> next time I tried sudo apt-get etc what came up was...
>
> Reading packaged lists..Done
> Building dependency tree
> Reading state information done...done
> E: Couldnt find package flashplugin-nonfree
>
>
Hi, I have to compliment you on *your* patience :)
Seems to me you don't have the repositories enabled. Don't have this
problems history in front of me right now, but have you gone to
System/Administration/Software Sources/Third Party Software and made
sure all sources are selected?

BTW, how many sources do you see there?

Andy Ruddock (andy-ruddock) said : #17

Looking back at your first post, it's Ctrl-i (as in "i" for "install") to mark for installation - not Ctrl-l

Be sure all software sources are selected under menu: System->Administration->Software source: Ubuntu software

Then open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo aptitude update
sudo apt-get upgrade
sudo aptitude install flashplugin-nonfree

give your user password when requested, you don't see nothing when you type it, then press enter.

Hope this helps

John Kelly (lioganach) said : #19

miraculously I believe that it has installed but when I try to access Enclyopaedia Britannica it says that I need Java script as well. Is there a quick way to check to see that it is indeed installed and how with your help can I have java script
thanks
John

John Kelly (lioganach) said : #20

Thanks Andy Ruddock, that solved my question.

To install java

Be sure all software sources are selected under menu: System->Administration->Software source: Ubuntu software

Then open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo aptitude update
sudo apt-get upgrade
sudo aptitude install sun-java6-jre sun-java6-plugin

give your user password when requested, you don't see nothing when you type it, then press enter.

Then confirm the license agreement using the tab or the arrows key to select ok and press enter

Hope this helps

Andy Ruddock (andy-ruddock) said : #22

Is that Java or Javascript?

Java and the applet plug-in can installed as per marcobra's fine instructions.

In Firefox you can check whether Javascript is enabled by selecting Edit -> Preferences and in the "Content" tab you'll find checkboxes for "Javascript" and "Java".

For a confirmation that java is working you can visit www.java.com - there's an online test to confirm you have java installed and working.

You can check your installation of flash by going to http://www.adobe.com/go/tn_15507 which will test your flash installation and display the version installed.

John Kelly (lioganach) said : #23

Hello Marcobra
did that....what appeared was.....

Get 1 http etc
!gn http etc
Get2 http
1GN http etc
HIT http etc
"
"
"
"
AT the bottom it says ..Reading Packaged lists done
and underneath
user name machine name "prompt"

John Kelly (lioganach) said : #24

no movie window appeared

and nothing shown in adobe as to what version installled
thanks
John

Andy Ruddock (andy-ruddock) said : #25

Can you confirm you're using FireFox 3.0 as your browser?

John Kelly (lioganach) said : #26

Not sure whether I have firefox3...so I downloaded it again

to have a box appear with

the firefox heading with underneath
archive edit view help
new open extract add files add folder.......HELP!

Andy Ruddock (andy-ruddock) said : #27

That sounds like "Archive Manager". To check the version of firefox, open it from the menu then select Help->About Mozilla Firefox the dialog that opens gives you the version number.
The great thing about Linux is that you almost never need to explicitly download software - rely on your package manager for software, because then you'll get security updates automatically.
To check plugins installed, start firefox and in the address box (where you'd normally type the URL) type "about:plugins" (without the quotation marks) and press return.

John Kelly (lioganach) said : #28

thanks for your help.
it appears I am on ubuntu 7.10 gutsy and firefox/2.0.0.6
I downloaded firefox 3 but can with your help get it into action!?

bottom of list it says....
flash video flv enabled YES!

Andy Ruddock (andy-ruddock) said : #29

I'd be more inclined to use the release that's available from the Ubuntu repositories.

# apt-get install firefox-3.0

Unfortunately the version available from the Ubuntu repositories is a pre-release version, to get an up to date release from the repositories would involve upgrading your entire operating system to 8.08 (Hardy).

You can always stick with firefox 2, many people feel that firefox 3 is a little unstable.

Can you help with this problem?

Provide an answer of your own, or ask John Kelly for more information if necessary.

To post a message you must log in.