Broadcom wireless drivers install and interface configuration

Asked by Anne Dowden on 2008-04-08

I need to use the wifi driver called ndiswrapper: Please could someone help by telling me how to go about installing this.

Thank you
Anne

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Anne Dowden
Solved:
2008-04-13
Last query:
2008-04-13
Last reply:
2008-04-13
Jim Hutchinson (jphutch) said : #2

Sorry I wasn't much help on the last issue. I totally missed the wired connection bit. Oh well, glad you got it working.

For the broadcom try https://help.ubuntu.com/community/WifiDocs/Device/Broadcom_BCM43xx_%28all,_ndiswrapper/firmware%29. Ignore the bit about the installer on the Ubuntu forums. It's not recommended any more. If the easy method doesn't work then there are some links there for ndiswrapper.

There are also a couple pages for your specific chipset (4318 via your info on the other question - Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)). You could try them as well.

https://help.ubuntu.com/community/WifiDocs/Device/Broadcom_BCM4318_%5bAirForce_One_54g%5d_%28Native_Driver%29
https://help.ubuntu.com/community/WifiDocs/Device/Broadcom_BCM4318_%5bAirForce_One_54g%5d

Anne Dowden (anne-dowden) said : #3

Thank you Jim

Don't worry about my last question, any input is a great help to me and you also helped on another question back in January.

I tried your first suggestion (presto123) and it seems to have worked, that is I have a green light. But I won't be able to try it out until someone (one of my children) comes along with their laptop. Unless of course you think I should unplug my router's ethernet connection and see if I still get a connection to the internet?

So should I say this problem is solved?

Thank you also Vojtech Trefney

Kind regards
Anne

Jim Hutchinson (jphutch) said : #4

Well, it's solved when you think it's solved. However, there are a couple things to address still. Mainly, how you plan to use the wifi on the computer. I'm no expert on this and I've never used a wifi card that could also be an access point but I'm pretty sure it's one or the other and not both. In other words, if you want your kids to connect to the computer via the wifi then it has to be an access point - which means you can't also use it to connect to your router and you will need to stay connected with wired ethernet. Since it sounds like you have a wireless router, I would suggest letting the kids connect to the router as that would be simpler in my opinion. I also kind of doubt that the AP function of the card is supported in the Linux driver. I could be wrong but broadcom cards are not well supported in general and advanced features probably less so. However, giving it a try would be fun though I have no idea where to start.

However, I would certainly suggest testing to see if you can use the wifi connection to connect to the router. That would help you know whether or not it's working right.

peter b (b1pete) said : #5

ok Anne, first a question to get myself up to speed on this new thread.

- would you please post the output of

sudo ndiswrapper -l

command here? (l above is the small L); that'll tell me whether the driver is properly installed. also,

- please tell me - is the antenna on the conn'n at the back of pc installed?

we'll continue after I see this message.

peter b

Anne Dowden (anne-dowden) said : #6

On Wed, 2008-04-09 at 00:27 +0000, peter b wrote:
> Your question #29262 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/29262
>
> peter b proposed the following answer:
> ok Anne, first a question to get myself up to speed on this new thread.
>
> - would you please post the output of
>
> sudo ndiswrapper -l

>
> command here?

anne@anne-desktop:~$ sudo ndiswrapper -l
[sudo] password for anne:
sudo: ndiswrapper: command not found

so I suppose it's not working properly!

> (l above is the small L); that'll tell me whether the
> driver is properly installed. also,
>
> - please tell me - is the antenna on the conn'n at the back of pc
> installed?

I have not connected an antenna to the back of the PC - Because I have
wifi on the motherboard as well as a wireless LAN card I have 2 antenna
(one looks like a mini pen in a pen holder and the other is just a stick
with an elbow joint) The green light is ON on the card slot at the back
of the PC. There is a small hole next to the motherboard antenna
connector, which is probably a green light but it is NOT ON.

I don't think that I should ever have got this card but I didn't realise
there was wifi on the motherboard. I spent so much time working out what
processor, RAM, and graphics card to get that I didn't pay enough
attention to the rest of it. I hope to be learning from my mistakes!

I am just so grateful for you and launchpad.
>
> we'll continue after I see this message.
>
> peter b

Thank you
Anne
>

Anne Dowden (anne-dowden) said : #7

On Tue, 2008-04-08 at 23:16 +0000, Jim Hutchinson wrote:
> Your question #29262 on Ubuntu changed:
> https://answers.edge.launchpad.net/ubuntu/+question/29262
>
> Status: Open => Answered
>
> Jim Hutchinson proposed the following answer:
> Well, it's solved when you think it's solved. However, there are a
> couple things to address still. Mainly, how you plan to use the wifi on
> the computer. I'm no expert on this and I've never used a wifi card that
> could also be an access point but I'm pretty sure it's one or the other
> and not both. In other words, if you want your kids to connect to the
> computer via the wifi then it has to be an access point - which means
> you can't also use it to connect to your router and you will need to
> stay connected with wired ethernet. Since it sounds like you have a
> wireless router, I would suggest letting the kids connect to the router
> as that would be simpler in my opinion. I also kind of doubt that the AP
> function of the card is supported in the Linux driver. I could be wrong
> but broadcom cards are not well supported in general and advanced
> features probably less so. However, giving it a try would be fun though
> I have no idea where to start.

If it was just me I would stick with wires (children can cause
problems!) but would they be able to connect wirelessly to the internet
via my router AND wirelessly via my computer in order to access
printers, scanner etc.?
>
> However, I would certainly suggest testing to see if you can use the
> wifi connection to connect to the router. That would help you know
> whether or not it's working right.

I am a bit nervous about trying this so think I will wait 'til I get an
answer from Peter about his questions.

Thank you so much
Anne
>

peter b (b1pete) said : #8

OK, Anne, pls. do not be worried at all about the above, things are pretty well under control.

now, firstly, there is no doubt, based on the output posted, that the drivers for broadcom wireless are not in place and as a consequence there is no way to get connected to any access point.

- secondly, again, based on your input re the modem-router that you connect through to internet (I ramble a little bit here just for your info) --> that 'gadget' that you ISP supplied to you (or probably you purchased it outright? at his suggestion) is a multipurpose device --> it is firstly a broadband modem that enables your PC(s) (pls observe PC(s) meaning) to connect to your ISP network; at the same time, is a router that assigns different addresses to various PC's connected to it AND because of that it 'hides' your PC's and eventual LAN to the outside world; MOREOVER, THIS IS V IMPORTANT, this router can be also AN ACCESS POINT --> let me explain, the router can accept, usually in an home enviro, 4 WIRED CONN'N AND ADDITIONALLY can accept up to 254 WIRELESS CONNECTIONS all with their distinctive IP adressess AND ALL -WIRED AND WIRELESS CONNECTED PC's are able to 'talk' and share resources to/from each other on the local LAN obviously if they are given individual permissions by their owners or, by the LAN administrator. AND to top all above off, ALL THESE mentioned PC's connected, wired and wireless, will be able to connect to internet BUT their addresses although different are translated by the router to appear as one that was given/assigned to you by the ISP; isn't that just great? a miracle of hightech?.

So, to put it in perspective, in your case, you already have a PC (the one that we worked on) that's connected -WIRED- to the router and has its own IP; if you do have already or will have additional PC's that connect EITHER wired or wireless to the router/access point they can be configured to form a LAN and share resources.

now, being cognizant of all above, what we'll do first, Anne pls, is to get your new os updated and upgraded with the latest packages available; pls do

sudo aptitude update

command - that'll update tour sources, woull see scrolling on the screen and get back to prompt then pls do

sudo aptitude upgrade

that'll upgrade your os; it'll take a little time to complete, let it finish -BOTH commands- do not interrupt please. upon completion you'll get a message that your system is up to date AND probably, will prompt you to reboot. Please do all that and tell me if everything completed WITH NO ERRORS. we'll continue after I get and answer from you.

peter b

Anne Dowden (anne-dowden) said : #9

On Wed, 2008-04-09 at 15:16 +0000, peter b wrote:
> Your question #29262 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/29262
>
> Status: Open => Answered
>
> peter b proposed the following answer:
> OK, Anne, pls. do not be worried at all about the above, things are
> pretty well under control.
>
> now, firstly, there is no doubt, based on the output posted, that the
> drivers for broadcom wireless are not in place and as a consequence
> there is no way to get connected to any access point.
>
> - secondly, again, based on your input re the modem-router that you
> connect through to internet (I ramble a little bit here just for your
> info) --> that 'gadget' that you ISP supplied to you (or probably you
> purchased it outright? at his suggestion) is a multipurpose device -->
> it is firstly a broadband modem that enables your PC(s) (pls observe
> PC(s) meaning) to connect to your ISP network; at the same time, is a
> router that assigns different addresses to various PC's connected to it
> AND because of that it 'hides' your PC's and eventual LAN to the outside
> world; MOREOVER, THIS IS V IMPORTANT, this router can be also AN ACCESS
> POINT --> let me explain, the router can accept, usually in an home
> enviro, 4 WIRED CONN'N AND ADDITIONALLY can accept up to 254 WIRELESS
> CONNECTIONS all with their distinctive IP adressess AND ALL -WIRED AND
> WIRELESS CONNECTED PC's are able to 'talk' and share resources to/from
> each other on the local LAN obviously if they are given individual
> permissions by their owners or, by the LAN administrator. AND to top all
> above off, ALL THESE mentioned PC's connected, wired and wireless, will
> be able to connect to internet BUT their addresses although different
> are translated by the router to appear as one that was given/assigned to
> you by the ISP; isn't that just great? a miracle of hightech?.
>
> So, to put it in perspective, in your case, you already have a PC (the
> one that we worked on) that's connected -WIRED- to the router and has
> its own IP; if you do have already or will have additional PC's that
> connect EITHER wired or wireless to the router/access point they can be
> configured to form a LAN and share resources.
>
> now, being cognizant of all above, what we'll do first, Anne pls, is to
> get your new os updated and upgraded with the latest packages available;
> pls do
>
> sudo aptitude update
>
> command - that'll update tour sources, woull see scrolling on the screen
> and get back to prompt then pls do
>
> sudo aptitude upgrade
>
> that'll upgrade your os; it'll take a little time to complete, let it
> finish -BOTH commands- do not interrupt please. upon completion you'll
> get a message that your system is up to date AND probably, will prompt
> you to reboot. Please do all that and tell me if everything completed
> WITH NO ERRORS. we'll continue after I get and answer from you.
>
> peter b
>
Peter, thank you for the reassurance.

I have pasted the output of my terminal commands here as it doesn't seem
to me that it's what you expected i.e. it didn't take very long, it
hasn't asked me to reboot and I see the words 'upgrade command
deprecated' Though could this be because I downloaded 205 updates just a
short while ago. (from the update icon)

anne@anne-desktop:~$ sudo aptitude update
[sudo] password for anne:
Ign cdrom://Ubuntu 7.10 _Gutsy Gibbon_ - Release i386 (20071016)
gutsy/main Translation-en_US
Ign cdrom://Ubuntu 7.10 _Gutsy Gibbon_ - Release i386 (20071016)
gutsy/restricted Translation-en_US
Get:1 http://fr.archive.ubuntu.com gutsy Release.gpg
[191B]
Ign http://fr.archive.ubuntu.com gutsy/main
Translation-en_US
Get:2 http://security.ubuntu.com gutsy-security Release.gpg [191B]
Ign http://security.ubuntu.com gutsy-security/main Translation-en_US
Ign http://fr.archive.ubuntu.com gutsy/restricted Translation-en_US
Ign http://fr.archive.ubuntu.com gutsy/universe Translation-en_US
Ign http://fr.archive.ubuntu.com gutsy/multiverse Translation-en_US
Get:3 http://fr.archive.ubuntu.com gutsy-updates Release.gpg [191B]
Ign http://fr.archive.ubuntu.com gutsy-updates/main Translation-en_US
Ign http://fr.archive.ubuntu.com gutsy-updates/restricted
Translation-en_US
Ign http://fr.archive.ubuntu.com gutsy-updates/universe
Translation-en_US
Ign http://fr.archive.ubuntu.com gutsy-updates/multiverse
Translation-en_US
Ign http://security.ubuntu.com gutsy-security/restricted
Translation-en_US
Ign http://security.ubuntu.com gutsy-security/universe Translation-en_US
Ign http://security.ubuntu.com gutsy-security/multiverse
Translation-en_US
Hit http://fr.archive.ubuntu.com gutsy Release
Hit http://security.ubuntu.com gutsy-security Release
Hit http://fr.archive.ubuntu.com gutsy-updates Release
Hit http://security.ubuntu.com gutsy-security/main Packages
Hit http://fr.archive.ubuntu.com gutsy/main Packages
Hit http://fr.archive.ubuntu.com gutsy/restricted Packages
Hit http://fr.archive.ubuntu.com gutsy/main Sources
Hit http://fr.archive.ubuntu.com gutsy/restricted Sources
Hit http://fr.archive.ubuntu.com gutsy/universe Packages
Hit http://security.ubuntu.com gutsy-security/restricted Packages
Hit http://security.ubuntu.com gutsy-security/main Sources
Hit http://security.ubuntu.com gutsy-security/restricted Sources
Hit http://fr.archive.ubuntu.com gutsy/universe Sources
Hit http://fr.archive.ubuntu.com gutsy/multiverse Packages
Hit http://fr.archive.ubuntu.com gutsy/multiverse Sources
Hit http://fr.archive.ubuntu.com gutsy-updates/main Packages
Hit http://fr.archive.ubuntu.com gutsy-updates/restricted Packages
Hit http://fr.archive.ubuntu.com gutsy-updates/main Sources
Hit http://fr.archive.ubuntu.com gutsy-updates/restricted Sources
Hit http://fr.archive.ubuntu.com gutsy-updates/universe Packages
Hit http://fr.archive.ubuntu.com gutsy-updates/universe Sources
Hit http://fr.archive.ubuntu.com gutsy-updates/multiverse Packages
Hit http://security.ubuntu.com gutsy-security/universe Packages
Hit http://security.ubuntu.com gutsy-security/universe Sources
Hit http://security.ubuntu.com gutsy-security/multiverse Packages
Hit http://security.ubuntu.com gutsy-security/multiverse Sources
Hit http://fr.archive.ubuntu.com gutsy-updates/multiverse Sources
Fetched 3B in 0s (3B/s)
Reading package lists... Done
anne@anne-desktop:~$ sudo aptitude upgrade
W: The "upgrade" command is deprecated; use "safe-upgrade" instead.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Initializing package states... Done
Writing extended state information... Done
Building tag database... Done
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Writing extended state information... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done
anne@anne-desktop:~$

Just for further info in case it's of any relevance - The gadget must be
my 'livebox' supplied to me by wanadoo my ISP. It has a second ethernet
socket, a USB socket and one other that I don't recognise. The USB
connection was useless (I am at the end of the line and broadband is not
very broad - you could say narrow but it's better than dial up!) So I
had to buy an ethernet card and fit it in my old computer.

Thank you for your explanations. Things are becoming clearer to me (I
only hope I can remember all this learning) 'though I now think that I
didn't really need any wifi stuff on my new computer at all. Having got
it, it does need to be working 'though and hopefully other people will
be helped by the time and effort you are giving to me otherwise I feel
quite bad and very stupid!

Kind regards
Anne

peter b (b1pete) said : #10

Anne, it's alright, you can use

sudo aptitude safe-upgrade

I did not know that you've already updated and upgraded your os; that did it what I was after. now, pls go -->System-->Admin-->synaptic package manager and click on it--> a new window will open after password entered-->you'll get an icon Search among others-->pls open it and enter

ndis

and click on ok; there will be 2 packages that we're interested in and appear after you scroll through the packages -->

one is called

ndiswrapper-common

and the second one

ndiswrapper-utils-......

please right click on the first one and select install; do the same thing on the second one. then press on the Apply icon and complete the procedure. and just to be on the safe side, after completion pls go back to search and enter ndis and ok scroll again to the two pkges above --> they should appear this time marked as installed.

after all done and ok please reboot your pc. on the next post we'll enter into the windows driver install procedure; these steps up to now are 'ground preparation' for the real driver install. tell me how it went pls.

peter b

Anne Dowden (anne-dowden) said : #11

On Wed, 2008-04-09 at 17:02 +0000, peter b wrote:
> Your question #29262 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/29262
>
> Status: Open => Answered
>
> peter b proposed the following answer:
> Anne, it's alright, you can use
>
> sudo aptitude safe-upgrade
>
> I did not know that you've already updated and upgraded your os; that
> did it what I was after. now, pls go -->System-->Admin-->synaptic
> package manager and click on it--> a new window will open after password
> entered-->you'll get an icon Search among others-->pls open it and enter
>
> ndis
>
> and click on ok; there will be 2 packages that we're interested in and
> appear after you scroll through the packages -->
>
> one is called
>
> ndiswrapper-common
>
> and the second one
>
> ndiswrapper-utils-......
>
> please right click on the first one and select install; do the same
> thing on the second one. then press on the Apply icon and complete the
> procedure. and just to be on the safe side, after completion pls go back
> to search and enter ndis and ok scroll again to the two pkges above -->
> they should appear this time marked as installed.
>
> after all done and ok please reboot your pc. on the next post we'll
> enter into the windows driver install procedure; these steps up to now
> are 'ground preparation' for the real driver install. tell me how it
> went pls.
>
> peter b
>

Peter, all went fine.

'though I was asked to put the ubuntu 7.10 disc into the rom drive
before package manager would install. I don't know why. Anyway all is
now installed and computer rebooted. Look forward to the windows driver
install procedure.

Kind regards
Anne

peter b (b1pete) said : #12

ok Anne, good to hear good news; you had to insert the cd because the packages mentioned were not downloaded to your pc by the os initial install -that's quite normal nothing to worry about.

Anne, rereading the last part of your previous post I'm little in the dark re 'the gadget' I'll explain

- the 'gadgets' come in various configurations and I'm not sure in my mind -exactly- what functions yours can fulfill. so, pls describe for my benefit how yours looks like, specifically, what I'm interested in is as follows

- there MUST be a port for 'gadget' conn'n to the ISP's cable or phone line
- just forget the power connector that's a given
- pls tell me how many other sockets are on the 'gadget' SIMILAR with the one we used to connect this new PC? pls count all of them INCLUDING the ONES THAT HAVE ALREADY patch cables installed (usually there are 4 altogether - TRUE OR FALSE?); is your old PC still connected WIRED to the 'gadget"?
- pls tell me does the 'gadget' have any antennas that can be seen? did you or somebody else with a pc connect WIRELESSLY to the 'gadget'?

I'm sorry for asking these questions but they are v important for me to be clear in my mind that YOUR 'gadget' HAS INDEED BUILT IN the capability to act as an access point. I certainly hope so because otherwise there is no access point to connect to after the PC wifi interface is configured.

now, windows drivers install with ndiswrapper -->Anne, herebelow there is a url , a howto very well kept up to date that we'll be using to carry out the task at hand

https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx/Feisty_No-Fluff

you'll see down the page that your BCM4318 rev2 identified at install (see 29155 question post of lspci) is listed and a specific action must be taken; I'll list below step 2c as described pertinent

pls do

wget http://dlsvr03.asus.com/pub/ASUS/wireless/WL-100g-03/Driverv3100640.zip

this command will download the windows driver to your desktop from asus site. it's a .zip file. Anne, pls from here on observe v closely the upper and lower characters that will be entered for future operations --> ndiswrapper has v strict rules when used. next

pls go Places-->Home folder-->a new window opens with the contents of your /home/<yourname> folder displayed ; pls tell me exactly what that <yourname> is, is it anne ? or Anne? or what exactly. next,

on the menu bar of THAT window pls select file-->create folder-->click on selection-->a new unnamed folder appears-->right click on it --> select rename-->click on selection AND PLS ENTER, SAY, EXACTLY,

bcm4318drivers

so, just make sure that all is ok then double click on this bcm4318drivers folder-->it'll open and NOTHING should be displayed (folder is empty) next

pls go back to /home/<yourname> folder and leave it open then point your mouse over the downloaded .zip file on the desktop, right click on it-->select cut option and move your mouse over an open area of /home/<yourname> folder, right click on it-->select paste option-->the folder should be now transferred-->right click on it-->select extract here option-->a new folder created which, in all probabilities is called drivers, I'm not sure though, next

double click on this newly created folder and there should be some folders and probably some files-->please open the folder that has on its name something like WINXP--> there should be some files there-->THE ONES -ONLY 2 OF THEM- THAT WE'RE INTERESTED ARE, the first

xxxxxx.inf

and

xxxxxx.sys

PLEASE TELL ME EXACTLY WHAT THEY ARE CALLED (SUBSTITUTE xxxxxx ABOVE), next

please copy and paste THESE TWO FILES -ONLY- to the newly created folder

bcm4318drivers

in the previous steps. once all these preparatory steps done and obviously all should be ok -it' a fairly simple exercise- please tell me the answers to the questions above and how this exercise went-->we'll continue after I hear from you.

peter

naufal (musp-student) said : #13

hello,
what is your wireless device?
I'm running Broadcom bcm4318 wireless card without using ndiswrapper...

peter b (b1pete) said : #14

Anne,

tonight curiosity pushed me to google a little on the term 'livebox' that you mentioned in a previous post-->I found some info, see below

http://help.orange.co.uk/documentDisplay.do?clusterName=DefaultCluster&preview=1&groupId=1&page=http://ESERVER_b15f0aab-3f8d-4930-bfc9-c152574bb29f.xhtml&docType=1006&resultType=5002&docProp=$solution_id&docPropValue=kb14497

now, question pls -is that the 'gadget' that you mentioned - livebox -that you're having and using?

from this url I could see that you're located somewhere in Europe -here in Canada I never seen such 'gadget'; it is supplied by orange/wanadoo apparently. it is different than the ones we're using here - I could see that it has 1 only socket for wired connections and I gather, reading its setup procedures that it MAY accept wireless connections too.

so, you CANNOT use more than one wired connection - there are NO additional sockets (here with our 'gadgets' we can use up to 4 hence up to 4 PC's CAN be connected). it also appears that the 'gadget' once setup for wired connection - your case- IT WAS AUTOMATICALLY set to ACCEPT WIRELESS connections also. that would be a v important thing to find out; IF THAT IS THE CASE; pls make a question to your ISP -->for sure they'll tell you. if the answer is YES that's what we're after --> have the access point present and ready to accept connections.

we'll be exchanging more info when you're ready with answers to this and last post.

peter

PS. I could see a new post from naufal saying that he uses bcm4318 wifi without ndiswrapper --> probably he is not aware that your i686 distro requires ndiswrapper.

Anne Dowden (anne-dowden) said : #15

OK Peter,

Sorry to be so long replying, but have been in quite a pickle with both old and new PCs i.e. trying to get them both connected to the net via my router/livebox/gadget. I have not succeded. If they are both plugged in via ethernet cable only my old PC will pick up a connection. have decided to leave it till later, think I'm trying to do too many things at the same time.

Anyway, to start with your first post -
The gadget - there is a port connection to the ISP phone line.
There are 4 sockets altogether on the gaget- 2 Ethernet, 1 USB and 1 other which I don't recognise (it says next to it 'USB PC') (I'm not counting the 2 phoneline sockets or the power supply)
There is no visible antenna nor has anyone tried to connect wirelessly to the 'livebox', but according to the set up instructions for the 'gadget' it can have a wireless connection and there is a symbol for an antenna next to one of the lights on top of the 'gadget' and the light is ON.

My home folder name is anne

The 2 files are called - bcmwl5.inf - and - bmcwl5.sys

Everything seems to have gone fine.

Now your second post -

The Gadget/livebox that I have seems to be a bit different to the one that you discovered on the net, but having looked at the url. I think it is the same, it's just that all the sockets are not mentioned. Re. my discription of gadget above it should accept a wireless connection so it would be just great to use the wifi on my new PC to connect.

I am in France by the way.

I hope I have answered everything.

Kind regards
Anne

peter b (b1pete) said : #16

Anne, great, all's OK. the only thing that it is still a little up in the air - in my mind at least - as far as your livebox is concerned is the number of sockets FOR PC WIRED CONNECTIONS (which MUST BE RJ45 type or cat 5/5e cable that uses 8 wires); the way I could see on the site where livebox is described/shown I could see only one socket for such connection; the second one that looks similar is NOT for PC connection ie, RJ45 (it is a RJ11 used for connecting the livebox to the phone line and usually uses 4 or 6 wires). anyhow, as you said, we won't be concerned with this issue now, you made the decision to connect the new PC WIRELESS and if you want, after this is accomplished, there still is a socket avail for a WIRED conn'n for your old PC.

so, let's continue with the task at hand. first thing that I'd like you to do pls. to be sure that all is OK prior to running the crucial command that installs the drivers is to run

cd /home/anne/bcm4318drivers

then

ls -l

l above is small L. you should (must) see ONLY TWO FILES --> one called bcmwl5.inf and the second one bmcwl5.sys EXACLY LIKE THAT. IF THAT IS SO next pls run

sudo ndiswrapper -i /home/anne/bcm4318drivers/bcmwl5.inf

if this command succedes we're pretty well out of the woods so to speak. there should be some output following this command run --> pls post this output.

next, to find whether the drivers were installed properly pls run

sudo ndiswrapper -l

l above is small L. there should be some output after running this command. --> pls post this output here too. just for your info --> if the output of these two commands are as I expect it to be the rest is just a walk in the park. we'll continue after that.

peter

peter b (b1pete) said : #17

I'M V V SORRY ANNE< I FORGOT AND IT IS V IMPORTANT

- PLEASE ATTACH THE WIFI ANTENNA TO THE BACK OF PC PRIOR TO RUNNING THE LAST TWO COMMANDS.

peter

Anne Dowden (anne-dowden) said : #18

On Fri, 2008-04-11 at 00:44 +0000, peter b wrote:
> Your question #29262 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/29262
>
> peter b proposed the following answer:
> I'M V V SORRY ANNE< I FORGOT AND IT IS V IMPORTANT
>
> - PLEASE ATTACH THE WIFI ANTENNA TO THE BACK OF PC PRIOR TO RUNNING THE
> LAST TWO COMMANDS.
>
> peter

Peter,

I haven't run the commands yet. Please could you clarify, which antenna
I should put on which connector at the back of the PC - Because I have
wifi on the motherboard as well as a wireless LAN card I have 2 antenna
(one looks like a mini pen in a pen holder and the other is just a stick
with an elbow joint) At the back of the PC there is a green light, which
is ON, next to the antenna connection on the wireless LAN card slot.
Also there is a small hole next to the motherboard antenna
connector, which is probably a green light but it is NOT ON. The 'mini
pen with holder' antenna came with the motherboard and the 'elbow
jointed' antenna came with the WLAN card. Sorry to be so daft, but what
goes where please.

Kind regards
Anne
>

peter b (b1pete) said : #19

Anne, facing the back of PC on the right hand side -far right- opposite keyboard connection - there is a bunch of 6 audio connectors stacked vertically on two rows of three - the top two are coloured one orange and the farthest from the keyboard connector is blue

then even farther to the right next to the farthest blue connector abovem somewhere mid distance going down from the top two audio connectors, there should be, probably, most likely, a threaded connector (probably yellow because it's made of brass) --> this is the connector for the wifi on motherboard --> pls connect the elbow type omnidirectional antenna here.

further down from this connector there should be a LED that will be lit when the wifi is used.

peter

peter b (b1pete) said : #20

now, it depends what type of case you've got -the above is for a desktop flat case- if vertical type case everything above is rotated 90 degrees.

Anne Dowden (anne-dowden) said : #21

Thank you Peter,

My PC's case is vertical, all connected up as you describe. I will now
follow the steps in your previous post.

Kind regards
Anne

On Fri, 2008-04-11 at 14:00 +0000, peter b wrote:
> Your question #29262 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/29262
>
> peter b proposed the following answer:
> now, it depends what type of case you've got -the above is for a desktop
> flat case- if vertical type case everything above is rotated 90 degrees.
>

Anne Dowden (anne-dowden) said : #22

On Fri, 2008-04-11 at 00:35 +0000, peter b wrote:
> Your question #29262 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/29262
>
> Status: Open => Answered
Peter results below

> peter b proposed the following answer:
> Anne, great, all's OK. the only thing that it is still a little up in
> the air - in my mind at least - as far as your livebox is concerned is
> the number of sockets FOR PC WIRED CONNECTIONS (which MUST BE RJ45 type
> or cat 5/5e cable that uses 8 wires); the way I could see on the site
> where livebox is described/shown I could see only one socket for such
> connection; the second one that looks similar is NOT for PC connection
> ie, RJ45 (it is a RJ11 used for connecting the livebox to the phone line
> and usually uses 4 or 6 wires). anyhow, as you said, we won't be
> concerned with this issue now, you made the decision to connect the new
> PC WIRELESS and if you want, after this is accomplished, there still is
> a socket avail for a WIRED conn'n for your old PC.
>
> so, let's continue with the task at hand. first thing that I'd like you
> to do pls. to be sure that all is OK prior to running the crucial
> command that installs the drivers is to run
>
> cd /home/anne/bcm4318drivers
>
> then
>
> ls -l
>
> l above is small L. you should (must) see ONLY TWO FILES --> one called
> bcmwl5.inf and the second one bmcwl5.sys EXACLY LIKE THAT. IF
> THAT IS SO next pls run
>
> sudo ndiswrapper -i /home/anne/bcm4318drivers/bcmwl5.inf
>
> if this command succedes we're pretty well out of the woods so to speak.
> there should be some output following this command run --> pls post this
> output.

anne@anne-desktop:~/bcm4318drivers$ sudo ndiswrapper
-i /home/anne/bcm4318drivers/bcmwl5.inf
[sudo] password for anne:
installing bcmwl5 ...
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2
forcing parameter IBSSGMode from 0 to 2

>
> next, to find whether the drivers were installed properly pls run
>
> sudo ndiswrapper -l
>
> l above is small L. there should be some output after running this
> command. --> pls post this output here too. just for your info --> if
> the output of these two commands are as I expect it to be the rest is
> just a walk in the park. we'll continue after that.
>
anne@anne-desktop:~/bcm4318drivers$ sudo ndiswrapper -l
bcmwl5 : driver installed
        device (14E4:4318) present (alternate driver: bcm43xx)
anne@anne-desktop:~/bcm4318drivers$

> peter
>
I hope this is what you were expecting Peter.

Kind regards
Anne

peter b (b1pete) said : #23

it looks good/promising; pls run the second command that'll tell us if all is ok1 -->it should be, we're pros.

sudo ndiswrapper -l

l above is small L; please post the output --> thanks.

peter

Anne Dowden (anne-dowden) said : #24

On Fri, 2008-04-11 at 20:49 +0000, peter b wrote:
> Your question #29262 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/29262
>
> Status: Open => Answered
>
> peter b proposed the following answer:
> it looks good/promising; pls run the second command that'll tell us if
> all is ok1 -->it should be, we're pros.
>
> sudo ndiswrapper -l
>
> l above is small L; please post the output --> thanks.
>
> peter
>
Second command below -

anne@anne-desktop:~$ sudo ndiswrapper -l
[sudo] password for anne:
bcmwl5 : driver installed
        device (14E4:4318) present (alternate driver: bcm43xx)
anne@anne-desktop:~$

Regards
Anne

peter b (b1pete) said : #25

perfect! OK1 --> all's under control.

I propose/suggest to leave it at that for the day if it's alright with you. here's almost 6 pm and I have some things that my attendance is required, I have to go out around 6:30. I hope you understand; also your time is close to 11 pm?

we'll continue with the rest which is not much tomorrow around 10 ish in the morning our time if ok with you. I'm around for the next 15 min or so.

great job Anne!

peter

peter b (b1pete) said : #26

hello Anne,

I came home a little earlier than I thought; I'll post below the next steps so you have them early and do them; so, here we go

now, first, pls. do

sudo depmod -a

you'll see no output but there'll be a short delay until the anne@anne..... appears again on terminal. after this pls do

sudo modprobe ndiswrapper

then do

sudo cp /etc/network/interfaces /etc/network/interfaces.orig

there'll be some output, then do

echo -e 'auto lo\niface lo inet loopback\n' | sudo tee /etc/network/interfaces

then do

sudo ndiswrapper -m

then do

echo 'ndiswrapper' | sudo tee -a /etc/modules

the above should not produce any error messages. if they DO

             pls post all messages after the commands above and DO NOT run following commands UNTIL I see the messages.

if they DO NOT pls continue with commands as follows

now, we'll blacklist the bcm43xx driver in the kernel. pls do

sudo gedit /etc/modprobe.d/blacklist

the editor will open a new window, move the cursor JUST WITH THE ARROW KEYS AFTER THE LAST CHARACTER OF THE LAST ENTRY then press twice enter key--> you'll have a blinking cursor AT THE BEGINNING OF A NEW LINE; AT THIS BLINKING CURSOR ENTER EXACTLY THE FOLLOWING LINES; OBVIOUSLY, YOU"LL HAVE TO PRESS ENTER AFTER THE FIRST LINE TO OPEN THE SECOND ONE

# Blacklist bcm43xx wifi driver
blacklist bcm43xx

check entries AND AT THE BLINKING CURSOR AT THE END OF SECOND LINE PRESS ENTER KEY ONCE MORE AND LEAVE IT THERE. BE V CAREFUL OF ALL ABOVE EDITING PLS.

now, on the command bar pls select File-->Save and press it; after that File-->Quit. the editor will close and new editted file saved.

now, just reboot the PC. we'll continue after that.

peter

Anne Dowden (anne-dowden) said : #27

Peter,

No error message but there was no output after 'sudo
cp /etc/network/interfaces /etc/network/interfaces.orig' Should I
continue?

anne@anne-desktop:~$ sudo depmod -a
[sudo] password for anne:
anne@anne-desktop:~$ sudo modprobe ndiswrapper
anne@anne-desktop:~$ sudo cp /etc/network/interfaces /etc/network/interfaces.orig
anne@anne-desktop:~$

Anne

On Sat, 2008-04-12 at 02:42 +0000, peter b wrote:
> Your question #29262 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/29262
>
> peter b proposed the following answer:
> hello Anne,
>
> I came home a little earlier than I thought; I'll post below the next
> steps so you have them early and do them; so, here we go
>
> now, first, pls. do
>
> sudo depmod -a
>
> you'll see no output but there'll be a short delay until the
> anne@anne..... appears again on terminal. after this pls do
>
> sudo modprobe ndiswrapper
>
> then do
>
> sudo cp /etc/network/interfaces /etc/network/interfaces.orig
>
> there'll be some output, then do
>
> echo -e 'auto lo\niface lo inet loopback\n' | sudo tee
> /etc/network/interfaces
>
> then do
>
> sudo ndiswrapper -m
>
> then do
>
> echo 'ndiswrapper' | sudo tee -a /etc/modules
>
> the above should not produce any error messages. if they DO
>
> pls post all messages after the commands above and DO NOT
> run following commands UNTIL I see the messages.
>
> if they DO NOT pls continue with commands as follows
>
> now, we'll blacklist the bcm43xx driver in the kernel. pls do
>
> sudo gedit /etc/modprobe.d/blacklist
>
> the editor will open a new window, move the cursor JUST WITH THE ARROW
> KEYS AFTER THE LAST CHARACTER OF THE LAST ENTRY then press twice enter
> key--> you'll have a blinking cursor AT THE BEGINNING OF A NEW LINE; AT
> THIS BLINKING CURSOR ENTER EXACTLY THE FOLLOWING LINES; OBVIOUSLY,
> YOU"LL HAVE TO PRESS ENTER AFTER THE FIRST LINE TO OPEN THE SECOND ONE
>
> # Blacklist bcm43xx wifi driver
> blacklist bcm43xx
>
> check entries AND AT THE BLINKING CURSOR AT THE END OF SECOND LINE PRESS
> ENTER KEY ONCE MORE AND LEAVE IT THERE. BE V CAREFUL OF ALL ABOVE
> EDITING PLS.
>
> now, on the command bar pls select File-->Save and press it; after that
> File-->Quit. the editor will close and new editted file saved.
>
> now, just reboot the PC. we'll continue after that.
>
> peter
>

peter b (b1pete) said : #28

just to check that the file interfaces was copied pls do

places-->home folder-->on left panel double click file system--> on the right panel double click etc --> scroll down on right panel to folder network--> double click on it--> on right panel there should be, among others, 2 files--> one should be called interfaces the other interfaces.orig

pls confirm and carry on the other commands.

peter

Anne Dowden (anne-dowden) said : #29

Yes those 2 files are there. I will continue with the commands;

thank you
Anne

On Sat, 2008-04-12 at 14:07 +0000, peter b wrote:
> Your question #29262 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/29262
>
> Status: Open => Answered
>
> peter b proposed the following answer:
> just to check that the file interfaces was copied pls do
>
> places-->home folder-->on left panel double click file system--> on the
> right panel double click etc --> scroll down on right panel to folder
> network--> double click on it--> on right panel there should be, among
> others, 2 files--> one should be called interfaces the other
> interfaces.orig
>
> pls confirm and carry on the other commands.
>
> peter
>

Anne Dowden (anne-dowden) said : #30

Peter,

Command not found?

anne@anne-desktop:~$ echo -e 'auto lo\niface lo inet loopback\n' | sudo
tee/etc/network/interfaces
[sudo] password for anne:
sudo: tee/etc/network/interfaces: command not found
anne@anne-desktop:~$

What should I do now please?

Anne

On Sat, 2008-04-12 at 14:07 +0000, peter b wrote:
> Your question #29262 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/29262
>
> Status: Open => Answered
>
> peter b proposed the following answer:
> just to check that the file interfaces was copied pls do
>
> places-->home folder-->on left panel double click file system--> on the
> right panel double click etc --> scroll down on right panel to folder
> network--> double click on it--> on right panel there should be, among
> others, 2 files--> one should be called interfaces the other
> interfaces.orig
>
> pls confirm and carry on the other commands.
>
> peter
>

peter b (b1pete) said : #31

Anne, pls just copy and paste the command as I listed it in the previous post, one line pls, - as shown below

echo -e 'auto lo\niface lo inet loopback\n' | sudo tee /etc/network/interfaces

peter

Anne Dowden (anne-dowden) said : #32

Peter

Copied from previous post and pasted below

echo -e 'auto lo\niface lo inet loopback\n' | sudo tee
/etc/network/interfaces

It doesn't paste on one line but I typed it into terminal as one line.
Is there a space after tee ? I didn't put one.

Anne

On Sat, 2008-04-12 at 14:45 +0000, peter b wrote:
> Your question #29262 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/29262
>
> Status: Open => Answered
>
> peter b proposed the following answer:
> Anne, pls just copy and paste the command as I listed it in the previous
> post, one line pls, - as shown below
>
> echo -e 'auto lo\niface lo inet loopback\n' | sudo tee
> /etc/network/interfaces
>
> peter
>

peter b (b1pete) said : #33

the commands CANNOT be parsed as shown on your post; pls use the link on the e-mail to this ticket and ON THE BROWSER it'll be displayed as I called it and as it should be.

Anne Dowden (anne-dowden) said : #34

Peter,

I tried to paste into terminal from your post this is what I got

anne@anne-desktop:~$ echo -e 'auto lo\niface lo inet loopback\n' | sudo
tee
[sudo] password for anne:

How do I back track in terminal?

Sorry
Anne

On Sat, 2008-04-12 at 14:45 +0000, peter b wrote:
> Your question #29262 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/29262
>
> Status: Open => Answered
>
> peter b proposed the following answer:
> Anne, pls just copy and paste the command as I listed it in the previous
> post, one line pls, - as shown below
>
> echo -e 'auto lo\niface lo inet loopback\n' | sudo tee
> /etc/network/interfaces
>
> peter
>

peter b (b1pete) said : #35

in terminal window on the menu bar pls go-->view-->select full screen-->enable (tick) full screen.

yes, there is a space.

Anne Dowden (anne-dowden) said : #36

Peter,

All done and rebooted.

Anne

On Sat, 2008-04-12 at 15:20 +0000, peter b wrote:
> Your question #29262 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/29262
>
> Status: Open => Answered
>
> peter b proposed the following answer:
> in terminal window on the menu bar pls go-->view-->select full
> screen-->enable (tick) full screen.
>
> yes, there is a space.
>

peter b (b1pete) said : #37

ok, great Anne--> you've fought your way through. now pls do

ifconfig

and

iwconfig

pls post here the outputs.

peter b

Anne Dowden (anne-dowden) said : #38

On Sat, 2008-04-12 at 16:53 +0000, peter b wrote:
> Your question #29262 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/29262
>
> Status: Open => Answered
>
> peter b proposed the following answer:
> ok, great Anne--> you've fought your way through. now pls do
>
> ifconfig
>
> and
>
> iwconfig
>
> pls post here the outputs.
>
> peter b

Peter,

Output below

anne@anne-desktop:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:1E:8C:7C:77:8F
          inet addr:192.168.1.10 Bcast:192.168.1.255
Mask:255.255.255.0
          inet6 addr: fe80::21e:8cff:fe7c:778f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:541 errors:0 dropped:0 overruns:0 frame:0
          TX packets:571 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:367762 (359.1 KB) TX bytes:82521 (80.5 KB)
          Interrupt:17

eth1 Link encap:Ethernet HWaddr 00:1D:60:2E:F9:78
          UP BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
          Interrupt:17 Memory:febfe000-fec00000

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:2 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:164 (164.0 b) TX bytes:164 (164.0 b)

wlan0 Link encap:Ethernet HWaddr 00:15:AF:63:E8:80
          UP BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

wmaster0 Link encap:UNSPEC HWaddr
00-15-AF-63-E8-80-00-00-00-00-00-00-00-00-00-00
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

anne@anne-desktop:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:""
          Mode:Managed Frequency:2.412 GHz Access Point:
Not-Associated
          Retry min limit:7 RTS thr:off Fragment thr=2346 B
          Link Quality:0 Signal level:0 Noise level:0
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth1 IEEE 802.11g ESSID:off/any
          Mode:Managed Frequency:2.462 GHz Access Point:
Not-Associated
          Bit Rate:54 Mb/s Tx-Power:25 dBm
          RTS thr:2347 B Fragment thr:2346 B
          Power Management:off
          Link Quality:0 Signal level:0 Noise level:0
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

anne@anne-desktop:~$

Hope this is as it should be.

Anne
>

peter b (b1pete) said : #39

ok Anne, that's great. now, for your info--> your PC WIRED interface is --> eth0

and your PC WIRELESS interface is --> wlan0

the last one is not 'tied' to an AP for the time being; pls do

gedit /etc/network/interfaces

and post its contents here; after I see it we'll edit it. pls do also

sudo iwlist wlan0 scan

and post the output here too, thx.

peter

Anne Dowden (anne-dowden) said : #40

On Sat, 2008-04-12 at 17:44 +0000, peter b wrote:
> Your question #29262 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/29262
>
> Status: Open => Answered
>
> peter b proposed the following answer:
> ok Anne, that's great. now, for your info--> your PC WIRED interface is
> --> eth0
>
> and your PC WIRELESS interface is --> wlan0
>
> the last one is not 'tied' to an AP for the time being; pls do
>
> gedit /etc/network/interfaces
>
> and post its contents here; after I see it we'll edit it. pls do also
>
> sudo iwlist wlan0 scan
>
> and post the output here too, thx.
>
> peter
>
Peter

The first command gave this in a new window

auto lo
iface lo inet loopback

Do I give the second command in this window or in the original window or
maybe it doesn't matter?

Anne

peter b (b1pete) said : #41

sudo iwlist wlan0 scan

command is run in a terminal window. rereading the outputs of two commands if.... and iw..... previous, pls run also in a terminal

sudo iwlist eth1 scan

it may very well be that there are TWO wireless interfaces--> we'll see.

peter

peter b (b1pete) said : #42

Anne, just a note, a v important one

-- please do not be confused --> the

gedit /......

is a command that opens gedit --> the editor, which is NOT a terminal. you RUN IT though from a TERMINAL. hope that it clears the confusion.

Anne Dowden (anne-dowden) said : #43

On Sat, 2008-04-12 at 18:06 +0000, peter b wrote:
> Your question #29262 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/29262
>
> Status: Open => Answered
>
> peter b proposed the following answer:
> sudo iwlist wlan0 scan
>
> command is run in a terminal window. rereading the outputs of two
> commands if.... and iw..... previous, pls run also in a terminal
>
> sudo iwlist eth1 scan
>
> it may very well be that there are TWO wireless interfaces--> we'll see.
>
> peter
>
Peter,

The output for sudo iwlist wlan0 scan

wlan0 Scan completed :
          Cell 01 - Address: 00:16:41:A6:0C:C3
                    ESSID:"Livebox-f334"
                    Mode:Master
                    Channel:10
                    Frequency:2.457 GHz
                    Quality=45/64 Signal level=47/65
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:tsf=0000000514c9f203

anne@anne-desktop:~$

and for sudo iwlist eth1 scan

eth1 Scan completed :
          Cell 01 - Address: 00:16:41:A6:0C:C3
                    ESSID:"Livebox-f334"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.457 GHz (Channel 10)
                    Quality:100/100 Signal level:-32 dBm Noise
level:-96 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:bcn_int=100
                    Extra:atim=0

anne@anne-desktop:~$

Thank you for the gedit explanation I did not realise.

Anne

peter b (b1pete) said : #44

ok, I could see that there are two distinct mac addresses for

eth1 --> 00:1D:60:2E:F9:78

and

wlan0 --> 00:15:AF:63:E8:80

so there are TWO distinct wireless interfaces on your PC!!! and both access the AP essid Livebox-f334

also, the AP Live...... HAS AN ENCRYPTION KEY SET --> for this YOU'LL HAVE TO TALK TO YOUR ISP ABOUT IT and what kind of encryption used etc.

now, we'll edit the interfaces file for, say, interface wlan0

so pls do

sudo gedit /etc/network/interfaces

then add the following lines as shown below AGAIN OBSERVING the good editing practice as shown on a prev post --> pls see editing blacklist howto previous

auto wlan0
iface wlano inet dhcp
wireless-essid Livebox-f334

SO, THE FINISHED/FINAL FILE should look like see below

auto lo
iface lo inet loopback

auto wlan0
iface wlano inet dhcp
wireless-essid Livebox-f334

CHECK pls and do file-->save and then file-->quit, then open a terminal and do

sudo ifup wlan0

next then do

ifconfig wlan0

and then

sudo iwlist wlan0 scan

pls post the output here

peter

Anne Dowden (anne-dowden) said : #45

Peter,

output for last post below

anne@anne-desktop:~$ sudo gedit /etc/network/interfaces
[sudo] password for anne:
anne@anne-desktop:~$ sudo ifup wlan0
Ignoring unknown interface wlan0=wlan0.
anne@anne-desktop:~$ ifconfig wlan0
wlan0 Link encap:Ethernet HWaddr 00:15:AF:63:E8:80
          UP BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

anne@anne-desktop:~$ sudo iwlist wlan0 scan
wlan0 Scan completed :
          Cell 01 - Address: 00:16:41:A6:0C:C3
                    ESSID:"Livebox-f334"
                    Mode:Master
                    Channel:10
                    Frequency:2.457 GHz
                    Quality=47/64 Signal level=39/65
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:tsf=0000000729388183

anne@anne-desktop:~$

Hope all is still OK
Anne

On Sat, 2008-04-12 at 19:31 +0000, peter b wrote:
> Your question #29262 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/29262
>
> Status: Open => Answered
>
> peter b proposed the following answer:
> ok, I could see that there are two distinct mac addresses for
>
> eth1 --> 00:1D:60:2E:F9:78
>
> and
>
> wlan0 --> 00:15:AF:63:E8:80
>
> so there are TWO distinct wireless interfaces on your PC!!! and both
> access the AP essid Livebox-f334
>
> also, the AP Live...... HAS AN ENCRYPTION KEY SET --> for this YOU'LL
> HAVE TO TALK TO YOUR ISP ABOUT IT and what kind of encryption used etc.
>
> now, we'll edit the interfaces file for, say, interface wlan0
>
> so pls do
>
> sudo gedit /etc/network/interfaces
>
> then add the following lines as shown below AGAIN OBSERVING the good
> editing practice as shown on a prev post --> pls see editing blacklist
> howto previous
>
> auto wlan0
> iface wlano inet dhcp
> wireless-essid Livebox-f334
>
> SO, THE FINISHED/FINAL FILE should look like see below
>
> auto lo
> iface lo inet loopback
>
>
> auto wlan0
> iface wlano inet dhcp
> wireless-essid Livebox-f334
>
> CHECK pls and do file-->save and then file-->quit, then open a terminal
> and do
>
> sudo ifup wlan0
>
> next then do
>
> ifconfig wlan0
>
> and then
>
> sudo iwlist wlan0 scan
>
> pls post the output here
>
> peter
>

peter b (b1pete) said : #46

Anne, something bothers me

sudo ifup wlan0

command did not yield the proper output so far we'll know more after this. so, let's do

ip route list

then pls do

sudo dhclient

and post the output here pls.

also pls do system-->admin-->network-->after entering password -->new window opens --> pls tell me how many interfaces are there/displayed --> there must be a wired for sure, maybe a modem, and wireless; just tell me the total number, the type and which one has a checkmark (tick) on

peter

Anne Dowden (anne-dowden) said : #47

On Sun, 2008-04-13 at 07:11 +0000, peter b wrote:
> Your question #29262 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/29262
>
> Status: Open => Answered
>
> peter b proposed the following answer:
> Anne, something bothers me
>
> sudo ifup wlan0
>
> command did not yield the proper output so far we'll know more after
> this. so, let's do
>
> ip route list
>
> then pls do
>
> sudo dhclient
>
> and post the output here pls.
>
> also pls do system-->admin-->network-->after entering password -->new
> window opens --> pls tell me how many interfaces are there/displayed
> --> there must be a wired for sure, maybe a modem, and wireless; just
> tell me the total number, the type and which one has a checkmark (tick)
> on
>
> peter
>
Peter,

Output posted below

anne@anne-desktop:~$ ip route list
192.168.1.0/24 dev eth0 proto kernel scope link src 192.168.1.10
169.254.0.0/16 dev eth0 scope link metric 1000
default via 192.168.1.1 dev eth0
anne@anne-desktop:~$ sudo dhclient
[sudo] password for anne:
Internet Systems Consortium DHCP Client V3.0.5
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/eth1/00:1d:60:2e:f9:78
Sending on LPF/eth1/00:1d:60:2e:f9:78
Listening on LPF/wlan0/00:15:af:63:e8:80
Sending on LPF/wlan0/00:15:af:63:e8:80
Listening on LPF/wmaster0/
Sending on LPF/wmaster0/
Listening on LPF/eth0/00:1e:8c:7c:77:8f
Sending on LPF/eth0/00:1e:8c:7c:77:8f
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5
DHCPDISCOVER on wmaster0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 3
DHCPOFFER from 192.168.1.1
DHCPREQUEST on eth0 to 255.255.255.255 port 67
DHCPACK from 192.168.1.1
bound to 192.168.1.10 -- renewal in 256966 seconds.
anne@anne-desktop:~$

The Network Settings Window shows 4 interfaces -
1 wireless (wlano), 2 wireless (eth1) and 3 wired all saying 'Roaming
mode enabled' The 4th one is a modem connection which says 'this network
interface is not configured' All four have a dash in the checkbox, which
I cannot alter by clicking on. I don't know if that means they are
checked or not (normally there is a tick when a box is checked)?

I am sorry this is taking up so much of your time, I didn't expect you
to be working so late/early nor on a Sunday. I am very grateful.

Kind regards
Anne

peter b (b1pete) said : #48

ok Anne, all's just the way I expected it to be, that's great, the interfaces are there on the network manager (from here on we'll refer to the syst-->admin-->network window as 'network manager' --> it is a great tool)

your PC is using currently eth0 interface -the WIRED one - as a default. the 'gadget' has assigned

an IP address --> 192.168.1.10 and bond to it;
the GATEWAY (that's the technical term of the router function) is --> 192.168.1.1 and we know also the name of it which is

Livebox-f334 which is for wireless purposes the so called ESSID we also know that this AP has a key that is on.

so, what we'll do next is ask the network manager to use the wireless wlan0 interface instead of the wired eth0 one (notice pls, v important for you to know, that different interfaces can be used IF they are there or, if they have drivers installed for them otherwise they will not even display in network mgr.) next, pls open network manager an do

- highlight interface wlan0
- press button properties-->new win opens
- apply a checkmark on enable this connection button (top of window)
- in network name (ESSID) enter Livebox-f334 EXACTLY as shown
- in Password type pls select WPA Personal by scrolling down)
- Configuration pls select Automatic configuration (DHCP)

make sure all's correct then -->OK-->window closes; then on network mgr window

- apply a checkmark (tick) the box in front of the wireless connection wlan0

keep the mouse on the connection and see a bullet running left-right-left ..... --> it changes the interface to wlan0 -->wait until it stops -->the new wlan0 interface is configured and the PC should connect wirelessly to the 'gadget' called Livebox-f334

the above will happen IF, and only IF, the key that's on it allows it to --> I do not know; if it DOES not connect a discussion with your ISP is required about how to connect --> what type of encryption s in use ie WEP, WPA, WPA2 etc, etc.etc, and after that your PC will have to be conf accordingly; but that's another topic for another ticket --> it concerns encrypted connections not interfaces.

so Anne, summary and conclusion, the wireless interface was created, it is in place, it works --> scans ok for access points adjacent, it identifies them properly, it is present in network mgr, it responds properly to commands in other words it is working the way it should. I can not do any more under this topic, it is of no help to the community. from here on another ticket/question must be opened with a different topic re connection encryption, configuration and setting it up to be used with the newly created interface. I hope you see my point.

pls tell me if the pc could connect --> the light at the top of the 'gadget' as well as the one at the back of the pc close to the antenna should blink intermittently

it was a pleasant experience working with you on this ticket and getting it solved. pls send me just for my curiosity, a short message, whether you did or did not have success connecting, after that pls close this ticket as solved.

best regards and cheerios,

peter b

Anne Dowden (anne-dowden) said : #49

Peter,

Thank you for all you've done. However I did not get a connection. According to my ISP the Livebox encryption is WEP and I do have a key. Having put all this information into the respective boxes in Network Manager, I still did not get a connection.
As you found out I do have 2 wireless interfaces. Only one of them had a green light which was ON, however this went out after we ran the 'blacklist' commands in Gedit and never came on again.
I have been looking at the French Ubuntu Forum Website. I may get some answers there.

Thank you again
Anne

peter b (b1pete) said : #50

sorry to hear that; one more thing pls do

sudo gedit /etc/network/interfaces

and edit the file to look as follows, as usual exactly like that

auto lo
iface lo inet loopback

iface eth0 inet dhcp

iface eth1 inet dhcp
wireless-essid Livebox-f334

iface wlano inet dhcp
wireless-essid Livebox-f334

check and file-->save then file-->quit

then, as you already know how to change interfaces in network manager pls give a try to the second wireless eth1 --> maybe that's the one and not wlan0; just do pls same thing we did with wlan0 in network mgr.

reboot the PC, a green light should come on. just send me a small message how it went. because of WEP you still won't be able to connect but at least the interface should come on and probably default to the wired interface afterwards.

peter

Anne Dowden (anne-dowden) said : #51

Peter,

Still no green light. I notice that sometimes we are using 'wlano' and other times 'wlan0' Is this specific or is there no difference?

Regards
Anne

peter b (b1pete) said : #52

no Anne, if so, that's a big mistake--> IT ALWAYS HAS TO BE wlan0 -->that is, the last character MUST BE zero and the others MUST BE lower case; linux is very strict about these things.

peter

peter b (b1pete) said : #53

ok Anne, I said in one of the posts that it was a pleasant experience working on this ticket with you, herebelow a little tip howt to go about WEP; I'm tresspassing a little here but, I think that whoever will read this thread will find it quite helpful; so, here we go, you said that you've got a WEP key, so first

open network manager -->highlight wlan0 conn'n --> properties --> Password type entry --> scroll down and pick WEP key -->there are two options-->one is an ascii type key, the other is a hexadecimal key, pls choose the one that IS YOUR KEY EITHER ascii OR hex type--> at the same time pls MAKE SURE THAT ALL OTHER ENTRIES ARE EXACTLY AS DISCUSSED IN PREV POSTS ie Livebox..... entry in ESSID, Auto ..... (DHCP) entry in Configuration box --> after that press OK

now, in a terminal pls do these in order

sudo iwconfig wlan0 essid Livebox-f334
sudo iwconfig wlan0 key xxxxxxxxxx
sudo ifconfig wlan0 up
sudo dhclient3 wlan0

where xxxxxxx is the key you said you've got; after this you should be ready to surf.

peter