after upgrading to 16.04 (xubuntu) network drive not mounted

Asked by Willem Hobers on 2016-02-06

I upgraded from Xubuntu 14.04 to 16.04, because I would like to attribute to the testing.

After the upgrade my network drive does not mount.

fstab
//192.168.178.73/Thuis /media/Thuis cifs noserverino,guest,user=,nounix,_netdev,dir_mode=0777,file_mode=0777 0 0

This worked until the upgrade.

When trying to mount I get:

mount: wrong fs type, bad option, bad superblock on //192.168.178.73/Thuis,
       missing codepage or helper program, or other error
       (for several filesystems (e.g. nfs, cifs) you might
       need a /sbin/mount.<type> helper program)

       In some cases useful info is found in syslog - try
       dmesg | tail or so.

And if I do dmesg | tail, it gives:

[ 21.141585] cgroup: new mount options do not match the existing superblock, will be ignored
[ 24.103109] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 24.103661] forcedeth 0000:00:07.0 eth1: MSI enabled
[ 31.195496] FS-Cache: Loaded
[ 31.232146] FS-Cache: Netfs 'cifs' registered for caching
[ 31.233761] Key type cifs.spnego registered
[ 31.233773] Key type cifs.idmap registered
[ 31.234020] CIFS VFS: No username specified
[ 327.314333] CIFS VFS: No username specified
[ 349.637971] CIFS VFS: No username specified

does any one know if I have to change the fstab after upgrading to 16.04?

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2017-01-01
Last query:
2017-01-01
Last reply:
2016-02-11

I suggest you report a bug. Xenial is not ready and not stable.

Manfred Hampl (m-hampl) said : #2

If you try mounting manually, do you get the same error?

sudo mount -v -t cifs -o noserverino,guest,user=,nounix,_netdev,dir_mode=0777,file_mode=0777 //192.168.178.73/Thuis /media/Thuis

Willem Hobers (whobers) said : #3

Manfred, thanks.

I tried as you suggested. No luck, though.

willem@SM01:~$ dmesg | tail
[ 17.790776] audit: type=1400 audit(1455128543.834:11): apparmor="STATUS" operation="profile_load" profile="unconfined" name="sanitized_helper" pid=430 comm="apparmor_parser"
[ 19.651540] cgroup: new mount options do not match the existing superblock, will be ignored
[ 25.089471] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 25.090027] forcedeth 0000:00:07.0 eth1: MSI enabled
[ 31.734336] FS-Cache: Loaded
[ 31.785076] FS-Cache: Netfs 'cifs' registered for caching
[ 31.786764] Key type cifs.spnego registered
[ 31.786776] Key type cifs.idmap registered
[ 31.791500] CIFS VFS: No username specified
[ 295.827734] CIFS VFS: No username specified

Any hints, ideas as to what I am doing wrong?

Willem Hobers (whobers) said : #4

How do i reach out to the xenial-people to report this as a bug?
Op 6 feb. 2016 22:07 schreef "actionparsnip" <
<email address hidden>>:

> Your question #284714 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/284714
>
> Status: Open => Answered
>
> actionparsnip proposed the following answer:
> I suggest you report a bug. Xenial is not ready and not stable.
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/ubuntu/+question/284714/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+question/284714
>
> You received this question notification because you asked the question.
>

Manfred Hampl (m-hampl) said : #5

1. Do you get an error message on screen when you try the manual mount command?

2. The dmesg line "CIFS VFS: No username specified" might indicate that the syntax "user=," is no more allowed?

3. For reporting bugs you can use the ubuntu-bug command or you can create a bug document on the Launchpad bug pages (a link "create bug report" is available on your question page https://answers.launchpad.net/ubuntu/+question/284714 )

You can also run:

ubuntu-bug gvfs

and start the process that way

Willem Hobers (whobers) said : #7

1 Not sure what you mean by manual, but if I double click on the icon
which point to the network drive I get:

mount: wrong fs type, bad option, bad superblock on //192.168.178.73/Thuis,
        missing codepage or helper program, or other error
        (for several filesystems (e.g. nfs, cifs) you might
        need a /sbin/mount.<type> helper program)

        In some cases useful info is found in syslog - try
        dmesg | tail or so.

2 I am not sure that message is new: i think that was in the logs even
before the upgrade.

3 I will report the bug.

Thank for your help,

Op 11-02-16 om 08:32 schreef Manfred Hampl:
> Your question #284714 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/284714
>
> Status: Open => Answered
>
> Manfred Hampl proposed the following answer:
> 1. Do you get an error message on screen when you try the manual mount
> command?
>
> 2. The dmesg line "CIFS VFS: No username specified" might indicate that
> the syntax "user=," is no more allowed?
>
> 3. For reporting bugs you can use the ubuntu-bug command or you can
> create a bug document on the Launchpad bug pages (a link "create bug
> report" is available on your question page
> https://answers.launchpad.net/ubuntu/+question/284714 )
>

Manfred Hampl (m-hampl) said : #8

What I meant with manual mounting is:

Open a terminal window (e.g. by simultaneously pressing ctrl-alt-t)

and issue the command

sudo mount -v -t cifs -o noserverino,guest,user=,nounix,_netdev,dir_mode=0777,file_mode=0777 //192.168.178.73/Thuis /media/Thuis

What response do you get?

Willem Hobers (whobers) said : #9

Manfred, thanks.

I did as you suggested, as before the result is:

sudo mount -v -t cifs -o
noserverino,guest,user=,nounix,_netdev,dir_mode=0777,file_mode=0777
//192.168.178.73/Thuis /media/Thuis
[sudo] wachtwoord voor willem:
mount: wrong fs type, bad option, bad superblock on //192.168.178.73/Thuis,
        missing codepage or helper program, or other error
        (for several filesystems (e.g. nfs, cifs) you might
        need a /sbin/mount.<type> helper program)

        In some cases useful info is found in syslog - try
        dmesg | tail or so.

Op 11-02-16 om 11:17 schreef Manfred Hampl:
> Your question #284714 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/284714
>
> Status: Open => Needs information
>
> Manfred Hampl requested more information:
> What I meant with manual mounting is:
>
> Open a terminal window (e.g. by simultaneously pressing ctrl-alt-t)
>
> and issue the command
>
> sudo mount -v -t cifs -o
> noserverino,guest,user=,nounix,_netdev,dir_mode=0777,file_mode=0777
> //192.168.178.73/Thuis /media/Thuis
>
> What response do you get?
>

Manfred Hampl (m-hampl) said : #10

Ok, not telling more than the mount attempt via the GUI.

If you try omitting the "user=," part of the options, does it then work?

Willem Hobers (whobers) said : #11

tried removing "user=,"

willem@SM01:~$ sudo mount -v -t cifs -o
noserverino,guest,nounix,_netdev,dir_mode=0777,file_mode=0777
//192.168.178.73/Thuis /media/Thuis
[sudo] wachtwoord voor willem:
mount: wrong fs type, bad option, bad superblock on //192.168.178.73/Thuis,
        missing codepage or helper program, or other error
        (for several filesystems (e.g. nfs, cifs) you might
        need a /sbin/mount.<type> helper program)

        In some cases useful info is found in syslog - try
        dmesg | tail or so.
willem@SM01:~$ dmesg | tail
[ 16.675288] input: HDA NVidia Front Headphone as
/devices/pci0000:00/0000:00:05.0/sound/card0/input11
[ 16.828232] cgroup: new mount options do not match the existing
superblock, will be ignored
[ 22.777078] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 22.789713] forcedeth 0000:00:07.0 eth1: MSI enabled
[ 28.143049] FS-Cache: Loaded
[ 28.179740] FS-Cache: Netfs 'cifs' registered for caching
[ 28.181224] Key type cifs.spnego registered
[ 28.181238] Key type cifs.idmap registered
[ 28.181493] CIFS VFS: No username specified
[ 82.154633] CIFS VFS: No username specified

Up until now I figured that trying sudo apt-get install cifs-utils would
be, well, nonsense.

it turns out, though: it wasn't.

  cifs-utils keyutils were installed. Then I did:

willem@SM01:~$ sudo mount -v -t cifs -o
noserverino,guest,user=,nounix,_netdev,dir_mode=0777,file_mode=0777
//192.168.178.73/Thuis /media/Thuis

and got:

mount.cifs kernel mount options:
ip=192.168.178.73,unc=\\192.168.178.73\Thuis,noserverino,nounix,dir_mode=0777,file_mode=0777,user=,pass=********

Will now reboot and see if the drive is mounted at startup.

Op 11-02-16 om 12:57 schreef Manfred Hampl:
> Your question #284714 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/284714
>
> Status: Open => Needs information
>
> Manfred Hampl requested more information:
> Ok, not telling more than the mount attempt via the GUI.
>
> If you try omitting the "user=," part of the options, does it then work?
>

Willem Hobers (whobers) said : #12

The drive is now mounted at startup, via fstab.

I am not certain what I can learn from this. Why would it have been necessary to do apt-get install cifs-utils after the upgrade to 16.04? Should I perhaps report that as a bug?

I suggest you report a bug

Willem Hobers (whobers) said : #14

Thanks actionparsnip, that solved my question.