software center will not load

Asked by Slavko Mangovski on 2013-12-25

2013-12-17 17:09:36,515 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2013-12-17 17:09:39,383 - softwarecenter.region - WARNING - failed to use geoclue: 'org.freedesktop.Geoclue.Error.notAvailable: Geoclue master client has no usable Address providers'
2013-12-17 17:09:40,429 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2013-12-17 17:09:40,455 - softwarecenter.plugin - INFO - activating plugin '<module 'webapps_activation' from '/usr/share/software-center/softwarecenter/plugins/webapps_activation.pyc'>'
2013-12-17 17:09:40,520 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/gi/importer.py', 51, 'find_module')'
2013-12-17 17:09:40,520 - root - ERROR - Could not find any typelib for LaunchpadIntegration
2013-12-17 17:09:40,748 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()

I had latest version of Ubuntu however after trying to launch software center system became unstable and keeps crashing.

Thanks for your answers.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Slavko Mangovski
Solved:
2013-12-29
Last query:
2013-12-29
Last reply:
2013-12-29

What is the output of :

lsb_release -a; uname -a; apt-cache policy software-center

Thanks

https://help.ubuntu.com/community/PackageManagerTroubleshootingProcedure

Please follow ALL steps in the procedure.

Please post full Terminal output from step 5 and step 9 here:

https://answers.launchpad.net/ubuntu/+question/241270

Slavko Mangovski (mango-8) said : #3

actionparsnip:

this is the output:

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 13.10
Release: 13.10
Codename: saucy
Linux sarisa-HP-Pavilion-dv6-Notebook-PC 3.11.0-14-generic #21-Ubuntu SMP Tue Nov 12 17:07:40 UTC 2013 i686 i686 i686 GNU/Linux
software-center:
  Installed: 13.10-0ubuntu1
  Candidate: 13.10-0ubuntu1
  Version table:
 *** 13.10-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ saucy/main i386 Packages
        100 /var/lib/dpkg/status

If you run :

gksudo software-center

Does it run ok?

Slavko Mangovski (mango-8) said : #5

actionparsnip:

No, it opens up and then it freezes.

Slavko Mangovski (mango-8) said : #6

It also freezes the whole system and I can't even shut down the computer - have to use the on/off button.

If you run :

sudo apt-get update

What is the full output please

Thanks

Still waiting for the Terminal output from post #2.

Slavko Mangovski (mango-8) said : #9

sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo apt-get update
[sudo] password for sarisa:
Ign http://security.ubuntu.com saucy-security InRelease
Ign http://extras.ubuntu.com saucy InRelease
Get:1 http://security.ubuntu.com saucy-security Release.gpg [933 B]
Get:2 http://extras.ubuntu.com saucy Release.gpg [72 B]
Get:3 http://security.ubuntu.com saucy-security Release [49.6 kB]
Hit http://extras.ubuntu.com saucy Release
Hit http://extras.ubuntu.com saucy/main Sources
Hit http://extras.ubuntu.com saucy/main i386 Packages
Get:4 http://security.ubuntu.com saucy-security/main Sources [20.0 kB]
Get:5 http://security.ubuntu.com saucy-security/restricted Sources [14 B]
Get:6 http://security.ubuntu.com saucy-security/universe Sources [6,663 B]
Get:7 http://security.ubuntu.com saucy-security/multiverse Sources [701 B]
Get:8 http://security.ubuntu.com saucy-security/main i386 Packages [60.3 kB]
Ign http://extras.ubuntu.com saucy/main Translation-en_US
Get:9 http://security.ubuntu.com saucy-security/restricted i386 Packages [14 B]
Ign http://extras.ubuntu.com saucy/main Translation-en
Get:10 http://security.ubuntu.com saucy-security/universe i386 Packages [23.0 kB]
Get:11 http://security.ubuntu.com saucy-security/multiverse i386 Packages [1,388 B]
Get:12 http://security.ubuntu.com saucy-security/main Translation-en [29.0 kB]
Hit http://security.ubuntu.com saucy-security/multiverse Translation-en
Hit http://security.ubuntu.com saucy-security/restricted Translation-en
Get:13 http://security.ubuntu.com saucy-security/universe Translation-en [14.4 kB]
Ign http://dl.google.com stable InRelease
Get:14 http://dl.google.com stable Release.gpg [198 B]
Get:15 http://dl.google.com stable Release [1,347 B]
Get:16 http://dl.google.com stable/main i386 Packages [1,210 B]
Ign http://us.archive.ubuntu.com saucy InRelease
Ign http://security.ubuntu.com saucy-security/main Translation-en_US
Ign http://us.archive.ubuntu.com saucy-updates InRelease
Ign http://security.ubuntu.com saucy-security/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com saucy-backports InRelease
Ign http://dl.google.com stable/main Translation-en_US
Ign http://dl.google.com stable/main Translation-en
Hit http://us.archive.ubuntu.com saucy Release.gpg
Ign http://security.ubuntu.com saucy-security/restricted Translation-en_US
Get:17 http://us.archive.ubuntu.com saucy-updates Release.gpg [933 B]
Ign http://security.ubuntu.com saucy-security/universe Translation-en_US
Hit http://us.archive.ubuntu.com saucy-backports Release.gpg
Hit http://us.archive.ubuntu.com saucy Release
Get:18 http://us.archive.ubuntu.com saucy-updates Release [49.6 kB]
Hit http://us.archive.ubuntu.com saucy-backports Release
Hit http://us.archive.ubuntu.com saucy/main Sources
Hit http://us.archive.ubuntu.com saucy/restricted Sources
Hit http://us.archive.ubuntu.com saucy/universe Sources
Hit http://us.archive.ubuntu.com saucy/multiverse Sources
Hit http://us.archive.ubuntu.com saucy/main i386 Packages
Hit http://us.archive.ubuntu.com saucy/restricted i386 Packages
Hit http://us.archive.ubuntu.com saucy/universe i386 Packages
Hit http://us.archive.ubuntu.com saucy/multiverse i386 Packages
Hit http://us.archive.ubuntu.com saucy/main Translation-en
Hit http://us.archive.ubuntu.com saucy/multiverse Translation-en
Hit http://us.archive.ubuntu.com saucy/restricted Translation-en
Hit http://us.archive.ubuntu.com saucy/universe Translation-en
Get:19 http://us.archive.ubuntu.com saucy-updates/main Sources [57.8 kB]
Get:20 http://us.archive.ubuntu.com saucy-updates/restricted Sources [14 B]
Get:21 http://us.archive.ubuntu.com saucy-updates/universe Sources [40.4 kB]
Get:22 http://us.archive.ubuntu.com saucy-updates/multiverse Sources [1,353 B]
Get:23 http://us.archive.ubuntu.com saucy-updates/main i386 Packages [172 kB]
Get:24 http://us.archive.ubuntu.com saucy-updates/restricted i386 Packages [14 B]
Get:25 http://us.archive.ubuntu.com saucy-updates/universe i386 Packages [117 kB]
Get:26 http://us.archive.ubuntu.com saucy-updates/multiverse i386 Packages [1,776 B]
Get:27 http://us.archive.ubuntu.com saucy-updates/main Translation-en [76.9 kB]
Hit http://us.archive.ubuntu.com saucy-updates/multiverse Translation-en
Hit http://us.archive.ubuntu.com saucy-updates/restricted Translation-en
Get:28 http://us.archive.ubuntu.com saucy-updates/universe Translation-en [63.2 kB]
Hit http://us.archive.ubuntu.com saucy-backports/main Sources
Hit http://us.archive.ubuntu.com saucy-backports/restricted Sources
Hit http://us.archive.ubuntu.com saucy-backports/universe Sources
Hit http://us.archive.ubuntu.com saucy-backports/multiverse Sources
Hit http://us.archive.ubuntu.com saucy-backports/main i386 Packages
Hit http://us.archive.ubuntu.com saucy-backports/restricted i386 Packages
Hit http://us.archive.ubuntu.com saucy-backports/universe i386 Packages
Hit http://us.archive.ubuntu.com saucy-backports/multiverse i386 Packages
Hit http://us.archive.ubuntu.com saucy-backports/main Translation-en
Hit http://us.archive.ubuntu.com saucy-backports/multiverse Translation-en
Hit http://us.archive.ubuntu.com saucy-backports/restricted Translation-en
Hit http://us.archive.ubuntu.com saucy-backports/universe Translation-en
Ign http://us.archive.ubuntu.com saucy/main Translation-en_US
Ign http://us.archive.ubuntu.com saucy/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com saucy/restricted Translation-en_US
Ign http://us.archive.ubuntu.com saucy/universe Translation-en_US
Ign http://us.archive.ubuntu.com saucy-updates/main Translation-en_US
Ign http://us.archive.ubuntu.com saucy-updates/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com saucy-updates/restricted Translation-en_US
Ign http://us.archive.ubuntu.com saucy-updates/universe Translation-en_US
Ign http://us.archive.ubuntu.com saucy-backports/main Translation-en_US
Ign http://us.archive.ubuntu.com saucy-backports/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com saucy-backports/restricted Translation-en_US
Ign http://us.archive.ubuntu.com saucy-backports/universe Translation-en_US
Fetched 790 kB in 19s (40.8 kB/s)
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo dpkg --configure -a
Setting up software-center (13.10-0ubuntu1) ...

and that's it.....

Slavko Mangovski (mango-8) said : #10

After the above the system becomes unresponsive and I have to reboot using the on/off button.

Slavko Mangovski (mango-8) said : #11

Mark:

I cannot get step 1. When I try to change enable all repositories (changing "Source Code" to enabled) and close the Software Sources the system tries to update the Software Center and becomes unresponsive.

Why are you ignoring my instructions?????

OK, skip steps 1 and 2. Proceed starting with step 3.

Why did you not give this feedback 2 days ago??

Slavko Mangovski (mango-8) said : #14

Sorry Mark, I tried following your instructions. You said to follow ALL steps so that's what I did.

https://help.ubuntu.com/community/Repositories/Ubuntu#Download_Server

says that I should add repositories.

Thanks for all your help.

Slavko Mangovski (mango-8) said : #15

Mark:

sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ ubuntu-support-status
Support status summary of 'sarisa-HP-Pavilion-dv6-Notebook-PC':

You have 1713 packages (92.4%) supported until July 2014 (9m)
You have 8 packages (0.4%) supported until September 2014 (9m)

You have 13 packages (0.7%) that can not/no-longer be downloaded
You have 120 packages (6.5%) that are unsupported

Run with --show-unsupported, --show-supported or --show-all to see more details
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo grep -R proxy /etc/apt/*
[sudo] password for sarisa:
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo grep -R proxy /etc/apt/*
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ grep proxy /etc/environment
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ echo $http_proxy

sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ echo $ftp_proxy

sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ grep proxy /etc/bash.bashrc
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ grep proxy ~/.bashrc
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ cat /etc/apt/apt.conf
cat: /etc/apt/apt.conf: No such file or directory
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo fuser -vvv /var/lib/dpkg/lock
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo fuser -vvv /var/cache/apt/archives/lock
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=13.10
DISTRIB_CODENAME=saucy
DISTRIB_DESCRIPTION="Ubuntu 13.10"
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ uname -a
Linux sarisa-HP-Pavilion-dv6-Notebook-PC 3.11.0-14-generic #21-Ubuntu SMP Tue Nov 12 17:07:40 UTC 2013 i686 i686 i686 GNU/Linux
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo rm /var/lib/apt/lists/lock
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo rm /var/cache/apt/archives/lock
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo rm /var/lib/dpkg/lock
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo cp -arf /var/lib/dpkg /var/lib/dpkg.backup
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo mv /var/lib/dpkg/status /var/lib/dpkg/status-bad
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status || sudo cp /var/backups/apt.extended_states.0 /var/lib/dpkg/status
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo mv /var/lib/dpkg/available /var/lib/dpkg/available-bad
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo cp /var/lib/dpkg/available-old /var/lib/dpkg/available
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo rm -rf /var/lib/dpkg/updates/*sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo rm -rf /var/lib/apt/lists
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo rm /var/cache/apt/*.bin
rm: cannot remove ‘/var/cache/apt/*.bin’: No such file or directory
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo mkdir /var/lib/apt/lists
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo mkdir /var/lib/apt/lists/partial
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ LANG=C;sudo apt-get clean
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ LANG=C;sudo apt-get autoclean
Reading package lists... Done
Building dependency tree
Reading state information... Done
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ LANG=C;sudo apt-get --purge autoremove
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  linux-headers-3.11.0-12* linux-headers-3.11.0-12-generic*
  linux-image-3.11.0-12-generic* linux-image-extra-3.11.0-12-generic*
0 upgraded, 0 newly installed, 4 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 210 MB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 234652 files and directories currently installed.)
Removing linux-headers-3.11.0-12-generic ...
Removing linux-headers-3.11.0-12 ...
Removing linux-image-extra-3.11.0-12-generic ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.11.0-12-generic /boot/vmlinuz-3.11.0-12-generic
update-initramfs: Deleting /boot/initrd.img-3.11.0-12-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.11.0-12-generic /boot/vmlinuz-3.11.0-12-generic
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.11.0-14-generic
Found initrd image: /boot/initrd.img-3.11.0-14-generic
Found linux image: /boot/vmlinuz-3.11.0-13-generic
Found initrd image: /boot/initrd.img-3.11.0-13-generic
Found linux image: /boot/vmlinuz-3.11.0-12-generic
Found linux image: /boot/vmlinuz-3.8.0-31-generic
Found initrd image: /boot/initrd.img-3.8.0-31-generic
Found memtest86+ image: /memtest86+.bin
done
Purging configuration files for linux-image-extra-3.11.0-12-generic ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.11.0-12-generic /boot/vmlinuz-3.11.0-12-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.11.0-12-generic /boot/vmlinuz-3.11.0-12-generic
Removing linux-image-3.11.0-12-generic ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.11.0-12-generic /boot/vmlinuz-3.11.0-12-generic
update-initramfs: Deleting /boot/initrd.img-3.11.0-12-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.11.0-12-generic /boot/vmlinuz-3.11.0-12-generic
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.11.0-14-generic
Found initrd image: /boot/initrd.img-3.11.0-14-generic
Found linux image: /boot/vmlinuz-3.11.0-13-generic
Found initrd image: /boot/initrd.img-3.11.0-13-generic
Found linux image: /boot/vmlinuz-3.8.0-31-generic
Found initrd image: /boot/initrd.img-3.8.0-31-generic
Found memtest86+ image: /memtest86+.bin
done
Purging configuration files for linux-image-3.11.0-12-generic ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.11.0-12-generic /boot/vmlinuz-3.11.0-12-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.11.0-12-generic /boot/vmlinuz-3.11.0-12-generic
Setting up software-center (13.10-0ubuntu1) ...

The above is from Step 5.
After the last response "Setting up software-center (13.10-0ubuntu1) ..." there is nothing further for more then an hour.

Output from step 5 looks good.

Now send us the output from step 9.

Post it here:

https://answers.launchpad.net/ubuntu/+question/241270

Slavko Mangovski (mango-8) said : #17

Hi Mark, this is the output from step 9:

sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo rm /usr/lib/python*/dist-packages/__pycache__/*pyc
[sudo] password for sarisa:
rm: cannot remove ‘/usr/lib/python*/dist-packages/__pycache__/*pyc’: No such file or directory
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo apt-get install --reinstall python3-gi
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo apt-get purge software-center
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ rm -rf ~/.cache/software-center
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ rm -rf ~/.config/software-center
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ rm -rf ~/.cache/update-manager-coresarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo rm /var/lib/apt-xapian-index/cataloged_times.p
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo rm /var/lib/apt-xapian-index/values
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo update-apt-xapian-index --verbose --force
Reading plugin /usr/share/apt-xapian-index/plugins/aliases.py.
Reading plugin /usr/share/apt-xapian-index/plugins/app-install.py.
Reading plugin /usr/share/apt-xapian-index/plugins/apttags.py.
Reading plugin /usr/share/apt-xapian-index/plugins/cataloged_time.py.
Reading plugin /usr/share/apt-xapian-index/plugins/debtags.py.
Reading plugin /usr/share/apt-xapian-index/plugins/descriptions.py.
Reading plugin /usr/share/apt-xapian-index/plugins/display_name.py.
Reading plugin /usr/share/apt-xapian-index/plugins/origin.py.
Reading plugin /usr/share/apt-xapian-index/plugins/relations.py.
Reading plugin /usr/share/apt-xapian-index/plugins/sections.py.
Reading plugin /usr/share/apt-xapian-index/plugins/sizes.py.
Reading plugin /usr/share/apt-xapian-index/plugins/software_center.py.
Reading plugin /usr/share/apt-xapian-index/plugins/template.py.
Reading plugin /usr/share/apt-xapian-index/plugins/translated-desc.py.
Most recent dataset: Sat Dec 28 12:14:50 2013.
Most recent update for: Fri Dec 13 16:39:25 2013.
Aggregating value information.
Initializing plugins.
Reading .desktop files from /usr/share/app-install/desktop/: done.
Rebuilding Xapian index: done.
Installing the new index.
Removing old index /var/cache/apt-xapian-index/index.2.
Writing value information to /var/lib/apt-xapian-index/values.
Writing prefix information to /var/lib/apt-xapian-index/prefixes.
Writing documentation to /var/lib/apt-xapian-index/README.
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo update-apt-xapian-index --force
The index /var/lib/apt-xapian-index is up to date, but rebuilding anyway as requested.
Reading .desktop files from /usr/share/app-install/desktop/: done.
Rebuilding Xapian index: done.
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo apt-get update
Ign http://dl.google.com stable InRelease
Ign http://us.archive.ubuntu.com saucy InRelease
Get:1 http://dl.google.com stable Release.gpg [198 B]
Get:2 http://dl.google.com stable Release [1,347 B]
Ign http://us.archive.ubuntu.com saucy-updates InRelease
Ign http://security.ubuntu.com saucy-security InRelease
Ign http://us.archive.ubuntu.com saucy-backports InRelease
Ign http://extras.ubuntu.com saucy InRelease
Get:3 http://dl.google.com stable/main i386 Packages [1,210 B]
Get:4 http://us.archive.ubuntu.com saucy Release.gpg [933 B]
Get:5 http://security.ubuntu.com saucy-security Release.gpg [933 B]
Get:6 http://extras.ubuntu.com saucy Release.gpg [72 B]
Get:7 http://us.archive.ubuntu.com saucy-updates Release.gpg [933 B]
Get:8 http://us.archive.ubuntu.com saucy-backports Release.gpg [933 B]
Get:9 http://extras.ubuntu.com saucy Release [9,753 B]
Get:10 http://security.ubuntu.com saucy-security Release [49.6 kB]
Get:11 http://us.archive.ubuntu.com saucy Release [49.6 kB]
Get:12 http://extras.ubuntu.com saucy/main Sources [14 B]
Ign http://dl.google.com stable/main Translation-en_US
Get:13 http://us.archive.ubuntu.com saucy-updates Release [49.6 kB]
Ign http://dl.google.com stable/main Translation-en
Get:14 http://extras.ubuntu.com saucy/main i386 Packages [14 B]
Get:15 http://us.archive.ubuntu.com saucy-backports Release [49.6 kB]
Get:16 http://security.ubuntu.com saucy-security/main Sources [20.0 kB]
Get:17 http://us.archive.ubuntu.com saucy/main Sources [1,009 kB]
Get:18 http://security.ubuntu.com saucy-security/universe Sources [6,663 B]
Get:19 http://security.ubuntu.com saucy-security/restricted Sources [14 B]
Get:20 http://security.ubuntu.com saucy-security/multiverse Sources [701 B]
Get:21 http://security.ubuntu.com saucy-security/main i386 Packages [60.3 kB]
Ign http://extras.ubuntu.com saucy/main Translation-en_US
Ign http://extras.ubuntu.com saucy/main Translation-en
Get:22 http://security.ubuntu.com saucy-security/restricted i386 Packages [14 B]
Get:23 http://us.archive.ubuntu.com saucy/universe Sources [6,108 kB]
Get:24 http://security.ubuntu.com saucy-security/universe i386 Packages [23.0 kB]
Get:25 http://security.ubuntu.com saucy-security/multiverse i386 Packages [1,388 B]
Get:26 http://security.ubuntu.com saucy-security/main Translation-en [29.0 kB]
Get:27 http://us.archive.ubuntu.com saucy/restricted Sources [4,759 B]
Get:28 http://us.archive.ubuntu.com saucy/multiverse Sources [175 kB]
Get:29 http://security.ubuntu.com saucy-security/multiverse Translation-en [587 B]
Get:30 http://us.archive.ubuntu.com saucy/main i386 Packages [1,238 kB]
Get:31 http://security.ubuntu.com saucy-security/restricted Translation-en [14 B]
Get:32 http://security.ubuntu.com saucy-security/universe Translation-en [14.4 kB]
Get:33 http://us.archive.ubuntu.com saucy/restricted i386 Packages [9,688 B]
Get:34 http://us.archive.ubuntu.com saucy/universe i386 Packages [5,652 kB]
Get:35 http://us.archive.ubuntu.com saucy/multiverse i386 Packages [133 kB]
Ign http://security.ubuntu.com saucy-security/main Translation-en_US
Ign http://security.ubuntu.com saucy-security/multiverse Translation-en_US
Get:36 http://us.archive.ubuntu.com saucy/main Translation-en [711 kB]
Ign http://security.ubuntu.com saucy-security/restricted Translation-en_US
Ign http://security.ubuntu.com saucy-security/universe Translation-en_US
Get:37 http://us.archive.ubuntu.com saucy/multiverse Translation-en [101 kB]
Get:38 http://us.archive.ubuntu.com saucy/restricted Translation-en [2,686 B]
Get:39 http://us.archive.ubuntu.com saucy/universe Translation-en [3,886 kB]
Get:40 http://us.archive.ubuntu.com saucy-updates/main Sources [57.8 kB]
Get:41 http://us.archive.ubuntu.com saucy-updates/universe Sources [40.4 kB]
Get:42 http://us.archive.ubuntu.com saucy-updates/restricted Sources [14 B]
Get:43 http://us.archive.ubuntu.com saucy-updates/multiverse Sources [1,353 B]
Get:44 http://us.archive.ubuntu.com saucy-updates/main i386 Packages [172 kB]
Get:45 http://us.archive.ubuntu.com saucy-updates/restricted i386 Packages [14 B]
Get:46 http://us.archive.ubuntu.com saucy-updates/universe i386 Packages [117 kB]
Get:47 http://us.archive.ubuntu.com saucy-updates/multiverse i386 Packages [1,776 B]
Get:48 http://us.archive.ubuntu.com saucy-updates/main Translation-en [76.9 kB]
Get:49 http://us.archive.ubuntu.com saucy-updates/multiverse Translation-en [717 B]
Get:50 http://us.archive.ubuntu.com saucy-updates/restricted Translation-en [14 B]
Get:51 http://us.archive.ubuntu.com saucy-updates/universe Translation-en [63.2 kB]
Get:52 http://us.archive.ubuntu.com saucy-backports/main Sources [14 B]
Get:53 http://us.archive.ubuntu.com saucy-backports/restricted Sources [14 B]
Get:54 http://us.archive.ubuntu.com saucy-backports/universe Sources [795 B]
Get:55 http://us.archive.ubuntu.com saucy-backports/multiverse Sources [834 B]
Get:56 http://us.archive.ubuntu.com saucy-backports/main i386 Packages [14 B]
Get:57 http://us.archive.ubuntu.com saucy-backports/restricted i386 Packages [14 B]
Get:58 http://us.archive.ubuntu.com saucy-backports/universe i386 Packages [602 B]
Get:59 http://us.archive.ubuntu.com saucy-backports/multiverse i386 Packages [709 B]
Get:60 http://us.archive.ubuntu.com saucy-backports/main Translation-en [14 B]
Get:61 http://us.archive.ubuntu.com saucy-backports/multiverse Translation-en [525 B]
Get:62 http://us.archive.ubuntu.com saucy-backports/restricted Translation-en [14 B]
Get:63 http://us.archive.ubuntu.com saucy-backports/universe Translation-en [617 B]
Ign http://us.archive.ubuntu.com saucy/main Translation-en_US
Ign http://us.archive.ubuntu.com saucy/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com saucy/restricted Translation-en_US
Ign http://us.archive.ubuntu.com saucy/universe Translation-en_US
Ign http://us.archive.ubuntu.com saucy-updates/main Translation-en_US
Ign http://us.archive.ubuntu.com saucy-updates/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com saucy-updates/restricted Translation-en_US
Ign http://us.archive.ubuntu.com saucy-updates/universe Translation-en_US
Ign http://us.archive.ubuntu.com saucy-backports/main Translation-en_US
Ign http://us.archive.ubuntu.com saucy-backports/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com saucy-backports/restricted Translation-en_US
Ign http://us.archive.ubuntu.com saucy-backports/universe Translation-en_US
Fetched 19.9 MB in 53s (372 kB/s)
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo apt-get dist-upgrade
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo apt-get install software-center ubuntu-desktop
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo dpkg-reconfigure software-center --force
Updating software catalog...this may take a moment.
INFO:softwarecenter.db.pkginfo_impl.aptcache:aptcache.open()
WARNING:softwarecenter.db.update:The file: '/usr/share/app-install/desktop/sonic-visualiser:x-sonicvisualiser.desktop' could not be read correctly. The application associated with this file will not be included in the software catalog. Please consider raising a bug report for this issue with the maintainer of that application
WARNING:softwarecenter.db.update:The file: '/usr/share/app-install/desktop/sonic-visualiser:x-sonicvisualiser-layer.desktop' could not be read correctly. The application associated with this file will not be included in the software catalog. Please consider raising a bug report for this issue with the maintainer of that application
Software catalog update was successful.
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo update-software-center
Updating software catalog...this may take a moment.
INFO:softwarecenter.db.pkginfo_impl.aptcache:aptcache.open()
WARNING:softwarecenter.db.update:The file: '/usr/share/app-install/desktop/sonic-visualiser:x-sonicvisualiser.desktop' could not be read correctly. The application associated with this file will not be included in the software catalog. Please consider raising a bug report for this issue with the maintainer of that application
WARNING:softwarecenter.db.update:The file: '/usr/share/app-install/desktop/sonic-visualiser:x-sonicvisualiser-layer.desktop' could not be read correctly. The application associated with this file will not be included in the software catalog. Please consider raising a bug report for this issue with the maintainer of that application
Software catalog update was successful.
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo apt-get install --reinstall software-center
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$

Check the Terminal output.

The output shows this error:

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

So please run this command and send us the output:

sudo dpkg --configure -a

Afterwards, check if Software Center works correctly....

Slavko Mangovski (mango-8) said : #19

Here it is:

sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo dpkg --configure -a
[sudo] password for sarisa:
Setting up software-center (13.10-0ubuntu1) ...
Updating software catalog...this may take a moment.
INFO:softwarecenter.db.pkginfo_impl.aptcache:aptcache.open()
WARNING:softwarecenter.db.update:The file: '/usr/share/app-install/desktop/sonic-visualiser:x-sonicvisualiser.desktop' could not be read correctly. The application associated with this file will not be included in the software catalog. Please consider raising a bug report for this issue with the maintainer of that application
WARNING:softwarecenter.db.update:The file: '/usr/share/app-install/desktop/sonic-visualiser:x-sonicvisualiser-layer.desktop' could not be read correctly. The application associated with this file will not be included in the software catalog. Please consider raising a bug report for this issue with the maintainer of that application
Software catalog update was successful.
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$

Slavko Mangovski (mango-8) said : #20

Software Center still not working correctly, it opened up then it shows error and closes down:

sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ gksudo software-center
2013-12-29 10:26:18,667 - softwarecenter.region - WARNING - failed to use geoclue: 'org.freedesktop.Geoclue.Error.notAvailable: Geoclue master client has no usable Address providers'
2013-12-29 10:26:19,137 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2013-12-29 10:26:19,140 - softwarecenter.plugin - INFO - activating plugin '<module 'webapps_activation' from '/usr/share/software-center/softwarecenter/plugins/webapps_activation.pyc'>'
2013-12-29 10:26:19,171 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/gi/importer.py', 51, 'find_module')'
2013-12-29 10:26:19,171 - root - ERROR - Could not find any typelib for LaunchpadIntegration
2013-12-29 10:26:19,313 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()
2013-12-29 10:26:25,051 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/share/software-center/softwarecenter/utils.py', 271, 'get_title_from_html')'
2013-12-29 10:26:25,051 - root - WARNING - failed to parse: '<div style="background-color: #161513; width:1680px; height:200px;">
 <div style="background: url('/site_media/exhibits/2013/09/AAMFP_Leaderboard_700x200_1.jpg') top left no-repeat; width:700px; height:200px;"></div>
</div>' ('ascii' codec can't encode character u'\xa0' in position 70: ordinal not in range(128))
2013-12-29 10:26:25,052 - softwarecenter.ui.gtk3.views.lobbyview - WARNING - skipping exhibit for: 'u'amnesia-amfp'' not available
2013-12-29 10:26:25,053 - softwarecenter.ui.gtk3.views.lobbyview - WARNING - skipping exhibit for: 'u'zhackers-volume2-usc'' not available

(software-center:3176): Gdk-ERROR **: The program 'software-center' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadDrawable (invalid Pixmap or Window parameter)'.
  (Details: serial 2605 error_code 9 request_code 62 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$

Slavko Mangovski (mango-8) said : #21

I tried rebooting and got: the application Ubuntu Software Center closed unexpectedly.

Slavko Mangovski (mango-8) said : #23

Still crashes.

This is from the first solution:

sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo rm /etc/apt/sources.list.d/*
[sudo] password for sarisa:
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ sudo rm /etc/apt/sources.list.d/*
rm: cannot remove ‘/etc/apt/sources.list.d/*’: No such file or directory
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ /usr/share/software-center/softwarecenter/ui/gtk3/views/lobbyview.py
bash: /usr/share/software-center/softwarecenter/ui/gtk3/views/lobbyview.py: Permission denied
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ open /usr/share/software-center/softwarecenter/ui/gtk3/views/lobbyview.py
Couldn't get a file descriptor referring to the console
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ #self.exhibit_banner.set_exhibits([FeaturedExhibit()])
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ gksudo software-center
2013-12-29 11:00:02,336 - softwarecenter.backend.login_impl.login_sso - ERROR - _on_credentials_error for Ubuntu One: dbus.Dictionary({dbus.String(u'errtype'): dbus.String(u'DBusException'), dbus.String(u'message'): dbus.String(u'Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.')}, signature=dbus.Signature('ss')) ()
2013-12-29 11:00:02,674 - softwarecenter.region - WARNING - failed to use geoclue: 'org.freedesktop.Geoclue.Error.notAvailable: Geoclue master client has no usable Address providers'
2013-12-29 11:00:03,058 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2013-12-29 11:00:03,068 - softwarecenter.plugin - INFO - activating plugin '<module 'webapps_activation' from '/usr/share/software-center/softwarecenter/plugins/webapps_activation.pyc'>'
2013-12-29 11:00:03,105 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/gi/importer.py', 51, 'find_module')'
2013-12-29 11:00:03,105 - root - ERROR - Could not find any typelib for LaunchpadIntegration
2013-12-29 11:00:03,210 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()
2013-12-29 11:00:12,168 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/share/software-center/softwarecenter/utils.py', 271, 'get_title_from_html')'
2013-12-29 11:00:12,168 - root - WARNING - failed to parse: '<div style="background-color: #161513; width:1680px; height:200px;">
 <div style="background: url('/site_media/exhibits/2013/09/AAMFP_Leaderboard_700x200_1.jpg') top left no-repeat; width:700px; height:200px;"></div>
</div>' ('ascii' codec can't encode character u'\xa0' in position 70: ordinal not in range(128))
2013-12-29 11:00:12,199 - softwarecenter.ui.gtk3.views.lobbyview - WARNING - skipping exhibit for: 'u'amnesia-amfp'' not available
2013-12-29 11:00:12,204 - softwarecenter.ui.gtk3.widgets.exhibits - WARNING - download failed: '<class 'gi._glib.GError'>', 'Operation not supported'

(software-center:4114): Gdk-ERROR **: The program 'software-center' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadDrawable (invalid Pixmap or Window parameter)'.
  (Details: serial 2174 error_code 9 request_code 62 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Traceback (most recent call last):
  File "/usr/share/software-center/update-software-center-agent", line 116, in <module>
    if not update_from_software_center_agent(db, cache, options.ignore_cache, include_sca_qa):
  File "/usr/share/software-center/softwarecenter/db/update.py", line 1099, in update_from_software_center_agent
    token = helper.find_oauth_token_sync()
  File "/usr/share/software-center/softwarecenter/backend/ubuntusso.py", line 141, in find_oauth_token_sync
    sso.find_credentials()
  File "/usr/share/software-center/softwarecenter/backend/login_impl/login_sso.py", line 74, in find_credentials
    self.proxy.find_credentials(self.appname, self._get_params())
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$

and this from the 2nd solution:sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ gksudo gedit /usr/share/software-center/softwarecenter/ui/gtk3/views/lobbyview.py

(gedit:5519): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$ gksudo software-center
Traceback (most recent call last):
  File "/usr/bin/software-center", line 130, in <module>
    app = SoftwareCenterAppGtk3(options, args)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 338, in __init__
    self.icons)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/session/appmanager.py", line 66, in __init__
    self.oauth_token = helper.find_oauth_token_sync()
  File "/usr/share/software-center/softwarecenter/backend/ubuntusso.py", line 141, in find_oauth_token_sync
    sso.find_credentials()
  File "/usr/share/software-center/softwarecenter/backend/login_impl/login_sso.py", line 74, in find_credentials
    self.proxy.find_credentials(self.appname, self._get_params())
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
sarisa@sarisa-HP-Pavilion-dv6-Notebook-PC:~$

nothing happens.

It is not clear if you made the necessary modifications inside the file

/usr/share/software-center/softwarecenter/ui/gtk3/views/lobbyview.py

or not....

Try this command to start editing the file:

sudo nano /usr/share/software-center/softwarecenter/ui/gtk3/views/lobbyview.py

Use CTRL-W to search in the nano editor and use CTRL-O to save any changes in nano.

You have to search and comment the line in the file lobbyview.py that contains the following expression :
(to comment you need to put the character # at the start of the line)

"self.exhibit_banner.set_exhibits([FeaturedExhibit()])"

after commenting that line, just save and close the file, and try to open the software-center.

Do not run

#self.exhibit_banner.set_exhibits([FeaturedExhibit()])

in the Terminal. That configuration line exists in the lobbyview.py file.

Configuration lines are stored in configuration FILES and are NOT commands.

Only commands should be run in the Terminal.

#self.exhibit_banner.set_exhibits([FeaturedExhibit()]) is NOT a command.

I suggest reading the guides here as well:

https://help.ubuntu.com/community/ExternalGuides

Slavko Mangovski (mango-8) said : #25

I rebooted and started the software-center. So far it has not crashed. I'm not sure whether it works correctly, though. When I click on 'Installed' it takes forever and no results. But it seems that the other functions work. Thank you!

Slavko Mangovski (mango-8) said : #26

I don't know if this is connected to the previous problem but I tried to install something and it didn't work:

installArchives() failed: (Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 215437 files and directories currently installed.)
Unpacking flightgear-data-aircrafts (from .../flightgear-data-aircrafts_2.10.0-2ubuntu1_all.deb) ...
dpkg-deb (subprocess): cannot copy archive member from '/var/cache/apt/archives/flightgear-data-aircrafts_2.10.0-2ubuntu1_all.deb' to decompressor pipe: failed to read (Input/output error)
dpkg-deb: error: subprocess paste returned error exit status 2
dpkg: error processing /var/cache/apt/archives/flightgear-data-aircrafts_2.10.0-2ubuntu1_all.deb (--unpack):
 cannot copy extracted data for './usr/share/games/flightgear/Aircraft/SenecaII/Models/SenecaII.ac' to '/usr/share/games/flightgear/Aircraft/SenecaII/Models/SenecaII.ac.dpkg-new': unexpected end of file or stream
No apport report written because MaxReports is reached already
Errors were encountered while processing:
 /var/cache/apt/archives/flightgear-data-aircrafts_2.10.0-2ubuntu1_all.deb
dpkg: dependency problems prevent configuration of flightgear-data-all:
 flightgear-data-all depends on flightgear-data-aircrafts (>= 2.10.0); however:
  Package flightgear-data-aircrafts is not installed.

dpkg: error processing flightgear-data-all (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of flightgear:
 flightgear depends on flightgear-data-all (>= 2.10.0~); however:
  Package flightgear-data-all is not configured yet.

dpkg: error processing flightgear (--configure):
 dependency problems - leaving unconfigured