Saucy 13.10 Bluetooth Kills Wifi Centrino 1030

Asked by Ray Strilec on 2013-11-17

I am having multiple bluetooth problems since upgrading to 13.10. When trying to connect to my Jawbone Jambox : 1) I cannot get a2dp (high fidelity audio) to connect, which worked under 13.04. 2) I can connect the headset service, but when I do my wifi network connection stops working. I don't get an indication that the network connection dropped, it just stops. I cannot load webpages or ping the router IP address. Once I disconnect the bluetooth connection the wifi connection will resume working.

I have an ASUS U56E laptop with an Intel Centrino Wireless-N 1030 [Rainbow Peak] integrated wireless and bluetooth adapter.

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2013-11-18
Last reply:
2013-12-04

What is the output of:

sudo lshw -C network; lsb_release -a; uname -a; sudo rfkill list

Thanks

Ray Strilec (rstrilec) said : #2

$ sudo lshw -C network; lsb_release -a; uname -a; sudo rfkill list
  *-network
       description: Wireless interface
       product: Centrino Wireless-N 1030 [Rainbow Peak]
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 34
       serial: bc:77:37:cc:7b:bc
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.11.0-13-generic firmware=18.168.6.1 ip=192.168.1.104 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:51 memory:de800000-de801fff
  *-network
       description: Ethernet interface
       product: AR8151 v2.0 Gigabit Ethernet
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: eth0
       version: c0
       serial: 14:da:e9:14:0b:6e
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion=1.0.1.1-NAPI latency=0 link=no multicast=yes port=twisted pair
       resources: irq:54 memory:dd400000-dd43ffff ioport:a000(size=128)
LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 13.10
Release: 13.10
Codename: saucy
Linux asus-quantal 3.11.0-13-generic #20-Ubuntu SMP Wed Oct 23 07:38:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
0: hci0: Bluetooth
 Soft blocked: no
 Hard blocked: no
1: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no
2: asus-wlan: Wireless LAN
 Soft blocked: no
 Hard blocked: no
3: asus-bluetooth: Bluetooth
 Soft blocked: no
 Hard blocked: no

So when you enable the bluetooth, the wifi turns off. Is that right?

Ray Strilec (rstrilec) said : #4

No. Wifi works with bluetooth enabled but stops once I connect to a device. I've only tried an audio devices thus far.

Do you have the latest BIOS (If your PC uses one)?

Ray Strilec (rstrilec) said : #6

Yes. I installed the latest BIOS last week while working on this problem.

Try:

echo "options iwlwifi 11n_disable=1 bt_coex_active=0 power_save=0 auto_agg=0 swcrypto=1" | sudo tee /etc/modprobe.d/iwlwifi.conf > /dev/null

As one big command. Reboot to test.

Ray Strilec (rstrilec) said : #8

Thank you. That fixed part 2 of the problem. I can now connect headset service to the Jambox and wifi works reliably. I've tested it several times.

However, Part 1 of the problem, connect a2dp is a little tricky. I am using blueman to manage my bluetooth connections. I have found that I can connect to the headset service of the Jambox but cannot connect to the audio sink. If I connect and then restart pulseaudio by issuing a pulseaudio -k command, I can then go back to blueman, right click on Jambox, and I will then see an "audio profile" option in the menu. I can select a2dp and it will work. This is less than completely reliable and once I disconnect, I have not found a way to reconnect. This could be a pulseaudio issue.

Launchpad Janitor (janitor) said : #9

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Luke Hudson (lukeletters) said : #10

I had this same problem.
Pinging my router gives an average of 2.3ms.
Connecting via bluetooth to the headset didn't change this significantly, but as soon as I used A2DP playback the pings go up to 11000ms or even get dropped completely.
This doesn't occur if using a different sound device, or if using HSP/HFP mode.

The workaround suggested by actionparsnip worked for me.

This is on Linux Mint 16 (based on Ubuntu Saucy).

Vladimir Ivanov (ivanov-bg) said : #11

I had same problem on my Ubuntu 14.04LTS laptop - when play music on my bluetooth speakers, the wi-fi connection stops (I remain connected to the router, but with no Internet connection).
I fixed my problem using the actionparsnip's suggestion, but skipped disabling 11n. Everything is OK now, but can somebody explain the remaining options from the command?
Thanks in advance

Donald Lhoƫst (d-lhoest-y) said : #12

Hello everyone,

I had (HAD) the exact same problem. If this still affects you, the answer for me was here : https://answers.launchpad.net/ubuntu/+question/239371 which consist in the following command :

echo "options iwlwifi 11n_disable=1 bt_coex_active=0 power_save=0 auto_agg=0 swcrypto=1" | sudo tee /etc/modprobe.d/iwlwifi.conf > /dev/null

Regards!

Buck Evan (bukzor) said : #13

This workaround fixed this issue for me:

    echo "options iwlwifi bt_coex_active=0" | sudo tee -a /etc/modprobe.d/iwlwifi.conf

The other workaround sets a bunch of unrelated options, and also blanks any pre-existing config.