problemas de actualizacion

Asked by Pablo Eirín

Ejecutando actualiaciones en Ubunutu 10.04 LTS ha ocurrido un problema desde entonces no puedo acceder ni a "Centro de Software", ni acceder al "Gestor de Actualizaciones" ni a "Orígenes del Software".

En la barra de menu me aparece una señal de prohibido con el siguiente mensaje:

"Ha ocurrido un error; ejecute el Gestor de Paquetes desde el menu contextual o apt-get desde una terminal para ver dónde está el problema.

El mensaje de error fue: << Error: BrokenCount > 0 >> normalmente, esto significa que ha instalado paquetes cuyas dependencias no se han podido satisfacer"

Con anterioridad había tratado de desinstalar openoffice para instalar libreoffice pero no fui capaz.

Alguien sabe como puedo reparar el sistema operativo:

Muchas gracias por adelantado.

Question information

Language:
Spanish Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Pablo Eirín (pablo-eirin) said :
#1

Para más datos desde el terminal me aparece el siguiente mensaje:

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Corrigiendo dependencias... falló.
Los siguientes paquetes tienen dependencias incumplidas:
  libc-dev-bin: Depende: libc6 (< 2.12) pero 2.15-0ubuntu10.3 está instalado
  libc6-dev: Depende: libc6 (= 2.11.1-0ubuntu7.12) pero 2.15-0ubuntu10.3 está instalado
  libnih1: Depende: libc6 (< 2.12) pero 2.15-0ubuntu10.3 está instalado
  python-louis: Depende: liblouis0 (>= 1.7.0-2) pero no es instalable
E: Error, pkgProblemResolver::Resolve generó cortes, esto puede haber sido causado por paquetes retenidos.
E: No se puede corregir las dependencias

Alguien sabe cómo puedo corregir estas depedencias?

Revision history for this message
Adolfo Jayme (fitojb) said :
#2

Intenta con la siguiente orden en terminal:

sudo apt-get -f install

Revision history for this message
Pablo Eirín (pablo-eirin) said :
#3

Ya lo he intentado y me aparece el siguiente mensaje:

pablo@pablo-laptop:~$ sudo apt-get -f install
[sudo] password for pablo:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Corrigiendo dependencias... falló.
Los siguientes paquetes tienen dependencias incumplidas:
  libc-dev-bin: Depende: libc6 (< 2.12) pero 2.15-0ubuntu10.3 está instalado
  libc6-dev: Depende: libc6 (= 2.11.1-0ubuntu7.12) pero 2.15-0ubuntu10.3 está instalado
  libnih1: Depende: libc6 (< 2.12) pero 2.15-0ubuntu10.3 está instalado
  python-louis: Depende: liblouis0 (>= 1.7.0-2) pero no es instalable
E: Error, pkgProblemResolver::Resolve generó cortes, esto puede haber sido causado por paquetes retenidos.
E: No se puede corregir las dependencias

Revision history for this message
Pablo Eirín (pablo-eirin) said :
#4

Me imagino que de alguna forma tendré que corregir las dependencias desde el "Gestor de Paquetes Synaptic" así como eliminar los repositorios repetidos y los multiverse que podrían estar dando problemas. El caso es que no se cómo.

Revision history for this message
Sergio Meneses (sergiomeneses) said :
#5

Entra a synaptic y vas a estado, allí te muestra los paquetes rotos.... lo de los repositorios los eliminas en "Origenes de Software"

Revision history for this message
Adolfo Jayme (fitojb) said :
#6

Sí, como dice Sergio, los paquetes rotos pueden corregirse con Synaptic muy fácilmente:

1.- Una vez abierto el programa, ve al menú Editar ‣ Corregir paquetes rotos
2.- Luego, en la barra de herramientas de Synaptic, pulsa el botón de Aplicar los cambios

P.D.: Si no tienes Synaptic instalado: sudo apt-get install synaptic
P.D. 2: También puedes intentar http://www.linuxforums.org/forum/debian-linux/59318-package-problem-broken-dependency-more.html#post742320

Revision history for this message
Pablo Eirín (pablo-eirin) said :
#7

Adolfo, he realizado la operación que mehas indicado y me aparece el siguiente mensaje:

E: Error, pkgProblemResolver::Resolve generó cortes, esto puede haber sido causado por paquetes retenidos.
E: No se pueden corregir las dependencias

He probado la opción las opciones indicadas en el link que me has dejado, todo parece funcionar menos el comando upgrade ante el cual me aparece el siguiente mensaje:

pablo@pablo-laptop:~$ sudo apt-get upgrade
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Tal vez quiera ejecutar `apt-get -f install' para corregirlo.
Los siguientes paquetes tienen dependencias incumplidas:
  libc-dev-bin: Depende: libc6 (< 2.12) pero 2.15-0ubuntu10.3 está instalado
  libc6-dev: Depende: libc6 (= 2.11.1-0ubuntu7.12) pero 2.15-0ubuntu10.3 está instalado
  libnih1: Depende: libc6 (< 2.12) pero 2.15-0ubuntu10.3 está instalado
  python-louis: Depende: liblouis0 (>= 1.7.0-2) pero no es instalable
E: Dependencias incumplidas. Pruebe de nuevo usando -f.
pablo@pablo-laptop:~$ sudo apt-get dist-upgrae
E: Operación inválida: dist-upgrae
pablo@pablo-laptop:~$ sudo apt-get dist-upgrade
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Tal vez quiera ejecutar `apt-get -f install' para corregirlo.
Los siguientes paquetes tienen dependencias incumplidas:
  libc-dev-bin: Depende: libc6 (< 2.12) pero 2.15-0ubuntu10.3 está instalado
  libc6-dev: Depende: libc6 (= 2.11.1-0ubuntu7.12) pero 2.15-0ubuntu10.3 está instalado
  libnih1: Depende: libc6 (< 2.12) pero 2.15-0ubuntu10.3 está instalado
  python-louis: Depende: liblouis0 (>= 1.7.0-2) pero no es instalable
E: Dependencias incumplidas. Pruebe de nuevo usando -f.

De alguna forma tendré que corregir esas dependencias a mano o reinstalar esas librerias.

Revision history for this message
Manfred Hampl (m-hampl) said :
#8

Follow the instructions in step 1 to 6 of https://help.ubuntu.com/community/PackageManagerTroubleshootingProcedure with the only excaption that in step 6 you should not create a new question document, but you should continue in this current one https://answers.launchpad.net/ubuntu/+question/225947

Revision history for this message
Pablo Eirín (pablo-eirin) said :
#9

Thanks for your answer Manfred but I can not access neither to the "Ubuntu Software Center" nor "Software Sources";

Anyway, I went directly to step 5 as it is indicated in the forum. When I type the comman:

find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; cat -n "$1"' _ '{}' \;

appears the following message:

"exec command not found"

Computer Operative System is completly collapsed now.

Revision history for this message
Sergio Meneses (sergiomeneses) said :
#10

Te recomendaria que uses la guia: https://help.ubuntu.com/community/PackageManagerTroubleshootingProcedure allí podras encontrar una serie de procedimientos para solucionar problemas con el manejador de paquetes.

PD: recuerda marcar tus preguntas como solucionadas.

Revision history for this message
Manfred Hampl (m-hampl) said :
#11

If you cannot use software-center and if the "find..." command fails with "exec command not found", then your system is really not in a healthy state.

I think I have to propsoe two options:
1. you consider reinstalling the operating system. You would have to use caution not to overwrite you data (if there are any important data on your system).
2. you want to try repairing your system. I cannot predict the effort that is needed for that, and cannot promise if it will succeed.

The first steps for option 2 would be answering a few questions about your system:
Does you system boot into Ubuntu, can you log in?
What happens if you try running software-center?
If you can log in, please open a terminal (e.g. by simultaneously pressing ctrl-alt-t) and issue the commands

uname -a
lsb_release -a
which bash
echo $PATH

Then select all output of these commands (by using the terminal menu entry "edit - select all"), copy it (edit - copy) and paste into a new message of this question thread.

Can you help with this problem?

Provide an answer of your own, or ask Pablo Eirín for more information if necessary.

To post a message you must log in.