11.04 wont load on my new machine [was 10.04]

Asked by Ben on 2011-04-11

I installed 9.04 on my new HP touchsmart 610 then upgraded through 9.10 then on to 10.04. At that point on start when I choose to start with Ubunto 10.04 the screen starts flashing through the colors RED, green, Blue, White and some other colors. I then figured out how to download 10.10 to a CD and tried to install it I choose english as the language and when it goes to the next screen it starts doing the color thing again. I want the latest version of Ubunto on my machine but if that is not possible how do I go back to the latest version (9.10) that acctually worked.

Question information

English Edit question
Ubuntu ubiquity Edit question
No assignee Edit question
Last query:
Last reply:
Mario Gervais (mgervais) said : #1

I recommend to install 10.04 right form the 10.04 ISO. I don't trust enough upgrading and you did it form 9.04... iiisssshhhh What do you think about installing 10.04?

Mario Gervais (mgervais) said : #2

Oups... If you want to go back to a latest version, just have to install it form the CD. What is the version of this TouchSmart 610?

Ben (iamcoolbs) said : #3

Thanks for the reply,

It is a HP touchsmart 610 PC 610-1050y

Sent from my iPhone

On Apr 11, 2011, at 8:56 PM, Mario Gervais <email address hidden> wrote:

> Your question #152461 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/152461
> Mario Gervais proposed the following answer:
> Oups... If you want to go back to a latest version, just have to install
> it form the CD. What is the version of this TouchSmart 610?
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/ubuntu/+question/152461/+confirm?answer_id=1
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+question/152461
> You received this question notification because you are a direct
> subscriber of the question.

I suggest you test your RAM using the entry in the grub menu as well as make sure you have the latest BIOS. May help

delance (olivier-delance) said : #5

"I want the latest version of Ubuntu" : next version will be released at end of this month. You could download the Beta1 of Natty 11.04, make a CD from it and check with a Live session (boot on CD and choose "Try" instead of "Install"). So you will know if next version will work correctly. Your issue looks more like a graphic card/chipset badly managed.

I'm trying to install natty on the same hardware, and I encounter the same problem. Even with the Live session I get the flashy color thing. It's an intel i5 core chipset with the integrated intel hd graphics, and that should all be supported by natty.

The install should work on any vga, right? so this kind of problem "can't happen" unless something truly pathological--or unrelated to video--is going on.

Add the bootoption:


May help

Yes. Then ubiquity goes. But still the system is nonfunctional. X crashes, and grep EE from Xorg.log shows three items:

open /dev/db0: No such file or directory
Lite-On Technology Corp. Wireless Device: failed to initialize for relative axes.
AT Translated Set 2 keyboard: Couldn't open mtdev device

I'm using the natty install cds handed out at UDS. AFAICT this is a 32-bit cd, which may be wrong, since the computer is a 64-bit computer. I assumed that it would be able to install the 64-bit version, but perhaps that was wrong. Still, that should be irrelevant to the failure of X to start.

And, since the installer is completely dependent on X (sigh), as is networkmanager, I am being harmed by the "ease" of installation of a graphical-only system. Is there any hope?

In addition, X seems to segfault, at least sometimes. Judging from the trace, the segfault is in mtdev_open from libmtdev.so.1.

Can we change the status to something other than "answered", since the actual problem is that 10.04, and 11.04, is failing to install on a touchsmart, and that this is a clear regression, since 9.04 reportedly works fine.

I'm a bit annoyed because I carefully checked the hardware against what is supported in natty, and all the devices in this computer should work.

I should add further that the screen looks nothing like the normal graphical installer screen. https://help.ubuntu.com/community/GraphicalInstall

Instead, I get a texty screen, but not the Debianish one described here as the "alternate installer" http://www.ubuntu.com/download/ubuntu/alternative-download

This is rather confusing. Perhaps I get a different screen because it's failing to make my video work. Or perhaps because... who knows??

I'd take photos of what I see and attach them here, but I don't see how.

delance (olivier-delance) said : #12

You can use website imageshack.us to share pictures.
You could try the alternative installer, which will install latest video driver. But as 11.04 was just delivered, I presume you will get same video driver than from CD. I had a look at next Linux Kernel (39), they don't talk of new driver for your AMD Radeon GPU.

AMD Radeon GPU??

You can see the specs at HP. It has "Integrated Intel HD Graphics", specifically, those from the Core i5 650 processor set. This is a Clarkdale processor. Not sure why you're speaking of AMD or Radeon.

It's a pretty theory that I could use the alternative installer. My network is a password protected wireless network. Is that going to fly?

The installations screens that I see are these with minor differences.


It's rather odd that this is so different from this one:


Also note that the actual errors from X (EE lines) are not about video, but about the keyboard and touchscreen input devices. (Though the /dev/fb0 absence is more than a little odd; I have no experience debugging udev to see what's going on there, and I don't know whether it should be visible or not.)

When X tries to start, I get some screen flashing and corrupted display as well.

Should be supported in kernels >= 2.6.33, and Xorg >= 2.11.

Hijacking this question is probably not the best idea. I've created a new one at https://answers.launchpad.net/ubuntu/+source/ubiquity/+question/158859.

Launchpad Janitor (janitor) said : #22

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Launchpad Janitor (janitor) said : #24

This question was expired because it remained in the 'Open' state without activity for the last 15 days.