10.10 RAM upgrade from 4GB to 8GB wont boot

Asked by Lonny Barry on 2010-11-15

$ uname -a
Linux xerxes 2.6.35-22-generic #35-Ubuntu SMP Sat Oct 16 20:45:36 UTC 2010 x86_64 GNU/Linux

Originally installed with 4 GB RAM.
Upgraded to 8 GB, the system posts, the BIOS shows all 8 GB, but even GRUB fails to load (negating the possibility for a RAM test).
Change the hardware configuration to 4GB (two 2GB DIMM) and the system operates normally.
Change the hardware configuration to 6GB (one 2GB DIMM and one 4GB DIMM) and the system operates normally.
Change the hardware configuration to 8GB (two 4GB DIMM) and the system posts, and seizes at the handoff to the operating system (prior to Grub taking over), left with a non-blinking cursor at the top left hand of the monitor.

Help please. I'd rather not go back to Windows. The laptop vendor (Toshiba A665-S6093) insists that since the bios detects all 8GB, then it must be Ubuntu failing somehow to boot. They say they will assist only once the laptop is restored to a Windows operating system. Not an attractive option.

Thanks in advance!

Lonny

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2010-11-16
Last query:
2010-11-16
Last reply:
2010-11-16
mycae (mycae) said : #1

I am unsure about this, but a random question would be : can you boot from removable media (eg. liveCD)?

Lonny Barry (lbarry) said : #2

Unfortunately, no. I thought of just reinstalling once the memory was upgraded, since I have nightly rsync backups of the entire drive. But no, the system will not boot from a usb stick. I have not made a bootable CD.

Run a memory test. You may have a bad stick

Lonny Barry (lbarry) said : #4

With 8 GB installed, it will not even run Grub, hence the inability to run a memtest. However, I can boot with

    6GB (2GB + 4GB stick one) - successful
    6GB (2GB + 4GB stick two) - successful

Thanks

Boot to liveCD and you can memtest there

Lonny Barry (lbarry) said : #6

Finalizing CD now. I'll post results of the mem test here in about 15 minutes.

Lonny Barry (lbarry) said : #7

With 8GB installed, the system would not boot the CD. Unless you have some other insight, i'm going to RMA the memory and try again with a different distributor.

Its odd that the bios recognizes the 8GB but will not boot an OS.

Thanks

The OS not loading, not even the liveCD is a bad sign dude

peter b (b1pete) said : #9

are there any options in bios such as memory speed, latency, configuration on each bank etc ? are there any manufacturer recommendations re modules tested, mem manufacturers ? is the latest bios version installed ?

Latest BIOS may be needed to access more ram

Lonny Barry (lbarry) said : #11

I think _was_born_ under a bad sign.

I've flashed bios as suggested, upgraded from 1.6 to 1.8.
Interesting to note in the release notes (http://tinyurl.com/25yw4cl) one
issue each concerning RAM for the past two revisions. Neither of which
addressed this problem.

In short, system still hangs right after the post. I'm RMA'ing the memory
today.

Shopping for a different vendor, try this all over agin.

Thanks guys, for your advice.

Lonny

On Tue, Nov 16, 2010 at 12:11 AM, actionparsnip <
<email address hidden>> wrote:

> Your question #134192 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/134192
>
> actionparsnip proposed the following answer:
> Latest BIOS may be needed to access more ram
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/ubuntu/+question/134192/+confirm?answer_id=9
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+question/134192
>
> You received this question notification because you are a direct
> subscriber of the question.
>

Lonny Barry (lbarry) said : #12

Thanks actionparsnip, that solved my question.

Lonny Barry (lbarry) said : #13

Ultiimately, the vendor RMA'ed the RAM, shipped out an exact duplicate and resolved the issue. RAM tests proved that the second set of DIMMs were flawlessly recognized by the MB and OS.