Feedback on the Lenovo ThinkPad P17 Gen1 (202010-28339)

Asked by Jesus Niño on 2021-01-18

Hi. I have problem with mi NVIDIA DRIVER. I can't connect any monitor by using my USB port type-c.
It seems a problem with Nvidia Drivers.
QuadroT1000 Mobile
Details:
When I plug my monitor, I can see my desktop for a short time... but after 2 seconds it dissapears and I can't see it again.
It seems like is detected but then it doesnt work

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu-Certification Edit question
Assignee:
No assignee Edit question
Last query:
2021-01-23
Last reply:
2021-01-25
William Hsu (williamhsu) said : #1

Hi, Jesus,

Good day! Thank you for bringing this issue to our attention.
Would it be possible to provide us more system information (Kernel version and BIOS version)?
# Kernel version
$ uname -a
# BIOS version
$ sudo dmidecode -s bios-version

Your help would be appreciated! Thank you! :)

Hi Jesus,

Thank you for you feedback.

Firstly, please help to check the image version $ cat /etc/buildstamp
If it prints ' sutton-simon-focal-amd64-20201209-146' or ' sutton-simon-focal-amd64-20201012-119' , that is the correct OEM image.

Please give it a try following.

1. Please make sure Nvidia driver working;
2. Plug in the USB-type-C port;
3. If the issue reproduce, please try to press 'video-hot' key ( Fn+F7) to switch the display modes;
4. Choose the mode which you want to and check the issue reproduce or not

If the issue reproduces too, please help to provide the info what is asked by Williamhsu. Please provide us the USB-type-C cable and monitor' details at the same time. Thank you so much.

Jesus Niño (jneusse) said : #3

On 21/01/21 21:50, William Hsu wrote:
> Your question #695071 on Ubuntu-Certification changed:
> https://answers.launchpad.net/ubuntu-certification/+question/695071
>
> Status: Open => Needs information
>
> Hi, William
>
> # Kernel version: 5.8.0-40-generic
> # BIOS version N30ET32W (1.15 )

I have 2 Type C port. (VGA) for two monitors.

Nvidia Driver

HDMI port works perfect.

Thanks

>

William Hsu (williamhsu) said : #4

Hi, Jesus,

Good day! Thank you for the prompt response.
We're going to leverage this information to figure out this issue and then get back to you as soon as possible.

Have a nice day! :)

Cheers,
William

William Hsu (williamhsu) said : #5

Hi, Jesus,

Good day! Please allow me to give you a quick update here.
Per internal discussion, the platform (ThinkPad P17 Gen1) got the Ubuntu certification with 5.6 Kernel only. So, there may be something wrong with the 5.8.0-40-generic. Therefore, the QA team has added a task into our daily queue and is going to work on the issue reproduction to see if we can observe the issue.

Any investigation would be shared here as possible as we can.
Thank you!

Cheers,
William

Can you help with this problem?

Provide an answer of your own, or ask Jesus Niño for more information if necessary.

To post a message you must log in.