Feedback on the Dell Vostro 5481 - Bucky V5 14

Asked by Ioan Cristea on 2019-02-08

Hello,

I have a problem with my dell vostro 5481.
The fingerprinter is not seen by the system in lsusb appear the device id 27c6:538c, with no manufacturer.
In the users settings nothing appear about register fingerprint.

Also deep sleep not working.
It enter in sleep but not wake-up (the laptop restart).
I have a OEM ubuntu instalation with latest oem kernel.

Against this is ubuntu certified hardware, some things not working.

Please help me with that problems.

EDIT: resume after suspend problem
After many tests I discover that my laptop OEM Ubuntu 18.04 comes with sleep mode config as: mem_sleep_default=deep in /etc/default/grub, and when I delete this config, it works.
I want to have deep sleep on, because of low consumption in sleep state.

PARTIAL SOLVED
I discover that when I power up the laptop, login and resume after suspend cause laptop to restart.
But if I power up laptop and before login I restart it, and after login suspend and resume works OK. It also apply if I CTRL+ALT+DEL before ubuntu boot logo appears.

I tried to see the grub config with press "E" key before boot, but I can't enter to grub editor when I use that method to make suspend works.

Please If others experienced user can help me.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu-Certification Edit question
Assignee:
No assignee Edit question
Solved by:
Jerry Kao
Solved:
2019-04-08
Last query:
2019-04-08
Last reply:
2019-04-01
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Po-Hsu Lin (cypressyew) said : #2

Re-open this,

Thanks for letting us know about this issue, I will loop this to the correct place.

Also for the fingerprint, it sounds like there are two issues here
1. Name, the name should be updated in this database, http://www.linux-usb.org/usb-ids.html
 2. Fingerprint reader support, unfortunately it is badly supported in Linux world. You may try your luck with fingerprint-gui project, please refer to this FAQ. https://answers.launchpad.net/ubuntu-certification/+faq/2217

Ioan Cristea (krioft) said : #3

Hello. I come with some edit at resume after suspend problem.

Jerry Kao (jerry.kao) said : #4

Hi Loan,

Could you help to provide following info

1) release version (lab_release -a)
2) kernel version (uname -a)
3) bios version (sudo dmidecode -s bios-version)

Thanks,

Ioan Cristea (krioft) said : #5

1)
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.10
Release: 18.10
Codename: cosmic

2) Linux ioan-laptop 4.15.0-1034-oem #39-Ubuntu SMP Fri Feb 15 13:10:11 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

3) 1.3.0

Best Jerry Kao (jerry.kao) said : #6

Hi Ioan,

The resume issue will be fixed in next BIOS release soon.

Ioan Cristea (krioft) said : #7

Thanks for your help!
I will keep eye on dell website.

Ioan Cristea (krioft) said : #8

Hi,

Resume after suspend problem solved by upgrade BIOS to 2.2.0 from Dell website.
Fingerprint not working but I wait good news.

Thanks Jerry Kao

Ioan Cristea (krioft) said : #9

Thanks Jerry Kao, that solved my question.