Need Network Driver for Ubuntu 14.04 on the Dell OptiPlex 5050

Asked by Chuah Yeow Chiang on 2017-11-20

I have recently acquired a Dell Optiplex 5050, pre-installed with Ubuntu 16.04.
However, due to the application that I need to install, which can only run on Ubuntu 14.04, I had to reinstall the whole system with Ubuntu 14.04.
However, after installation, the system cannot recognize the onboard Network adapter (which is an Intel Ethernet Connection (5) 1219-V.
I am not able to find any website where I can download the device driver for this (including Dell Support site).

I would really appreciate if I can receive some help in this.

Thank you.

Regards,
ChuahYC

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu-Certification Edit question
Assignee:
No assignee Edit question
Last query:
2017-11-20
Last reply:
2017-11-23
Yung Shen (kaxing) said : #1

Hi ChuahYC,

Unfortunately, the easily way to get back the driver, you will need to find the pre-load version of Ubuntu 16.04 image, you might want to check with Dell service.

For your application you can try put it into a container, please find more information here: https://linuxcontainers.org/lxd/getting-started-cli/

Kind regards,
Yung
FAQ #1523: “Where can I find a Pre-install/Manufacturer image”.

Po-Hsu Lin (cypressyew) said : #2

BTW,
the driver for this should be included in the kernel, so you can try to run dist-upgrade on your 14.04 system (3.13 kernel) to upgrade your kernel, or try with 14.04.5 + dist-upgrade (4.4 kernel)

Chuah Yeow Chiang (ycchuah) said : #3

Dear Yung Shen & Poh-Hsu Lin,
     Thanks for the suggestion. I found the solution at the following(at the part described by DevRobot, where I need to download and compile the device driver, and do a "modprobe e1000e"):
https://askubuntu.com/questions/650953/intel-e1000e-ethernet-not-working

Except, I downloaded the latest source code for the device driver from here (ver.3.3.6):
https://downloadcenter.intel.com/download/15817/Intel-Network-Adapter-Driver-for-PCI-E-Gigabit-Network-Connections-under-Linux-?product=71307

Also, I have to redo the steps every time I update the 14.04 kernel, as the version of the device driver contained in the kernel is still older version.

Yes, contacted Dell Support, unfortunately, no answer, and didn't get back to me for the past 4 days.

Regards,
ChuahYC

Po-Hsu Lin (cypressyew) said : #4

Have you tried 14.04.5 (with 4.4 kernel) yet?
Or the application you need must be run on 3.13 kernel?

Chuah Yeow Chiang (ycchuah) said : #5

Hello,
      It's a customized 14.04LTS version, provided by my principle. (Sorry, am not sure the rest of the details). I only have the installation image provided by them.

      Anyway, the problem is already resolved, and the system already delivered to my client, hence, I shall consider this case closed. :)

      Just that, this is a good lesson learn, in case I need to setup another system on Dell PC next time.

      Thank you.

Regards,
ChuahYC

Can you help with this problem?

Provide an answer of your own, or ask Chuah Yeow Chiang for more information if necessary.

To post a message you must log in.