Feedback on the Lenovo ThinkPad Edge E555 - GordonAMD

Asked by Elie Michel

I have many weird networking issues. At the beginning, everything worked like a charme, but something like 3h after installing Ubuntu, the wireless has been disconnected and could not reconnect any more (loading, but failing, then loading again). So I started using the ethernet connector, which worked. After rebooting, the wireless was here again. But not for long. Two days after, I could not manage to use the ethernet any more. I investigated a bit, and found that for both the wired and wireless connections, the problem came from DHCP, that timed out. I though it was a software issue and installed Fedora 21, but the same problem was there too. I also tried to reinstall the drivers from Realtek website.

Currently, I can definitely not use the ethernet, and am forced to rmmod and modprobe again my wireless driver every 5-10min! (restarting network-manager was not enough, neither ifconfig down and up or anything else I could try). Anoying...

PS: Also, the certification page for the ethernet card does not work:

Question information

English Edit question
Ubuntu-Certification Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Ara Pulido (ara) said :

Thanks for your comments and for reporting the error in our website.

This model is currently certified only for the pre-install version of Ubuntu. You can read about the pre-install version of Ubuntu and its differences at:

I would recommend you to try with Ubuntu 15.04, to see if it makes things better.

Revision history for this message
Elie Michel (elie-michel-fr) said :

Thanks for your prompt answer!

So, if this modified version of Ubuntu exists, were could I get it? Or at least the missing drivers, if that is the cause of the issue?

Revision history for this message
Launchpad Janitor (janitor) said :

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Revision history for this message
Po-Hsu Lin (cypressyew) said :

to your last question, only the manufacturer could provide the modified image, please refer to this FAQ: Where can I find a Pre-install/Manufacturer image

For reporting a non-working device, please refer to this FAQ: XXXX is broken, I need to file a bug

Can you help with this problem?

Provide an answer of your own, or ask Elie Michel for more information if necessary.

To post a message you must log in.