Running Terminator on Windows 10 bash

Asked by Andrew on 2016-05-02

Hi. I've been using Terminator for a long time in Linux. Now that Windows has its Linux/bash subsystem, I'd like to also have it available there. I understand that's a whole different matter, and there may be no interest in supporting or troubleshooting. If so, no worries, but I figured I'd let smarter people than I take a stab at it. I'll explain what I've done so far, then where things stand.

I have installed xming as an X11 server. It does work-- little things like xeyes, etc work well. I also have gtk, and can run programs that depend on it, such as gnome-calculator. I have installed terminator via apt-get. It was a massive installation, with loads of dependencies, and appeared to install correctly. I created a config file in ~/.config/terminator/config:

[global_config]
[keybindings]
[profiles]
  [[default]]
    scrollback_lines = 50000
    font = Monospace 8
    use_system_font = False
    background_image = None
[layouts]
  [[default]]
    [[[child1]]]
      type = Terminal
      parent = window0
    [[[window0]]]
      type = Window
      parent = ""
[plugins]

After all of that, I tried starting it by running /usr/bin/terminator. No luck... The output of the attempt appears at the end of this post. Sorry for not putting it inline, but it's pretty verbose.

Any suggestions on how I might get this working? I know that running this under Windows Ubuntu/Bash is pretty bleeding-edge. But, I'd truly love to have this running. Terminator has been good to me on Linux, and I'd like to also have it in Windows. Many thanks in advance.

#### Run attempt output:

# /usr/bin/terminator
/usr/share/terminator/terminatorlib/terminator.py:92: Warning: Attempt to add property GnomeProgram::sm-connect after class was initialised
  self.gnome_program = gnome.init(APP_NAME, APP_VERSION)
/usr/share/terminator/terminatorlib/terminator.py:92: Warning: Attempt to add property GnomeProgram::show-crash-dialog after class was initialised
  self.gnome_program = gnome.init(APP_NAME, APP_VERSION)
/usr/share/terminator/terminatorlib/terminator.py:92: Warning: Attempt to add property GnomeProgram::display after class was initialised
  self.gnome_program = gnome.init(APP_NAME, APP_VERSION)
/usr/share/terminator/terminatorlib/terminator.py:92: Warning: Attempt to add property GnomeProgram::default-icon after class was initialised
  self.gnome_program = gnome.init(APP_NAME, APP_VERSION)
process 11585: D-Bus library appears to be incorrectly set up; failed to read machine uuid: Failed to open "/etc/machine-id": No such file or directory
See the manual page for dbus-uuidgen to correct this issue.

(terminator:11585): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
process 11585: D-Bus library appears to be incorrectly set up; failed to read machine uuid: Failed to open "/etc/machine-id": No such file or directory
See the manual page for dbus-uuidgen to correct this issue.

(terminator:11585): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
process 11585: D-Bus library appears to be incorrectly set up; failed to read machine uuid: Failed to open "/etc/machine-id": No such file or directory
See the manual page for dbus-uuidgen to correct this issue.

(terminator:11585): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
process 11585: D-Bus library appears to be incorrectly set up; failed to read machine uuid: Failed to open "/etc/machine-id": No such file or directory
See the manual page for dbus-uuidgen to correct this issue.

(terminator:11585): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
process 11585: D-Bus library appears to be incorrectly set up; failed to read machine uuid: Failed to open "/etc/machine-id": No such file or directory
See the manual page for dbus-uuidgen to correct this issue.

(terminator:11585): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
PluginRegistry::load_plugins: Importing plugin __init__.py failed: 'module' object has no attribute 'AVAILABLE'
process 11585: D-Bus library appears to be incorrectly set up; failed to read machine uuid: Failed to open "/etc/machine-id": No such file or directory
See the manual page for dbus-uuidgen to correct this issue.

(terminator:11585): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Traceback (most recent call last):
  File "/usr/bin/terminator", line 118, in <module>
    TERMINATOR.create_layout(OPTIONS.layout)
  File "/usr/share/terminator/terminatorlib/terminator.py", line 265, in create_layout
    window, terminal = self.new_window()
  File "/usr/share/terminator/terminatorlib/terminator.py", line 192, in new_window
    terminal = maker.make('Terminal')
  File "/usr/share/terminator/terminatorlib/factory.py", line 94, in make
    output = func(**kwargs)
  File "/usr/share/terminator/terminatorlib/factory.py", line 106, in make_terminal
    return(terminal.Terminal())
  File "/usr/share/terminator/terminatorlib/terminal.py", line 178, in __init__
    self.reconfigure()
  File "/usr/share/terminator/terminatorlib/terminal.py", line 782, in reconfigure
    self.titlebar.update()
  File "/usr/share/terminator/terminatorlib/titlebar.py", line 113, in update
    title_font = pango.FontDescription(self.config.get_system_prop_font())
  File "/usr/share/terminator/terminatorlib/config.py", line 371, in get_system_prop_font
    '/desktop/gnome/interface/font_name')
glib.GError: No D-BUS daemon running

Question information

Language:
English Edit question
Status:
Answered
For:
Terminator Edit question
Assignee:
No assignee Edit question
Last query:
2016-05-02
Last reply:
2017-06-08

That's a fascinating experiment. I see two issues in your output.

1) There is no DBus server, and disabling the DBus functionality in Terminator might fix the whole thing... although this might be a red-herring. You can disable the DBus stuff by using the "-u" option when starting Terminator. (Alternatively, figure out how to run a DBus server, but I don't think I can provide suggestions for that.)

2) Another potential problem is that you are not running a real full GTK desktop session, and as a result a lot of the gconf settings never get set. There was a similar bug (LP#1476072) where a KDE user couldn't start Terminator at one point. A fix for that was committed before the 0.98 release (http://bazaar.launchpad.net/~gnome-terminator/terminator/trunk/revision/1584). As I recall the Ubuntu on Windows is currently using 14.04 userspace, and if you installed Terminator from the repos you would get 0.97 release. So you could also try out either 0.98 or a checkout of the current trunk.

Please let us know if you get this working. It's just freaky!

Ugh. Answers didn't expand the bug: https://bugs.launchpad.net/terminator/+bug/1476072

Hello,

I just ran it without issues. Installed bash on Windows 14393. Installed Xming and apt-get terminator that's it. I didn't create a config file and it just works

Regards

Actually I had the same problem here to run terminator (and other GUI programs for Linux) into Bash on Windows, and found a solution in Reddit:

https://www.reddit.com/r/Windows10/comments/4rsmzp/bash_on_windows_getting_dbus_and_x_server_working/

You just need to download Xming (like Carlos said) or any other X Server for Windows, and run the commands described in Reddit Link into your bash window to configure the default DISPLAY and D-Bus settings. After that everything should work fine.

Hello,

I began experiencing your issue after upgrading from 0.97 to 0.98 and the mentioned reddit fixed the error. Just type:

sudo sed -i 's$<listen>.*</listen>$<listen>tcp:host=localhost,port=0</listen>$' /etc/dbus-1/session.conf

And restart bash.

That's all

I have experienced better results with vcxsrv because with Xming maximize doesn't work also I have to adjust manually the DPI. With vcxsrv it doesn't happen.

Regards

rcoe67 (rcoe) said : #6

Tried the recommended d-bus config but am getting this (trying both xming and vcxsrv):

root@SKELETOR:~# terminator
ConfigBase::load: Unable to open /root/.config/terminator/config ([Errno 2] No such file or directory: '/root/.config/terminator/config')

(terminator:46): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
/usr/bin/dbus-launch terminated abnormally with the following error: EOF in dbus-launch reading address from bus daemon

(terminator:46): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
/usr/bin/dbus-launch terminated abnormally with the following error: EOF in dbus-launch reading address from bus daemon

(terminator:46): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
/usr/bin/dbus-launch terminated abnormally with the following error: EOF in dbus-launch reading address from bus daemon

(terminator:46): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
/usr/bin/dbus-launch terminated abnormally with the following error: EOF in dbus-launch reading address from bus daemon

(terminator:46): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
/usr/bin/dbus-launch terminated abnormally with the following error: EOF in dbus-launch reading address from bus daemon

PluginRegistry::load_plugins: Importing plugin __init__.py failed: 'module' object has no attribute 'AVAILABLE'

(terminator:46): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
/usr/bin/dbus-launch terminated abnormally with the following error: EOF in dbus-launch reading address from bus daemon

(terminator:46): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
/usr/bin/dbus-launch terminated abnormally with the following error: EOF in dbus-launch reading address from bus daemon

Traceback (most recent call last):
  File "/usr/bin/terminator", line 118, in <module>
    TERMINATOR.create_layout(OPTIONS.layout)
  File "/usr/share/terminator/terminatorlib/terminator.py", line 265, in create_layout
    window, terminal = self.new_window()
  File "/usr/share/terminator/terminatorlib/terminator.py", line 192, in new_window
    terminal = maker.make('Terminal')
  File "/usr/share/terminator/terminatorlib/factory.py", line 94, in make
    output = func(**kwargs)
  File "/usr/share/terminator/terminatorlib/factory.py", line 106, in make_terminal
    return(terminal.Terminal())
  File "/usr/share/terminator/terminatorlib/terminal.py", line 178, in __init__
    self.reconfigure()
  File "/usr/share/terminator/terminatorlib/terminal.py", line 782, in reconfigure
    self.titlebar.update()
  File "/usr/share/terminator/terminatorlib/titlebar.py", line 113, in update
    title_font = pango.FontDescription(self.config.get_system_prop_font())
  File "/usr/share/terminator/terminatorlib/config.py", line 371, in get_system_prop_font
    '/desktop/gnome/interface/font_name')
glib.GError: No D-BUS daemon running

Tried restarting bash and also windows.

Running windows build 14986.rs_prerelease.161202-1928

Have you tried running terminator as a regular user?

El 10:14PM Jue Dic 29, 2016, rcoe67 <email address hidden>
escribió:

> Question #293117 on Terminator changed:
> https://answers.launchpad.net/terminator/+question/293117
>
> rcoe67 posted a new comment:
> Tried the recommended d-bus config but am getting this (trying both
> xming and vcxsrv):
>
> root@SKELETOR:~# terminator
> ConfigBase::load: Unable to open /root/.config/terminator/config ([Errno
> 2] No such file or directory: '/root/.config/terminator/config')
>
> (terminator:46): GConf-WARNING **: Client failed to connect to the D-BUS
> daemon:
> /usr/bin/dbus-launch terminated abnormally with the following error: EOF
> in dbus-launch reading address from bus daemon
>
>
> (terminator:46): GConf-WARNING **: Client failed to connect to the D-BUS
> daemon:
> /usr/bin/dbus-launch terminated abnormally with the following error: EOF
> in dbus-launch reading address from bus daemon
>
>
> (terminator:46): GConf-WARNING **: Client failed to connect to the D-BUS
> daemon:
> /usr/bin/dbus-launch terminated abnormally with the following error: EOF
> in dbus-launch reading address from bus daemon
>
>
> (terminator:46): GConf-WARNING **: Client failed to connect to the D-BUS
> daemon:
> /usr/bin/dbus-launch terminated abnormally with the following error: EOF
> in dbus-launch reading address from bus daemon
>
>
> (terminator:46): GConf-WARNING **: Client failed to connect to the D-BUS
> daemon:
> /usr/bin/dbus-launch terminated abnormally with the following error: EOF
> in dbus-launch reading address from bus daemon
>
> PluginRegistry::load_plugins: Importing plugin __init__.py failed:
> 'module' object has no attribute 'AVAILABLE'
>
> (terminator:46): GConf-WARNING **: Client failed to connect to the D-BUS
> daemon:
> /usr/bin/dbus-launch terminated abnormally with the following error: EOF
> in dbus-launch reading address from bus daemon
>
>
> (terminator:46): GConf-WARNING **: Client failed to connect to the D-BUS
> daemon:
> /usr/bin/dbus-launch terminated abnormally with the following error: EOF
> in dbus-launch reading address from bus daemon
>
> Traceback (most recent call last):
> File "/usr/bin/terminator", line 118, in <module>
> TERMINATOR.create_layout(OPTIONS.layout)
> File "/usr/share/terminator/terminatorlib/terminator.py", line 265, in
> create_layout
> window, terminal = self.new_window()
> File "/usr/share/terminator/terminatorlib/terminator.py", line 192, in
> new_window
> terminal = maker.make('Terminal')
> File "/usr/share/terminator/terminatorlib/factory.py", line 94, in make
> output = func(**kwargs)
> File "/usr/share/terminator/terminatorlib/factory.py", line 106, in
> make_terminal
> return(terminal.Terminal())
> File "/usr/share/terminator/terminatorlib/terminal.py", line 178, in
> __init__
> self.reconfigure()
> File "/usr/share/terminator/terminatorlib/terminal.py", line 782, in
> reconfigure
> self.titlebar.update()
> File "/usr/share/terminator/terminatorlib/titlebar.py", line 113, in
> update
> title_font = pango.FontDescription(self.config.get_system_prop_font())
> File "/usr/share/terminator/terminatorlib/config.py", line 371, in
> get_system_prop_font
> '/desktop/gnome/interface/font_name')
> glib.GError: No D-BUS daemon running
>
> Tried restarting bash and also windows.
>
> Running windows build 14986.rs_prerelease.161202-1928
>
> --
> You received this question notification because you are subscribed to
> the question.
>

rcoe67 (rcoe) said : #8

Windows runs bash as root, for some reason. So, I created a regular user account and tried to run terminator from that shell, same result.

Marcos Carvalho (carvmarc) said : #9

Downgrade to 0.97 and it works

Inigo Flores (flowix) said : #10

I recently upgraded to Windows 10 Creators Update, and then upgraded the Ubuntu subsystem to 16.04. Terminator stopped working once again.

Terminator still refused to start after running:

    sudo sed -i 's$<listen>.*</listen>$<listen>tcp:host=localhost,port=0</listen>$' /etc/dbus-1/session.conf

I managed to fix it by commenting out the following line in /etc/dbus-1/session.conf:

  <auth>EXTERNAL</auth>

Which should now be:

  <!--auth>EXTERNAL</auth-->

This edit is suggested in the comments within the same /etc/dbus-1/session.conf file.

Noelle (nmvega) said : #11

Both parts of @Inigo Flores' solution worked for me. The only minor modification I made to it was this:

<!-- <auth>EXTERNAL</auth> -->

Can you help with this problem?

Provide an answer of your own, or ask Andrew for more information if necessary.

To post a message you must log in.