Keybinding. Is it possible to prevent multipe instances?

Asked by Kenny Schiff on 2010-07-09

I have mapped <super> + o to do a selection. This works properly and when I'm complete, Shutter sits properly in my Ubuntu 10.04 notification area. If I trigger <super> + o again, another instance of Shutter is launched. Is there a method that can be used for use a keyboard combo that would work properly when a running instance of Shutter exists? or is it possible to prevent shutter from running another instance?

Question information

Language:
English Edit question
Status:
Answered
For:
Shutter Edit question
Assignee:
No assignee Edit question
Last query:
2010-07-09
Last reply:
2010-07-25

Sounds like a bug. I've configured Shutter this way (using Ubuntu 10.04
as well) and everything works fine.

What version of Shutter are you using? Did you configure the keybindings
in the preferences or did you follow an alternative approach, e.g.
creating a new GNOME hotkey? What winndow manager are you using? Compiz,
metacity?

Regards
Mario

Kenny Schiff (kschiff) said : #2

1-I'm using Shutter v0.86.2 Rev.847
2-Since it's confusing which is the master keybinding wise, I've configured
different bindings in different places. I have <super>o configured in the
Shutter preferences, and completely different ones configured in the Ubuntu
keyboard shortcuts applet
3-Am using Compiz

After doing some experimentation I discovered that CompizSettingsManager
wins settings wise. If one launches from here, and has no other conflicting
bindings, only one instance of Shutter is alive at a time. So for now, my
issue is solved.

That said, the keybindings thing is confusing.

[image: CompizConfig Settings Manager_006.png]

On Fri, Jul 9, 2010 at 1:21 AM, Mario Kemper (Romario) <
<email address hidden>> wrote:

> Your question #117081 on Shutter changed:
> https://answers.launchpad.net/shutter/+question/117081
>
> Status: Open => Answered
>
> Mario Kemper (Romario) proposed the following answer:
> Sounds like a bug. I've configured Shutter this way (using Ubuntu 10.04
> as well) and everything works fine.
>
> What version of Shutter are you using? Did you configure the keybindings
> in the preferences or did you follow an alternative approach, e.g.
> creating a new GNOME hotkey? What winndow manager are you using? Compiz,
> metacity?
>
> Regards
> Mario
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/shutter/+question/117081/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/shutter/+question/117081
>
> You received this question notification because you are a direct
> subscriber of the question.
>

...this is actually my first contribution to the "community" since i was just recently converted to linux.
This shutter seems to be a decent gun to shoot at your screen, but I have the same problem.

I worked around this multiple instance issue by starting shutter and using it's own hotkeys.

But there's another issue: it seems to be a bit laggy. Although already running (and the timeout set to 0) it takes a few seconds to grab the screen(s). But that could be related to my high number of screens and the resolution. (3200x1200+1200x1024) on different cards)

Regards,
Alex.

Vadim Peretokin (vperetokin) said : #4

That's probably the case, I believe thumbnail generation is done
syncronously.

On Jul 22, 2010 9:34 PM, "Alexander Doberauer" <
<email address hidden>> wrote:

Question #117081 on Shutter changed:
https://answers.launchpad.net/shutter/+question/117081

Alexander Doberauer posted a new comment:
...this is actually my first contribution to the "community" since i was
just recently converted to linux.
This shutter seems to be a decent gun to shoot at your screen, but I have
the same problem.

I worked around this multiple instance issue by starting shutter and
using it's own hotkeys.

But there's another issue: it seems to be a bit laggy. Although already
running (and the timeout set to 0) it takes a few seconds to grab the
screen(s). But that could be related to my high number of screens and
the resolution. (3200x1200+1200x1024) on different cards)

Regards,
Alex.

--
You received this question notification because you are an answer
contact for Shutter.

The multiple instances issue will be handled in the upcoming version, see:
https://launchpad.net/shutter/+milestone/0.87

There is a lag because Shutter saves the screenshot directly to disk - this takes some time (especially when working with a geometry like that). I think that this option will solve most of the problem:
https://bugs.launchpad.net/bugs/348161

Can you help with this problem?

Provide an answer of your own, or ask Kenny Schiff for more information if necessary.

To post a message you must log in.