SchoolTool as default page on apache server

Asked by Romano on 2015-07-27

Hi all

Ubuntu Linux 14.04.1
SchoolTool 2.8.4

I managed to re-direct the URL http://schooltool.germansaturdayschool.org.au to the Ubuntu server that runs our SchoolTool.

However it just loads the default Apache page.
I understand that this is correct and that there must be a proxy re-direct on my server.

I tried to follow the instructions...
http://book.schooltool.org/apache.html#apache

... but can not get it to work.

Is it possible to use webmin to get this done?
On the sample code for the virtual host I replaced ever "school.example.org" with "schooltool.germansaturdayschool.org.au"
is this correct?

I rebooted apache and in fact the server x times.
This made no difference.

Can somebody help with this?
Regards Romano

Question information

Language:
English Edit question
Status:
Solved
For:
SchoolTool Edit question
Assignee:
No assignee Edit question
Solved by:
Romano
Solved:
2015-08-17
Last query:
2015-08-17
Last reply:
2015-08-17
Tom Hoffman (tom-hoffman) said : #1

Perhaps you could add apache configuration code in a comment?

Romano (romano-studer) said : #2

I hope this helps

/etc/apache2/sites-available

contains 3 files

000-default.conf
+++++++++++++++

<VirtualHost *:80>
 # The ServerName directive sets the request scheme, hostname and port that
 # the server uses to identify itself. This is used when creating
 # redirection URLs. In the context of virtual hosts, the ServerName
 # specifies what hostname must appear in the request's Host: header to
 # match this virtual host. For the default virtual host (this file) this
 # value is not decisive as it is used as a last resort host regardless.
 # However, you must set it for any further virtual host explicitly.
 #ServerName www.example.com

 ServerAdmin webmaster@localhost
 DocumentRoot /var/www/html

 # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
 # error, crit, alert, emerg.
 # It is also possible to configure the loglevel for particular
 # modules, e.g.
 #LogLevel info ssl:warn

 ErrorLog ${APACHE_LOG_DIR}/error.log
 CustomLog ${APACHE_LOG_DIR}/access.log combined

 # For most configuration files from conf-available/, which are
 # enabled or disabled at a global level, it is possible to
 # include a line for only one particular virtual host. For example the
 # following line enables the CGI configuration for this host only
 # after it has been globally disabled with "a2disconf".
 #Include conf-available/serve-cgi-bin.conf
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

schooltool.germansaturdayschool.org.au.txt
++++++++++++++++++++++++++++++++++++++

<VirtualHost *:80>
  ServerName school1tool.germansaturdayschool.org.au
  <Proxy *>
      order allow,deny
      allow from all
      deny from none
  </Proxy>

  ProxyPreserveHost on
  RewriteEngine On

  RewriteRule ^/schooltool.task_results(/?.*) http://127.0.0.1:7080/schooltool.task_results/$1 [P,L]
  RewriteRule ^(/?.*) http://127.0.0.1:7080/++vh++http:schooltool.germansaturdayschool.org.au:80/++$1 [P,L]

</VirtualHost>

default-ssl.conf
++++++++++++++

<IfModule mod_ssl.c>
 <VirtualHost _default_:443>
  ServerAdmin webmaster@localhost

  DocumentRoot /var/www/html

  # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
  # error, crit, alert, emerg.
  # It is also possible to configure the loglevel for particular
  # modules, e.g.
  #LogLevel info ssl:warn

  ErrorLog ${APACHE_LOG_DIR}/error.log
  CustomLog ${APACHE_LOG_DIR}/access.log combined

  # For most configuration files from conf-available/, which are
  # enabled or disabled at a global level, it is possible to
  # include a line for only one particular virtual host. For example the
  # following line enables the CGI configuration for this host only
  # after it has been globally disabled with "a2disconf".
  #Include conf-available/serve-cgi-bin.conf

  # SSL Engine Switch:
  # Enable/Disable SSL for this virtual host.
  SSLEngine on

  # A self-signed (snakeoil) certificate can be created by installing
  # the ssl-cert package. See
  # /usr/share/doc/apache2/README.Debian.gz for more info.
  # If both key and certificate are stored in the same file, only the
  # SSLCertificateFile directive is needed.
  SSLCertificateFile /etc/ssl/certs/ssl-cert-snakeoil.pem
  SSLCertificateKeyFile /etc/ssl/private/ssl-cert-snakeoil.key

  # Server Certificate Chain:
  # Point SSLCertificateChainFile at a file containing the
  # concatenation of PEM encoded CA certificates which form the
  # certificate chain for the server certificate. Alternatively
  # the referenced file can be the same as SSLCertificateFile
  # when the CA certificates are directly appended to the server
  # certificate for convinience.
  #SSLCertificateChainFile /etc/apache2/ssl.crt/server-ca.crt

  # Certificate Authority (CA):
  # Set the CA certificate verification path where to find CA
  # certificates for client authentication or alternatively one
  # huge file containing all of them (file must be PEM encoded)
  # Note: Inside SSLCACertificatePath you need hash symlinks
  # to point to the certificate files. Use the provided
  # Makefile to update the hash symlinks after changes.
  #SSLCACertificatePath /etc/ssl/certs/
  #SSLCACertificateFile /etc/apache2/ssl.crt/ca-bundle.crt

  # Certificate Revocation Lists (CRL):
  # Set the CA revocation path where to find CA CRLs for client
  # authentication or alternatively one huge file containing all
  # of them (file must be PEM encoded)
  # Note: Inside SSLCARevocationPath you need hash symlinks
  # to point to the certificate files. Use the provided
  # Makefile to update the hash symlinks after changes.
  #SSLCARevocationPath /etc/apache2/ssl.crl/
  #SSLCARevocationFile /etc/apache2/ssl.crl/ca-bundle.crl

  # Client Authentication (Type):
  # Client certificate verification type and depth. Types are
  # none, optional, require and optional_no_ca. Depth is a
  # number which specifies how deeply to verify the certificate
  # issuer chain before deciding the certificate is not valid.
  #SSLVerifyClient require
  #SSLVerifyDepth 10

  # SSL Engine Options:
  # Set various options for the SSL engine.
  # o FakeBasicAuth:
  # Translate the client X.509 into a Basic Authorisation. This means that
  # the standard Auth/DBMAuth methods can be used for access control. The
  # user name is the `one line' version of the client's X.509 certificate.
  # Note that no password is obtained from the user. Every entry in the user
  # file needs this password: `xxj31ZMTZzkVA'.
  # o ExportCertData:
  # This exports two additional environment variables: SSL_CLIENT_CERT and
  # SSL_SERVER_CERT. These contain the PEM-encoded certificates of the
  # server (always existing) and the client (only existing when client
  # authentication is used). This can be used to import the certificates
  # into CGI scripts.
  # o StdEnvVars:
  # This exports the standard SSL/TLS related `SSL_*' environment variables.
  # Per default this exportation is switched off for performance reasons,
  # because the extraction step is an expensive operation and is usually
  # useless for serving static content. So one usually enables the
  # exportation for CGI and SSI requests only.
  # o OptRenegotiate:
  # This enables optimized SSL connection renegotiation handling when SSL
  # directives are used in per-directory context.
  #SSLOptions +FakeBasicAuth +ExportCertData +StrictRequire
  <FilesMatch "\.(cgi|shtml|phtml|php)$">
    SSLOptions +StdEnvVars
  </FilesMatch>
  <Directory /usr/lib/cgi-bin>
    SSLOptions +StdEnvVars
  </Directory>

  # SSL Protocol Adjustments:
  # The safe and default but still SSL/TLS standard compliant shutdown
  # approach is that mod_ssl sends the close notify alert but doesn't wait for
  # the close notify alert from client. When you need a different shutdown
  # approach you can use one of the following variables:
  # o ssl-unclean-shutdown:
  # This forces an unclean shutdown when the connection is closed, i.e. no
  # SSL close notify alert is send or allowed to received. This violates
  # the SSL/TLS standard but is needed for some brain-dead browsers. Use
  # this when you receive I/O errors because of the standard approach where
  # mod_ssl sends the close notify alert.
  # o ssl-accurate-shutdown:
  # This forces an accurate shutdown when the connection is closed, i.e. a
  # SSL close notify alert is send and mod_ssl waits for the close notify
  # alert of the client. This is 100% SSL/TLS standard compliant, but in
  # practice often causes hanging connections with brain-dead browsers. Use
  # this only for browsers where you know that their SSL implementation
  # works correctly.
  # Notice: Most problems of broken clients are also related to the HTTP
  # keep-alive facility, so you usually additionally want to disable
  # keep-alive for those clients, too. Use variable "nokeepalive" for this.
  # Similarly, one has to force some clients to use HTTP/1.0 to workaround
  # their broken HTTP/1.1 implementation. Use variables "downgrade-1.0" and
  # "force-response-1.0" for this.
  BrowserMatch "MSIE [2-6]" \
    nokeepalive ssl-unclean-shutdown \
    downgrade-1.0 force-response-1.0
  # MSIE 7 and newer should be able to use keepalive
  BrowserMatch "MSIE [17-9]" ssl-unclean-shutdown

 </VirtualHost>
</IfModule>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

Douglas Cerna (replaceafill) said : #3

What files (symlinks) are listed in your /etc/apache2/sites-enabled directory?

You probably just need to disable the default configuration file (sudo a2dissite 000-default.conf)

Romano (romano-studer) said : #4

Thank you very much for your help!

What files (symlinks) are listed in your /etc/apache2/sites-enabled directory?
Only one file:
000-default.conf

sudo a2dissite 000-default.conf <----- this is a command correct?

I am using the Ubuntu server only via the Webmin interface.
I had a look around for something like Terminal on the Mac... no go.
There is a SSH Login but that is Java driven and it is blocked for some security reason.

Do I need to delete the 000-default.conf in the sites-available directory?

Regards
Romano

Douglas Cerna (replaceafill) said : #5

Ok. Having just that file in /etc/apache2/sites-enabled is the reason why you see the default Apache page. You need to disable that and enable the schooltool.germansaturdayschool.org.au.txt config file. And yes "sudo a2dissite 000-default.conf" is a command to disable an Apache site.

I have no experience with Webmin, but you can probably find how to enable/disable sites (or virtualhosts) in its documentation.

Romano (romano-studer) said : #6

http://book.schooltool.org/apache.html#apache

I finally was able to run the commands as in above.

Now I got rid of the default apache page when loading the default page.
Instead I get "Service Unavailable. (http://203.143.84.237)

I can still go to SchoolTool via the explicit http://203.143.84.237:7080.

Can anybody give me some more hints...

Regards
Romano

Douglas Cerna (replaceafill) said : #7

Assuming you only have your SchoolTool virtualhost enabled, what's in your /var/log/apache2/error.log file?

Romano (romano-studer) said : #8

Hi Douglas
Thank you for your response.
Here is a dump...

Regards
Romano

[Sun Aug 02 06:45:19.084799 2015] [mpm_prefork:notice] [pid 1326] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.11 configured -- resuming normal operations
[Sun Aug 02 06:45:19.084835 2015] [core:notice] [pid 1326] AH00094: Command line: '/usr/sbin/apache2'
[Thu Aug 06 12:44:09.522035 2015] [mpm_prefork:notice] [pid 1326] AH00169: caught SIGTERM, shutting down
[Thu Aug 06 12:44:10.638042 2015] [mpm_prefork:notice] [pid 26896] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.11 configured -- resuming normal operations
[Thu Aug 06 12:44:10.638120 2015] [core:notice] [pid 26896] AH00094: Command line: '/usr/sbin/apache2'
[Thu Aug 06 12:48:14.117119 2015] [mpm_prefork:notice] [pid 26896] AH00169: caught SIGTERM, shutting down
[Thu Aug 06 12:48:53.762423 2015] [mpm_prefork:notice] [pid 1365] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.11 configured -- resuming normal operations
[Thu Aug 06 12:48:53.763964 2015] [core:notice] [pid 1365] AH00094: Command line: '/usr/sbin/apache2'
[Thu Aug 06 13:03:28.890763 2015] [mpm_prefork:notice] [pid 1365] AH00169: caught SIGTERM, shutting down
[Thu Aug 06 13:04:04.333610 2015] [mpm_prefork:notice] [pid 1355] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.11 configured -- resuming normal operations
[Thu Aug 06 13:04:04.335112 2015] [core:notice] [pid 1355] AH00094: Command line: '/usr/sbin/apache2'
[Thu Aug 06 13:12:19.512978 2015] [mpm_prefork:notice] [pid 1355] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using vps.portal-gss-melbourne.com. Set the 'ServerName' directive globally to suppress this message
[Thu Aug 06 13:12:19.943425 2015] [mpm_prefork:notice] [pid 1355] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.11 configured -- resuming normal operations
[Thu Aug 06 13:12:19.943447 2015] [core:notice] [pid 1355] AH00094: Command line: '/usr/sbin/apache2'
[Thu Aug 06 13:16:52.195289 2015] [mpm_prefork:notice] [pid 1355] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using vps.portal-gss-melbourne.com. Set the 'ServerName' directive globally to suppress this message
[Thu Aug 06 13:16:52.356468 2015] [mpm_prefork:notice] [pid 1355] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.11 configured -- resuming normal operations
[Thu Aug 06 13:16:52.356491 2015] [core:notice] [pid 1355] AH00094: Command line: '/usr/sbin/apache2'
[Thu Aug 06 13:19:24.999631 2015] [mpm_prefork:notice] [pid 1355] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using vps.portal-gss-melbourne.com. Set the 'ServerName' directive globally to suppress this message
[Thu Aug 06 13:19:25.161600 2015] [mpm_prefork:notice] [pid 1355] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.11 configured -- resuming normal operations
[Thu Aug 06 13:19:25.161635 2015] [core:notice] [pid 1355] AH00094: Command line: '/usr/sbin/apache2'
[Thu Aug 06 13:19:32.242180 2015] [proxy:error] [pid 1889] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:19:32.242260 2015] [proxy_http:error] [pid 1889] [client 118.82.32.238:57122] AH01114: HTTP: failed to make connection to backend: 127.0.0.1
[Thu Aug 06 13:19:33.410305 2015] [proxy:error] [pid 1888] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:19:33.410383 2015] [proxy_http:error] [pid 1888] [client 118.82.32.238:17044] AH01114: HTTP: failed to make connection to backend: 127.0.0.1
[Thu Aug 06 13:19:34.829210 2015] [proxy:error] [pid 1890] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:19:34.829271 2015] [proxy_http:error] [pid 1890] [client 118.82.32.238:41901] AH01114: HTTP: failed to make connection to backend: 127.0.0.1
[Thu Aug 06 13:19:36.123117 2015] [proxy:error] [pid 1891] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:19:36.123208 2015] [proxy_http:error] [pid 1891] [client 118.82.32.238:3797] AH01114: HTTP: failed to make connection to backend: 127.0.0.1
[Thu Aug 06 13:19:38.525896 2015] [proxy:error] [pid 1887] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:19:38.525977 2015] [proxy_http:error] [pid 1887] [client 118.82.32.238:29790] AH01114: HTTP: failed to make connection to backend: 127.0.0.1
[Thu Aug 06 13:19:40.196387 2015] [proxy:error] [pid 1892] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:19:40.196468 2015] [proxy_http:error] [pid 1892] [client 118.82.32.238:61444] AH01114: HTTP: failed to make connection to backend: 127.0.0.1
[Thu Aug 06 13:19:46.259377 2015] [proxy:error] [pid 1889] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:19:46.259417 2015] [proxy_http:error] [pid 1889] [client 118.82.32.238:3819] AH01114: HTTP: failed to make connection to backend: 127.0.0.1
[Thu Aug 06 13:20:05.606488 2015] [mpm_prefork:notice] [pid 1355] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using vps.portal-gss-melbourne.com. Set the 'ServerName' directive globally to suppress this message
[Thu Aug 06 13:20:05.720661 2015] [mpm_prefork:notice] [pid 1355] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.11 configured -- resuming normal operations
[Thu Aug 06 13:20:05.720690 2015] [core:notice] [pid 1355] AH00094: Command line: '/usr/sbin/apache2'
[Thu Aug 06 13:20:14.283000 2015] [proxy:error] [pid 1933] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:20:14.283074 2015] [proxy_http:error] [pid 1933] [client 118.82.32.238:3761] AH01114: HTTP: failed to make connection to backend: 127.0.0.1
[Thu Aug 06 13:20:16.116679 2015] [proxy:error] [pid 1935] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:20:16.116740 2015] [proxy_http:error] [pid 1935] [client 118.82.32.238:29637] AH01114: HTTP: failed to make connection to backend: 127.0.0.1
[Thu Aug 06 13:20:17.547729 2015] [proxy:error] [pid 1934] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:20:17.547791 2015] [proxy_http:error] [pid 1934] [client 118.82.32.238:33196] AH01114: HTTP: failed to make connection to backend: 127.0.0.1
[Thu Aug 06 13:43:03.896436 2015] [mpm_prefork:notice] [pid 1355] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using vps.portal-gss-melbourne.com. Set the 'ServerName' directive globally to suppress this message
[Thu Aug 06 13:43:04.133088 2015] [mpm_prefork:notice] [pid 1355] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.11 configured -- resuming normal operations
[Thu Aug 06 13:43:04.133121 2015] [core:notice] [pid 1355] AH00094: Command line: '/usr/sbin/apache2'
[Thu Aug 06 13:43:43.554081 2015] [proxy:error] [pid 2299] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:43:43.554167 2015] [proxy_http:error] [pid 2299] [client 118.82.32.238:17580] AH01114: HTTP: failed to make connection to backend: 127.0.0.1, referer: http://203.143.84.237/
[Thu Aug 06 13:43:48.663705 2015] [proxy:error] [pid 2298] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:43:48.663767 2015] [proxy_http:error] [pid 2298] [client 118.82.32.238:59791] AH01114: HTTP: failed to make connection to backend: 127.0.0.1
[Thu Aug 06 13:43:48.708379 2015] [proxy:error] [pid 2300] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:43:48.708452 2015] [proxy_http:error] [pid 2300] [client 118.82.32.238:13641] AH01114: HTTP: failed to make connection to backend: 127.0.0.1, referer: http://203.143.84.237/
[Thu Aug 06 13:43:51.419453 2015] [proxy:error] [pid 2297] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:43:51.419528 2015] [proxy_http:error] [pid 2297] [client 118.82.32.238:3884] AH01114: HTTP: failed to make connection to backend: 127.0.0.1
[Thu Aug 06 13:43:51.449871 2015] [proxy:error] [pid 2301] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:43:51.449931 2015] [proxy_http:error] [pid 2301] [client 118.82.32.238:3892] AH01114: HTTP: failed to make connection to backend: 127.0.0.1, referer: http://203.143.84.237/
[Thu Aug 06 13:44:06.464817 2015] [proxy:error] [pid 2298] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:44:06.464865 2015] [proxy_http:error] [pid 2298] [client 118.82.32.238:45903] AH01114: HTTP: failed to make connection to backend: 127.0.0.1
[Thu Aug 06 13:44:06.502573 2015] [proxy:error] [pid 2300] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:44:06.502620 2015] [proxy_http:error] [pid 2300] [client 118.82.32.238:20993] AH01114: HTTP: failed to make connection to backend: 127.0.0.1, referer: http://203.143.84.237/
[Thu Aug 06 13:45:30.120122 2015] [proxy:error] [pid 2301] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:45:30.120179 2015] [proxy_http:error] [pid 2301] [client 118.82.32.238:52856] AH01114: HTTP: failed to make connection to backend: 127.0.0.1
[Thu Aug 06 13:45:30.144052 2015] [proxy:error] [pid 2299] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:45:30.144106 2015] [proxy_http:error] [pid 2299] [client 118.82.32.238:23626] AH01114: HTTP: failed to make connection to backend: 127.0.0.1, referer: http://203.143.84.237/
[Thu Aug 06 13:45:34.156674 2015] [proxy:error] [pid 2298] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:45:34.156723 2015] [proxy_http:error] [pid 2298] [client 118.82.32.238:3905] AH01114: HTTP: failed to make connection to backend: 127.0.0.1
[Thu Aug 06 13:45:34.203807 2015] [proxy:error] [pid 2300] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:45:34.203847 2015] [proxy_http:error] [pid 2300] [client 118.82.32.238:3918] AH01114: HTTP: failed to make connection to backend: 127.0.0.1, referer: http://203.143.84.237/
[Thu Aug 06 13:45:36.325469 2015] [proxy:error] [pid 2297] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:45:36.325511 2015] [proxy_http:error] [pid 2297] [client 118.82.32.238:28902] AH01114: HTTP: failed to make connection to backend: 127.0.0.1
[Thu Aug 06 13:45:36.373891 2015] [proxy:error] [pid 2301] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:45:36.373942 2015] [proxy_http:error] [pid 2301] [client 118.82.32.238:37724] AH01114: HTTP: failed to make connection to backend: 127.0.0.1, referer: http://203.143.84.237/
[Thu Aug 06 13:46:07.472686 2015] [proxy:error] [pid 2298] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:46:07.472729 2015] [proxy_http:error] [pid 2298] [client 118.82.32.238:10682] AH01114: HTTP: failed to make connection to backend: 127.0.0.1
[Thu Aug 06 13:46:07.506619 2015] [proxy:error] [pid 2300] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:46:07.506666 2015] [proxy_http:error] [pid 2300] [client 118.82.32.238:3973] AH01114: HTTP: failed to make connection to backend: 127.0.0.1, referer: http://203.143.84.237/
[Thu Aug 06 13:46:29.985580 2015] [proxy:error] [pid 2301] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:46:29.985636 2015] [proxy_http:error] [pid 2301] [client 118.82.32.238:34126] AH01114: HTTP: failed to make connection to backend: 127.0.0.1
[Thu Aug 06 13:46:30.477078 2015] [proxy:error] [pid 2299] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:46:30.477124 2015] [proxy_http:error] [pid 2299] [client 118.82.32.238:8251] AH01114: HTTP: failed to make connection to backend: 127.0.0.1
[Thu Aug 06 13:50:50.593970 2015] [proxy:error] [pid 2297] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:50:50.594067 2015] [proxy_http:error] [pid 2297] [client 118.82.32.238:38035] AH01114: HTTP: failed to make connection to backend: 127.0.0.1
[Thu Aug 06 13:53:55.054992 2015] [proxy:error] [pid 2358] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:53:55.055063 2015] [proxy_http:error] [pid 2358] [client 118.82.32.238:46633] AH01114: HTTP: failed to make connection to backend: 127.0.0.1
[Thu Aug 06 13:53:55.097005 2015] [proxy:error] [pid 2301] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 13:53:55.097046 2015] [proxy_http:error] [pid 2301] [client 118.82.32.238:39092] AH01114: HTTP: failed to make connection to backend: 127.0.0.1, referer: http://schooltool.germansaturdayschool.org.au/
[Thu Aug 06 15:30:37.565139 2015] [proxy:error] [pid 2299] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 15:30:37.565195 2015] [proxy_http:error] [pid 2299] [client 190.53.152.168:16511] AH01114: HTTP: failed to make connection to backend: 127.0.0.1
[Thu Aug 06 15:30:37.950028 2015] [proxy:error] [pid 2298] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 15:30:37.950078 2015] [proxy_http:error] [pid 2298] [client 190.53.152.168:16512] AH01114: HTTP: failed to make connection to backend: 127.0.0.1
[Thu Aug 06 15:30:38.290847 2015] [proxy:error] [pid 2300] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 15:30:38.290897 2015] [proxy_http:error] [pid 2300] [client 190.53.152.168:16514] AH01114: HTTP: failed to make connection to backend: 127.0.0.1
[Thu Aug 06 21:15:21.766285 2015] [proxy:error] [pid 2358] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Thu Aug 06 21:15:21.772024 2015] [proxy_http:error] [pid 2358] [client 114.76.98.65:51160] AH01114: HTTP: failed to make connection to backend: 127.0.0.1
[Fri Aug 07 06:39:24.665858 2015] [mpm_prefork:notice] [pid 1355] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using vps.portal-gss-melbourne.com. Set the 'ServerName' directive globally to suppress this message
[Fri Aug 07 06:39:24.878841 2015] [mpm_prefork:notice] [pid 1355] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.11 configured -- resuming normal operations
[Fri Aug 07 06:39:24.878859 2015] [core:notice] [pid 1355] AH00094: Command line: '/usr/sbin/apache2'
[Fri Aug 07 10:29:49.866669 2015] [proxy:error] [pid 9670] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Fri Aug 07 10:29:49.866745 2015] [proxy_http:error] [pid 9670] [client 54.153.1.168:50382] AH01114: HTTP: failed to make connection to backend: 127.0.0.1
[Fri Aug 07 10:37:50.495153 2015] [mpm_prefork:notice] [pid 1355] AH00171: Graceful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using vps.portal-gss-melbourne.com. Set the 'ServerName' directive globally to suppress this message
[Fri Aug 07 10:37:50.592063 2015] [mpm_prefork:notice] [pid 1355] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.11 configured -- resuming normal operations
[Fri Aug 07 10:37:50.592085 2015] [core:notice] [pid 1355] AH00094: Command line: '/usr/sbin/apache2'

Romano (romano-studer) said : #9

Hi all
I am still trying to get the school tool to run as the default page on my apache server...
I just went through the process of defining the default server as in instructions.
but I am still no wiser...
Can anybody help?

Douglas Cerna (replaceafill) said : #10

Hi Romano.

Sorry for the delay in reviewing your log. Were you able to fix the issue?

From these lines in your error log:

Fri Aug 07 10:29:49.866669 2015] [proxy:error] [pid 9670] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:7080 (*) failed
[Fri Aug 07 10:29:49.866745 2015] [proxy_http:error] [pid 9670] [client 54.153.1.168:50382] AH01114: HTTP: failed to make connection to backend: 127.0.0.1

it seems like SchoolTool was not started.

jerome jones (blessedchild44) said : #11

Is it that ur calling a public ip address on the same lan because they both
load when I click the links
On 6 Aug 2015 00:41, "Douglas Cerna" <email address hidden>
wrote:

> Question #269687 on SchoolTool changed:
> https://answers.launchpad.net/schooltool/+question/269687
>
> Status: Open => Needs information
>
> Douglas Cerna requested more information:
> Assuming you only have your SchoolTool virtualhost enabled, what's in
> your /var/log/apache2/error.log file?
>
> --
> You received this question notification because you are an answer
> contact for SchoolTool.
>

Romano (romano-studer) said : #12

Had to play around with this...
fixed it with this:

<VirtualHost *:80>
  ServerName 203.143.84.237

  <Proxy *>
      order allow,deny
      allow from all
      deny from none
  </Proxy>

  ProxyPreserveHost on
  RewriteEngine On

  RewriteRule ^/schooltool.task_results(/?.*) http://203.143.84.237:7080/schooltool.task_results/$1 [P,L]
  RewriteRule ^(/?.*) http://203.143.84.237:7080/++vh++http:203.143.84.237:80/++$1 [P,L]

</VirtualHost>