How to upgrade a Ubuntu appliance from SchoolTool 1.7 to 2.0

Asked by Robin Dexter on 2012-01-28

Hi

I am reviewing SchoolTool on a prebuilt Ubuntu VMWare appliance (Ubuntu 11.10 VMware image with Tools) from http://www.trendsigma.net .
I have followed the instructions on the schooltool.org website in terms of entering the string

ppa:schooltool-owners/dev in the Ubuntu Software Center¶

It seems to install OK, but when it comes up it shows:

Server Running SchoolTool 1.7 (development)

Is there a way of updating the image so it is running SchoolTool 2.0?

I am not a Ubuntu expert so may be missing something elementary

Thanks

Robin

Question information

Language:
English Edit question
Status:
Solved
For:
SchoolTool Edit question
Assignee:
No assignee Edit question
Solved by:
Tom Hoffman
Solved:
2012-01-29
Last query:
2012-01-29
Last reply:
2012-01-29
Best Tom Hoffman (tom-hoffman) said : #1

I'm not entirely clear on what triggers the update after you add the
ppa (because the Software Center is kind of opaque).

So try opening a terminal and doing:
'sudo apt-get update'
'sudo apt-get dist-upgrade'

--Tom

On Sat, Jan 28, 2012 at 7:01 AM, Robin Dexter
<email address hidden> wrote:
> New question #186094 on SchoolTool:
> https://answers.launchpad.net/schooltool/+question/186094
>
> Hi
>
> I am reviewing SchoolTool on a prebuilt Ubuntu VMWare appliance (Ubuntu 11.10 VMware image with Tools) from http://www.trendsigma.net .
> I have followed the instructions on the schooltool.org website in terms of entering the string
>
> ppa:schooltool-owners/dev in the Ubuntu Software Center¶
>
>
> It seems to install OK, but when it comes up it shows:
>
> Server Running SchoolTool 1.7 (development)
>
> Is there a way of updating the image so it is running SchoolTool 2.0?
>
> I am not a Ubuntu expert so may be missing something elementary
>
> Thanks
>
> Robin
>
> --
> You received this question notification because you are a member of
> SchoolTool Owners, which is an answer contact for SchoolTool.

Tom Hoffman (tom-hoffman) said : #2

Let me know if that actually works.

Robin Dexter (robin-dexter) said : #3

Hi Tom

Thanks for your prompt response.
I reinstalled on a fresh Ubuntu image using the shell command line commands
and it worked fine

Cheers

Robin

On 29 January 2012 13:45, Tom Hoffman
<email address hidden>wrote:

> Your question #186094 on SchoolTool changed:
> https://answers.launchpad.net/schooltool/+question/186094
>
> Status: Answered => Needs information
>
> Tom Hoffman changed the question status:
> Let me know if that actually works.
>
> --
> You received this question notification because you asked the question.
>

--
Robin Dexter
Chairman of the Board of Directors
Sophia Mundi Steiner School

Robin Dexter (robin-dexter) said : #4

Thanks Tom Hoffman, that solved my question.