Referencer reports <class 'xml.parsers.expat.ExpatError'> when quering ISI

Asked by Stefan Bucher on 2011-08-24

Hi everyone

I got kind of a large overall problem. Perhaps it is a bug, yet I don't know. Here is what I did:

I installed referencer from the ubuntu software-center (Natty, Unity). Then I linked PDF's to referencer to administrate my library and have an easy and quick access to my literature. A feature I like (according to promised program features) is the automatic retrieval of literature info (journal, pages etc.) - but that does not happen...

When I link the pdf - the only data that are taken out of the pdf is the doi and places the pdf-name as title (as it seems). When I try to retrieve information (even with correct paper title) nothing happens - the information in the referencer remains the same. Even if I give more info like (the correct) year and author, the information are not retrieved from the net. What is the problem here? (I use VPN-connection to my university. Access to ISI is possible when I manually access documents.)

I already tried to purge and reinstall referencer --> no change whatsoever in behaviour.

After that I tried to retreive metadate explicitly from ISI by clicking the respective button in icon bar. The answer was (translated from german):
____________________________
Exception: <class 'xml.parsers.expat.ExpatError'>

Module: isi-plugin
Explanation: no element found: line 1, column 0
_____________________________

The terminal output is:
________________________________________
bool Transfer::waitForFlag(volatile bool&):
 Waiting...
void Transfer::openCB(const Gnome::Vfs::Async::Handle&, Gnome::Vfs::Result):
 result not OK

(referencer:5003): libgnomevfsmm-WARNING **: gnome-vfsmm Async::Handle::cancel(): This method currently leaks memory.
bool Transfer::waitForFlag(volatile bool&):
 waitForFlag completed due to transferfail
PyObject* referencer_download(PyObject*, PyObject*):
 got 0 characters

virtual bool PythonPlugin::doAction(Glib::ustring, std::vector<Document*>):
 PythonPlugin::doAction: NULL return value
__________________________________________

The for curiousity I clicked on the Lyx button. Answer there (translated from german):
__________________________________________
Exception: <type 'exceptions.TypeError'>

Module: lyx
Explanation: exceptions must be old-style classes or derived from BaseException, not str
__________________________________________

Terminal output was:
__________________________________________
virtual bool PythonPlugin::doAction(Glib::ustring, std::vector<Document*>):
 PythonPlugin::doAction: NULL return value
__________________________________________

Oh, and btw I have this bug https://bugs.launchpad.net/referencer/+bug/494684 too. Yet, I don't know how to install the code provided as a patch in that post. I'm just an ordinary user --> I would need some explanation on how to install such a patch.

Thanks in advance for your efforts.
Stefan

Question information

Language:
English Edit question
Status:
Solved
For:
Referencer Edit question
Assignee:
No assignee Edit question
Solved by:
CasperUA
Solved:
2011-10-19
Last query:
2011-10-19
Last reply:
2011-09-28
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Stefan Bucher (buchers) said : #2

anyone an idea?

Stefan Bucher (buchers) said : #3

Hi
Unfortunately, I was not able to find a solution for the problem so far.
Anyone having an idea?

thanks

-------- Weitergeleitete Nachricht --------
Von: Launchpad Janitor <email address hidden>
Reply-to: <email address hidden>
An: <email address hidden>
Betreff: Re: [Question #169030]: Referencer reports <class
'xml.parsers.expat.ExpatError'> when quering ISI
Datum: Sat, 10 Sep 2011 09:12:13 +0000

Your question #169030 on Referencer changed:
https://answers.launchpad.net/referencer/+question/169030

    Status: Open => Expired

Launchpad Janitor expired the question:
This question was expired because it remained in the 'Open' state
without activity for the last 15 days.

John S (jcspray) said : #4

Stefan: do not 'bump' questions. If you're not getting an answer here, try the mailing list.

Best CasperUA (spolet) said : #5

Stefan: Try to install libgnomevfs2-extra

Sergey

Stefan Bucher (buchers) said : #6

Thanks CasperUA, that solved my question.