Version of LimeSurvey

Asked by David Chen on 2014-04-15

Hi,

What version of limesurvey currently using? Am I able to use the latest version V2.05 from Limesurvey.org?

Thanks,
David

Question information

Language:
English Edit question
Status:
Answered
For:
queXS Edit question
Assignee:
No assignee Edit question
Last query:
2014-04-16
Last reply:
2014-04-16
Adam Zammit (adamzammit) said : #1

Dear David,

queXS uses Limesurvey 1.92+ (last 1.92 release), that has been modified and included in queXS.

You can't use Limesurvey 2.05 without modifying queXS. I will eventually upgrade the Limesurvey version in queXS. Is there something in particular you need from version 2.05?

Regards,
Adam Zammit

David Chen (getmyinfo2000) said : #2

Hi Adam,

Thank you for quick reply.

Latest version fixed a lot of bugs compare to version 1.92+. It also has new GUI and new features. In particular, VV import/export improve a lot.

Can you outline what need to be modified in order to use version 2.05? I know some programming. I will give a try if not too difficult.

Thanks,
David

Adam Zammit (adamzammit) said : #3

Hi David,

You would need to replace the 1.92+ version included in queXS with 2.05+, and port the modifications made to 1.92+ to 2.05+.

My way of approaching it would be to look at the changes applied via the queXS BZR repository from around revision 280 and port them across. This may also be useful: http://sourceforge.net/p/quexs/code/568/log/?path=/branches/quexslimesurvey192

It will be a bit fiddly but not too difficult. I would be very happy to assist you as best I can.

Regards,
Adam Zammit

Berri Torre (berritorre) said : #4

It would be really great if Quexs could be update the LS version. There has been so much improvement in Limesurvey since 1.92 that I just couldn't imagine going back.

What was necessary to change in the LS version so that it works for Quexs? Ideally there would be no custom code, so updates of Limesurvey would be much easier. I saw that there are plans to implement a interface to communicate with any survey tool. That should solve the problem of outdated LS versions as well, right?

Adam Zammit (adamzammit) said : #5

When queXS is updated to use LS 2.05/2.06 I plan not to make modifications to the Limesurvey code. I plan to rely on the Limesurvey remote control features instead.

Currently this is on the to-do list but I haven't had the time/funding to proceed with this. At the moment Limesurvey 1.92+ has all the features we require internally. I would be happy to assist with the change to 2.05/2.06 if you want to get a branch started or if funding is available.

Regards,
Adam Zammit

Can you help with this problem?

Provide an answer of your own, or ask David Chen for more information if necessary.

To post a message you must log in.