DebianSqueeze/Pipelight-Silverlight Installer Fails

Asked by neo on 2015-05-01

Hello ,

i installed Pipelight on DebianSqueeze after

Compiling Wine 1.7.41 (all required packages installed)
Installing Wine-Compholio 1.7.15 trough Ubuntu PPA (Debian Squeeze equals more/less Ubuntu LUCID)
Downloaded Pipelight/Tarball
Configured/Installed Pipelight with a refer to Wine-Compholio
Enabled Silverlight 5.1 (Succesful)

but now when i go to Amazon Prime,

Wine installer starts and Silverlight installer too, but somehow it fails to install properly.

Also the Silverlight does not show up, neither in Iceweasel, nor in Seamonkey.

What went wrong? What can i do?

Thanks

Richard

Question information

Language:
English Edit question
Status:
Solved
For:
Pipelight Edit question
Assignee:
No assignee Edit question
Last query:
2015-05-02
Last reply:
2015-05-08
Michael Müller (mqchael) said : #1

Wine Compholio 1.7.15 is too old and I doubt that it is still compatible with current Pipelight versions. I would recommend to remove Wine Compholio again and instead try the AVLinux packages. AVLinux is a slightly modified version of Squeeze, but I expect the packages to also work on plain Squeeze. You can find them at http://repos.fds-team.de/stable/debian/pool/main/w/wine-staging/

You will need the following packages:

wine-staging-i386_1.7.41~avlinux_i386.deb
wine-staging_1.7.41~avlinux_i386.deb

Now recompile pipelight, but pass "--wine-path=/opt/wine-staging/bin/wine" as parameter to configure. In case it still doesn't work, take a look at http://pipelight.net/cms/page-help.html and provide more debug output (pipelight-plugin --system-check, debug output when starting browser from a terminal - also see Capture debug output).

neo (csae2608) said : #2

thank you for your solution! will try that out later.

somehow Amazon Prime now works,

after installation of Flash Plugin 11 manually (it is no more available
in Debian Squeeze and neither have i found it on DebMultimedia)

So now i am able to fully use DebianSqueeze at the moment.

Only thing is , i would like to adresse the DVB-T Player Elgato EyeTV
410 via firewire through Linux. 'this system is macintosh only.

I am on Macmini 2.1

Most other Systems i was not able to install on this machine, including
Knoppix, Wheezy, Jessie (the mac-installer)

so i am happy contine using squeeze for some time!

On 01.05.2015 14:16, Michael Müller wrote:
> Your question #266204 on Pipelight changed:
> https://answers.launchpad.net/pipelight/+question/266204
>
> Status: Open => Needs information
>
> Michael Müller requested more information:
> Wine Compholio 1.7.15 is too old and I doubt that it is still compatible
> with current Pipelight versions. I would recommend to remove Wine
> Compholio again and instead try the AVLinux packages. AVLinux is a
> slightly modified version of Squeeze, but I expect the packages to also
> work on plain Squeeze. You can find them at http://repos.fds-
> team.de/stable/debian/pool/main/w/wine-staging/
>
> You will need the following packages:
>
> wine-staging-i386_1.7.41~avlinux_i386.deb
> wine-staging_1.7.41~avlinux_i386.deb
>
> Now recompile pipelight, but pass "--wine-path=/opt/wine-
> staging/bin/wine" as parameter to configure. In case it still doesn't
> work, take a look at http://pipelight.net/cms/page-help.html and
> provide more debug output (pipelight-plugin --system-check, debug output
> when starting browser from a terminal - also see Capture debug output).
>

neo (csae2608) said : #3

thanks ,

i was able to install silverlight + flash via your solution provided.
only dependencies that i had to update were gphoto2.2 +
libgphoto2.2-port0 or similar that on squeeze are only Version 2.4.8 and
Wine-Staging Required 2.4.10 or greater.
Could download The Required Debs From Ubuntu Natty Archive.

"Hoping to get Wheezy installed on Macmini cause Squeeze altough LTS has
no more Packages Online at Debian Website"

Yours,
Richard

On 01.05.2015 14:16, Michael Müller wrote:
> Your question #266204 on Pipelight changed:
> https://answers.launchpad.net/pipelight/+question/266204
>
> Status: Open => Needs information
>
> Michael Müller requested more information:
> Wine Compholio 1.7.15 is too old and I doubt that it is still compatible
> with current Pipelight versions. I would recommend to remove Wine
> Compholio again and instead try the AVLinux packages. AVLinux is a
> slightly modified version of Squeeze, but I expect the packages to also
> work on plain Squeeze. You can find them at http://repos.fds-
> team.de/stable/debian/pool/main/w/wine-staging/
>
> You will need the following packages:
>
> wine-staging-i386_1.7.41~avlinux_i386.deb
> wine-staging_1.7.41~avlinux_i386.deb
>
> Now recompile pipelight, but pass "--wine-path=/opt/wine-
> staging/bin/wine" as parameter to configure. In case it still doesn't
> work, take a look at http://pipelight.net/cms/page-help.html and
> provide more debug output (pipelight-plugin --system-check, debug output
> when starting browser from a terminal - also see Capture debug output).
>

Michael Müller (mqchael) said : #4

I think we can consider this problem as solved since we do not officially support Squeeze and you found a working solution.