Error while executing playground.py

Asked by Hendrik on 2010-03-09

Hi,
I am currently working throgh the installation process and got stuck when adding the preparecampaign command to playground.py!

Everytime I execute playground.py (no matter what command or option) I receive the message:

-----------------------------------------------------------------------------------------------
ERROR:
Unable to remove path for wnsbase Python module in sandbox

ERROR:
Unable to install wnsbase files to sandbox
-----------------------------------------------------------------------------------------------

I don't have a clue how to fix this...

Thanks in advance
Hendrik

Question information

Language:
English Edit question
Status:
Solved
For:
openWNS SDK Edit question
Assignee:
No assignee Edit question
Solved by:
Hendrik
Solved:
2010-03-10
Last query:
2010-03-10
Last reply:
Hendrik (mostricht) said : #1

Problem solved - don't bother about it...

Dear Hendrik,

could you tell us what was wrong with the plugin installation? I think
it would be beneficial if we include a proper error message here, that
gives a hint on how to solve the issue. Did you have some issues with
access rights?

Best Regards,
  Daniel

Hendrik wrote:
> Question #103724 on openWNS SDK changed:
> https://answers.launchpad.net/openwns-sdk/+question/103724
>
> Status: Open => Solved
>
> Hendrik confirmed that the question is solved:
> Problem solved - don't bother about it...
>
>

Hendrik (mostricht) said : #3

Hi Daniel,
you are right - sorry for not committing a proper error message...
Unfortunately, I cannot provide any more information on the error because I already fixed it, but I'give it a try...

I had several problems, but here comes the whole story:
At first, I think the installation order as described in the installation guide is wrong.
"Installing the Wrowser" turned out to be kind of child's play, quite contrary to "Adding the wrowser-plugin into playground.py".
As per description it is not possible to add the wrowser-plugininto playground.py without having installed the PostgreSQL database, at least I couldn't manage it. Hence, I suggest to put the "Adding the wrowser-plugin into playground.py-chapter" AFTER "Installing the PostgreSQL database-chapter".

Furthermore (and at this point I am not sure whether I mixed something up with root) I actually had some issues with access rights. This might be caused by alternating between root and normal user. I couldn't execute playground.py without having errors concerning removing/installing something - chmod -R 777 on the whole folder worked wonders :-)

And, while we're at it, at chapter "Adding a database user" (when installing PostgreSQL 8.3.9) "$ su postgres" should be changed into "$ sudo su postgres", I reckon.

Hope this could help!

Cheers
Hendrik