no desktop after switching desktop modes in unr

Asked by z_diver on 2009-04-01

I don't see any toolbars after logging in if I switch to standard desktop mode. Alt+f2 does not work either. It's just a blank screen upon login.

Jaunty on Asus 900 eee pc
with all updates installed.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Netbook Remix Edit question
Assignee:
No assignee Edit question
Last query:
2009-04-02
Last reply:
2009-07-19
z_diver (chuck-lagunadata) said : #1

Clarification: I do see the standard jaunty desktop interface directly after switching desktop modes in ubuntu-netbook-remix (UNR) 9.04 beta however, upon logging out and logging back in, all interface controls are have disappeared. I only have wallpaper and there is no method of interacting with the desktop. i.e. Ctrl+Alt+backspace does nothing nor does Alt+F2.

The first time this happened I found I had to reinstall because there was no way to stop the autologin process from taking me to this point. Subsequently, after a fresh install I created a new user account to test with and was able to reproduce this scenario.

jbouklas (jbouklas) said : #2

I had the same problem- the regular desktop interface looked great at first, but upon reboot, I could not access the bar on the top of the screen, and had no way to actually use the interface.

I'm a Linux noobie, more or less, and ended up just reinstalling the system (I needed the system to be up and running that morning and didn't have time to troubleshoot it thoroughly).

I was able to access terminal windows by clicking Ctrl-Alt-and the F keys, but I didn't how to bring the functionality back.

jbouklas (jbouklas) said : #3

I had the same problem- the regular desktop interface looked great at first, but upon reboot, I could not access the bar on the top of the screen, and had no way to actually use the interface.

I'm a Linux noobie, more or less, and ended up just reinstalling the system (I needed the system to be up and running that morning and didn't have time to troubleshoot it thoroughly).

I was able to access terminal windows by clicking Ctrl-Alt-and the F keys, but I didn't how to bring the functionality back.

jbouklas (jbouklas) said : #4

Didn't mean to answer the question! Clicked the wrong button when submitting...

z_diver (chuck-lagunadata) said : #5

I have a workaround that creates a nice clean desktop and is very
functional.

First I unchecked Maximus window manager and UNR Launcher under
preferences/startup apps.
Then I logged out and back in again and got the desktop with only one
black bar at the top with limited functionality. I then brought up the
main-menu using Alt+F1 and went to preferences>Switch desktop mode and
set it to Netbook Desktop (it had automatically been set to Classic by
unchecking the startup apps above however doing it this way, at least
the desktop is a bit functional still). So after the Launcher comes up,
use Alt+F1 again to enter System>Pref>Switch Desktop mode to Classic.
At that point you have a stable gnome-panel on the top of the screen
which just needs a bit of customization to make perfect for such a small
screen. For instance, I removed the little ubuntu icon which was 'show
desktop' and unlocked the window picker applet(little divider) and moved
it over making room for the new main menu button in the left corner.
The window picker is nice for such a small desktop. I usually don't
have too many windows open on the eeepc anyway. I'll post some
screenies later.

It's a bit of a workaround but Jaunty runs so nice on here, with desktop
effects enabled that it's worth it.

z

On Thu, 2009-04-02 at 15:07 +0000, jbouklas wrote:
> Your question #66076 on Ubuntu Netbook Remix changed:
> https://answers.launchpad.net/netbook-remix/+question/66076
>
> Status: Open => Answered
>
> jbouklas proposed the following answer:
> I had the same problem- the regular desktop interface looked great at
> first, but upon reboot, I could not access the bar on the top of the
> screen, and had no way to actually use the interface.
>
> I'm a Linux noobie, more or less, and ended up just reinstalling the
> system (I needed the system to be up and running that morning and didn't
> have time to troubleshoot it thoroughly).
>
> I was able to access terminal windows by clicking Ctrl-Alt-and the F
> keys, but I didn't how to bring the functionality back.
>

Andy (dr-diesel) said : #6

Same problem here is a Dell Mini 9, anyone have a proper fix?

Boynas (garyflores) said : #7

I have the same problem with also a Dell Mini 9.

I know that at some point I didn't have the top bar in the UNR desktop mode.. and I switched to Classic mode, to try to fix it. (by reloading the UNR mode) but I never got a taskbar in this mode. I can get to a text terminal by alt + F keys also, but I don't knoe where to start.

Is it maybe a command that the "desktop switcher" is not doing?

jisaac (jisaac) said : #8

Same problem here on Aspire One 110L...

jisaac (jisaac) said : #9

In the "Startup Applications Preferences" add:

Name: Gnome Window Manager
Command: gnome-wm

It solved the problem for me...

gsoundsgood (gsoundsgood) said : #10

z_diver's workaround did the trick for me on eee 900...thank you!

Peachy (peachy66) said : #11

hi im a complete noob and i have the same problem. 9.04 is fine when first installed, but upon reboot, only the wallpaper shows. now i dont know anything about directories or registry keys etc etc and ive tried following a few tips from other forums but to no avail :( can anybody help me out at all? i would be extremely grateful indeed. i need my mini 9 up and running for Uni.
Many thanks!
Peachy

Henrik (neu242) said : #12

Look at bug #349519 for a bugfix.

I solved the problem by having an SD-card inserted (USB stick should also do the trick) so I could start nautilus from the empty desktop by clicking on the removable media icon.
I then navigated to /usr/bin and executed gnome-terminal. Then I executed "gnome-panel &" and "gnome-wm" from the terminal, and added the two commands to the Startup Applications (found in System, Preferences)

sachin (sachin-khartude) said : #14

 I have the same problem

Can you help with this problem?

Provide an answer of your own, or ask z_diver for more information if necessary.

To post a message you must log in.