how to determine murano version

Asked by Peng Wu

At, the version has the format of 1.0.0, which matches the Version in egg-info/PKG-INFO.

On the other hand, the egg-info/PKG-INFO as installed at /usr/lib/python2.7/site-packages/ would read like this:

How do we determine the version of the installed Murano?

Question information

English Edit question
Murano Edit question
Kirill Zaitsev Edit question
Solved by:
Kirill Zaitsev
Last query:
Last reply:
Revision history for this message
Kirill Zaitsev (kzaitsev) said :

This depends on how you have actually installed murano (from source or from packages)

You should be able to use something like `murano-api --version` to get version of murano api/engine installed.

Revision history for this message
Peng Wu (wu105) said :

I got the following:

murano --version
murano-api --version

Is 0.8.0 the engine version and 2.0.0 the client version?
Are these a match with ?

Revision history for this message
Best Kirill Zaitsev (kzaitsev) said :

`murano` CLI utility is python-muranoclient it is released independently and is versioned differently from murano-api/engine

Revision history for this message
Peng Wu (wu105) said :

Thanks for the quick response. Looks like we got murano api and engine at 2.0.0.

2.0.0 seems out of the murano version range 1.0.0 - 1.0.2 for Openstack Liberty listed at .

A follow up question would be whether Murano 2.0.0 can work with Openstack Liberty. Do I need to create another question entry?

Revision history for this message
Stan Lagun (slagun) said :

2.0.0 is Mitaka. However if you have a proper Murano installation with all python dependencies met (they differ from those in Liberty) there are no obstacles known to me for using Murano Mitaka to deploy apps on top of OpenStack Liberty. But it is true for standalone serivces like murano API/engine. But when it comes to murano-dashboard that is a Horizon plugin that need to be installed to the same python environment and thus can be incompatible with Horizon Liberty requirements. Not sure how I understand you got such setup or it is we who put incorrect version somewhere

Revision history for this message
Peng Wu (wu105) said :

Many thanks! This covers all aspects.

While I have to ask around about our environment, it seems that we have Mitaka's horizon and Murano installed on a dedicated machine and hooked up with a Liberty Openstack. It seems to be working. Not sure whether this mash would be a factor to the linked Bug #1583828.

Revision history for this message
Peng Wu (wu105) said :

Thanks Kirill Zaitsev, that solved my question.