How to forbiden magraph to open browser(firefox) automatically

Asked by Winston on 2020-07-06

Hi experts,
    I am running madgraph in remote service. When the madgraph run, it alwasy try to open the browser(firebox) and then it cause errors: Gdk-Message: 03:16:25.337: firefox: Fatal IO error 11 (Resource temporarily unavailable) on X server localhost:27.0.
###!!! [Child][MessageChannel] Error: (msgtype=0xFFF7,name=<unknown IPC msg name>) Channel error: cannot send/recv

another error:
INFO: Storing parton level results
INFO: End Parton
reweight -from_cards
decay_events -from_cards
INFO: Creating root files
Warning in <TTree::Bronch>: Using split mode on a class: TRootWeight with a custom Streamer
** Reading /afs/cern.ch/work/r/repan/MG5_aMC_v2_7_3/bin/pp_ttbar_semi/Events/run_02/unweighted_events.lhe
** [################################################################] (100.00%)
** Exiting...
Command "generate_events run_02" interrupted with error:
InvalidCmd : No event file corresponding to run_02 run.
quit

How can I turn off this function? The version I used is MG5_aMC_v2.7.3.

Best regards
Winston

Question information

Language:
English Edit question
Status:
Solved
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Last query:
2020-07-07
Last reply:
2020-07-10

Hi,

You can edit the file input/mg5_configuration.txt
and replace the lines:
#! Allow/Forbid the automatic opening of the web browser (on the status page)
#! when launching MadEvent [True/False]
# automatic_html_opening = True
by
#! Allow/Forbid the automatic opening of the web browser (on the status page)
#! when launching MadEvent [True/False]
automatic_html_opening = False

Cheers,

Olivier

Winston (adampan) said : #2

Hi Oliver,
  I have set up as you said but it still has problem. If I generate 1000 events, it's okay. But If I generate 100k events, the browser opened automatically and ended in error : Command "generate_events run_02" interrupted with error:
InvalidCmd : No event file corresponding to run_02 run.
quit

Thank you
Winston

> On Jul 6, 2020, at 2:11 PM, Olivier Mattelaer <email address hidden> wrote:
>
> Your question #691707 on MadGraph5_aMC@NLO changed:
> https://answers.launchpad.net/mg5amcnlo/+question/691707
>
> Status: Open => Answered
>
> Olivier Mattelaer proposed the following answer:
> Hi,
>
> You can edit the file input/mg5_configuration.txt
> and replace the lines:
> #! Allow/Forbid the automatic opening of the web browser (on the status page)
> #! when launching MadEvent [True/False]
> # automatic_html_opening = True
> by
> #! Allow/Forbid the automatic opening of the web browser (on the status page)
> #! when launching MadEvent [True/False]
> automatic_html_opening = False
>
> Cheers,
>
> Olivier
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/mg5amcnlo/+question/691707/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/mg5amcnlo/+question/691707
>
> You received this question notification because you asked the question.

Did you regenerate the process directory?

I'm running with that option set to False for more than 10 years and never face issue with it.

Cheers,

Olivier

Winston (adampan) said : #4

Yeah. I generated the process again from beginning, but the browser still opened before pythia8 started to run.

> On Jul 6, 2020, at 2:35 PM, Olivier Mattelaer <email address hidden> wrote:
>
> Your question #691707 on MadGraph5_aMC@NLO changed:
> https://answers.launchpad.net/mg5amcnlo/+question/691707
>
> Status: Open => Answered
>
> Olivier Mattelaer proposed the following answer:
> Did you regenerate the process directory?
>
> I'm running with that option set to False for more than 10 years and
> never face issue with it.
>
> Cheers,
>
> Olivier
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/mg5amcnlo/+question/691707/+confirm?answer_id=2
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/mg5amcnlo/+question/691707
>
> You received this question notification because you asked the question.

if you do from that directory
./bin/madevent
then type
display options automatic_html_opening

is it correctly set on False.

if not could you also check from the madgraph side
./bin/mg5_aMC
then type
display options automatic_html_opening

I have quickly checked the code and all the html opening are correctly protected by a check of that parameter.
So if the parameter is correctly set on False, then I will need to ask you to change the code to make it crash when trying to open the browser to understand how such opening is possible.

Cheers,

Olivier

Winston (adampan) said : #6

Hi Oliver,
   I tried :
./bin/mg5_aMC
then type
display options automatic_html_opening

The outcome is True. The option in mg5_configuration.txt already have been changed to False.
What should I do next?
Thanks for your help.
Best regards,
Winston

> On Jul 6, 2020, at 11:26 PM, Olivier Mattelaer <email address hidden> wrote:
>
> ./bin/mg5_aMC
> then type
> display options automatic_html_opening

Winston (adampan) said : #7

Hi. Oliver,
I find the reason.
# automatic_html_opening = False
I didn't remove the sign "#”.
After I remeve #, it works.
Best wishes
Winston

Sent from my iPhone

> On Jul 6, 2020, at 2:11 PM, Olivier Mattelaer <email address hidden> wrote:
>
> # automatic_html_opening = True

marked as solved