combine processes take long time

Asked by Cheng Tao on 2019-06-13

I am trying to generate process p p > n2 n2 j j QCD=0, (n2 > lepton lepton n1) with model MSSM_SLAH2, but it went so slowly and takes a whole night to just output 2~3 lines here:

INFO: Generating Helas calls for process: n2 > mu- mu+ n1 WEIGHTED<=4
INFO: Generating Helas calls for process: n2 > ta- ta+ n1 WEIGHTED<=4
INFO: Combine u u > n2 n2 u u QCD=0 @1 with decays n2 > e- e+ n1 WEIGHTED<=4, n2 > e- e+ n1 WEIGHTED<=4
INFO: Combine u u > n2 n2 u u QCD=0 @1 with decays n2 > e- e+ n1 WEIGHTED<=4, n2 > mu- mu+ n1 WEIGHTED<=4
INFO: Combine u u > n2 n2 u u QCD=0 @1 with decays n2 > e- e+ n1 WEIGHTED<=4, n2 > ta- ta+ n1 WEIGHTED<=4
INFO: Combine u u > n2 n2 u u QCD=0 @1 with decays n2 > mu- mu+ n1 WEIGHTED<=4, n2 > mu- mu+ n1 WEIGHTED<=4
INFO: Combine u u > n2 n2 u u QCD=0 @1 with decays n2 > mu- mu+ n1 WEIGHTED<=4, n2 > ta- ta+ n1 WEIGHTED<=4
INFO: Combine u u > n2 n2 u u QCD=0 @1 with decays n2 > ta- ta+ n1 WEIGHTED<=4, n2 > ta- ta+ n1 WEIGHTED<=4

This is a peculiarly long time Madgraph took to just output the folder. I don't know what could be the reason.

Question information

Language:
English Edit question
Status:
Answered
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Last query:
2019-06-13
Last reply:
2019-06-26

Hi,

I would guess that you are starting to swap and that this slow down the computation.
This part of the computation is quite demanding in term of RAM so this might be your issue.
How much RAM do you have available? Is it free and if not what kind of swap did you use?

Cheers,

Olivier

Cheng Tao (taoc97) said : #2

I have 8 cpu to run it and each take 16G of memory.

Ok then you should have enough RAM.
I'm looking at it and indeed I have it quite slow as well.
At the same time the final number of diagrams (per line) is 200k which is quite large, so this might be the reason. But will check with older version of the code to see if it is something new or not.

Cheers and thanks,

Olivier

> On 19 Jun 2019, at 15:37, Cheng Tao <email address hidden> wrote:
>
> Question #681402 on MadGraph5_aMC@NLO changed:
> https://answers.launchpad.net/mg5amcnlo/+question/681402
>
> Cheng Tao posted a new comment:
> I have 8 cpu to run it and each take 16G of memory.
>
> --
> You received this question notification because you are an answer
> contact for MadGraph5_aMC@NLO.

Hi,

I have check with
2.3.2 , 2.0.1, 1.5.8, 1.5.0, 1.3.3, 1.2.0
and they all present the behavior in term of speed for that process.

So this is certainly not something new. I will therefore put this as low priority and try to understand a bit more why this process is particularly slow.

Thanks,

Olivier

Can you help with this problem?

Provide an answer of your own, or ask Cheng Tao for more information if necessary.

To post a message you must log in.