Error running systematics module on generated events

Asked by Kelci Mohrman on 2019-05-30

Hello MG experts,

I have a question about an error that is produced when trying to make a 0+1 parton process gridpack. We are using the dim6top_LO_UFO model and our MadGraph version is 2.6.0.

In our process card, we have:

define p = p b b~
define j = p
define l+ = e+ mu+ ta+
define l- = e- mu- ta-
define vl = ve vm vt
define vl~ = ve~ vm~ vt~
generate p p > t t~ l+ vl DIM6=1 @0
add process p p > t t~ l- vl~ DIM6=1 @1
add process p p > t t~ l+ vl j DIM6=1 @2
add process p p > t t~ l- vl~ j DIM6=1 @3

When can generate events from the gridpack, but when we try to run the systematics module over these events, we get the following error:

Command "systematics GridRun_PostProc_42 --remove_wgts=all --start_id=1001 --pdf=306000,322500@0,322700@0,322900@0,323100@0,323300@0,323500@0,323700@0,323900@0,305800,13000,13065@0,13069@0,13100,13163@0,13167@0,13200@0,25200,25300,25000@0,42780,90200,91200,90400,91400,61100,61130,61200,61230,13400,82200,292200,292600@0,315000@0,315200@0,262000@0,263000@0 --mur=1,2,0.5 --muf=1,2,0.5 --together=muf,mur,dyn --dyn=-1,1,2,3,4" interrupted with error:
Exception : <rscale> -1 0.10700227E+04</rscale>
 <asrwt> 1 0.19826937E+02</asrwt>
 <pdfrwt beam="1"> 1 2 0.12435204E+00 0.12779190E+04</pdfrwt>
 <pdfrwt beam="2"> 1 -1 0.19537244E+00 0.62814801E+03</pdfrwt>
 <totfact> 0.11828276E+01</totfact>
  not parsed

We are not sure what is causing this error or how to fix it.

As one further note, when we looked at the LHE file, the only difference between this event and the preceding events appears to be the -1 in the <rscale> tag (the others are all non-negative). We are not sure whether or not this is related to the issue, but we are wondering what this integer means.

Thank you! - Kelci

Question information

Language:
English Edit question
Status:
Answered
For:
MadGraph5_aMC@NLO Edit question
Assignee:
No assignee Edit question
Last query:
2019-05-30
Last reply:
2019-05-31

This is the power of alpha s for this event.
I m trying to reproduce this now. Could you make this a bug report such that you can attach the lhe file and the full bug report.
Question do not allow to attach file. Even if you put an attachment by replying by email

Get Outlook for iOS<https://aka.ms/o0ukef>

________________________________
From: <email address hidden> on behalf of Kelci Mohrman <email address hidden>
Sent: Thursday, May 30, 2019 11:32 PM
To: Olivier Mattelaer
Subject: [Question #681157]: Error running systematics module on generated events

New question #681157 on MadGraph5_aMC@NLO:
https://answers.launchpad.net/mg5amcnlo/+question/681157

Hello MG experts,

I have a question about an error that is produced when trying to make a 0+1 parton process gridpack. We are using the dim6top_LO_UFO model and our MadGraph version is 2.6.0.

In our process card, we have:

define p = p b b~
define j = p
define l+ = e+ mu+ ta+
define l- = e- mu- ta-
define vl = ve vm vt
define vl~ = ve~ vm~ vt~
generate p p > t t~ l+ vl DIM6=1 @0
add process p p > t t~ l- vl~ DIM6=1 @1
add process p p > t t~ l+ vl j DIM6=1 @2
add process p p > t t~ l- vl~ j DIM6=1 @3

When can generate events from the gridpack, but when we try to run the systematics module over these events, we get the following error:

Command "systematics GridRun_PostProc_42 --remove_wgts=all --start_id=1001 --pdf=306000,322500@0,322700@0,322900@0,323100@0,323300@0,323500@0,323700@0,323900@0,305800,13000,13065@0,13069@0,13100,13163@0,13167@0,13200@0,25200,25300,25000@0,42780,90200,91200,90400,91400,61100,61130,61200,61230,13400,82200,292200,292600@0,315000@0,315200@0,262000@0,263000@0 --mur=1,2,0.5 --muf=1,2,0.5 --together=muf,mur,dyn --dyn=-1,1,2,3,4" interrupted with error:
Exception : <rscale> -1 0.10700227E+04</rscale>
<asrwt> 1 0.19826937E+02</asrwt>
<pdfrwt beam="1"> 1 2 0.12435204E+00 0.12779190E+04</pdfrwt>
<pdfrwt beam="2"> 1 -1 0.19537244E+00 0.62814801E+03</pdfrwt>
<totfact> 0.11828276E+01</totfact>
not parsed

We are not sure what is causing this error or how to fix it.

As one further note, when we looked at the LHE file, the only difference between this event and the preceding events appears to be the -1 in the <rscale> tag (the others are all non-negative). We are not sure whether or not this is related to the issue, but we are wondering what this integer means.

Thank you! - Kelci

--
You received this question notification because you are an answer
contact for MadGraph5_aMC@NLO.

I do not reproduce such issues, so I really need the extra information in order to be able to help you.

Can you help with this problem?

Provide an answer of your own, or ask Kelci Mohrman for more information if necessary.

To post a message you must log in.