error with compile Exrootanalysis

Asked by Charlie on 2018-03-19

Dear Expert,

I am using MG5_aMC_v2_6_1, when I try to install in madgraph Exrootanalysis, it give me this error:

2018-03-20 02:56:03 (60.5 KB/s) - ‘ExRootAnalysis.tgz’ saved [49519/49519]

compile ExRootAnalysis. This might take a while.
>> Generating tmp/src/ExRootAnalysisDict.cc
>> Compiling tmp/src/ExRootAnalysisDict.cc
In file included from tmp/src/ExRootAnalysisDict.cc:17:0:
./ExRootAnalysis/ExRootResult.h:70:10: error: ‘struct ExRootResult::PlotSettings’ is private
   struct PlotSettings
          ^
tmp/src/ExRootAnalysisDict.cc:147:10: error: within this context
          map< ::TObject*, ::ExRootResult::PlotSettings > fSettings; //!
          ^
Makefile:245: recipe for target 'tmp/src/ExRootAnalysisDict.o' failed
make: *** [tmp/src/ExRootAnalysisDict.o] Error 1
Error detected during the compilation. Please check the compilation error and run make manually.

My root(version5) is right installed , I have miss deleted something in .bashrc, I don't know if it's related to this.

Thank you very much!

Best!
Charlie

Question information

Language:
English Edit question
Status:
Solved
For:
MadGraph5_aMC@NLO Edit question
Assignee:
Pavel Demin Edit question
Solved by:
Charlie
Solved:
2018-03-20
Last query:
2018-03-20
Last reply:
2018-03-20

The installer seems to load correctly the version (and compile correctly on my mac).
So I guess this is an issue with your gcc version or something like that.

I have assigned this to Pavel, the author of that package.

Maybe you could give us more information on the machine on which you are running.
and your compilator suite.

Cheers,

Olivier

Pavel Demin (pavel-demin) said : #2

> My root(version5)

ExRootAnalysis isn't compatible with ROOT 5 anymore, it requires ROOT 6.

Thanks Pavel,

Is it the same for Delphes3?

Olivier

> On 20 Mar 2018, at 09:18, Pavel Demin <email address hidden> wrote:
>
> Question #666259 on MadGraph5_aMC@NLO changed:
> https://answers.launchpad.net/mg5amcnlo/+question/666259
>
> Status: Open => Answered
>
> Pavel Demin proposed the following answer:
>> My root(version5)
>
> ExRootAnalysis isn't compatible with ROOT 5 anymore, it requires ROOT 6.
>
> --
> You received this question notification because you are an answer
> contact for MadGraph5_aMC@NLO.

Pavel Demin (pavel-demin) said : #4

> Is it the same for Delphes3?

No. I've just tested Delphes 3.4.1 with ROOT 5.34.09 and it worked.

Pavel Demin (pavel-demin) said : #5

I've just found a workaround of this problem in ROOT 5:

http://bazaar.launchpad.net/~mgtools/mg5amcnlo/MG_MG_v4/revision/30

Charlie (xianhui) said : #6

I changed PlotSettings to be public and compile successful, can I safely use it?

Pavel Demin (pavel-demin) said : #7

> can I safely use it?

Yes.

Charlie (xianhui) said : #8

OK, Thank you!