ExRootAnalysis: no dictionary for class TRootLHEFEvent is available

Asked by Alexander Karlberg on 2013-02-23

Hi!

I have installed ExRootAnalysis via the install command in MG/ME. Now when I launch a process I get the following error

[...]
Error in <UnknownClass::RegisterModule>: cannot find dictionary module ExRootAnalysisDict_rdict.pcm in /home/karlberg/Install/root/lib:/home/karlberg/Install/root/lib:/home/karlberg/Install/MadGraph5_v1_5_1/ExRootAnalysis
Error in <UnknownClass::RegisterModule>: cannot find dictionary module ModulesDict_rdict.pcm in /home/karlberg/Install/root/lib:/home/karlberg/Install/root/lib:/home/karlberg/Install/MadGraph5_v1_5_1/ExRootAnalysis
Warning in <TClass::TClass>: no dictionary for class TRootLHEFEvent is available
Error in <TClonesArray::SetClass>: TRootLHEFEvent does not inherit from TObject

 *** Break *** segmentation violation

===========================================================
There was a crash.
This is the entire stack trace of all threads:
===========================================================
#0 0x00007fc103ec743e in waitpid () from /lib/x86_64-linux-gnu/libc.so.6
#1 0x00007fc103e4d29e in ?? () from /lib/x86_64-linux-gnu/libc.so.6
#2 0x00007fc1065e9fd7 in TUnixSystem::StackTrace() () from /home/karlberg/Install/root/lib/libCore.so
#3 0x00007fc1065ec8b3 in TUnixSystem::DispatchSignals(ESignals) () from /home/karlberg/Install/root/lib/libCore.so
#4 <signal handler called>
#5 0x00007fc10657d4e8 in TClonesArray::ExpandCreateFast(int) () from /home/karlberg/Install/root/lib/libCore.so
#6 0x000000000044c404 in ExRootTreeBranch::ExRootTreeBranch(char const*, TClass*, TTree*) ()
#7 0x0000000000449937 in ExRootTreeWriter::NewBranch(char const*, TClass*) ()
#8 0x0000000000436914 in main ()
===========================================================

The lines below might hint at the cause of the crash.
If they do not help you then please submit a bug report at
http://root.cern.ch/bugs. Please post the ENTIRE stack trace
from above as an attachment in addition to anything else
that might help us fixing this issue.
===========================================================
#5 0x00007fc10657d4e8 in TClonesArray::ExpandCreateFast(int) () from /home/karlberg/Install/root/lib/libCore.so
#6 0x000000000044c404 in ExRootTreeBranch::ExRootTreeBranch(char const*, TClass*, TTree*) ()
#7 0x0000000000449937 in ExRootTreeWriter::NewBranch(char const*, TClass*) ()
#8 0x0000000000436914 in main ()
===========================================================
[...]

Followed by the requested cross section. The first part about the missing dictionary modules I can get rid of by simply copying them from the tmp-folder into my root installation, but after that I still have an issue with the TRootLHEFEvent dictionary. It seems something has gone wrong in the installation of ExRootAnalysis. My guess is that some files weren't copied to the correct locations...

By the way, I have tried to download ExRootAnalysis directly from the MG webpage and compiling it. When running ExRootLHEFConverter directly on the produced .lhe file, I get exactly the same error.

I run Ubuntu 12.04 (64-bit). I have aslo tried on a machine running MacOSX and have the same problem there.

I hope you can help, and thanks in advance!
Alexander

Question information

Language:
English Edit question
Status:
Solved
For:
MadGraph5_aMC@NLO Edit question
Assignee:
Pavel Demin Edit question
Solved by:
Alexander Karlberg
Solved:
2013-02-23
Last query:
2013-02-23
Last reply:

By the way I am running Root 5.34. I am at moment trying to compile everything with 5.28 instead.

It seems to work with ROOT 5.28.

Last update: It seems to work with 5.32.04 but not with 5.34.05 which currently is the most recent version.

Hi Alexander,

Thanks for the information, I'm adding Pavel (the ExRootAnalysis author) such that he can take a look at this problem.

Thanks,

Olivier

On Feb 23, 2013, at 12:45 PM, Alexander Karlberg <email address hidden> wrote:

> Question #222642 on MadGraph5 changed:
> https://answers.launchpad.net/madgraph5/+question/222642
>
> Alexander Karlberg posted a new comment:
> Last update: It seems to work with 5.32.04 but not with 5.34.05 which
> currently is the most recent version.
>
> --
> You received this question notification because you are a member of
> MadTeam, which is an answer contact for MadGraph5.

Pavel Demin (pavel-demin) said : #5

Hi Alexander,

I've just tried ExRootLHEFConverter with ROOT 5.34.05 under Scientific Linux 5 64-bit and could not reproduce your problem.

I'll install a virtual machine with Ubuntu 12.04 64-bit and redo the test.

Here are the commands that I run:

wget http://madgraph.phys.ucl.ac.be/Downloads/ExRootAnalysis/ExRootAnalysis_V1.0.10.tar.gz
tar -zxf ExRootAnalysis_V1.0.10.tar.gz
cd ExRootAnalysis
make -j 8
wget http://<email address hidden>/Plotting/Plot_0/unweighted_events.lhe.gz
gunzip unweighted_events.lhe.gz
./ExRootLHEFConverter unweighted_events.lhe unweighted_events.root

Regards,

Pavel

Pavel Demin (pavel-demin) said : #6

Hi Alexander,

I've just tested ExRootLHEFConverter with ROOT 5.34.05 under Ubuntu 12.04 64-bit and still can't reproduce your problem.

My ROOT binaries can be downloaded from

http://cp3.irmp.ucl.ac.be/~demin/root-5.34.05-ub1204_amd64_gcc46.tgz

Regards,

Pavel

A.Hayreter (alperhayreter) said : #7

Dear Pavel,

I am having a similar problem, though not quite so but the title in this thread matches %100.

I use MG5_v2_1_2, and I installed ExRootAnalysis by install command in mg5_aMC.
Everything works fine, I generate events and have root file at the end without any problem.
But when I open the root file in ROOT (v 5.34/14) by the following command;

root -l unweighted_events.root

I get the following warnings;

Attaching file unweighted_events.root as _file0...
Warning in <TClass::TClass>: no dictionary for class TRootLHEFEvent is available
Warning in <TClass::TClass>: no dictionary for class TRootWeight is available
Warning in <TClass::TClass>: no dictionary for class TRootLHEFParticle is available
Warning in <TClass::TClass>: no dictionary for class TSortableObject is available

I am not sure whether this is related with MG5 or ROOT.
Any suggestions?

thanks.

Melissa (mcbeekveld) said : #8

Hi,

I have the same problem as Alpher, when I link my .root file then I get the same warnings, seamingly causing a segmentation fault shortly after. Any suggestions?

Cheers,
Melissa

Pavel Demin (pavel-demin) said : #10

Hi Tulio,

Could you please provide more details about what exactly doesn't work
for you? Have you tried to follow the instructions from
ExRootAnalysis/doc/README?

Cheers,

Pavel

Tulio wrote:
> Question #222642 on MadGraph5_aMC@NLO changed:
> https://answers.launchpad.net/mg5amcnlo/+question/222642
>
> Tulio posted a new comment:
> Hi, Does anybody solved the problem?
>
> I have the same problem as Melissa and Alper.
>
> Cheers,
> Tulio
>

Tulio (tulio-caviquioli) said : #11

Hi,

The problem was solved!

I didn't generated the files '.root' containing the histograms that I wanted to stack.

thanks
Tulio