how generate channel.conf for 1.4.x version

Asked by Davide Marchi on 2013-01-18

Hi friends,
i'm using Fedora17 and me-tv 1.4.0.9-1,

i've created the channel.conf using w_scan 20120605 version.
I've make it so: w_scan -x > it-My_City

But if i pass to me-tv this file, obtain the error: "Invalid Parameter count" and the channel import seems hang...
where i does wrong?

thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
Me TV Edit question
Assignee:
No assignee Edit question
Solved by:
Davide Marchi
Solved:
Last query:
Last reply:
Revision history for this message
Frédéric Côté (frederic-cote) said :
#1

Hi,
I think the "-X" switch must be uppercase and you must use the "-c" to
specify your country, so:
w_scan -X -c IT > channels.conf

I supposed you're from Italie so I put "IT" in the command (I'm from Canada
and I use "CA").

Cheers,
Fred

On Fri, Jan 18, 2013 at 3:35 PM, Davide Marchi <
<email address hidden>> wrote:

> New question #219572 on Me TV:
> https://answers.launchpad.net/me-tv/+question/219572
>
> Hi friends,
> i'm using Fedora17 and me-tv 1.4.0.9-1,
>
> i've created the channel.conf using w_scan 20120605 version.
> I've make it so: w_scan -x > it-My_City
>
> But if i pass to me-tv this file, obtain the error: "Invalid Parameter
> count" and the channel import seems hang...
> where i does wrong?
>
> thanks!
>
> --
> You received this question notification because you are an answer
> contact for Me TV.
>

--
"In a world without walls, who really needs Windows"
"Nothing is foolproof because fools are so ingenious"

Revision history for this message
Daniel Devlin (unixisit) said :
#2

If you are using w_scan which use the output gives 8VSB how ever the server needs it to be VSB_8 so you can edit the cannels.conf and change it. Or you can edit the channels_conf_line.cc and and 8VSB to it.

Revision history for this message
Davide Marchi (danjde) said :
#3

well, i can do: w_scan -X -c IT > channels.conf,
but time ago, me-tv, give me the possibility to "scan" from a channel.conf.
Now this is not possible and the number of channel are much much lower...

Revision history for this message
Frédéric Côté (frederic-cote) said :
#4

Hi Davide,

If you don't need the new architecture (client/server), stay with the
version 1.3. It is more advance and have more feature. The version 1.4 is
an attempt to split me-tv in two part but so far there is a lot of feature
not imported in the new configuration.

Cheers,
Frederic

On Wed, Feb 6, 2013 at 9:36 AM, Davide Marchi <
<email address hidden>> wrote:

> Question #219572 on Me TV changed:
> https://answers.launchpad.net/me-tv/+question/219572
>
> Status: Answered => Open
>
> Davide Marchi is still having a problem:
> well, i can do: w_scan -X -c IT > channels.conf,
> but time ago, me-tv, give me the possibility to "scan" from a channel.conf.
> Now this is not possible and the number of channel are much much lower...
>
> --
> You received this question notification because you are an answer
> contact for Me TV.
>

--
"In a world without walls, who really needs Windows"
"Nothing is foolproof because fools are so ingenious"

Revision history for this message
Davide Marchi (danjde) said :
#5

well Frederic,
but i'm using Fedora 17, and if i try to install me-tv, it came the 1.4 version.
For to use the 1.3 version i should recompile the source package.

thanks a lot
davide