"Expression too large" error

Asked by John on 2009-03-25

Is there any way to get around this? I'm trying to solve symbolically a system of 5 equations and 5 unknowns. I've written an input script which I was trying to verify, except the way I'm solving it must require too much memory. Should I be simplifying in between solving?

Question information

Language:
English Edit question
Status:
Answered
For:
Mathomatic Edit question
Assignee:
No assignee Edit question
Last query:
2009-03-25
Last reply:
2009-03-25

Simplifying often helps reduce the expression size, yes.
For example:

(x+1)^11
unfactor

results in the "Expression too large" error,
but running Mathomatic with the command line "mathomatic -m 10" will make the expression arrays 10 times larger,
so the above will succeed.

If you wish, you can email me the problem input script, and I will try and make it work.
My email address is "<email address hidden>".

Regards,
George

John (ho-2002) said : #2

Thanks for the help. I think I've solved the memory issue, now it's
just a matter of my slow cpu getting through all of the calculations.
I've attached the script so you can see if I'm doing anything out of the
ordinary.

Cheers,
John

George Gesslein II wrote:
> Your question #65258 on Mathomatic changed:
> https://answers.launchpad.net/mathomatic/+question/65258
>
> Status: Open => Answered
>
> George Gesslein II proposed the following answer:
> Simplifying often helps reduce the expression size, yes.
> For example:
>
> (x+1)^11
> unfactor
>
> results in the "Expression too large" error,
> but running Mathomatic with the command line "mathomatic -m 10" will make the expression arrays 10 times larger,
> so the above will succeed.
>
> If you wish, you can email me the problem input script, and I will try and make it work.
> My email address is "<email address hidden>".
>
> Regards,
> George
>
>

Your attached script did not get through to me.
Please send it to "<email address hidden>" or copy and paste it into your reply here in Answers.
Setting the memory size multiplier option (-m) greater than 100 is not recommended.

Regards,
George

Can you help with this problem?

Provide an answer of your own, or ask John for more information if necessary.

To post a message you must log in.