How to set marlin as default file manager

Asked by Devid Antonio Filoni on 2011-05-31

How can I set marlin as default file manager instead of nautilus? (marlin should be the default file manager also using the Unity session)

Question information

Language:
English Edit question
Status:
Solved
For:
Marlin Edit question
Assignee:
No assignee Edit question
Solved by:
Devid Antonio Filoni
Solved:
2011-06-05
Last query:
2011-06-05
Last reply:
2011-06-05

Yes, I'd like to know as well. It'd be useful while testing in Natty.

It doesn't work.

Doesn't work.

ammonkey (am-monkeyd) said : #6

Hello, to make marlin default filemanager just click on a folder in nautilus "open with" and select marlin and check default application. However nautilus on gnome draw the desktop too, marlin doesn't, u can disable nautilus desktop via gconf or u can remove the filemanager flag in the session files (if u re using unity) or in gconf on other systems.

Anyway it's a bit earlier to make marlin a default application, it's not released yet, we'll find an automated way to make it default when the time come.

Happy testing.

In Ubuntu 11.04 you cannot set the default application for directories. Looks like there is no way to use marlin as default file manager.

Adnane Belmadiaf (daker) said : #8

Hi you can try my branch lp:~daker/marlin/marlin-default-fm , it was tested on maverick.
to make it default just launch the make-marlin-default script, to restore it just run the same script again.

If you use nautilus to draw desktop if you click on a desktop icon nautilus will be open, also using your script... (already tried that)

ammonkey (am-monkeyd) said : #10

Of course nautilus would open its own windows. If u assign the folder mimetype to marlin, then u can launch it from a dock, panel/dash/launcher etc.

There is an only way to fix this:
- Marlin should be able to draw the desktop
- Modify mimetypes in /usr/share/applications/defaults.list to call marlin instead of nautilus

David, Marlin won't be drawing the desktop as it's a file manager and not a
desktop drawer. We have pantheon-wallpaper to draw the desktop.

That's fine.

harpreet bhatia (bluepicaso) said : #14

can someone help me to make it as default?
any steps uyou can share. i understand there is no desktopfile.
i am on ubuntu 12.10

ammonkey (am-monkeyd) said : #15

menubar edit>preferences > Behavior tab > "Set Marlin as default" (last switch)

or

Cog Menu > preferences > etc ...

harpreet bhatia (bluepicaso) said : #16

done works after restart
thanks

On Wed, Apr 3, 2013 at 4:41 PM, ammonkey <
<email address hidden>> wrote:

> Question #159780 on Marlin changed:
> https://answers.launchpad.net/marlin/+question/159780
>
> ammonkey posted a new comment:
> menubar edit>preferences > Behavior tab > "Set Marlin as default" (last
> switch)
>
> or
>
> Cog Menu > preferences > etc ...
>
> --
> You received this question notification because you are a direct
> subscriber of the question.
>

--

*Harpreet Singh Bhatia*

The Coding Box
w: www.thecodingbox.com<http://s.wisestamp.com/links?url=http%3A%2F%2Fwww.thecodingbox.com>|
e: <email address hidden><http://s.wisestamp.com/links?url=mailto%3Aharpreet%40thecodingbox.com>|
p: +91.9457634410<http://s.wisestamp.com/links?url=tel%3A%252B91.9457634410>

-- sent from Ubuntu