How do I change this message: "to get this branch, use..."?

Asked by David D Lowe on 2011-04-22

When displaying a branch, loggerhead helpfully displays the following message:

To get this branch, use:
bzr branch /folder/trunk

I would like to change this message to something like this:
To get this branch, use:
bzr branch bzr+ssh://username@server/folder/trunk

Question information

Language:
English Edit question
Status:
Answered
For:
loggerhead Edit question
Assignee:
No assignee Edit question
Last query:
2011-06-03
Last reply:
2011-06-08
Curtis Hovey (sinzui) said : #1

This is a bug in loggerhead: Bug #770432

John A Meinel (jameinel) said : #2

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 4/25/2011 8:32 PM, Curtis Hovey wrote:
> Question #153887 on loggerhead changed:
> https://answers.launchpad.net/loggerhead/+question/153887
>
> Linked to bug: #770432
> https://bugs.launchpad.net/bugs/770432
> "Logger head does not tell users how to branch"
>

The settings for this is actually:

 self.branch.get_config().get_user_option('public_branch')

So you set it by putting:

 public_branch = XXX

Into either ~/.bazaar/locations.conf or into $BRANCH/.bzr/branch.conf
If you set it in locations.conf you can set a group of branches with a
single setting. Such as:

[/path/to/repo]
public_branch = bzr+ssh://my/repo
public_branch:policy = appendpath

And at that point, any branch such as:
/path/to/repo/mybranch

Will show:

To get this branch, use:
bzr branch bzr+ssh://my/repo/mybranch

John
=:->

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (Cygwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAk22vlAACgkQJdeBCYSNAAOOXwCgpKegTYYanElss9CgEIU38x1b
G4AAoMbo7U24pIR8oSnnBigb7j3zoWZV
=ffhR
-----END PGP SIGNATURE-----

David D Lowe (flimm) said : #3

Modifying $BRANCH/.bzr/branch/branch.conf worked. Thanks!

If I'm using /etc/init.d/loggerhead , where would locations.conf be?

Jelmer Vernooij (jelmer) said : #4

On Tue, 2011-04-26 at 13:24 +0000, David D Lowe wrote:
> Question #153887 on loggerhead changed:
> https://answers.launchpad.net/loggerhead/+question/153887
>
> Status: Answered => Open
>
> David D Lowe is still having a problem:
> Modifying $BRANCH/.bzr/branch/branch.conf worked. Thanks!
>
> If I'm using /etc/init.d/loggerhead , where would locations.conf be?
Probably in ~/.bazaar/locations.conf of the user that's running
loggerhead. It might be nice to e.g.
support /etc/loggerhead/locations.conf for that.

Or perhaps the init scripts can override BZR_HOME to /etc/loggerhead ?

Cheers,

Jelmer

John A Meinel (jameinel) said : #5

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 4/26/2011 3:24 PM, David D Lowe wrote:
> Question #153887 on loggerhead changed:
> https://answers.launchpad.net/loggerhead/+question/153887
>
> Status: Answered => Open
>
> David D Lowe is still having a problem:
> Modifying $BRANCH/.bzr/branch/branch.conf worked. Thanks!
>
> If I'm using /etc/init.d/loggerhead , where would locations.conf be?
>

Whatever user is running loggerhead. I don't really know the details,
myself.

John
=:->

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (Cygwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAk22yggACgkQJdeBCYSNAAP3zwCeN91SLF6g67Px27Zh6gGRumF2
jmYAn2Egr3G7gk523ursnoTqjHpQFEIC
=fllS
-----END PGP SIGNATURE-----

David D Lowe (flimm) said : #6

Well, I couldn't get it working with /home/loggerhead/.bazaar/locations.conf (with appropriate user settings), or BZR_HOME.

Gary Poster (gary) said : #7

Hi David. I don't have an answer for you, but it has been a while since your made the last comment. Do you still have a problem with this?

David D Lowe (flimm) said : #8

Well, I can fix the message for single branches, but I can't fix it for a group of branches (except one by one).

Martin Pool (mbp) said : #9

@David maybe $HOME is not getting set correctly for the loggerhead daemon?

Gary Poster (gary) said : #10

Marking as answered to see if Martin's direction gives the right push.

David D Lowe (flimm) said : #11

I tried creating a new user with a home directory, but that didn't seem to work.

Martin Pool (mbp) said : #12

How are you starting the Loggerhead server? Is it running as a standalone server, or through Apache or something else?

Can you help with this problem?

Provide an answer of your own, or ask David D Lowe for more information if necessary.

To post a message you must log in.