How to setup magnets in Firefox 4?

Asked by Sergey Basalaev on 2011-05-22

After upgrading Firefox to 4.0 magnet links don't work anymore. It claims that no application uses this protocol. Is there a way to setup Firefox to handle these links?

Question information

Language:
English Edit question
Status:
Answered
For:
LinuxDC++ Edit question
Assignee:
No assignee Edit question
Last query:
2011-05-24
Last reply:
2011-05-25
Francois Botha (igitur) said : #1

On Sun, May 22, 2011 at 10:15 PM, Sergey Basalaev
<email address hidden> wrote:
> New question #158582 on LinuxDC++:
> https://answers.launchpad.net/linuxdcpp/+question/158582
>
> After upgrading Firefox to 4.0 magnet links don't work anymore. It claims that no application uses this protocol. Is there a way to setup Firefox to handle these links?

I suspect your magnet links are broken.

Open gconf-editor and navigate to /desktop/gnome/url-handlers/magnet/
set command to:
linuxdcpp -m '%s'

enabled needs to be checked and needs_terminal UNchecked.

regards,
Francois

Sergey Basalaev (sbasalaev) said : #2

> Francois Botha proposed the following answer:
>
> I suspect your magnet links are broken.
>
> Open gconf-editor and navigate to /desktop/gnome/url-handlers/magnet/
> set command to:
> linuxdcpp -m '%s'
>
> enabled needs to be checked and needs_terminal UNchecked.

Nope, this is the first thing I checked and all keys are there and set properly.
I also tried reinstalling linuxdcpp without effect.
Other unusual protocols like apt: or man: operate properly.

Steven Sheehy (steven-sheehy) said : #3

Have you tried to run the actual command to see if it works in a terminal?

linuxdcpp -m 'magnet:?xt=urn:tree:tiger:TTH&xl=SIZE&dn=FILENAME'

Sergey Basalaev (sbasalaev) said : #4

2011/5/24 Steven Sheehy <email address hidden>:
>
> Steven Sheehy requested more information:
> Have you tried to run the actual command to see if it works in a
> terminal?
>
> linuxdcpp -m 'magnet:?xt=urn:tree:tiger:TTH&xl=SIZE&dn=FILENAME'
>

Yes, this works perfectly. Just tried Midori and Epiphany browsers.
Both refuse to handle magnets as well.

Steven Sheehy (steven-sheehy) said : #5

Doesn't seem like an issue with linuxdcpp. Might be some issue with gnome or your browser. What version of Gnome are you using? If it's 3.0 they might have changed how it handles URIs.

Try going into firefox's preferences and manually setting it up on the Applications tab.

Sergey Basalaev (sbasalaev) said : #6

> Doesn't seem like an issue with linuxdcpp.
Yes, I feel the same. The whole thing happened when I upgraded to natty. But I'm still using classic Gnome environment (GNOME 2.32.1). And I wonder why browser still handles all other protocols like man: or apt:, but refuses to work with magnet:, though I see no difference in gconf-editor or elsewhere. If I'm the only one with this issue, that's even stranger.
In Preferences->Applications in Firefox, clicking on Other launches 'open file' dialog, so I can peek /usr/bin/linuxdcpp, but I cannot add '-m' argument to it. Is this parameter required required? If it is, I think I can bypass it by creating .desktop with proper command, but this will not explain why the standard way stopped working.

Steven Sheehy (steven-sheehy) said : #7

$ man linuxdcpp

As you can see, if you pass a magnet without -a it will still work. For me, when I configured linuxdcpp as magnet handler in gconf it showed up in the drop down list in firefox's application tab.

Can you help with this problem?

Provide an answer of your own, or ask Sergey Basalaev for more information if necessary.

To post a message you must log in.